16:00:45 <eglute> #startmeeting defcore
16:00:46 <openstack> Meeting started Wed Feb 24 16:00:45 2016 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:50 <openstack> The meeting name has been set to 'defcore'
16:00:52 <markvoelker> o/
16:00:57 <eglute> chair markvoelker
16:01:11 <eglute> #topic agenda
16:01:18 <eglute> #link  https://etherpad.openstack.org/p/DefCoreRing.13
16:01:31 <eglute> Hello Everyone, let us know if you are here for the defcore meeting
16:01:41 <CatherineD_> o/
16:02:05 <eglute> also, please review the agenda and add/edit as needed
16:02:45 <eglute> dwalleck is not able to make today's meeting, so we will move his agenda items to next week
16:02:59 <eglute> hogepodge are you around?
16:03:23 <gema> jo/
16:03:41 <hogepodge> o/
16:04:12 <eglute> #topic Multi-tenant tests
16:04:53 <eglute> hogepodge i saw you were talking to Mike in defcore channel about it, are you ready to go over this?
16:04:59 <hogepodge> A bit yeah.
16:05:27 <hogepodge> My original assertion is that multi-tenant tests get in the way of one of our goals of interoperability tests being user-runnable.
16:05:55 <hogepodge> And what many of those tests are measuring is more security related than interoperability related.
16:06:23 <hogepodge> I had proposed a large number of tests be flagged as a straw-man proposal, but it looks like that number will diminish significantly
16:06:27 <eglute> right
16:07:16 <hogepodge> Here's a bit of status, the list I flagged: https://etherpad.openstack.org/p/multi-tenant-defcore-tests
16:07:55 <hogepodge> 18 have a patch that removes the unnecessary multi-tenant requirement. https://review.openstack.org/#/c/283819/
16:08:38 <eglute> that looks good
16:08:53 <markvoelker> #link https://etherpad.openstack.org/p/multi-tenant-defcore-tests multitenant test list
16:08:56 <hogepodge> The authorization tests are scheduled to be removed from Tempest, which will only leave a few.
16:09:16 <markvoelker> #link https://review.openstack.org/#/c/283819/ patch removing unnecessary multi-tenancy
16:09:27 <hogepodge> but at the mid-cycle, I'd like us to consider a policy that restricts us from adding other multi-tenant tests from consideration.
16:09:40 <eglute> hogepodge i like that idea
16:10:04 <markvoelker> hogepodge: is that on the midcycle etherpad?  https://etherpad.openstack.org/p/DefCoreSpring2016MidCycle
16:11:17 <hogepodge> markvoelker: just added it. Thanks
16:12:26 <eglute> hogepodge so this would make your patch a lot smaller, correct?
16:13:53 <hogepodge> eglute: correct
16:14:42 <hogepodge> that patch was intended to provoke discussion and action to review the tests, which I finally got around to this week :-D
16:14:42 <eglute> thanks hogepodge. it would be good if you submitted a new patch. in the mean time, i assume you would like for us to review the tests in that ehterpad?
16:14:49 <eglute> :)
16:15:11 <hogepodge> eglute: it's not necessary, that's more of a working document which I'm going to use to build out defcore patches
16:15:20 <eglute> cool
16:15:33 <eglute> any other comments on this topic?
16:16:30 <eglute> #topic Add 2016.01 required test list
16:16:37 <eglute> #link https://review.openstack.org/#/c/283743/
16:16:44 <eglute> thanks CatherineD_ for adding those
16:16:50 <CatherineD_> But the total number
16:16:56 <eglute> these are required for RefStack correct
16:17:36 <eglute> sorry CatherineD_ ... looks like you were in the middle of the comment?
16:17:41 <CatherineD_> Of flagged tests would remain the same?
16:18:14 * CatherineD_ sorry my internet is slow.
16:19:01 <eglute> hogepodge?
16:19:16 <hogepodge> CatherineD_: when I was creating those files I was including flagged tests, but it may make sense to not, as vendors have found it a bit confusing. On one hand, if they pass flagged tests it's nice to know, on the other hand many vendors think they've failed when they're actually ok
16:20:03 <CatherineD_> Ok thx
16:20:29 <eglute> thanks hogepodge
16:20:46 <hogepodge> we should make required.py a generic tool and include instructions on how vendors can use it. We have more test refactoring happening this week and it would be better to generate that list dynamically rather than use a static version
16:21:07 <hogepodge> I was on that path at Vancouver last year, but then other work took me away
16:21:26 <eglute> is that something that we also need to add to the midcycle?
16:22:03 <hogepodge> I can pick that work up again, but not until late next week at earliest.
16:22:26 <eglute> that works for me
16:22:37 <eglute> ok, next topic Add 2016.01 required test list
16:22:42 <eglute> thanks CatherineD_ for adding that
16:23:10 <eglute> this is required for refstack, so we need to make sure to add it each time we pass a guideline
16:23:26 <CatherineD_> A user was asking for the required let on #refstack
16:23:53 <rockyg> o/
16:24:05 <hogepodge> CatherineD_: Can refstack parse the defcore project for new guidelines?
16:24:29 <eglute> i think we need to document somewhere all the things that need to happen for each new guideline. Maybe in a Hacking file?
16:25:30 <markvoelker> I'd suggest we etherpad it first, and then see if we can't simplify it.
16:25:47 <eglute> markvoelker sounds good. i like simplifying things
16:25:47 <rockyg> ++
16:26:15 <eglute> #action markvoelker and eglute to work on simplifying things required after each guideline is passed
16:26:31 <eglute> everyone, please review https://review.openstack.org/#/c/283743/
16:26:48 <CatherineD_> Right now parsing of the guideline is at the server side.  We will need to see whether it make sense for client side
16:27:36 <eglute> thanks CatherineD_ let me know what you find out
16:28:02 <eglute> #action CatherineD_ to check whether it makes sense to parse guidelines on refstack's client side
16:28:19 <eglute> any other comments on this topic?
16:28:46 <eglute> #topic RefStack questions
16:28:53 <eglute> #link http://lists.openstack.org/pipermail/defcore-committee/2016-February/001035.html
16:29:12 <eglute> thanks markvoelker for responding to those. i agree with your responses, but would like to hear from others
16:29:39 <markvoelker> In particular, Alex had a couple of questions in his reply that would be best answered by someone from the Foundation I believe
16:31:01 <eglute> hogepodge did you have a chance to look at the questions?
16:32:27 <hogepodge> a bit, a marketplace link shouldn't be a requirement for refstack. I do want to make links to refstack a part of the marketplace, and setting up that code on our side right now
16:33:34 * eglute wishes she could see if someone is typing
16:33:36 <hogepodge> I don't have too strong of opinions on how user-management happens on the refstack side. using openstack id is preferred for a number of things, just because it centralizes identity across other projects
16:34:34 <eglute> CatherineD_ do you have any other RefStack related questions besides what was in the email?
16:34:57 <catherineD> eglute: yes
16:35:12 <eglute> catherineD go ahead!
16:35:54 <catherineD> I think the discussion point is should anyone being able to list the users in RefStack
16:36:19 <catherineD> From last meeting , I think the direction is no..
16:36:36 <markvoelker> +1
16:36:49 <eglute> +1
16:36:50 <catherineD> some of the RefStack team member was questioning why someone can do that in gerrit and not in RefStack
16:37:39 <markvoelker> My larger question would be "why would we need to do it in RefStack, regardless of what some other tools do?"
16:37:45 <hogepodge> markvoelker: +1
16:37:48 <catherineD> +1
16:37:49 <eglute> i agree with markvoelker
16:37:59 <markvoelker> E.g. if there's a real use case for being able to do it, I'm not necessarily opposed...but there doesn't seem to be one.
16:38:10 <markvoelker> So my tendency is to keep it private.
16:38:30 <rockyg> one reason for no is that many of the individuals are actually proxies for the companies hey work for
16:38:32 <eglute> agreed, can always be added once a real use case comes up
16:38:51 <catherineD> ++
16:39:02 <eglute> but rockyg also has another great point for not having it
16:39:51 <eglute> catherineD any other questions?
16:40:13 <rockyg> plus, anonymous submitters need to stay anon for everyone bu foundation
16:40:28 <eglute> +1
16:40:34 <catherineD> that is it for me ... I just need to confirm the user list privacy topic
16:41:26 <eglute> thank you catherineD!
16:41:34 <eglute> #topic ID'ing new capabilities for 2016.07
16:41:37 <catherineD> thank you all !!!
16:41:56 <eglute> we still need volunteers for scoring capabilities
16:42:04 <eglute> any takers for Cinder, Swift, and Glance?
16:42:13 <markvoelker> I'll double up and help with glance
16:42:36 <hogepodge> I can do Cinder and Swift
16:42:37 <eglute> thank you markvoelker
16:42:41 <eglute> thank you hogepodge!
16:43:03 <hogepodge> I should know this, but do we have a work timeline anywhere?
16:43:16 <markvoelker> hogepodge: see bottom of etherpad.
16:43:20 <eglute> for scoring?
16:43:40 <markvoelker> Ideally if we can get a first pass done before the midcycle that would be best (so we can discuss in person)
16:43:51 <rockyg> so, looks like glance v2 won't make it into nova for mitaka.  so glance remains as is.
16:43:54 <markvoelker> Doens't have to be complete, but something we can start iterating on
16:44:01 <hogepodge> yes :-D
16:44:44 <gema> markvoelker: I have a question, I have been reading the keystone api and was wondering what's the criteria to call something "a capability"
16:44:45 <hogepodge> get-me-an-ip will land partially in mitaka in neutron, but the cross-project work is expected to be done early N
16:45:01 <gema> other than not needing admin to use it
16:45:07 <rockyg> Glance is done :-0
16:45:15 <hogepodge> we should consider the impact of that on our network capabilities, as it is being written specifically to address networking interoperability
16:45:39 <markvoelker> gema: This might help. =) https://github.com/openstack/defcore/blob/master/doc/source/process/Lexicon.rst
16:46:03 <hogepodge> gema: for defcore, a capability needs a non-admin test. that's the current bar
16:46:07 <gema> markvoelker: thank you, I was lost
16:46:13 <gema> hogepodge: ack, thanks
16:46:17 <markvoelker> In plainer terms, I think of a capability as something an end user of a cloud can expect to use.  Usually that means an API that's user-facing
16:46:57 <eglute> thanks markvoelker and hogepodge
16:47:09 <markvoelker> Capabilities also have to have tests, so you can look through tempest to get a rough idea of what capabilities are out there
16:47:15 <hogepodge> I don't think we have a great mapping between tests and how to translate that into user actionable API calls, but we're working with what we have
16:47:25 <eglute> anything else regarding scoring?
16:48:13 <gema> not from me, thanks for the tips
16:48:25 <eglute> #topic midcycle
16:48:51 <eglute> Next week, I would like to go over the agenda for the midcycle, and time-box different topics
16:48:59 <eglute> as well as prioritize the,
16:49:01 <eglute> them
16:49:25 <markvoelker> +1, I'm planning to work up a strawman schedule that we can discuss
16:49:29 <eglute> we will have some people call in for specific topics, so times will be helpful
16:49:32 <eglute> thanks markvoelker
16:49:46 <eglute> #action markvoelker  to work up a strawman schedule for midcycle that we can discuss
16:50:19 <eglute> so if there is a topic that is not on the midcycle etherpad that you would like to have discussed, please add it
16:50:27 <eglute> #link https://etherpad.openstack.org/p/DefCoreSpring2016MidCycle
16:50:41 <eglute> and put your name by your topics
16:51:20 <eglute> also, today is your last chance to respond to the dietary restrictions poll: http://doodle.com/poll/ewsiepmhv9p6r8e7,
16:51:28 <eglute> but i think everyone here has responded
16:51:31 <eglute> so thank you!
16:52:05 <eglute> another important topic for midcycle: Tuesday night. do we want something formal organized? if so, what?
16:52:33 <markvoelker> I think dinner is in order. =)
16:53:01 <eglute> anyone else interested in dinner?
16:53:03 <hogepodge> We're out at the Domain, which has a number of restaurants that are easy to get to from the venue. We're a ways away from downtown.
16:53:12 <eglute> we will need reservations
16:53:51 <rockyg> ++  I also suggest an informal gathering at the lonestar....great place for that
16:53:59 <brunssen> For a large group at a restaurant in the Domain we will want to have reservations.
16:54:16 <eglute> brunssen right, will try to make them this week
16:54:27 <brunssen> I am happy to set something up if you want me to do so?
16:54:31 <eglute> brunssen can you suggest several good restaurants in the area? i only know of one!
16:54:37 <eglute> brunssen that would be great!
16:54:51 <eglute> #action brunssen to book dinner for Tuesday night
16:55:09 <brunssen> OK, no problem.  I will send out a list of restaurants to the group and we can take an informal poll
16:55:25 <eglute> thank you!
16:55:48 <brunssen> Then I can make the reservation for Tuesday March 8
16:56:03 <eglute> that works for me :)
16:56:15 <eglute> 2 minutes remaining... any last words?
16:56:18 <brunssen> OK, consider it done.
16:56:27 <eglute> thank you brunssen!
16:57:01 <eglute> thanks everyone!
16:57:02 <rockyg> word
16:57:13 <eglute> #endmeeting