16:01:04 <hogepodge> #startmeeting defcore
16:01:05 <openstack> Meeting started Wed Jul  6 16:01:04 2016 UTC and is due to finish in 60 minutes.  The chair is hogepodge. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:08 <openstack> The meeting name has been set to 'defcore'
16:01:13 <hogepodge> #chair markvoelker eglute
16:01:14 <openstack> Warning: Nick not in channel: markvoelker
16:01:15 <openstack> Current chairs: eglute hogepodge markvoelker
16:01:23 <eglute> o/
16:01:25 <Rockyg> o/
16:01:49 <VanL> o/
16:02:05 <gema> o/
16:02:19 <catherineD|2> o/
16:02:26 <hogepodge> #link agenda https://etherpad.openstack.org/p/DefCoreLunar.10
16:02:48 <hogepodge> #topic Sessions for Barcelona
16:03:33 <hogepodge> The call for proposals closes this week for the OpenStack Summit in Barcelona. If you've submitted a talk or are planning to, can you add a link or description to the etherpad?
16:04:03 <gema> hogepodge: a talk about defcore or about anything?
16:04:38 <hogepodge> Generally about defcore or refstack or interop, but if you have any other talks you've submitted I'd like to hear about them too. :-D
16:05:03 <gema> alright
16:05:21 <hogepodge> Has anyone submitted anything yet?
16:05:28 <eglute> no.. have you?
16:05:47 <hogepodge> No, not yet.
16:05:51 <hogepodge> Ok, moving on.
16:05:53 <gema> I have submitted two about running clouds on AArch64 and by ODS I will have notes also on how interoperable they are
16:06:07 <eglute> i think having defcore 101 session would be good, what do ohters think
16:06:15 <gema> eglute: +1
16:06:16 <hogepodge> gema: great! can you put a link or abstract into the etherpad?
16:06:24 <Rockyg> ++
16:06:31 <gema> hogepodge: yeah, no prob
16:06:53 <hogepodge> eglute: I think a 101 would be good, I really want to make sure it captures the process practically from testing to flagging to evaluating
16:07:05 <hogepodge> I can start to put something together for it
16:07:13 <eglute> hogepodge sounds good!
16:07:21 <gema> if we do a 101 talk, we should include a bit about the test spec
16:07:31 <gema> so developers are aware
16:07:31 <eglute> gema +1
16:07:33 <hogepodge> gema: +1
16:07:34 <Rockyg> i think it's good to have the 101 talk and a soon to be/nw capabilities requirement/what's changing talk
16:07:58 <eglute> Rockyg +1 on changes
16:08:08 <Rockyg> I think that should be every summit
16:08:30 <eglute> we should have working group session(s) again as well
16:08:38 <eglute> where we will be covering changes
16:08:50 <hogepodge> #link call for speakers page https://www.openstack.org/summit-login/login?BackURL=%2Fsummit%2Fbarcelona-2016%2Fcall-for-presentations%2F
16:08:58 <eglute> but if we have a general session, we can cover changes as well
16:09:34 <hogepodge> Working group sessions will be sorted out later this summer, and I'll have more information about how we can get one or two once the process opens
16:10:03 <Rockyg> thanks, hogepodge
16:10:45 <hogepodge> ok, anything else?
16:11:09 <hogepodge> #topic flag os-network extension tests
16:11:36 <hogepodge> #link https://review.openstack.org/#/c/329220/
16:11:58 <hogepodge> VanL: eglute: it doesn't like like dwalleck is here today? Do you have any updates on the status of this?
16:12:12 <eglute> I do not...
16:12:17 <VanL> This is a pretty straightforward flag request
16:12:51 <VanL> There is an additional functionality being pulled in - os-networks
16:12:59 <hogepodge> We were hoping for more updates on the progress in Tempest. As part of flag requests we want to encourage engagement with upstream so we can make sure the underlying issue is resolved
16:13:55 <VanL> We can try to do that, but time is short due to some other factors
16:14:06 <eglute> +1 on more involvement, but we shouldnt hold back the PR. I had +1 only for more discussion, will change it to +2
16:14:25 <VanL> There was one -1, looks like due to formatting that is now fixed
16:14:31 <VanL> otherwise its +6
16:15:31 <VanL> eglute +1 - this shouldn't be controversial
16:15:33 <VanL> :)
16:15:35 <hogepodge> VanL: based on the comments from markvoelker it appears part of the holdup is following up with a bug
16:16:09 <hogepodge> It's not controversial, but we'd like to track the progress and create an environment where we can come back to these problems and try to fix them at the source
16:16:13 <VanL> I can chase down Daryl. I just know that he has a bunch of other things on his plate that have been put higher than this
16:16:23 <hogepodge> Understand
16:17:09 <VanL> He is, unsurprisingly, following the orders of his direct manager - who is telling him to work on other things, not upstream tempest right now.
16:17:35 <VanL> He's out of round tuits for a while due to some of the other issues that have been bubbling here over the past months
16:18:09 <Rockyg> hogepodge, perhaps we wan get a defcore impact tag in tempest?  It might raise the visibility of our bugs
16:18:20 <hogepodge> ok
16:18:32 <VanL> Can we +2 the PR?
16:18:57 <eglute> i am ready to move it forward, unless there are other comments
16:19:49 <hogepodge> If your cloud isn't running upstream code it's difficult to reproduce and make sure the problem is fixed. I can +2, but I don't feel ok merging until markvoelker +2s it also.
16:20:15 <eglute> Mark had it at +1,
16:20:43 <VanL> The issue is an atomic test issue - it pulls in a non-defcore function
16:20:48 <eglute> I changed mine to +2.
16:21:24 <VanL> (Turns out we have this function, but we have it on a different URL path due to... reasons..., but fixing that will take too long for right now.)
16:21:40 <hogepodge> Let me look at the test and see how deep it funs. I'll review post meeting today.
16:21:50 <eglute> thank you hogepodge
16:21:57 <hogepodge> s/funs/runs/
16:22:30 <hogepodge> #topic Move network router tests
16:22:32 <VanL> (We plan on fixing the URL path, but right now this should be flagged)
16:22:55 <hogepodge> #link https://review.openstack.org/#/c/326755/
16:23:35 <hogepodge> catherineD|2: do you have an input on this review?
16:23:48 <hogepodge> Is Charles around?
16:23:55 <cjvolzka> I am
16:25:29 <cjvolzka> I only noticed this because we don't yet support routers causing us to fail these tests. Since all the other routers tests were put under L3 it made sense to me that these should as well.
16:26:10 <hogepodge> cjvolzka: ok, makes sense
16:26:27 <eglute> +2
16:26:50 <hogepodge> I'll give it a review after the meeting, any other comments on this?
16:26:57 <cjvolzka> Once L3 moves out of advisory then these would all become required again. As they are now we're indirectly requiring router functionality even though routers aren't yet required.
16:27:50 <hogepodge> cjvolzka: yeah, do you think at L3 is something that is reasonably required for defcore given the multitude of networking models?
16:29:34 <cjvolzka> There was some debate on this in the past when routers was first proposed. We don't currently support it, but that's only ancedotal. We're more private cloud focused but it is on our roadmap.
16:30:10 <hogepodge> cjvolzka: understand. will you make the mid-cycle? I think this could be a useful topic for discussion during one of our sessions there
16:30:14 <catherineD|2> hogepodge: in general, required capability (L2)  should not include non-require capability (L3) for 2016.08 ...
16:30:36 <cjvolzka> hogepodge: Sadly no :(
16:31:26 <hogepodge> cjvolzka: ok, could you send me or the mailing list an e-mail so I can get some background for discussion?
16:31:52 <cjvolzka> hogepodge: sure, np
16:32:02 <hogepodge> networks is going to be a really big addition, and I want to make sure we get as much of it right early as we can
16:32:19 <hogepodge> cjvolzka: thank you
16:32:48 <hogepodge> anything else on this topic?
16:33:06 <hogepodge> #action hogepodge to add networks agenda item to midcycle
16:33:24 <hogepodge> #topic Maintenance and flag patches
16:33:41 <hogepodge> #link Flags not carried forward https://review.openstack.org/#/c/310582/
16:34:02 <hogepodge> That patch reconciles the flags on 2015.07 and 2016.01
16:34:14 <eglute> looks good to me!
16:34:18 <hogepodge> catherineD|2: had a policy question about it that I need to answer
16:34:27 <hogepodge> #link Gate on active guidelines https://review.openstack.org/#/c/335251/
16:34:44 <catherineD|2> hogepodge: yea just a question about : Should flags identified in a latest guideline be carried backward to previous guidelines? if so, how many previous guidelines needed to be updated.
16:34:59 <hogepodge> catherineD|2: I would think just to active guidelines
16:35:35 <catherineD|2> ok make senses .. Adding flags will not affect results ... removing flags will
16:35:59 <hogepodge> catherineD|2: yeah, and it changes the optics of previous guidelines if we change them
16:36:03 <eglute> looks like Mark just gave it +2, so if no objections, i will merge it
16:36:03 <markvoelker> And they only need to be carried forward if the rationale for the flag is still valid.
16:36:11 <hogepodge> markvoelker: +1
16:36:36 <hogepodge> markvoelker: yeah, that should be one of the last things we do before presenting next to the board, pulling flags forward or dropping them as needed
16:36:47 <catherineD|2> hogepodge: ++
16:36:56 <Rockyg> ++
16:37:14 * markvoelker is on a slow mobile link from somewhere in the Appalachians so please pardon me being quiet today
16:37:19 <hogepodge> #link Add test aliases https://review.openstack.org/#/c/329577/3
16:37:43 <catherineD|2> hogepodge: I reviewed this one
16:37:55 <hogepodge> More tempest tests moved, I helped write that patch up and the submitter is very anxious about landing it.
16:37:59 <hogepodge> catherineD|2: ty
16:38:18 <catherineD|2> Adding alias to these tests does not help or hurt anything ...
16:38:53 <eglute> ready to merge then?
16:38:57 <catherineD|2> first of all these were flagge tessts since Dec 2015 and subject to remove and indeed were removed
16:39:14 <catherineD|2> and the test does not exist any more ...
16:39:25 <hogepodge> catherineD|2: I see
16:39:51 <catherineD|2> I don't mind either way but how do we prevent users from spending time on non-necessary debug?
16:40:22 <eglute> catherineD|2 good question... topic for midcycle?
16:40:46 <hogepodge> catherineD|2: eglute: +1 on midcycle topic
16:40:50 <catherineD|2> perhaps educate users that if the flagged message state to be removed ... then users should not pay attention to them?
16:41:20 <catherineD|2> yea let's add it the midcycle ..
16:41:29 <hogepodge> catherineD|2: and that they don't need to pass them. I had a very difficult time communicating this.
16:41:38 <catherineD|2> meanwhile we can merge the patch for the effort ... but it is really useless
16:41:51 <eglute> merged already, thanks markvoelker
16:42:01 <hogepodge> Anything else on these?
16:42:20 <hogepodge> #topic Regroup capabilities
16:42:34 <hogepodge> #link https://bugs.launchpad.net/defcore/+bug/1579162
16:42:34 <openstack> Launchpad bug 1579162 in defcore "Group capabilities consistently" [Low,New]
16:43:01 <hogepodge> VanL: and I were going to work on this, but I think we were sidetracked with other issues.
16:43:09 <hogepodge> I was going through the bug tracker this morning and was reminded of it.
16:43:31 <VanL> I had totally forgotten
16:43:42 <hogepodge> Basically, the issue is the grouping if networks capabilities is inconsistent with other capabilities, and looking at reconciling it.
16:44:07 <hogepodge> I brought it up just to remind ourselves about it.
16:44:32 <hogepodge> Anyone have comments on it?
16:44:56 <eglute> hogepodge and VanL if you have a proposal for midcycle, we could review it then?
16:45:11 <VanL> That would work
16:45:12 <hogepodge> eglute: sure, just have to write it up
16:45:22 <eglute> thank you :)
16:45:25 <hogepodge> midcycle is filling up rather rapidly, which brings us to the next topic
16:45:37 <hogepodge> #topic DefCore Mid-cycle/Sprint
16:45:55 <hogepodge> Thank you VanL and eglute for arranging space for us at RAX San Antonio
16:46:10 <gema> +1, thanks!
16:46:22 <eglute> it was all VanL!
16:46:23 <hogepodge> markvoelker has put together an initial agenda
16:46:25 <hogepodge> #link https://etherpad.openstack.org/p/DefCoreSummer2016Sprint
16:46:58 <hogepodge> We should be looking at the topics and making comments so we can nail down the final agenda.
16:47:06 <VanL> FYI, this was from our internal team: "we were able to reserve 1479 for the original dates provided below.  This meeting room is off the main lobby and has the below necessary room requirements.  Reminder that all visitor names will need to be provided to the Front Desk at least a day prior to arrival."
16:47:56 <eglute> #action everyone: add your name/company if attending midcycle in person
16:48:01 <hogepodge> VanL: thanks, I added that note to the etherpad agenda
16:49:20 <hogepodge> #action everyone review agenda and propose additions/changes
16:49:20 <VanL> There will be food trucks around on Tuesday, and there are a number of close restaurants Wed/Thurs. I'll make sure we have snacks.
16:50:12 <hogepodge> Anything else on this?
16:50:18 <VanL> Drinks will also be available
16:50:22 <VanL> and provided
16:50:43 <eglute> i will send out calendar invite for midcycle days
16:50:59 <hogepodge> #action eglute to send out calendar invitation for midcycle
16:51:04 <Rockyg> I hope you have some good bourbon...
16:51:25 <eglute> not officially :D
16:51:32 <VanL> Rockyg: LOL. Not *those* kind of drinks.
16:51:37 <hogepodge> #topic Waiver for additional responses on Nova API calls
16:51:47 <hogepodge> #link https://review.openstack.org/#/c/333067/
16:52:41 <VanL> My only issue is that I want strict API checking to go through the normal defcore process
16:53:23 <VanL> It doesn't just get "turned on" at some point - changes in the API that are required for TM compliance must be scored, weighed, etc.
16:53:35 <hogepodge> I'm not sure what more I can say this week. Administratively I'd like to see the Foundation have a way to work this out, so just a reminder that it's there.
16:54:48 <eglute> VanL can you create a launchpad issue for strict API checking?
16:54:57 <hogepodge> It's related to this, which gives a formal path for additional properties https://review.openstack.org/#/c/335247/
16:55:02 <eglute> I would like to move forward with this waiver
16:55:14 <hogepodge> eglute: VanL: I can create that too if you'd like
16:55:25 <eglute> hogepodge that would be great
16:55:32 <VanL> +1 hogepodge
16:55:52 <eglute> markvoelker are you ok with the waiver?
16:56:02 <hogepodge> eglute: don't want to speak for markvoelker, but I think he's waiting on WG and board consensus? I don't want to +2 my own proposal.
16:56:17 <hogepodge> so to that end reviews are helpful
16:56:25 <eglute> i think the board agreed that we need a waiver
16:57:09 <eglute> i am ok with going forward with this. we can amend the waiver later as things come up
16:57:11 <markvoelker> Generally yes, I'm ok with it.  From the BoD meeting I got the general impression they were ok with the idea too
16:57:52 <hogepodge> with two minutes left, I'm going to post the last few agenda items
16:57:56 <hogepodge> #topic wrap up
16:58:07 <hogepodge> #link Test Spec https://review.openstack.org/#/c/317531/
16:58:17 <hogepodge> I'm sure this will get lots of attention at the sprint
16:58:35 <hogepodge> #link blueprint for test result ownership https://blueprints.launchpad.net/refstack/+spec/test-results-ownership
16:58:59 <hogepodge> #link blueprint for marking results as used in certification https://blueprints.launchpad.net/refstack/+spec/certification-test-record
16:58:59 <eglute> thanks gema and catherineD|2 for working on them
16:59:02 <catherineD|2> Please help to review the RefStack blueprint and spec
16:59:17 <hogepodge> #link review for associating test results to products https://review.openstack.org/#/c/332260/
16:59:29 <catherineD|2> I hope to have these land and review in the midcycle ..
16:59:35 <hogepodge> RefStack is an important companion project to defcore, reviews and comments are greatly valued.
16:59:44 <gema> will do
16:59:49 <hogepodge> Thanks everyone!
16:59:58 <gema> thank you guys!
17:00:03 <catherineD|2> Thank you!
17:00:04 <hogepodge> #endmeeting