16:00:14 <eglute> #startmeeting defcore
16:00:17 <hogepodge> o/
16:00:21 <openstack> Meeting started Wed Aug 17 16:00:14 2016 UTC and is due to finish in 60 minutes. The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:23 <markvoelker> o/
16:00:25 <openstack> The meeting name has been set to 'defcore'
16:00:41 <eglute> #chair markvoelker hogepodge
16:00:42 <openstack> Current chairs: eglute hogepodge markvoelker
16:00:43 <gema> o/
16:00:45 <eglute> #topic agenda
16:00:52 <eglute> #link https://etherpad.openstack.org/p/DefCoreLunar.14
16:01:09 <catherine_d|1> o/
16:01:13 <eglute> hello everyone, please review agenda and add things as needed
16:01:40 <eglute> #topic Finalize items for August 23rd Board Meeting
16:02:08 <eglute> next Tuesday is board meeting, and there are several items that will require board's approval
16:02:19 <VanL> o/
16:02:22 <markvoelker> The first item here is the 2016.08 Guideline draft
16:02:27 <eglute> if there is something missing from that list, let us know!
16:02:29 <eglute> #topic 2016.08 Guideline
16:02:36 <markvoelker> #link https://review.openstack.org/#/c/351339/ 2016.08 draft
16:02:57 <eglute> hogepodge question: will 2016.08 use 1.6 schema?
16:03:37 <hogepodge> eglute: I hope so, it's not a major update, rather fixes and prevents some errors and ambiguities that slipped through with 1.5
16:03:59 <markvoelker> ++, it's a fairly simple change and hogepodge already has a patch up that depends on mine to do it.
16:04:07 <eglute> sounds good
16:04:12 <eglute> thank you hogepodge and markvoelker
16:04:15 <hogepodge> eglute: the main 2016.08 is the heart of the update that the board needs to see, the 1.6 schema update is administrative
16:04:22 <markvoelker> Speaking of which
16:04:29 <topol> o/
16:04:30 <markvoelker> Typically what we do is go ahead and merge a patch that creates the json file, then prepare another change that simply changes it from "draft" to "approved" which we land after the Board votes
16:04:56 <hogepodge> markvoelker: we will also want to mark the 2015.07 guideline as "superceded"
16:05:00 <markvoelker> So if folks can take one more look over 351339 we can go ahead and land it (and hogepodge's patch too)
16:05:05 <eglute> right, i think the board needs to approve both schema changes and the guideline
16:05:08 <markvoelker> hogepodge: yup, right
16:06:02 <markvoelker> eglute: Per last Board meeting, I think the Board probably considers the schema change "nonsubstantive" and therefore something they'd like to be informed of but don't need to approve before we start using it.
16:06:18 <hpe-hj> Greetings, as a quick intro this is Hank Janssen from HPE. I am mostly in a lurker status till I understand things better :)
16:06:19 <markvoelker> E.g. it doesn't change what's required of anyone, just how we format the Guideline.
16:06:42 <eglute> welcome hpe-hj!
16:07:05 <eglute> markvoelker right, i think we can get everything approved at once
16:07:11 <markvoelker> ++
16:07:15 <Rockyg> ++
16:07:39 <markvoelker> Ok, so does anyone have any last items to fix in 351339, or should we go ahead and land it?
16:07:56 <markvoelker> (we can still iterate in subsequent patches until we put it into the Board packet)
16:08:09 <shamail> LGTM personally
16:08:14 <eglute> +2
16:08:22 <Rockyg> land it!
16:08:33 <catherine_d|1> +1 I just reveiw again
16:08:34 <VanL> +1
16:08:51 <eglute> thank you catherine_d|1, appreciate it!!
16:08:59 * markvoelker looks to eglute and hogepodge to merge it since he submitted it
16:09:21 <eglute> done!
16:09:51 <eglute> #topic gate jobs and schema
16:09:59 <eglute> #link https://review.openstack.org/#/c/351363/
16:10:35 <hogepodge> I believe that this guideline hits the major points of what core interoperable OpenStack is, and represents years of work by the members of this working group. Thanks to everyone who got us here, especially VanL and catherine_d|1 who have been here since day 1, zehicle for running the committee at the beginning, and markvoelker and eglute for guiding it over the last year.
16:11:30 <Rockyg> ++
16:11:30 <eglute> hogepodge thank you!!! it has been incredible watching this group grow and mature
16:11:41 <shamail> ++
16:11:44 <eglute> and getting to work with everyone!
16:11:47 <gema> +2
16:12:00 <VanL> Thanks hogepodge. You neglected to mention yourself and all your work
16:12:02 <catherine_d|1> hogepodge: yea it has been a long time ... I am glad we reach this state
16:12:13 <catherine_d|1> VanL: ++
16:12:24 * markvoelker is happy too, but will be happier when he can merge the change marking it approved =)
16:12:31 <gema> sorry I went for coffee and this sounds like someone is leaving, noone is leaving, right?
16:12:47 <gema> we are just a happy bunch today :D
16:13:03 <Rockyg> Nope Just high fives all 'round
16:13:15 <gema> then I Am happy to for that big milestone :D
16:13:17 <hogepodge> gema: no one is leaving :-D
16:13:26 <eglute> #topic high5s!
16:13:33 <hogepodge> I forgot to mention Rockyg too for all her work in the early process
16:13:33 <gema> +!
16:13:35 <gema> +1
16:13:38 <eglute> thanks everyone :D
16:13:53 <shamail> lol ^5
16:14:17 <eglute> ok... back to schema?
16:14:37 <eglute> #topic 1.6 schema
16:14:49 <Rockyg> kewl. Thanks eglute for putting that in the minutes
16:14:57 <eglute> #link https://review.openstack.org/#/c/351363/
16:15:01 <markvoelker> eglute: I'm already +2 on this one so basically I think as long as Jenkins still reports it's clean after the other merge is complete we're good to go.
16:15:04 <eglute> Rockyg i do what i can!
16:15:19 <markvoelker> (assuming no one else finds fault with it)
16:15:34 <eglute> markvoelker i bet jenkins wont be happy since the other 2016.08.json was merged
16:15:39 <eglute> but i can move it forward
16:16:02 <eglute> any comments on the new schema?
16:16:34 <catherine_d|1> RefStack has merged a patch to support 1.6 https://review.openstack.org/#/c/356154/
16:16:43 <eglute> thank you catherine_d|1!
16:16:45 <catherine_d|1> +1 for this patch from RefStack
16:17:07 <eglute> and Jenkins reported back :) so when it is fixed, we will merge it
16:17:16 <hogepodge> I'll try to rebase right now
16:17:29 * hogepodge wonders if openstack git/gerrit is slow for everyone or just me
16:17:52 * catherine_d|1 it is slow
16:18:01 <eglute> internet is slow for me today in general.
16:18:04 <gema> infra have broken clouds before and they will break them again (reading twitter feeds from monty)
16:18:46 <eglute> thanks hogepodge, when you rebase, we will move it forward. please change 2016.08.json to indicate new schema as well :)
16:19:04 <VanL> gema: Context?
16:20:01 <gema> git gerrit being slow
16:20:06 <eglute> #topic multiple credentials tests
16:20:06 <gema> I was trying to find a reason
16:20:20 <eglute> #link https://review.openstack.org/#/c/338609/
16:20:32 <markvoelker> eglute: just saw you +2'd this one this morning. Two +2's, so I think it's ready to go.
16:20:48 <eglute> yup, unless there are any final comments
16:21:28 * markvoelker hears crickets
16:21:40 <eglute> silence is agreement :)
16:21:47 <eglute> done.
16:21:49 <eglute> thanks!
16:22:00 <eglute> #topic Interoperability Issues Report
16:22:10 <eglute> #link https://review.openstack.org/#/c/354528/
16:22:16 <eglute> wow, thanks markvoelker for writing it up
16:22:35 * shamail has not had a chance to review the report yet
16:22:52 <eglute> if you have not had a chance yet, please review it. it is really good.
16:22:55 <gema> it is amazing and very comprehensive
16:23:07 <shamail> Nice!
16:23:14 <markvoelker> Lots of comments on this one over the past week...I think I responded to the majority of the feedback and made adjustments accordingly. If I missed something, feel free to shout (through gerrit please)
16:24:10 <eglute> markvoelker i will do another read later today
16:24:38 <markvoelker> I guess we need to decide if we want to try to land this in time for the Board meeting next week....
16:24:49 <markvoelker> I don't think there's any particular rush, but based on the feedback so far it sort of feels like we're actually pretty close.
16:24:53 <eglute> i presume we want to present it at the board meeting, correct?
16:25:26 <gema> that was the original idea
16:25:36 <eglute> perhaps AlanClark is around? I will check with him if it is worth saving it for the joint board + TC meeting
16:25:37 <hogepodge> I'm for leaving discussion open for the next few days, and merging on Friday if there are no show stoppers
16:25:39 <shamail> I think it would make a good topic for the meeting
16:26:04 <markvoelker> Just so folks are aware on BoD meeting schedules:
16:26:06 <markvoelker> The next BoD meeting is next week and we need to land it soonish if we want the board to have a chance to read it prior to the meeting.
16:26:11 * hogepodge notes he'll be leaving on vacation tomorrow, so it's all kind of the same to him until Tuesday anyway
16:26:11 <shamail> That's a better idea eglute. :)
16:26:21 <markvoelker> If we don't want to go for this meeting, the next one is Barcelona
16:26:39 <eglute> right, and the Barcelona meeting is joint with TC
16:26:48 <hogepodge> so land Thursday after reviews and edits today?
16:26:49 <eglute> or part of it is
16:26:51 <catherine_d|1> hogepodge: pls do not fix the conflict for https://review.openstack.org/#/c/351363/ yet ...RefStack merged the 1.6 patch but the website has not updated.... I will let you know when it does
16:27:09 <Rockyg> How about if it's not 100%, we give them a draft of it?
16:27:29 <eglute> Rockyg that works too. We can give them a preview :)
16:27:35 <Rockyg> something to chew on for the summit meeting
16:28:02 <shamail> I'd like to suggest getting time with the board on 8/23 for guideline approval and then putting another topic in Barcelona for the TC/board meeting to cover the report. Can you split agenda items and request time in both?
16:28:11 <eglute> ok, so everyone please review the report if you haven't yet
16:28:32 <eglute> shamail yes, so far defcore had time in all meetings that i remember requesting
16:28:41 <shamail> Great
16:29:12 <eglute> any other comments on the report?
16:29:21 <markvoelker> Also, in case folks didn't notice: the links in Jenkins reports on the patch have rendered versions of the docs
16:29:24 <markvoelker> E.g. http://docs-draft.openstack.org/28/354528/10/check/gate-defcore-docs-ubuntu-xenial/d46227c//doc/build/html/periodic_reports/fall_2016.html
16:29:30 <markvoelker> Some folks may find those easier to read
16:29:50 <eglute> oh nice
16:30:03 <eglute> i knew it was around, just have not looked
16:30:05 <eglute> thanks markvoelker
16:30:37 <eglute> markvoelker
16:30:56 <eglute> markvoelker if we are changing the name, should we change the name in this report as well?
16:30:59 <Rockyg> kewl. Thanks!
16:31:17 <markvoelker> eglute: I'm leaving it as-is until the Board actually votes on changing our name
16:31:25 <gema> I was told not to change the name on the spec until it is approved also :D
16:31:34 <eglute> works for me!
16:31:56 <eglute> this brings us the next topic
16:32:00 <eglute> #topic Docs changes
16:32:10 <eglute> #link https://review.openstack.org/#/c/327086/
16:32:29 <markvoelker> Hmm...that last merge created a conflict. I'll rebase it, looks trivial.
16:32:40 <gema> markvoelker: you are missing the spec at least
16:32:46 <eglute> thanks markvoelker for working on this.
16:32:55 <gema> I will add comment
16:33:00 <markvoelker> gema: thanks
16:33:12 <eglute> i think we need to increment the process doc name to 2016B
16:33:55 <markvoelker> eglute: I didn't because 2016A is still status: Draft anyway
16:34:00 <eglute> oh
16:34:07 <eglute> didnt realize that
16:34:10 <markvoelker> (see line 4)
16:34:16 <eglute> in that case, it is already incremented
16:34:26 <eglute> yeah
16:35:02 <eglute> any other comments on the doc changes?
16:36:29 <eglute> #topic v2.0 Guideline
16:36:36 <eglute> #link https://review.openstack.org/#/c/310621/
16:37:05 <hogepodge> This is very much a work in progress
16:37:32 <markvoelker> Looks like you had a chance to sync up with Andrey though? Progress is good. =)
16:37:47 <hogepodge> I'm trying to capture the design decisions we made in SA, so I'm starting with a rough draft in RST form with rationale and use cases
16:38:16 <hogepodge> Although a WIP, comments on the work is welcome. I want to make sure we get it right since it will be a major version increase
16:38:55 <hogepodge> So start with design, then implement a schema and sample migration to test against.
16:39:41 <hogepodge> I won't have much to add before the next meeting, since I'll be out in the wilderness until Tuesday next week.
16:40:26 <eglute> hogepodge thank you! and have fun
16:40:47 <gema> yep, enjoy :D
16:40:49 <eglute> i will try to review it before next meeting
16:41:01 <Rockyg> definitely, enjoy!
16:41:43 <hogepodge> That's all I have
16:41:49 <eglute> anyone already had a chance to review WIP and have comments?
16:42:15 * markvoelker already left some comments
16:42:26 <eglute> thanks markvoelker
16:42:33 <eglute> next topic?
16:42:40 <eglute> #topic RefStack
16:42:44 <eglute> catherine_d|1 all yours!
16:42:54 <eglute> #link https://review.openstack.org/#/c/353903/
16:42:54 <catherine_d|1> eglute: thx
16:43:36 <catherine_d|1> Everyone please help to review this patch ...
16:44:10 <catherine_d|1> The blueprint is based on hogepodge: 's requirement
16:45:36 <eglute> thanks catherine_d|1 i will review it later today
16:45:40 <catherine_d|1> We are actually on hold and may not have enought time to deliver the vendor/product feature for newton
16:45:44 <hogepodge> catherine_d|1: based on our design discussions on the first day in SA
16:45:45 <gema> will do tomorrow
16:46:25 <Rockyg> I'll do it today or tomorrow.
16:47:16 <catherine_d|1> Thank you everyone ...
16:47:23 <eglute> anything else catherine_d|1?
16:47:40 <catherine_d|1> that is it ...
16:47:42 <eglute> #topic Tempest.conf documentation
16:47:50 <eglute> gema all yours!
16:48:14 <gema> so I am starting to run defcore tests on our new clouds and I have engineers asking me for the "right configuration" to run our tests
16:48:28 <gema> for example, yesterday I got a run back that had 40 tests (out of 99) executed
16:48:51 <gema> so I thought it is the perfect time for me to document how to write a good tempest.conf for defcore for my team and for everyone else
16:48:56 <hogepodge> gema: can you create an etherpad to start building the document from? I can add a bunch of configuration items
16:49:02 <gema> yep
16:49:31 <gema> #link https://etherpad.openstack.org/p/defcore-tempest-configuration
16:49:45 <gema> if you put there what you have from the top of your head and catherine does the same
16:49:55 <gema> I will go through a few rounds of testing and get it documented
16:50:03 <gema> the question is, where does this document belong?
16:50:09 <gema> in defcore or refstack?
16:50:15 <eglute> gema can you send this to the mailing list as well? asking for collaboration?
16:50:20 <gema> yep
16:50:23 <gema> will do
16:50:27 <eglute> I think refstack?
16:50:32 <eglute> thank you gema
16:50:35 <gema> yw
16:50:45 <gema> thank you all for your help
16:51:02 <eglute> i am not opposed to having it in defcore, but i think refstack might be a better fit
16:51:20 <gema> ok , I will coordinate with catherine_d|1 on where to put it then
16:51:21 <eglute> catherine_d|1 what do you think
16:51:48 <Rockyg> The doc should get published, so where is th best plac for it to live once public?
16:52:42 <eglute> hogepodge markvoelker what do you think?
16:52:47 <luzC> @Rockyg I think it can live on Refstack
16:52:48 <catherine_d|1> I always have a mix feeling on tempest conf ... if it is in RefStack it should be a working tempest ... if it is in DefCore it is reference doc in my mind ...
16:53:01 <luzC> but it will be a good contribution to Tempest docs too
16:53:20 <gema> luzC: isn't that too specific to live in tempest?
16:53:31 <catherine_d|1> a working tempest.conf means it will work for all cases ... and I am not sure that can be achieved
16:53:47 <gema> catherine_d|1: agreed, some bits will be specific to each cloud
16:53:59 <eglute> interop for tempest should be a thing
16:54:04 <catherine_d|1> and each clouds implementation
16:54:24 <gema> true, but we are documenting the things that are common
16:54:28 <gema> and very specific to tempest
16:54:32 <markvoelker> I'd suggest we just start compiling the info the wiki and we'll think through what/if we should publish it in a more formal format once we see what we've got.
16:54:40 <gema> trying to lower the barrier to entry to run tempest
16:54:45 <eglute> markvoelker that works for me
16:54:46 <gema> for an end user
16:55:01 <gema> markvoelker: sounds good to me
16:55:23 <eglute> gema +1 on lowering the entry to run tempest. i think it is super important
16:55:36 <eglute> last topic before we run out of time
16:55:41 <eglute> #topic next week
16:55:53 <eglute> there are some events next week that people might be attending
16:55:55 <hogepodge> eglute: I don't feel strongly about where it lives, but having a reference to point users to is helpful
16:56:05 <catherine_d|1> hogepodge: ++
16:56:16 <eglute> does anyone plan on NOT attending the meeting next week?
16:56:27 <markvoelker> I'll be at OpenStack East in Manhattan. So, not wilderness exactly but wild lands to say the least.
16:56:33 <eglute> if most people are here, it will meeting as usual
16:56:34 <hogepodge> I'll be available, but am ok with taking a break
16:56:51 <eglute> markvoelker hehe, same email brought it to my attention
16:57:02 <eglute> so break next week? or meeting?
16:57:11 <gema> summer break!
16:57:31 <luzC> @gema +1
16:57:33 <markvoelker> Break is fine with me. We'll have some folks away and most of what we're doing right now is iterating in gerrit.
16:57:42 <eglute> ok, summer break it is!
16:57:46 <gema> thanks :D
16:57:51 <eglute> #action eglute to cancel next week's meeting
16:58:18 <Rockyg> I'm at QSEast, too.
16:58:26 <eglute> #action everyone review gerrit issues this week that are needed for next week, please!
16:58:50 <eglute> thanks everyone! see you all here in 2 weeks then!
16:58:59 <Rockyg> thanks
16:59:06 <eglute> #endmeeting