17:00:38 <kiall> #startmeeting designate
17:00:39 <openstack> Meeting started Wed Sep 11 17:00:38 2013 UTC and is due to finish in 60 minutes.  The chair is kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:42 <openstack> The meeting name has been set to 'designate'
17:00:50 <kiall> Heya
17:00:56 <simonmcc> yo
17:00:58 <kiall> Who's about?
17:01:00 <msisk> Howdy!
17:01:00 <eankutse> eankutse here
17:01:07 <betsy> here
17:01:28 <kiall> mugise is AFK today, he had another commitment this evening
17:01:41 <eankutse> k
17:02:11 <kiall> So - There's no written agenda for today,  as until today there was very little to discuss
17:02:23 <jmcbride> reporting for duty!
17:02:39 <kiall> But - I've just pushed up the first part of the V2 API RecordSet support.
17:02:44 <kiall> So - Progress :D
17:03:02 <eankutse> saw that.
17:03:11 <eankutse> planing to review
17:03:20 <eankutse> Learn
17:03:35 <jmcbride> also, I noticed the "Future meeting" section on https://wiki.openstack.org/wiki/Meetings/DNSaaS#DNSaaS_Meetings has 2 items
17:04:01 <kiall> I've, so far, just managed to get the storage layer updated to manage RecordSets - I'll likely have the bones of the V2 RecordSets API in there by this time tomorrow, and adapting the V1 API to work again after that..
17:04:10 <kiall> jmcbride: ah - I missed those
17:04:42 <kiall> So - Anyway, I just wanted to get that out there..
17:04:56 <tsimmons> That
17:05:05 <tsimmons> 's great it'll be good to play with V2 :)
17:05:13 <kiall> Soon :)
17:05:40 <kiall> Before we move to the other two items, I've see two draft reviews from the RAX. Both are looking good :)
17:05:52 <kiall> Looking forward to the final reviews :
17:05:55 <kiall> :D*
17:06:28 <kiall> #topic Incubation Vote - When we do go for it?
17:06:55 <kiall> I'm not sure who added this one, are they about?
17:07:32 <kiall> Guess not :)
17:07:44 <jmcbride> I don't know, but I have some thoughts to discuss
17:08:17 <kiall> So - I think the best time is during the switchover between two dev cycles, i.e as Icehouse starts, or "J" starts
17:08:26 <jmcbride> Some time ago I had a chance to review the notes from the actual meeting, seems like the biggest item was the need for more contributors, amirite?
17:08:36 <kiall> jmcbride: absolutly
17:09:22 <jmcbride> I know RAX has had some recent contributions — but I'm not convinced it is sufficient, but I don't know what is the magic number.
17:09:57 <kiall> jmcbride: right, I don't think there is a magic number.
17:10:05 <kiall> https://github.com/stackforge/designate/graphs/contributors <-- I think this is what they used for the #'s
17:10:38 <jmcbride> kiall: You are a pretty busy fellow ;)
17:10:48 <kiall> So - Havana ends/Icehouse starts in about a Month (17th Oct or so)
17:11:23 <kiall> I reckon we take another look at Incubation just after the Design Summit
17:11:38 <tsimmons> That seems reasonable.
17:11:40 <jmcbride> What will be different at that time?
17:12:43 <kiall> jmcbride: we'll, you RAX guys have commits in, more in the pipeline, Graham is now familar enough with Designate to actually start writing code etc .. So Given ~2 months from now, hopefully the numbers will be "enough different"
17:13:07 <kiall> And - I'm saying we revisit the issue and decide on a yay or nay for applying...
17:13:48 <jmcbride> Makes sense. Do they ever look at the number of project committers/reviewers?
17:14:12 <jmcbride> (I mean *official project committers/reviewers)
17:14:14 <kiall> as in, checking up on the #'s every so often? I'm not sure
17:14:51 <kiall> Ah.
17:15:27 <kiall> So - No, they, to my understanding don't care so much about who's core, just who's knowledgeable enough to take over should a bus hit the core team ;)
17:16:21 <jmcbride> that would have to be one helluva bus (would need to fly/float!)
17:16:54 * CaptTofu is here (late)
17:16:55 <jmcbride> I like the idea of waiting 2 months.
17:17:00 <kiall> Anyway - I reckon the #'s will have changed enough by then, that at the very least it will be worth considering.. and chatting with the PPB about there thoughts..
17:17:26 <kiall> (or whatever they call themselves now.. I think the "PPB" name is out ;))
17:18:25 <kiall> #action kiall to add an future agenda item for post-summit to review incubation
17:18:42 <kiall> Shall we move on? :)
17:19:06 <tsimmons> Sure.
17:19:06 <eankutse1> yes
17:19:25 <kiall> It's a pity mugsie is AFK, as this next one has ended up tied into the async work he's doing. I'll do my best to explain :)
17:19:27 <kiall> #topic New Agent Architecture
17:20:12 <kiall> So, Last week we discussed the async architecture.. After that chat, Graham found a bunch of holes in the plan
17:20:52 <kiall> Specifically around the handling of multiple contradictory async requests at the same time..
17:21:17 <kiall> i.e. create zone, followed immediately by delete zone.. If the ordering ending up incorrect, things are left inconsistent.
17:21:47 <eankutse1> This also involves the ticket idea right?
17:21:54 <kiall> Yea
17:22:01 <kiall> So, the current plan (forgive me for being brief .. Graham knows all the details on this) goes something like this:
17:22:37 <kiall> 1) We need a single service instance responsible for a given zone, otherwise we simply can't guarantee FIFO.
17:23:35 <eankutse1> k. So Graham is still planning to document the architecture right?
17:23:51 <kiall> Yea - Just it had to be re-written totally
17:24:06 <kiall> So, "agent" will be renamed to a "pool manager" - it's responsible for handling backend changes for all the zones in a given pool, with Active/Standy for HA
17:24:06 <eankutse1> That would help us understand and provide input
17:25:01 <kiall> The pool manager will be the "thing" that interacts with the backend classes, and hence will give a single place to control the zone changes
17:25:31 <kiall> This solves all sorts of issues, and add's a feature we've been taking about since before the project was open source ;)
17:25:59 <tsimmons> So central would send messages about what it would like to do to the pool manager, who would actually perform those changes to the various backends?
17:26:25 <kiall> 2) Interactions between central and pool manager are entirely async, and it's the pool managers responsibility to tell central "this change is complete, and live.." which triggers the PENDING->ACTIVE switch
17:26:33 <kiall> tsimmons: yes
17:27:09 <kiall> The backend would be free to choose "how" to distribute the changes to all the DNS servers..
17:27:22 <tsimmons> That makes a lot of sense.
17:27:55 <kiall> It could be a simple DB insert like PowerDNS, NFS for Bind9 zones, remote rndc for Bind9 etc
17:29:30 <kiall> That leaves us with only 1 instance of the pool manager responsible for a single domain, using a simple lock, we can (mostly) guarantee FIFO
17:30:37 <kiall> Should we end up with out of order requests, as determined by the zone serial number passed to the pool manager, we can trigger a resync zone.. Graham was doing some testing today to see how often this is likely to happen in the "real world"
17:31:10 <kiall> 3) For small installs, or simple dev installs, we'll follow what nova-conductor did..
17:31:33 <kiall> The poolmanager will be either standalone as a full service, or "embedded" into central.
17:31:53 <kiall> (We already essentually do this will all our services during the tests)
17:32:25 <kiall> And - Other than the flow diagrams etc Graham's shown me, That's about all I can probably explain in IRC :)
17:33:54 <jmcbride> Thanks for the summary.  It will help to see the document/diagrams to complete the full picture
17:34:21 <eankutse1> Kiall: thx for updates
17:34:31 <kiall> A few months back, RAX and HP had a intro call.. One of the big issues I mentioned back there was the correct handling of contradictory changes coming in at the same time, along with the inability to have a salable way to emit "exits" events for metering and billing/ceilometer .. Graham's plan solves both of these, while putting us on the path to supporting multiple pools at the same time :)
17:35:11 <kiall> The plan is the start with a feature incomplete version of pools, i.e. max 1 pool, similar to today.. Later, that will extend to schedule zones over a group of pools.
17:36:56 <kiall> So - That ends the agenda items...
17:36:58 <kiall> #topic Open discussion
17:37:22 <kiall> Anything else from anyone else? :)
17:38:01 <tsimmons> Kiall: I'd like to have some time to talk to you a little more about my draft, probably offline.
17:38:22 <kiall> tsimmons: sure, anytime
17:38:40 <simonmcc> nothing from me
17:38:50 <kiall> I'll likely be around late tonight, as I'm wanting to get another chunk of the V2 API RecordSet change in
17:39:15 <tsimmons> Cool, I'll be in the IRC the rest of the day.
17:39:38 <kiall> Cool - I'll ping you once I've made it home and had some dinner :)
17:39:48 <tsimmons> Great :)
17:40:31 <kiall_> Got disconnected there.
17:40:37 <eankutse1> nothing else from me
17:40:46 <betsy> me either
17:41:00 <tsimmons> We could follow up on some of the action items from a couple of meetings ago quickly.
17:41:13 <kiall> tsimmons: sire
17:41:15 <kiall> sure*
17:41:35 <tsimmons> I'll just paste them in. Some aren't as relevant now as they were then.
17:41:37 <tsimmons> * ACTION: New doc section to be added for backend specific, starting
17:41:37 <tsimmons> with CaptTofu's mysqlbind docs..  (kiall, 17:27:48)
17:41:37 <tsimmons> * ACTION: Add doc section on plain bind9 backend, including agent
17:41:37 <tsimmons> limitations..  (kiall, 17:30:34)
17:41:37 <tsimmons> * ACTION: Get a blueprint together discussing the future of the agent,
17:41:38 <tsimmons> and how it will interact with API v2's "server pools"  (kiall,
17:41:38 <tsimmons> 17:31:03)
17:41:39 <tsimmons> * ACTION: add usage example for python-designate cli  (simonmcc,
17:41:39 <tsimmons> 17:36:45)
17:41:40 <tsimmons> * ACTION: Document designateclient python bindings..  (kiall,
17:41:40 <tsimmons> 17:39:57)
17:42:34 <simonmcc> Thanks tsimmons I had forgotten about that, I was working on the designate cli today, let me put that back on the todo list
17:43:48 <kiall> Okay - the agent limitations part of #2 is now defunct by Graham's new plan, and as with simonmcc, totally forgot about the other parts! Apologies. I'll get the bind9 docs in order, tomorrow AM, and we can update them when the latest bind9 review goes in.
17:43:58 <CaptTofu> gah, reminder I need to do docs
17:44:21 <kiall> Hah - As you can tell, busy isn't word for life at HP! :)
17:44:34 <CaptTofu> there is no english word for it.
17:44:51 <kiall> re the client, I'll get the usage docs copied from our wiki tonight, and and bindings.. sometime this week.
17:45:07 <kiall> #action kiall - Add new static agenda topic: "Review last weeks action items"
17:45:37 <kiall> Hopefully ^ will prevent future forgetfulness :)
17:46:03 <tsimmons> Yeah, we know some of this stuff isn't of max importance for you guys, but we really appreciate all of it :)
17:46:04 <betsy> :)
17:46:33 <kiall> tsimmons: absolutely - time is the only thing we can't make more of (yet ;))
17:47:27 <kiall> #action kiall review all previous action items, include anything incomplete on the next agenda
17:48:32 <kiall> Okay - So, we'll get ^ covered off.. and make sure we review the items each week.
17:48:56 <kiall> Have we got anything else before we close out? :)
17:49:05 <tsimmons> Not me.
17:49:29 <kiall> tsimmons: also, i'm not sure if this sent earlier..  But I'll ping you once I'm home, fed and back online in a few hours re your draft...
17:49:38 <kiall> (sent it right as I disconnected)
17:49:49 <tsimmons> kiall: yep, got it.
17:50:18 <kiall> Okay .. Thanks all :) Let's call it a day, a whole 10 minutes early ;)
17:50:34 <eankutse1> :-)
17:50:36 <tsimmons> Alright, thanks guys!
17:50:37 <kiall> #endmeeting