17:00:19 <kiall> #startmeeting Designate
17:00:20 <openstack> Meeting started Wed Nov 20 17:00:19 2013 UTC and is due to finish in 60 minutes.  The chair is kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:23 <openstack> The meeting name has been set to 'designate'
17:00:35 <kiall> Agenda: https://wiki.openstack.org/wiki/Meetings/Designate
17:00:40 <kiall> Who's about?
17:00:51 <msisk> Here.
17:00:56 <eankutse> here
17:01:00 <mugsie> here
17:01:18 <tsimmons> Here. (sort of, in class)
17:01:38 <kiall> Looks like we're short a few .. ekarlso / simonmcc about?
17:01:46 <artom> Here.
17:01:48 <simonmcc> here
17:01:52 <kiall> Anyway - Let's start :)
17:01:57 <kiall> #topic Review action items from last week
17:02:27 <kiall> Two items from last week, both for me: place incubation on agenda (done..) .. and put agenda up before the day of the meet (done!)
17:02:50 <eankutse> great!
17:02:50 <kiall> #topic Incubation Discussion
17:02:54 <eankutse> :-)
17:03:12 <kiall> So - It's been a while since we last discussed this.
17:03:23 <kiall> (IRC lag is awful today :/)
17:03:53 <mugsie> do we have a page done up for this?
17:04:02 <kiall> I believe we should discuss the merits today, and have a quick vote next week.
17:04:12 <mugsie> cool
17:04:15 <kiall> mugsie: no, the logs from today should probably be turned into one though
17:04:49 <kiall> So - The key reasons we didn't get the +1 for incubation last time, was the # of people involved was too low ..
17:05:54 <kiall> What do people think? Are we at a point yet where we can reapply and not get knocked down due to ^ again?
17:06:14 <artom> What's enough people according to them?
17:06:19 <simonmcc> so we have 3 major orgs involved now?
17:06:38 <kiall> artom: there wasn't a specific #
17:06:46 <jmcbride> We also have a fella from Redhat in Austin this week that wanted to meet with us about Designate
17:07:10 <artom> kiall, heh, so we don't know what to aim for.
17:07:16 <vinod1> That makes it 4 orgs.  Should be good to reapply I think
17:07:16 <kiall> jmcbride: cool, do you happen to know the name?
17:07:20 <kiall> artom: pretty much :)
17:07:32 <artom> Conversely, how many people/orgs came onboard since that verdict?
17:07:47 <kiall> 2 (3 if you include vinod1's RH suggestion)
17:07:54 <mugsie> I am not sure... what have other groups who have gotten incubated had?
17:07:56 <jmcbride> Kiall: The fella from Redhat's name is Alex Barreto
17:07:56 <kiall> Previousally, it was just HP, and really just me
17:08:34 <kiall> Humm - That doesn't sound like the RH guy I was speaking to in Hong Kong. Anyway, sidetrack :)
17:08:40 <artom> Well there's RAX now, and eNovance, though I'm pretty alone over here.
17:08:47 <jmcbride> would it make sense to informally chat with the folks that were on the incubation review to see their current thoughts?
17:08:59 <mugsie> yeah, i think thats a good idea
17:09:16 <mugsie> they could give guidence for what others have had
17:09:49 <kiall> jmcbride: absolutely, but, I think we should have a Yay or Nay amongst ourselves first
17:10:22 <jmcbride> what do we have to lose with a "yay"?
17:10:55 <mugsie> isn't it difficult to reapply again if we get a no, right?
17:11:02 <kiall> jmcbride: lots :) We don't want to be rejected a second time, so we need to feel that we're ready, regardless of what others think!
17:11:31 <jmcbride> good point.
17:11:36 <artom> Well, over here at eNovance it's not yet deployed in production.
17:11:50 <artom> So to err on the cautious side, I'd say nay just for that.
17:11:53 <simonmcc> I'm beginning to wonder what incubation actually gets us
17:12:01 <artom> Does RAX have a prod deployment?
17:12:10 <jmcbride> seems to me that before voting, it would be nice to hear back from an informal chat with the  incubation folks
17:12:14 <jmcbride> Rackspace does not.
17:12:17 <simonmcc> artom - that's a good point AFAIK, HP is the only prod designate
17:12:19 <kiall> simonmcc: more users, developers, etc
17:12:42 <artom> Maybe wait until it's deployed in prod in more places then?
17:12:45 <kiall> there are a few other designate deploys - none contributors though
17:13:00 <artom> Or perhaps contributing deploys.
17:13:02 <mugsie> right, i think that is agood benchmark
17:13:11 * kiall would need to look through a years worth of IRC logs to find the details though
17:13:25 <mugsie> 2 -3 more contributing deploys
17:13:26 <simonmcc> I'm with artom, a few more production environments would be a strong case
17:14:17 <kiall> I think I agree, but I'm not sure when that will happen, so I'm not convinced
17:15:07 <simonmcc> does RAX or eNovance have a timeline, even if they can't publish it?
17:15:33 <artom> There's traction over here for a prod deployment, but since everyone has a million other things to do, it's hard to concretise and move forward.
17:15:50 <eankutse> We are currently looking at feature parity (maybe API v2) to start some deployment
17:15:54 <eankutse> no specific time
17:15:57 <eankutse> yet tho
17:16:29 <kiall> Applying for incubation is encouraged to be done at the beginning of a development cycle, which is now-ish, 6 months from now, 12 months from now etc etc
17:16:50 <jmcbride> I just chatted with the DB project (trove)
17:17:08 <jmcbride> When they applied for incubation, they only had two organizations (Rackspace and HP)
17:17:27 <jmcbride> two orgs contributing to the code.  Only one of them had an actual deployment.
17:17:41 <mugsie> jmcbride: it was 2 production deploys though, wasnt it?
17:17:49 <mugsie> ah..
17:17:57 <kiall> HP had it in beta, RAX in production
17:18:24 <ekarlso> start deployment of what ? trove?
17:18:35 <ekarlso> sorry didn't follow too closely
17:18:40 <kiall> ekarlso: discussing incubation
17:18:57 <kiall> jmcbride just had a quick chat with the trove folks sitting next to him ;)
17:19:07 <ekarlso> ah, RAX doesn't use trove ?
17:19:18 <kiall> Yes - they do
17:19:24 <kiall> Anyway - total sidetrack :)
17:19:35 <ekarlso> ok ;)
17:20:09 <eankutse> So are there also technical requirements that Designate would have to meeting for incubation and are we ready with those?
17:20:30 <jmcbride> here is the document the trove (formerly known as Reddwarf) folks put together: https://wiki.openstack.org/wiki/ReddwarfAppliesForIncubation
17:21:00 <kiall> eankutse: yes/no .. I believe things are changing slightly now so some tech requirements must be met before applying, but I also think we meet most of them
17:21:30 <eankutse> k
17:21:33 <kiall> e.g. automated testing via jenkins/gerrit, devstack integration (we have a DS fork with that..) etc
17:21:45 <kiall> #link https://wiki.openstack.org/wiki/Designate_Incubation_Application
17:21:51 <kiall> #link https://wiki.openstack.org/wiki/Designate_Incubation_Application
17:22:04 <kiall> First link ^ is our original application
17:22:05 <jmcbride> This part in particular is probably something we need to address regarding number of contributors: https://wiki.openstack.org/wiki/ReddwarfAppliesForIncubation#Other_project_developers_and_qualifications:
17:22:24 <kiall> (Probably needs some updating ;))
17:22:31 <eankutse> Kiall: both links are the same
17:22:42 <kiall> eankutse: lol.. whoops :)
17:22:48 <kiall> #link https://wiki.openstack.org/wiki/Designate_Incubation_Application
17:22:59 <kiall> (easier to find the links in the summary ^ way)
17:23:17 <kiall> OMG
17:23:27 <kiall> #link https://wiki.openstack.org/wiki/ReddwarfAppliesForIncubation
17:23:29 <kiall> finally ;)
17:23:33 <eankutse> :-)
17:25:19 <kiall> So. What are peoples gut feelings - Is it time? or wait for some condition, or wait so some period of time? (Not a vote - We'll vote next week, after getting a chance to discuss with others outside this room..)
17:25:41 <ekarlso> you need to have a certain number of tests etc before you can apply
17:25:55 <mugsie> I say wait, unless we get a good indication of passing in informal talks
17:26:08 <kiall> ekarlso: That seems like a really arbitrary requirement - link? ;)
17:26:27 <mugsie> we do have the advantage that we had quite a bit of coverage in HK, and were in the OpenStack newsletter this week
17:26:31 <eankutse> I suggest we open up a wiki page where we can document what we find as requirements over the next week and then use that as one of the inputs to voting later
17:26:44 <jmcbride> How many developers with contributions do we have?
17:26:48 <kiall> #link https://wiki.openstack.org/wiki/Governance/NewProjects
17:27:04 <kiall> jmcbride: if you believe GitHub, 16..
17:27:11 <ekarlso> nvm me kiall
17:27:25 <jmcbride> trove (reddwarf) had 17
17:28:15 <simonmcc> ekarlso are you referring to this: https://etherpad.openstack.org/p/incubation-requirements (from this thread: http://lists.openstack.org/pipermail/openstack-tc/2013-November/000404.html)
17:28:18 <kiall> jmcbride: were all of those active?
17:28:30 <jmcbride> kiall: I don't know, let me ask.
17:28:54 <ekarlso> don't know of emails or such, just remember a discussion in #-infra
17:29:38 <kiall> According to GitHub - Trove currently has 41 .. Still not sure I believe GH's numbers though
17:30:05 <mugsie> #link https://wiki.openstack.org/wiki/Designate/Incubation_Discussion
17:30:18 <mugsie> created the wiki page for people to put thoughts into later on ^
17:30:23 <kiall> Thanks mugsie
17:30:52 <eankutse> mugsie: thx
17:30:56 <kiall> mugsie: can you summarize the logs after this meet onto that page?
17:31:07 <simonmcc> looks like at least one other project is applying for incubation on this cycle: http://lists.openstack.org/pipermail/openstack-tc/2013-November/000414.html (Manila)
17:31:09 <kiall> Then, we can continue adding etc
17:31:12 <mugsie> yup, action me on it will you?
17:31:20 * kiall has never heard of Manila
17:31:33 <ekarlso> http://stackalytics.com/?release=havana&metric=commits&project_type=all&module=trove&company=&user_id=
17:31:59 <ekarlso> that's 40 engineers during havana
17:32:16 <ekarlso> 10 until now for IH
17:32:50 <simonmcc> line 31 onwards of this is interesting: https://etherpad.openstack.org/p/ManilaIncubationApplication
17:33:00 <kiall> Okay - How about, we summarize thoughts so far on that wiki page, have a chat with some TC folks, and come back next week?
17:33:26 <simonmcc> ok
17:33:29 <kiall> heh - cice find simonmcc  :)
17:33:33 <kiall> nice*
17:34:01 <eankutse> agree
17:34:16 <kiall> #action kiall put Incubation back on agenda for next week.
17:34:34 <kiall> #action Reach out to some TC folks for opinions
17:34:50 <jmcbride> kiall: the trove folks invited everyone on the project to add their names to the incubation application list
17:35:08 <artom> Wat.
17:35:08 <jmcbride> individuals were responsible for adding themselves if they thought they were contributors.
17:35:34 <kiall> jmcbride: okay - I suppose that makes sense!
17:36:36 <kiall> Okay - I think we pause here, and move on to the next topic. We'll summarize to Grahams wiki page and discuss again next week. Any final comments before we do?
17:36:57 <jmcbride> The trovians also said that "project developers" is not clearly defined. If you have folks that are working on a deployment but not necessarily contributing code - they probably fit the definition.
17:37:35 <kiall> That explains 1 or 2 of the names I noticed in there ;)
17:37:58 <russellb> note that it's just just a raw number
17:38:02 <russellb> it's how  many are actively participating
17:38:13 <russellb> not just how many have submitted a patch or two
17:38:23 <kiall> russellb: heya :)
17:38:25 <russellb> not* just a raw number
17:39:12 <russellb> also, we're working on coming up with a much clearer definition of the TC's expectations: http://lists.openstack.org/pipermail/openstack-tc/2013-November/000415.html
17:40:33 <kiall> Excellent - We'll have to read up on those, I assume these came out of summit discussions?
17:40:59 <artom> I think some of those still need clarification.
17:41:01 <artom> Ex: "Project should have a diverse and active team of contributors"
17:41:18 <kiall> russellb: I might ping you tomorrow with some Q's, and seeking some opinions. If you don't mind?
17:42:09 <russellb> sounds great
17:42:14 <russellb> it's still a work in progress
17:42:23 <russellb> the docs are just being started
17:42:35 <russellb> but just letting you guys know that we recognize that more clarification is needed, and we're working to resolve that
17:42:35 <jmcbride> russellb: no doubt, it just updated before my eyes ;)
17:42:47 <russellb> and hopefully will have something in the coming weeks
17:43:05 <artom> Awesome :)
17:43:07 <mugsie> cool
17:43:22 <kiall> Okay - I think that's a pretty good reason to simply wait another few weeks before deciding
17:43:46 <mugsie> ##agreed
17:43:52 <russellb> yeah, i think if you applied, we'd probably want to wait a few weeks while we settle on criteria
17:43:52 <kiall> Anyone disagree?
17:43:52 <artom> #link https://etherpad.openstack.org/p/incubation-requirements
17:44:13 <tsimmons> Sounds reasonable.
17:44:27 <eankutse> We definitely could use some time
17:44:29 <simonmcc> waiting sounds the best plan
17:44:32 <kiall> Great - Let's move on so!
17:44:39 <kiall> Thanks russellb + everyone :)
17:44:43 <kiall> #topic Blueprint Backlog - Prioritization
17:44:45 <kiall> over to you mugsie
17:44:54 <russellb> np
17:44:55 <mugsie> thanks
17:45:34 <mugsie> basically, there is a lot of blueprints sitting in launchpad, and i think we should at somepoint in the near future go through them
17:45:53 <betsy> mugsie: good idea
17:45:58 <mugsie> decides the priorities, ordering, and if they are requried at all
17:46:10 <eankutse> agree
17:46:28 <mugsie> I would suggest a separate meeting one day next week, where we can do bp's item by item
17:46:40 <mugsie> (or the week after)
17:46:54 <kiall> That's probably a good idea - we're short on time as is
17:46:54 <betsy> Next week is Thanksgiving week here. :)
17:47:05 <mugsie> well, that would not be a good idea then :)
17:47:11 <mugsie> week after?
17:47:18 <betsy> sounds good to me
17:47:48 <mugsie> IRC, or VC (Google Hangouts etc)?
17:48:20 <eankutse> fine with me
17:48:26 <eankutse> would prefer VC
17:48:27 <artom> 20 bps...
17:48:34 <artom> How long can each one take?
17:48:39 <artom> IRC is obviously slower
17:48:39 <kiall> I'm easy - Just AFK Friday/Monday of this week
17:49:14 <mugsie> i reckon, some will be 30 seconds, some will be 5 mins...
17:49:16 <mugsie> not long overall
17:49:31 <mugsie> I will set a date, and let everyone know then?
17:49:42 <artom> OK for me.
17:50:07 <kiall> mugsie: need emails addresses for anyone to organize a time?
17:50:13 <mugsie> Are people ok with google hangouts? best one i have found for larger groups
17:50:19 <mugsie> and yes, what kiall said
17:50:25 <mugsie> or we could use the -dev mailing list
17:50:37 <mugsie> but do we want to?
17:51:14 <kiall> I think, for this case, we probably want to keep the call just for those of us involved.
17:51:21 <mugsie> cool.
17:51:25 <eankutse> i think so too
17:51:40 <mugsie> best thing, people email me? graham.hayes@hp.com
17:51:40 <eankutse> i can give my email here if that's fine
17:51:55 <eankutse> ok. Will email mugsie
17:52:17 <kiall> #action mugsie to organize VC for BP backlog review and general planning
17:52:39 <tsimmons> Sure. That works. Availability for Dec 2 - Dec 6?
17:52:56 <kiall> Please email him so we can get everyone on 1 thread to organize the whole timezone and scheduling malarky :)
17:53:28 <kiall> Okay - Moving very very quickly on!
17:53:29 <kiall> #topic Blueprint Standards
17:53:45 <mugsie> basicly, tying in with the last topic
17:53:47 <kiall> mugsie suggested this item too .. (and I know I'm the worst offender)
17:54:19 <kiall> But - I think betsy's BP serves as a perfect template for what we *should* be doing .. https://wiki.openstack.org/wiki/Designate/Blueprints/Blacklist_API
17:54:33 <mugsie> have a minimum set of standards for a bp to be marked as accepted... I would suggest having a template wiki page, people can get started from
17:54:39 <betsy> :D
17:54:46 <mugsie> and yeah, betsy's is the one to aim for :)
17:54:59 * artom feels inadequate.
17:55:06 <kiall> betsy: you'll notice ekarlso's WIP blueprint is based on your template ;) https://wiki.openstack.org/wiki/Designate/Blueprints/Reverse
17:56:12 <mugsie> thats it really, I would suggest that i stick an example templte up, with a few guides, and we vote on it nxt week?
17:56:15 <artom> But then not all bps have APIs in them.
17:56:41 <kiall> artom: It's more about the level of detail, the intro paragraph  explaining the why etc rather than the API spec
17:57:01 <mugsie> yup, just an overview of general changes to the system
17:57:04 <kiall> Moving really really quickly on - 2 mins left..
17:57:07 <tsimmons> Sounds reasonable. It'll be good to them in a standard format.
17:57:14 <kiall> #topic Open Discussion
17:57:22 <kiall> Any other business?
17:57:33 <eankutse> Kiall: I know you've been busy but did you get the chance to look at APIv2 Filtering yet?
17:57:49 <kiall> ekarlso has a  WIP blueprint up at https://wiki.openstack.org/wiki/Designate/Blueprints/Reverse for handling floating IP reverse DNS. It's not complete, but feel free to ping either of us with Q's
17:58:13 <kiall> eankutse: I managed to get almost all of today on V2 stuff, but not filtering specifically.
17:58:28 <eankutse> k
17:58:40 <artom> OpenStack aims to be compatible with the AWS APIs, no?
17:58:50 <artom> Should Designate do the same with Route53?
17:58:54 <kiall> I'm getting to the point that I'm keeping email and chat closed so I can stay distraction free ;)
17:59:09 <mugsie> artom: i would say no
17:59:12 <hub_cap> kiall: half past
17:59:21 <betsy> artom: agree with mugsie
17:59:23 <kiall> hub_cap: that's right
17:59:41 <eankutse> kiall: cool. Hope you'll be successful on that :-). Looking fwd to the Filtering stuff when you get the chance
17:59:48 <kiall> artom: that's a whole other discussion - I'm of the opinion that we pay no attention to the R53 API. But - That's just me
17:59:56 <mugsie> mainly because it is a terrible API
18:00:19 <artom> Hehe, ok then. Was just asking :)
18:00:21 <betsy> I'm in full agreement with that.
18:00:29 <artom> Seems there's a strong consensus against it.
18:00:40 <betsy> ;)
18:00:48 <kiall> Okay - Times up. Thanks all! Please feel free to add agenda items onto the wiki for next week.
18:00:50 <kiall> #endmeeting