17:00:16 <kiall> #startmeeting designate
17:00:17 <openstack> Meeting started Wed Jan 22 17:00:16 2014 UTC and is due to finish in 60 minutes.  The chair is kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:20 <openstack> The meeting name has been set to 'designate'
17:00:31 <artom> o/
17:00:32 <kiall> Hey all - Who's about today?
17:00:36 <vinod1> here
17:00:38 <betsy> o/
17:00:46 <mugsie> o/
17:00:52 <kiall> Cool :)
17:00:54 <eankutse> here
17:01:29 <jmcbride> Good day folks!
17:01:54 <kiall> So - We have no pre-prepared agenda for today, With the mini-summit so close, I've been full steam ahead on some internal work. Trying to complete a good chunk of it before travelling
17:02:09 <mugsie> same ^
17:02:17 <kiall> #topic Review action items from last week
17:02:38 <kiall> so, we had 1 item from last .. "send email to Openstack mailing list"
17:02:44 <kiall> that was re the mini-summit
17:03:08 <kiall> jmcbride sent that during the week
17:03:08 <kiall> #link http://lists.openstack.org/pipermail/openstack-dev/2014-January/024862.html
17:03:25 <mugsie> any extra interest form that jmcbride ?
17:03:29 <kiall> jmcbride: did you get any response privately? or via eventbrite?
17:04:21 <jmcbride> so, mostly Redhat folks are now trickling in
17:04:26 <artom> I said I'd attend via Hangouts...
17:04:27 <jmcbride> but otherwise, I have not seen anything
17:04:38 <artom> Not sure how that will work out...
17:04:58 <jmcbride> I'll check our current registration
17:05:18 <kiall> artom: we'll be as inclusive as possible :)
17:05:34 <jmcbride> I have 10 folks registered.
17:05:50 <jmcbride> 1 red hatter has confirmed but not registered
17:05:57 <jmcbride> 2 are TBD in person attendance.
17:06:11 <kiall> Cool - So 10-13 in person?
17:06:31 <jmcbride> 14 if you include me.
17:06:44 <kiall> Cool :) This should be fun!
17:06:55 <betsy> I'm looking forward to it
17:06:56 <mugsie> yup
17:07:05 <jmcbride> yep.  I'm hoping to get some tasty austin lunch staples too, so keep your fingers crossed.
17:07:06 <kiall> I also see you've updated the agenda you wrote up
17:07:08 <kiall> #link https://etherpad.openstack.org/p/DesignateAustinWorkshop2014-01
17:07:22 <jmcbride> Yes, I was hoping to get feedback from you guys
17:07:58 <kiall> Looks good, I think on the morning of day 1 we can fill in the "Design sessions" topics, based on "Review Icehouse progress and start blueprint review"
17:08:10 <jmcbride> kiall: agreed
17:08:32 <kiall> #action kiall find 2 hours to write mini-dns spec ahead of time -_-
17:08:57 <kiall> I'm still on the fence over ^ - hence this would be a great time to discuss it ;)
17:08:58 <jmcbride> kiall: that would be great - or at least refine it in your head and we can do a bit of whiteboarding
17:09:12 <jmcbride> kiall: we also have some feedback for you on it
17:09:22 <artom> kiall, actually, about that... you want to discuss that now?
17:09:27 <ekarlso> hey folks
17:09:39 <kiall> myself and mugsie have had a few pub conversations about it, generally refining more each time, but I'm not sure I'm in a great position to articulate it correctly yet
17:10:06 <jmcbride> kiall: I'm adding it to the agenda to specifically address
17:10:08 <kiall> The act of writing it down should help get the final pieces cleared up
17:10:41 <kiall> Cool - Thanks Joe
17:11:29 <jmcbride> "The design sessions priorities" section is where you can add more topics you would like to address outside of icehouse
17:11:30 <kiall> So, other than HP and RAX folks, are there any other folks here today that will be there in person? or hangouts?
17:12:01 <jmcbride> If we have time left over, we can simply start at the top of all known blueprints and prioritize/discusss
17:12:03 <rjrjr_> i'll be on via hangout
17:12:21 <jmcbride> Artom will also be on hangout
17:12:45 <kiall> rjrjr_: Great :) So, we'll have a few via hangouts.
17:13:06 <artom> If you go out for food/beers, I'll bring my laptop to a local Irish pub ;)
17:13:11 <jmcbride> Rackspace will also have our DNS operations lead in person (Jason Bratton).
17:13:15 <ekarlso> I own't be there :p, hangout though !
17:13:20 <kiall> jmcbride: "If we have time left over," <-- you mean today, or in person?
17:13:31 <jmcbride> ekarlso, can you register so I know to expect you?
17:13:47 <jmcbride> ekarlso: in person during workshop
17:13:59 <jmcbride> ^kiall: in person during workshop
17:14:26 <jmcbride> I'm not sure I want to take you guys to an irish pub in Austin
17:14:35 <jmcbride> Your expectations will be TOO high!
17:14:37 <kiall> jmcbride: perfect :) The last week, myself / mugsie / ekarlso's heads has been been in Ops mode rather than Dev mode ;)
17:15:05 <mugsie> jmcbride: I learnt a long time ago about irish pubs abroad :)
17:15:19 <kiall> Yea - There always .. Interesting places ;)
17:15:34 <artom> Hey, having been in Scotland (not the same, I know) and here in Montreal... We're doing quite OK here :)
17:15:52 <jmcbride> nice, well, I'll try and find an Austin favorite that measure up...
17:16:08 <kiall> rjrjr_ / artom - Whats your TZ difference to Austin? And - Are they any topics you have a particular interest it?
17:16:21 <kiall> (To try and schedule those conversations for your working hours!)
17:16:33 <artom> I'm EST, so +1
17:16:41 <artom> Reverse DNS for me, mostly
17:16:48 <artom> Possible better BIND support
17:16:58 <rjrjr_> MST
17:17:25 <artom> It'll depend on what I get fed in my backlog and what gets decided, if anything
17:18:13 <jmcbride> Sweet, so you guys will be an hour in both directions timezone wise.  Will the proposed times be cool?
17:18:19 <kiall> Okay - rjrjr_ - could you add any topics (even if there listed on the page) that you're interested in to the bottom of https://etherpad.openstack.org/p/DesignateAustinWorkshop2014-01
17:18:35 <rjrjr_> yes
17:18:37 <kiall> artom: feel free to update what I put down for you ;)
17:19:03 <kiall> Thanks!
17:19:21 <vinod1> richm:  Are there any topics that you would be interested in?
17:19:40 <artom> kiall, sure, I'll keep that info fresh.
17:19:44 <jmcbride> richm - welcome, do you know if you will be able to make it (at least via hangout)
17:20:19 <jmcbride> artom & rjrjr_ - can you send me your google usernames?
17:21:14 <kiall> Let's take that as a yes ;) Otherwise mugsie has them
17:21:19 <rjrjr_> rjrjr@cox,net
17:21:43 <rjrjr_> yes
17:22:16 <jmcbride> One other note about next week priorities, a dev from our Load Balancer team will also be attending (his name is jorge). He has some ideas about "global load balancing".
17:23:05 <kiall> Worth mentioning - next weeks Wednesday IRC meeting will obviously be cancelled, as we'll have just wrapped up the few days in person .. Just making sure that's clear :)
17:23:26 <kiall> jmcbride: excellent :)
17:24:14 <kiall> Anyway - So, Since we have no pre-prepared agenda today, if anyone has anything to bring up, or that they want to discuss, jump in at any time please :)
17:24:51 <artom> Well, re mini-dns...
17:25:01 <artom> Or you want to save that for the workshop?
17:25:08 <kiall> betsy: you're Blacklisted Domains review, is that ready to look over? Last time i looked, you had left a comment saying "not ready yet" :)
17:25:28 <betsy> I've got some changes that I'll submit today and that should be it
17:25:46 <betsy> Sorry, but I've been ill
17:26:02 <kiall> artom: I think we need to get that written up, it's a complex idea with lots of tradeoffs.. And I know I personally still haven't quite got the idea clear in my head
17:26:07 <kiall> betsy: unacceptable ;)
17:26:14 <betsy> :)
17:26:32 <kiall> No worries - I just didn't want it to sit there ready for review for ages without getting looked at ;)
17:27:27 <kiall> Okay - Well, If nobody has anything else, we can call it a day?
17:27:57 <jmcbride> yep, have a great week, see ya'll in Austin!
17:28:05 <kiall> jmcbride: BTW
17:28:11 <eankutse> see you
17:28:17 <artom> kiall, well, I just have... an "alternative"?
17:28:29 <artom> Not comments about the idea itself.
17:28:55 <kiall> jmcbride: Myself and mugsie be in Austin on Sunday, and staying in the Radission .. Just FYI
17:29:02 <kiall> artom: an alternative?
17:29:43 <artom> Well, instead of implementing mini-dns, the same effect can be achieved by mandating the multi backend with a PowerDNS master.
17:29:47 <jmcbride> kiall: sweet, I emailed all attendees my contact info.  I might be able to slip away for dinner/drinks Sunday, so let me know.
17:30:17 <kiall> jmcbride: depends how tried we are ;) Land at like 6am or something.
17:31:06 <kiall> artom: That's certainly an option, but has some drawbacks in terms of the potential phase 2 features..
17:31:45 <kiall> Inbound AXFR, RFC / nsupdate Dynamic DNS, anything that modifies the content of the zone, would be really really awkward to fit into that model
17:32:29 <artom> Do we need to allow zone modification by means other than the API?
17:33:15 <kiall> I think we do, and I know rjrjr_ would agree ;) one of the pieces he discussed in the past was accepting RFC / nsupdate dynamic DNS updates
17:33:20 <eankutse> artom: we should not rule out use of nsupdate
17:33:38 <mugsie> afik redhat openshift needs it as well
17:33:42 <jmcbride> kiall/artom: regarding mini-DNS, I think it sounds feasible, but I think it will only work for use cases in which either zone transfers or dynamic dns protocol is supported.
17:33:49 <kiall> RedHat I'm sure are interested in that too - OpenShift / Origin requires a a RFC style dynamic DNS server
17:34:22 <artom> And so mini-dns would implement said RFC-style server?
17:34:42 <artom> And reflect any changes it receives via not-API in Designate's state?
17:34:45 <kiall> jmcbride: absolutely - this would never be a target of end user queries - that would be an epic failure waiting to happen IMHO ;)
17:35:39 <kiall> artom: yea, so, RFC dynamic DNS is actually quite simple to impelement (with the exception of transactional / atomic commits of whole changeset - but that's another topic to solve independently)
17:35:43 <jmcbride> kiall: agreed. My comment was targetted at how to get zone data transferred from master to slaves.
17:36:00 <kiall> When I say simple - I mean, simple once you have the other pieces in place
17:36:59 <jmcbride> kiall: I think we will benefit from that 2 hour homework assignment you gave yourself…
17:37:20 <kiall> jmcbride: and lots of RFC reading ;)
17:37:38 <jmcbride> kiall: before bed is the best time for that
17:37:55 <kiall> You'll never get past the first sentence that way
17:38:34 <rjrjr_> our mini-dns also needs to respond to refresh requests from slaves
17:38:48 <kiall> artom: Anyway - I know I see huge advantages by being able to alter the data we have via the standard DNS mechanisms, I think supporting that is key if we go with the "mini-dns" suggestion , or the enforce powerdns alternative route you suggested
17:39:18 <eankutse> Kiall: regarding RFC's that you plan to read
17:39:31 <eankutse> can you tell us which ones you plan to look at?
17:39:34 <kiall> eankutse: I meant you guys ;) I've read them all
17:39:37 <eankutse> I am interested as well
17:39:42 <eankutse> :-)
17:39:57 <eankutse> sleep reading RFC's?
17:40:19 <kiall> rfc1034, rfc1035, rfc2181 are some the main ones
17:40:25 <eankutse> cool
17:40:28 <artom> kiall, was just throwing the alternative out there. It seemed like mini-dns was reimplementing existing stuff for benefits that were unclear to me. But if we want storage <-> backend "bidirection" communications, I don't think we have the choice...
17:40:41 <kiall> 2136 is nsupdate / RFC style dynamic DNS
17:41:10 <artom> Unless we start doing funky stuff like polling the PowerDNS db to import changes into storage...
17:41:14 <kiall> Ehh - And I'm sure theres 100 others that aren't coming to mind right now
17:41:49 <eankutse> That's a good start
17:41:59 <eankutse> there'll be references from those to others
17:42:01 <kiall> artom: Well, powerDNS supports custom backends, lua based from memory, but we enter pretty dangerous territory there with ever becoming core OpenStack ;)
17:42:33 <artom> That's a whole other level of meta right there...
17:42:47 <kiall> And - Choosing PowerDNS as a core piece, as much as I like that idea, would likely be a roadblock for us over time as people have their favourite
17:42:49 <artom> "We put a backend in your backend so you can DNS while you DNS" ;)
17:43:11 <kiall> artom: hah :) Yep
17:43:36 <jmcbride> We should have a blueprint for the idea of supporting bidirectional updates (e.g. using dynamic DNS to update zones).
17:44:28 <kiall> oh eankutse .. rfc2845 would be another core piece.. providing a method of identification of users making queries etc to this
17:45:07 <jmcbride> http://i.imgur.com/kQ7DHB4.jpg
17:45:22 <kiall> lol
17:45:36 <artom> jmcbride, I didn't think anyone would actually do that :D
17:45:42 <artom> Bravo.
17:46:01 <kiall> artom: CloudFlare was (is?) based on PowerDNS and a custom backend for it ;)
17:46:10 <kiall> Okay - Well, I think it's time to wrap this up and call it a day :)
17:46:12 <eankutse> Kiall: thx. Keep them coming :-)
17:46:20 <kiall> hub_cap got here, so .. everyone leave please.
17:46:23 <kiall> ;)
17:46:28 <hub_cap> YEA BOI
17:46:48 <hub_cap> hi kiall ;) i totally saw a half past / half 30 thing on tv the other day
17:46:49 <artom> Hey, we got 15 more minutes officially, I intend to fill every last second with more memes :D
17:47:01 <kiall> Okay - Thanks all :) Cya next week !
17:47:12 <betsy> cya
17:47:18 <kiall> #endmeeting