17:01:16 <Kiall> #startmeeting designate
17:01:21 <openstack> Meeting started Wed Jun 11 17:01:16 2014 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:25 <openstack> The meeting name has been set to 'designate'
17:01:25 <Kiall> Hey Guys - Who's here today?
17:01:29 <richm> here
17:01:30 <betsy> o/
17:01:31 <rjrjr_> here
17:01:36 <timfreund> hello
17:01:37 <eankutse> here
17:01:44 <Kiall> mugsie is out today, so won't be here
17:02:03 <Kiall> #topic Review action items from last week (and the week before!)
17:02:08 <vinod> o/
17:02:37 <Kiall> first was mugsie to translate etherpads over to launchpad blueprints - he asked me to push this till next week
17:03:03 <Kiall> first from the week before was "eankutse to get initial answers to jbrattons questions" .. I just saw a draft of this from eankutse
17:03:15 <eankutse> yes. it's here #link http://paste.openstack.org/show/83671/
17:03:21 <Kiall> #link http://paste.openstack.org/show/83671/
17:03:26 <eankutse> but will put it in bp
17:03:29 <Kiall> beat me to it :)
17:03:33 <eankutse> :-)
17:04:05 <Kiall> Great - We'll be able to iterate on the answers once it's in there to get a good idea of what we need to allow for in mdns
17:04:12 <eankutse> sure
17:04:24 <Kiall> Next was "eankutse to pick Jbratton's brain on ops side of things for minidns/pools" .. Seems to me the previous item covered it
17:04:37 <eankutse> that;s the intent
17:05:28 <Kiall> Next two were "kiall to write our various initial load scenarios" and "kiall to file BP on exposing the NS (and SOA?) record in the V2 API" - And I've not had time this week :( Every spare minute was getting the devstack gate running right
17:05:50 <Kiall> #action kiall to file BP on exposing NS/SOA records in V2 API
17:06:00 <eankutse> saw all the commits you did :-)
17:06:09 <Kiall> #action kiall to write out mdns initial load scenarios and add to eankutse's BP
17:06:22 <Kiall> (I think your BP and those will be pretty related)
17:06:28 <eankutse> yes they are
17:06:42 <Kiall> Okay - That was all the actions we missed last week
17:06:55 <Kiall> #topic Mini DNS - is 'mdns-designate-mdns-functional' a place holder or explicit functionality? (eankutse)
17:07:06 <Kiall> (what a BP name, I apologize for that ;))
17:07:16 <eankutse> 1 sec
17:07:24 <Kiall> #link https://blueprints.launchpad.net/designate/+spec/mdns-designate-mdns-functional
17:07:31 <eankutse> yep
17:07:46 <eankutse> so
17:08:04 <eankutse> is this item standing on it's own?
17:08:12 <eankutse> or is it considered done when
17:08:15 <Kiall> So - My idea when I filed this BP was that, this would be where the skeleton designate-mdns service we now have turns from a skeleton to something useful - even if it's not all of mdns.
17:08:20 <eankutse> the items below it are done?
17:08:54 <Kiall> This would be where we actually get more than "SERVFAIL" and get real answers from mdns for simple queries - e.g. SOA lookups
17:09:10 <Kiall> (but not AXFR just yet, or TSIG sign requests)
17:09:20 <eankutse> ok.
17:09:45 <eankutse> so these would be things leading up to AXFR
17:09:48 <Kiall> If that doesn't make sense to anyone but me, we can add/remove BPs etc
17:09:50 <eankutse> and TSIG
17:10:02 <eankutse> ok.
17:10:03 <betsy> kiall: makes sense to me
17:10:07 <Kiall> eankutse: yea - that was my thinking when I split mdns up into a pile of BPs
17:10:27 <betsy> and leads to smaller patch submissions
17:10:33 <betsy> makes reviewing easier
17:10:54 <Kiall> Ideally, once this happens, and mdns can answer a simple SOA query, we can fork and have 3 people working on different things.. 1 getting AXFR working, 1 adding TSIG support, 1 writing the supporting code to send DNS notifies
17:11:12 <Kiall> (fork != github style fork ;))
17:11:26 <eankutse> cool
17:11:37 <Kiall> Oh .. There is 1 other BP blocking this one
17:11:42 <Kiall> #link https://blueprints.launchpad.net/designate/+spec/mdns-designate-mdns-dnspy-translations
17:12:24 <Kiall> That was intended to be where we would write out the "converter" methods to translate from our objects, over to dnspy's objects
17:12:27 <eankutse> i was thinking this would happen in pieces
17:12:34 <eankutse> as we implement the other functionality
17:12:39 <eankutse> eg NOTIFY,
17:12:41 <eankutse> SOA
17:12:43 <eankutse> AXFR
17:13:01 <eankutse> these would 'build up' this bp
17:13:07 <eankutse> as we go
17:13:24 <Kiall> e.g. translating an "A" designate.objects.Record to dns.rdata.a.A() (or w/e the dnspy class is called)
17:13:32 <vinod> Is the blue print mdns-designate-mdns-dnspy-translations different from https://blueprints.launchpad.net/designate/+spec/mdns-designate-mdns-notify?
17:13:38 <vinod> I would assume so
17:13:50 <vinod> The description for blueprint mdns-designate-mdns-dnspy-translations talks about NOTIFY
17:13:56 <Kiall> vinod: dooh - description is wrong
17:13:58 <Kiall> title*
17:14:10 <Kiall> copy and paste fail while filing all them
17:14:44 <Kiall> refresh please :)
17:14:45 <Kiall> https://blueprints.launchpad.net/designate/+spec/mdns-designate-mdns-dnspy-translations
17:15:08 <Kiall> That was my original intent for that BP - does that change things?
17:15:50 <tsimmons> (They're chatting)
17:16:09 <Kiall> lol - I was wondering ;)
17:16:41 <eankutse> so Kiall: what do you think about the piecemeal approach?
17:16:43 <vinod> I would think that it would be easier to do the translations as we use dnspython objects
17:17:05 <Kiall> vinod / eankutse sure - we can cross that BP out and do it bit by bit
17:17:13 <eankutse> I like that
17:17:36 <Kiall> and .. marked as obsolete.
17:17:46 <vinod> +1 on that
17:18:09 <Kiall> Anyone disagree before we move on?
17:18:42 <rjrjr_> i'm good.
17:18:45 <betsy> kiall: I liked your approach better, but I’m not the one doing the code.
17:18:46 <betsy> :)
17:18:49 <Kiall> lol
17:18:56 <betsy> So, I’m good
17:19:04 <richm> +1
17:19:28 <Kiall> I think getting 1 done before the meat of the mdns-functional done would be a good idea, all is likely not necessary
17:19:41 <Kiall> getting all done is likely not necessary*
17:20:00 <Kiall> Okay .. Moving on so :)
17:20:03 <Kiall> #topic DevStack (kiall)
17:20:20 <Kiall> I think everyone noticed the binge of DevStack patches ;)
17:20:28 <vinod> #action kiall Mark https://blueprints.launchpad.net/designate/+spec/mdns-designate-mdns-dnspy-translations as obsolete
17:20:31 <eankutse> :-)
17:20:32 <betsy> 3 cheers for Kiall!
17:20:51 <Kiall> it's not all cheers - I had to revert some stuff too :(
17:21:02 <vinod> So is all the devstack stuff done now?
17:21:04 <Kiall> https://github.com/stackforge/designate/commit/f205633c6303dd209ece20237ed60fa5043689da
17:21:35 <Kiall> That added some nice functionality which, sadly, broke when ran in the gate. as does https://review.openstack.org/#/c/97628/
17:22:18 <Kiall> We're going to have to figure out what exactly is breaking so we can get them merged.. I'm frankly stumped on the first one.. and just confused on why unbound is ending up installed, preventing the second one
17:22:50 <Kiall> richm: any chance you were able to identify how/why unbound was ending up installed?
17:24:14 <vinod> Is it being installed by one of the other projects?
17:24:40 <Kiall> vinod: "unbound" is nowhere to be found in devstack, so it shouldn't be
17:25:04 <Kiall> And - When ran locally in vagrant - it's not there...
17:25:12 <Kiall> (even with the same set of services/devstack options etc)
17:25:37 <Kiall> I'm starting to wonder if the infra folks are pre-installing it on all the single use slaves
17:26:00 <Kiall> maybe fungi / clarkb know?
17:26:43 <richm> Kiall: no, I'm not an ubuntu guy - I'll need to install a vm and do some investigating
17:26:44 <fungi> Kiall: yes, we install it because we need to cache local dns queries on job workers
17:27:18 <richm> ok - so looks like, for testing, we'll need to run the designate DNS server on another ip/port
17:27:25 <Kiall> fungi: ooo. Okay - I can chat with you after then.. We might be able to make them co-exist so long as neither bind to *:53
17:27:49 <fungi> Kiall: perhaps, get up with us in #-infra when you're free
17:28:12 <clarkb> Kiall: importantly we do it because the cloud providers DNS servers don't work...
17:28:14 <Kiall> richm: or we pick another IP - 127.*.*.* is all "ours" .. just have to make sure we're doing it in a sane way
17:28:31 <clarkb> Kiall: if you happen to have any sway in how dns is run at one of them ;)
17:28:44 <Kiall> clarkb: lol - recursive dns is not my area ;)
17:28:50 <Kiall> That's a whole other team
17:29:00 <Kiall> thanks fungi / clarkb - at least that solves 1 mystery :)
17:29:32 <Kiall> Okay - Anyway - I just put that on the agenda so people could think about/come up with solutions ;)
17:30:34 <Kiall> Also - You may have noticed I added a Vagrantfile to the contrib/devstack folder which will spin up DevStack with out plugin in either ubuntu or fedora
17:30:54 <Kiall> richm: that would be the quickest + easiest way to get a ubuntu VM :)
17:31:48 <Kiall> Unless there's any Q's on all the Devstack changes / what's needed going forward we'll move on..
17:31:52 <Kiall> So .. Any Q's? :)
17:32:02 <richm> Kiall: ok - will take a look
17:32:04 <rjrjr_> i'm good.
17:32:11 <eankutse> good work!
17:32:15 <vinod> are there more devstack changes to be done?
17:32:43 <Kiall> vinod: richm has a patch up that's blocked on the unbound thing that extends the testing we do
17:33:19 <Kiall> and we'll want to try and write some tempest tests if we can figure out how to hook into that, as that's going to be expected of us once we incubate
17:33:34 <rjrjr_> did we incubate?
17:33:39 <Kiall> That's next ;)
17:33:40 <vinod> Is this https://review.openstack.org/#/c/98968/ needed for incubation?
17:33:56 <Kiall> No - Nothing is blocking incubation anymore
17:34:03 <Kiall> #topic Incubation progress (kiall)
17:34:07 <Kiall> may as well ;)
17:34:16 <Kiall> #link https://review.openstack.org/#/c/97609/
17:34:19 <Kiall> ^ the voting ..
17:34:31 <Kiall> 6 Yay's, 0 Nay's
17:34:37 <betsy> It’s looking good
17:34:45 <eankutse> :-0
17:34:48 <eankutse> :-)
17:34:53 <Kiall> There's also 3 others who voted +1 before the updated patchset
17:35:03 <Kiall> markmc asked us to update the mission statemen
17:35:04 <Kiall> t
17:35:05 <vinod> So is somebody expected to do a +2 before we can get incubated?
17:35:36 <Kiall> myself and graham came up with an alternative wording which made people happy - https://review.openstack.org/#/c/97609/3/reference/programs.yaml
17:36:16 <Kiall> "Enable operators to meet their Domain Name System needs in a stable and scalable manner." <- original wording
17:36:16 <eankutse> That looks good!
17:36:26 <Kiall> Any concerns before it's too late to change it again?
17:36:50 <vinod> As long as the TC is happy, I am happy
17:37:01 <Kiall> :)
17:37:02 <tsimmons> in a* technology-agnostic?
17:37:13 <Kiall> tsimmons: NOOOOO
17:37:26 <betsy> tsimmsons: +1
17:37:27 <tsimmons> :O
17:37:36 * Kiall closes his eyes and pretends he didn't hear that
17:38:04 <vinod> eyes or ears?
17:38:07 <tsimmons> http://2.bp.blogspot.com/-UUBBVvfBUcM/T1t8Zi673mI/AAAAAAAAA0c/uEdZ-PA4IpI/s1600/homer-simpson-bush-gif.gif
17:38:09 <Kiall> both
17:38:15 <Kiall> ^ that
17:38:30 <tsimmons> I'm sure it'll be fine.
17:38:47 <Kiall> :)
17:38:54 <tsimmons> If Anne Gentle (technical writer) didn't care I don't think we have to ;)
17:38:58 <Kiall> Okay - Anyway, We'll be back on the agenda for the TC meet next week
17:39:03 <tsimmons> Sweet
17:39:14 <Kiall> If there are no -1's, I believe that's the end of it
17:39:31 <Kiall> (or the start, whichever ;))
17:40:06 <vinod> So after incubation do we move to openstack from stackforge?
17:40:30 <Kiall> vinod: yes, usually during the next scheduled Gerrit downtime
17:40:40 <Kiall> (you can't rename gerrit projects without downtime)
17:41:04 <betsy> kiall: oh, interesting. I thought it wasn’t until after integration
17:41:33 <Kiall> I don't think that's the case!
17:41:41 <Kiall> https://github.com/openstack/barbican suggests it's not :)
17:41:55 <tsimmons> Fun. I'm sure that won't mess any scripts up :P
17:42:13 <betsy> cool
17:42:16 <Kiall> tsimmons: you have no idea how much pain that's going to cause me ;)
17:43:25 <Kiall> Anyway - once accepted, we'll be expected to start doing things like A) submit our devstack plugin to devstack proper and fix all the issues they find, B) start writing tempest tests, C) start writing a horizon plugin etc
17:43:45 <Kiall> (HP has C covered, we have one we're happy to open source - when we can put it into openstack/horizon)
17:43:57 <tsimmons> Cool.
17:44:31 <Kiall> We'll also have to deal with the fun (aka pain) of the "integrated gate"
17:45:00 <Kiall> Approved patches will take much longer than land, but, they'll still land :)
17:45:22 <Kiall> http://status.openstack.org/zuul/ the center column gives you an idea of the integrated gate queue times
17:45:56 <betsy> I know. I’ve looked at that before and been glad we were in that queue
17:46:01 <Kiall> ;)
17:46:08 <betsy> The price of incubation
17:46:20 <richm> we are cloud developers - we should just horizontally scale out the gate :-)
17:46:32 <Kiall> richm: lol .. that's exactly what happens ;)
17:46:47 <Kiall> there are currently 900 instances acting as test slaves
17:46:53 <richm> egads
17:46:58 <Kiall> ;)
17:47:10 <Kiall> The first graph at the very bottom of the page shows it
17:47:16 <Kiall> #topic Open Discussion
17:47:30 <Kiall> (Since we're basically onto the open discussion topic anyway)
17:47:37 <eankutse> I have a quick follow up
17:47:40 <eankutse> regarding #link http://paste.openstack.org/show/83671/
17:47:49 <Kiall> Internal Server Error
17:47:49 <Kiall> The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.
17:47:51 <Kiall> ;)
17:48:07 <Kiall> there we go - 3 refreshes later and it came up
17:48:25 <eankutse> Can I add it to the current bp where it is?
17:48:45 <eankutse> since it will all be moved to designate-spec?
17:48:46 <Kiall> rather than in designate-specs? yea, for existing BPs moving them over seems pointless
17:48:52 <eankutse> yea
17:49:00 <eankutse> ok
17:49:17 <Kiall> Any other topics?
17:50:24 <Kiall> Going once?
17:50:26 <tsimmons> I have a quick question
17:50:52 <tsimmons> That's probably not relevant to everyone :) So it can wait till after, just fyi
17:51:07 <Kiall> lol .. sure?
17:51:28 <tsimmons> Alright, as far as extending the v2 api, should we use a similar method to v1, stevedore etc?
17:52:36 <vinod> I just wanted to check which patches were still waiting for reviews?
17:52:37 <Kiall> Yea, i think the old pattern worked well - using stevedore (well, entry points i.e the stuff behind stevedore) let's you write out of tree API extensions
17:52:49 <tsimmons> I mean you could just write more views/controllers and hack them into the root.py thing, but that seems messy.
17:52:57 <Kiall> I know we have some very HP-specific extensions for the V1 API
17:53:27 <Kiall> tsimmons: yea, hacking them in means forking when you want to add an private extension, and once you have a fork, things go wrong fast :)
17:53:49 <Kiall> (Just ask a certain cloud provider how that went down with Nova ;))
17:54:07 <tsimmons> Yeah that's no fun. So I guess I'll look at the other projects (none of which seem to use pecan in a similar way) and try and figure out an extension mechanism with pecan.
17:54:27 <Kiall> vinod: mugsie came up with this for review backlogs http://bit.ly/1u7Zvjy
17:54:36 <betsy> very bad idea
17:55:10 <Kiall> vinod: It'll be tailored to you, showing you the patches which you should "probably" look at
17:55:44 <vinod> Thanks kiall and musgsie for the link
17:56:19 <Kiall> tsimmons: yea, the others use WSME on top of Pecan - Which at the time, was simply not ready to be used in any way.
17:56:51 <tsimmons> Kiall: Should we switch to that now?
17:57:26 <Kiall> <PersonalOpinion>It's still not ready for prime time</PersonalOpinion>
17:57:45 <Kiall> But - It is something we should consider at some point.. Just not this cycle.
17:57:56 <tsimmons> Fine by me. I guess I'll just see what I can figure out with Stevedore
17:58:01 <tsimmons> and the current state.
17:58:15 <Kiall> Okay - Anything else before we call it a day?
17:58:22 <eankutse> none
17:58:44 <vinod> nothing else
17:58:58 <Kiall> Okay - Thanks all :)
17:59:00 <Kiall> and .. all yours SlickNik :)
17:59:01 <Kiall> #endmeeting