17:00:46 <Kiall> #startmeeting Designate
17:00:48 <openstack> Log:            http://eavesdrop.openstack.org/meetings/networking_ml2/2014/networking_ml2.2014-07-16-16.01.log.html
17:00:51 <pczesno> bye
17:00:54 <openstack> Meeting started Wed Jul 16 17:00:46 2014 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:58 <openstack> The meeting name has been set to 'designate'
17:01:04 <Kiall> Hey All - Who's here?
17:01:09 <Kiall> Agenda @ https://wiki.openstack.org/wiki/Meetings/Designate
17:01:10 <jaycaz> o/
17:01:10 <vinod1> o/
17:01:11 <timsim> o/
17:01:18 <eankutse> o/
17:01:34 <Kiall> #topic Action Items from last week
17:01:37 <mugsie> o/
17:01:42 <rjrjr_> here
17:01:45 <Kiall> No actions, nice and easy :)
17:01:55 <Kiall> #topic Subdomain/Parent Domain verification logic
17:02:00 <jaycaz> that would be me
17:02:00 <Kiall> jaycaz: over to you
17:02:05 <jaycaz> All right then
17:02:28 <betsy> sorry here
17:03:02 <jaycaz> vinod and I have been talking about subdomains, since I'm adding verification to make sure a tenant doesn't add a domain if another tenant owns a subdomain of the domain
17:03:29 <CaptTofu_> aye mates
17:03:33 <jaycaz> is it even possible to create a subdomain before a domain is created?
17:03:59 <mugsie> jaycaz: yes, you can create a sub domain before a domain
17:04:02 <Kiall> Yea - That has been a longstanding bug, the other way is handled, but not someone creating a domain "above" yours.
17:04:23 <jaycaz> all right, so how can we update the subdomains' parent IDs to make sure the user is aware the parent ID has changed?
17:05:03 <vinod1> is it possible to have only sub.example.com without having example.com for dns name resolution?
17:05:07 <jaycaz> vinod was thinking about adding an update_subdomain flag that would need to be set to True, otherwise creating a domain with existing subdomains would fail
17:05:38 <Kiall> jaycaz: The simple, as little code as necessary way, would be to query for all zones matching %.new-domain.com., and just update them, it will all happen inside of a TX, so should stay consistent.
17:06:08 <jaycaz> okay, that makes sense
17:06:38 <Kiall> re  update_subdomain flag, I'm not sure I understand the reasoning? The only thing we update is the hidden "parent domain" field?
17:06:44 <jaycaz> we were just concerned that 1. this would be in the create_domains function and would be called every time a domain was created (meaning possible performance issues for tenants with many domains)
17:07:03 <mugsie> jaycaz: it would mean preformance issues for all tenants
17:07:14 <jaycaz> and 2. should a create function update other objects besides the object being created?
17:07:17 <mugsie> you would have to search all tenants for the sub domains
17:07:35 <Kiall> jaycaz: re 2 - I think yes, since we're tracking the relationships
17:07:42 <mugsie> re 2 - yes - if needs be to create an object
17:07:52 <jaycaz> okay, so the user never sees this parameter then?
17:08:19 <jaycaz> and, as long as no other tenant owns a subdomain, an all_tenants search isn't required.  good point
17:08:27 <Kiall> jaycaz: yea - it's not exposed to the user, so they wouldn't "notice" change to the other domain
17:08:58 <jaycaz> all right, well that helps a lot!
17:09:04 <Kiall> :)
17:09:07 <jaycaz> as for the second part...
17:09:20 <jaycaz> how to search for subdomains across all tenants for the verification step?
17:09:30 <jaycaz> should we just do it the way it was done in autohost?
17:09:38 <Kiall> autohost?
17:09:53 <jaycaz> classic DNS
17:09:58 <jaycaz> sorry
17:10:30 <Kiall> Sounds like that might be something only the RAX folks know about ;)
17:10:39 <jaycaz> sigh, intern problems
17:10:55 <jaycaz> sorry about that
17:11:26 <mugsie> :D
17:11:29 <Kiall> So - The current is_subdomain method, we'll need something similar for is_superdomain - https://github.com/openstack/designate/blob/master/designate/central/service.py#L241
17:11:45 <jaycaz> I have a prototype for that atm
17:11:47 <Kiall> It's pretty inefficient, but is_superdomain should be easier
17:11:56 <Kiall> and it shows how to do the all tenants search
17:12:10 <jaycaz> the problem is to search across all tenants for a subdomain without doing something like *.domain.com.
17:12:33 <Kiall> I'm not sure we really have any other choice?
17:12:45 <mugsie> i don;t think so
17:13:11 <jaycaz> something someone suggested...
17:13:11 <eankutse> how about reversing labels and comparing that way?
17:13:30 <Kiall> e.g. Cust A could have bla.bla.bla.bla.bla.domain.com, and we need to find that when someone tries to create "domain.com"
17:13:39 <jaycaz> i.e. ".moc.niamod.*"
17:13:54 <jaycaz> that way it can be indexed much easier
17:14:19 <Kiall> is ".moc.niamod.%" really more efficient than "%.domain.com."?
17:14:45 <Kiall> I would have thought both would have been about as awful as each other :)
17:15:09 <jaycaz> if it's indexed, shouldn't it be?
17:16:10 <Kiall> Yea - Possibly..
17:16:13 <mugsie> jaycaz: I actually agree that it may be faster to reverseit
17:16:25 <mugsie> but not sure of the implications
17:16:46 <mugsie> (ie would we have a method in storage to reverse the string ;) )
17:17:00 <jaycaz> maybe add a column to storage?
17:17:10 <mugsie> hum..
17:17:10 <betsy> on the domains table?
17:17:19 <mugsie> that is 2 indexes of the same info
17:17:27 <mugsie> which i would not be ok with
17:17:28 <Kiall> Yea, we would have to, but, the Q for me is, do we let that implementation detail leak out of storage or not?
17:17:35 <Kiall> ^ too
17:18:09 <Kiall> It should be relatively easy to test, create a dummy table, script INSERT for 5 or 10 million entries, and give the queries a whirl.. If there is a significant difference, it should be noticeable with that # of rows
17:18:41 <Kiall> If it's not noticeable, then, we may just be making work for ourselves?
17:18:41 <jaycaz> Kiall: I just created a script to add random domains/subdomains, so I could test that out and let you know
17:18:51 <mugsie> yeah - just ensure it is random data, not sequential ;)
17:18:52 <Kiall> jaycaz: great minds and all that ;)
17:19:16 <jaycaz> Kiall: haha, of course :P
17:19:36 <Kiall> jaycaz: Okay, Why don't we see what sort of #'s we see when comparing the two, and go from there?
17:19:43 <mugsie> sounds good
17:19:44 <jaycaz> Kiall: sounds like a plan!
17:19:49 <Kiall> Also.. CaptTofu_ ... you're a DB guy.. Advice?
17:20:35 <Kiall> Would a LIKE 'string%' be significantly faster than LIKE '%string' with a large # of rows?
17:20:51 <Kiall> (Not sure he's still here TBH)
17:21:12 <Kiall> Okay.. Guess not, moving on.
17:21:15 <Kiall> #topic Submission of talks for Paris Openstack summit
17:21:18 <Kiall> vinod1: over to you
17:21:47 <vinod1> i wanted to check if anybody had ideas on submission of talks for the next summit
17:22:30 <vinod1> The deadline to submit speaking sessions for the Paris Summit 2014 is Monday July 28, 2014.
17:22:36 <vinod1> #link https://www.openstack.org/summit/openstack-paris-summit-2014/call-for-speakers/
17:23:12 <Kiall> I've not given talks much thought this time around, another than sballe has asked me to co-present a non-designate talk...
17:23:46 <mugsie> I was thinking about one for pools - as we should have something to show by then
17:23:49 <Kiall> Is anyone already planning on submitting a Designate talk BTW?
17:23:51 <sballe> Kiall, hi :-)
17:24:39 <vinod1> i haven't given much thought to it myself
17:24:42 <mugsie> and maybe a workshop to write a backend driver - showing the mDNS etc
17:25:13 <betsy> mugsie: I like that workshop idea
17:25:27 <mugsie> yeah -  i figure it could be an interesting one
17:25:58 <mugsie> i figured I would write it in advance, but walk throught the code "step by step" as i "write" it
17:26:01 <timsim> Should we not do similar talks from last summit, the ones for people who haven't checked out the project yet?
17:26:16 <mugsie> yeah - think tht is definitly worth it
17:26:27 <mugsie> especally as we have been incubated in the meantime
17:27:17 <mugsie> so far me, Kiall, rjrjr_ , and CaptTofu_ have given that talk
17:27:17 <Kiall> Okay - Do we have some volunteers for an intro talk?
17:27:29 <vinod1> i can take that
17:27:58 <Kiall> sounds good :)
17:28:27 <CaptTofu_> Kiall loves giving talks
17:28:38 <Kiall> CaptTofu_: yea, that's, umm. Not true.
17:28:38 <vinod1> and demos ;-)
17:29:02 <Kiall> demos I'm fine with.. even when they crash and burn.. ;)
17:29:14 <Kiall> brb - spilled water everywhere -_-
17:29:21 <eankutse> :-)
17:29:25 <rjrjr_> i would like to help out with any talks or demos again.
17:30:24 <rjrjr_> do we want to coordinate our talks again?
17:30:42 <vinod1> i think that worked well for us in the past
17:30:43 <Kiall> back - I think that worked well last time
17:31:05 <Kiall> mugsie: want to get an email thread / hangout going again?
17:31:07 <vinod1> so we should continue with that tradition
17:31:07 <mugsie> yeah - defintly
17:31:11 <mugsie> yeah - np
17:31:16 <mugsie> action me ;)
17:31:26 <rjrjr_> how about we throw around ideas and settle on some topics at our mid-meetup in a couple of weeks?
17:31:40 <mugsie> the deadline is the same day as we start rjrjr_ :(
17:31:44 <Kiall> rjrjr_: abstracts are due 27th I think
17:31:50 <rjrjr_> oh. 8^(
17:32:09 <Kiall> #action mugsie to setup etherpad / email thread / hangout for coordinating some talks
17:32:41 <Kiall> In case we have any silent people listening - anyone who wasn't on the last one - drop mugsie your email address and he'll get you invited
17:33:00 <Kiall> Okay - should we move on then?
17:33:02 <mugsie> yup
17:33:06 <mugsie> graham.hayes@hp.com
17:33:17 <Kiall> #topic Spec for Zone and Record TotalCount
17:33:24 <Kiall> #link https://review.openstack.org/#/c/106098/
17:33:28 <Kiall> #link http://docs-draft.openstack.org/98/106098/2/check/gate-designate-specs-docs/b622b44/doc/build/html/specs/juno/zone-and-record-totalcount.html
17:33:58 <Kiall> I think the spec looks good, but wanted to get peoples thoughts on the Format 1 vs Format 2 stuff so we can approve
17:34:05 <Kiall> (it's jaycaz's spec)
17:34:15 <vinod1> I like format 2
17:34:22 <timsim> He was taken by other interns.
17:34:24 <mugsie> I am in favor of 2
17:34:27 <timsim> But I like format 2 as well.
17:34:28 <Kiall> timsim: lol
17:34:35 <Kiall> Okay - Anyone prefer Format 1?
17:35:03 <Kiall> And - If you haven't seen it - take a sec to read the proposed change section
17:35:05 <eankutse> Kiall: what is the adv of format 2?
17:35:08 <Kiall> (Just let us know your reading)
17:35:17 <eankutse> I read
17:35:22 <betsy> I read it
17:35:46 <betsy> I like format 2 because it gives us a place to add more things in the future
17:35:50 <Kiall> eankutse: I prefer #2, as it allows us to expand on the set of metadata we supply overtime without growing the number of "root" elements in the JSON
17:36:21 <Kiall> It also "looks" right to have a container, as all the other root elements are also containers
17:36:29 <mugsie> ++
17:36:39 <mugsie> I would like to limt the amount of root elements
17:36:40 <eankutse> k.
17:37:24 <eankutse> + for format#2
17:37:35 <Kiall> OK - I think we can call that decided then..
17:38:24 <Kiall> #action jaycaz to update zone-and-record-totalcount spec to remove Format 1
17:38:24 <Kiall> 
17:38:42 <jaycaz> Kiall: sounds good!
17:38:43 <Kiall> Before we move on, does anyone have ant other comments/questions on that spec?
17:38:54 <eankutse> Looks great!
17:39:13 <mugsie> I am happy with it
17:39:24 <Kiall> Okay - Once updated, I'll Approve unless I see some -1's on it in the next day
17:39:49 <Kiall> Moving on :)
17:39:51 <Kiall> #topic Open Discussion
17:40:18 <Kiall> So .. Since our last meeting, we hit a milestone or two :)
17:40:35 <Kiall> 1) vinod1 got us a working mDNS :) Go vinod1 :)
17:40:56 <timsim> \o/
17:41:04 <vinod1> Thanks kiall
17:41:08 <eankutse> cool :-)
17:41:10 <richm> +1
17:41:13 <Kiall> 2) We're slowing becoming more and more "Official".. mugsie got our docs sorted :) http://docs.openstack.org/developer/designate/
17:41:19 <mugsie> vinod1: it was quite cool to dig at designate :D
17:41:35 <timsim> Oh snap, that's cool.
17:41:52 <mugsie> timsim: we had to actually code that red banner at the top left to get accepted
17:42:11 <betsy> mugsie: thx for doing that
17:42:11 <timsim> Hah, that's pretty awesome.
17:42:33 <mugsie> np - brought me back to my begining days in software dev ;)
17:42:37 <Kiall> and 3) While it hasn't merged yet.. betsy got our v2 RecordSet/Record API in order :) Now all we need to do is fix the historical "priority" is special thing, and we can call that API solid :)
17:42:46 <mugsie> \o/
17:42:55 <betsy> So close
17:42:58 <timsim> Very cool.
17:43:24 <Kiall> Yep! Looking forward to merging those and getting closer to stability rather than feature work :)
17:43:45 <Kiall> So - Anyone got anything else?
17:43:47 <vinod1> mugsie - can we get designate listed here too - http://docs.openstack.org/developer/openstack-projects.html
17:43:59 <mugsie> vinod1: yeah, need to ping the docs team
17:44:12 <Kiall> #action mugsie to try get designate listed here too - http://docs.openstack.org/developer/openstack-projects.html
17:44:13 <Kiall> ;)
17:44:48 * mugsie needs to go find how that page is generated
17:45:18 <Kiall> Nobody have anything else?
17:45:25 <eankutse> not me
17:45:26 <mugsie> I am good
17:45:28 <vinod1> got one
17:45:50 <vinod1> so when we update the docs do we need to do anything else before it shows up at http://docs.openstack.org/developer/designate/
17:46:03 <mugsie> nope
17:46:06 <Kiall> vinod1: no, magic happens and it should publish straight away
17:46:15 <Kiall> for the client - the docs only publish when we tag
17:46:29 <Kiall> and for specs - There isn't a place for those yet it seems
17:47:17 <Kiall> If you want http://status.openstack.org/zuul/ right after a change merges, you'll see our designate-docs jobs triggered in the "post" pipeline to build+publish
17:47:22 <Kiall> If you watch*
17:48:13 <Kiall> Okay - If that's everything, we can call it a day :)
17:48:15 <Kiall> Thanks all!
17:48:23 <eankutse> bye
17:48:28 <mugsie> o/
17:48:31 <jaycaz> see ya!
17:48:32 <Kiall> #endmeeting