17:01:10 <Kiall> #startmeeting Designate
17:01:11 <openstack> Meeting started Wed Nov 19 17:01:10 2014 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:15 <openstack> The meeting name has been set to 'designate'
17:01:16 <ekarlso-> ello folks :)
17:01:17 <Kiall> Hey Folks, who's about today?
17:01:19 <betsy> o/
17:01:20 <yalie__> bye
17:01:21 <mugsie> o/
17:01:24 <vinod> o/
17:01:32 <Kiall> rjrjr: about?
17:01:42 <mugsie> I saw him join a second ago
17:01:47 <Kiall> kk..
17:01:57 <Kiall> No actions from last week, so skipping that..
17:02:07 <Kiall> #topic Pools - Where are we? (kiall)
17:02:34 <Kiall> rjrjr pushed another patchset yesterday (or maybe the day before?).. I've been travelling, so haven't reviewed.. has anyone else had a chance?
17:02:43 <betsy> nope
17:02:57 <mugsie> no major movement afaik - need to do another review day :|
17:03:10 <rjrjr> should be finishing up the happy path by friday.  finally.
17:03:12 <vinod> It is marked as WIP. But I was looking it at now
17:03:24 <mugsie> rjrjr: cool
17:03:25 <mugsie> :)
17:03:31 <Kiall> rjrjr: excellent, I'm looking forward to getting the old stuff out :D
17:03:42 <betsy> I can give an update on pool storage
17:03:42 <Kiall> Any blockers etc etc?
17:03:48 <timsim> o/
17:03:54 <Kiall> betsy: sure..
17:04:07 <vinod> I did notice that there are some mismatches between the pool manager and minidns interfaces/calls
17:04:07 <vinod> rjrjr: Do you want me to fix them up
17:04:46 <rjrjr> or point them out.
17:05:26 <vinod> sure rjrjr: I will work with you after this meeting
17:06:00 <Kiall> betsy: still there? ;)
17:06:26 <timsim> It looks like she's lost connection
17:06:34 <timsim> She's putting in updates, but it's not showing up
17:06:36 <Kiall> ah, fair enough :)
17:07:11 <Kiall> So.. Somewhat related to pools, we've got a "fun" bug.. https://bugs.launchpad.net/designate/+bug/1392762
17:07:12 <uvirtbot> Launchpad bug 1392762 in designate "Concurrent requests can cause designate-central to lock up" [High,In progress]
17:07:14 <vinod> betsy is struggling with irc troubles
17:07:15 <vinod> network issues for her
17:07:17 <vinod> rjrjr: Is pool manager working in the devstack tests now?
17:07:46 <Kiall> it's relation to pools is that.. I believe we're best wait for all the old backend code to be removed before we fully fix it up
17:08:19 <Kiall> So, if you see me -1's pools reviews due to eventlet context switching.. You'll know it's that bug ;)
17:08:37 <Kiall> vinod: Okay, we'll come back to betsy later.. Unless she's back on again?
17:08:44 <rjrjr> vinod: yes
17:08:52 <timsim> She's fighting it :P
17:09:00 <timsim> Op, she's on the other channel
17:09:11 <betsy> Now!
17:09:12 <betsy> I’m working on the server to pool_attributes table migration. And changing the v1 api to CRUD pool_attributes instead of servers while still looking like it’s doing servers. And then changing ALL the code to not use servers
17:09:19 <betsy> :)
17:09:41 <Kiall> cool - sounds like progress! :)
17:09:57 <betsy> That should be the last of the pool storage
17:10:24 <Kiall> Excellent - Is rjrjr held up by that work? I'm guessing not?
17:10:59 <betsy> Not as far as I know - rjrjr?
17:11:08 <rjrjr> not held up.
17:11:12 <Kiall> Cool...
17:11:20 <Kiall> Okay, before we move on, any blockers re pools?
17:11:28 <rjrjr> no
17:11:34 <rjrjr> not exactly.
17:11:34 <Kiall> Excellent :)
17:11:35 <Kiall> #topic Mid-Cycle Dates/Locations/Topics
17:11:50 <Kiall> Have we figured out any more info on this?
17:11:58 <rjrjr> yes.
17:12:01 <mugsie> :D
17:12:35 <rjrjr> would the week of january 19 - 23 work for everyone?
17:13:09 <mugsie> I think so - Kiall how does that fit for you?
17:13:13 <timsim> Probably so.
17:13:16 <Kiall> Kinda.. I've got to be in CA 22nd/23rd (or 23rd/24th)
17:13:52 <rjrjr> guys, i'm open on when.  trying to accommodate your schedule.
17:13:59 <rjrjr> got approval to do this.
17:14:06 <mugsie> sweet
17:14:16 <mugsie> how logn do we want to put aside for it?
17:14:19 <mugsie> long*
17:14:26 <mugsie> 2,3,4 days?
17:14:31 <timsim> 3 or 4 I'd think.
17:14:40 <mugsie> which still could be ok for Kiall and CA
17:14:46 <Kiall> Yea, that's works nicely for me
17:14:57 <mugsie> Mon -> Thurs in Pheonix?
17:14:57 <timsim> Joe didn't seem too worried that (at least some) of us would be able to come.
17:15:04 <rjrjr> so january 19 - 22 then?
17:15:24 <mugsie> jmcbride joined - those dates suit you Joe?
17:16:00 <mugsie> Kiall: can you confirm the 1st day you haveto be in CA?
17:16:04 <Kiall> Yep - That should work for me, We'll want to figure out if everyone can manage 4 days.. But that can come a little later
17:16:22 <Kiall> mugsie: I'd love to, but nobody knows if it's the 22nd or 23rd yet
17:16:31 <mugsie> ah
17:16:44 <mugsie> i thought it was set :)
17:16:53 <jmcbride> I think that will work for me.
17:16:58 <Kiall> original schedule was for Fri 23rd and Sat 24th .. Which everyone agreed to, then it was realized the 24th was a Sat.. It's kinda still up in the air
17:17:16 <Kiall> It's the 22nd or 23rd either way
17:17:21 <mugsie> so, we can agree to start on the money anyway
17:17:25 <mugsie> monday*
17:17:30 * mugsie needs sleep
17:17:43 <mugsie> and then 3 - 4 days for the duration
17:17:46 <timsim> Want to set this tenatively, and come back to it next week? Jan 19-22?
17:18:04 <timsim> Or maybe 21st
17:18:08 <mugsie> that sound like a good base plan? and circle around mext week, when people have checked with amnagement
17:18:14 <Kiall> mugsie: ++
17:18:31 <timsim> Cool, sounds like fun.
17:18:38 <mugsie> #action: all - check and confirm dates above
17:19:18 <Kiall> Okay.. Moving on! rjrjr thanks for Hosting.. :)
17:19:18 <rjrjr> if it doesn't work, propose another slot.  i'm flexible as long as we nail down the dates in the next week or so.
17:19:26 <mugsie> ++
17:19:47 <vinod> rjrjr: Is there an ebay office in Phoenix?
17:19:58 <rjrjr> yes.
17:20:16 <Kiall> #action Pools Question - Do we want to treat nameservers differently than poolattributes, or is it just a type of poolattribute? (betsy)
17:20:36 <betsy> I’ve just got a question as to why nameservers are treated separately than pool_attributes
17:20:43 * mugsie *cough* #topic *cough*
17:20:47 <Kiall> lol
17:20:51 <Kiall> #ropic Pools Question - Do we want to treat nameservers differently than poolattributes, or is it just a type of poolattribute? (betsy)
17:20:52 <betsy> Aren’t they just a type of pool_attribute?
17:20:54 <Kiall> #topic Pools Question - Do we want to treat nameservers differently than poolattributes, or is it just a type of poolattribute? (betsy)
17:20:55 <Kiall> -_-
17:21:01 <betsy> :)
17:21:19 <betsy> We’ve currently got a namerserver object and a pool_attribute object
17:21:23 <mugsie> i think they are stored as a pool attrib, but displayed int he API separatly
17:21:38 <mugsie> in the API*
17:21:46 <mugsie> so, 2 objects is right
17:22:02 <mugsie> nameserver could inherit from pool_attrib
17:22:04 <betsy> Yeah, but we can still get that info from a pool_attriibute object vs a nameserver obj, can’t we?
17:22:14 <mugsie> yeah, we could
17:22:23 <mugsie> I am easy either way personlly
17:22:57 <betsy> what does everyone else think?
17:23:28 <Kiall> I'd argue we hide the pool_attributes table out of the way in the storage layer, since the _attributes tables were, from my memory, really about avoiding 1000s of small tables...
17:23:46 <Kiall> (i.e. Nameserver is the object, Pool Attributes aren't)
17:23:54 <betsy> ok
17:24:04 <betsy> But we still have other pool attribute objects, right?
17:24:21 <Kiall> Yea, when the scheduler comes along, we'll have more
17:24:35 <betsy> Okay. I’ll leave it for now and see how the code goes
17:24:36 <Kiall> I think nameservers are the only existing use of it
17:24:37 <rjrjr> i think it is a pool attribute.
17:24:59 <vinod> we have scope too as a pool attribute currently
17:25:04 <timsim> It seems like a pool attribute to me, but not one that'd factor into the scheduler.
17:25:35 <mugsie> timsim: ++
17:25:52 <Kiall> timsim: agreed, scheduler hints will likely be an attribute with type=scheduler_hint value=<Something Here>
17:26:13 <timsim> Yep, that makes sense.
17:26:28 <betsy> Ok. So leave the nameserver object as is?
17:27:07 <Kiall> Personally, I think so - But bearing in mind I've not read the patch yet, so "as is" could be different than I'm thinking :D
17:27:25 <betsy> ok. I’ll leave it for now and then y’all can review the patch
17:27:33 <mugsie> cool :)
17:27:43 <Kiall> #topic Open Discussion
17:27:46 <Kiall> Any other topics?
17:27:53 <jmcbride> yes
17:27:53 <Kiall> mugsie: do you have that poll link handy?
17:28:05 <jmcbride> regarding server pools
17:28:06 <jmcbride> rjrjr: You mentioned you were finishing the happy path on Friday.  Are you around next week (Thanksgiving week) for us to discuss any issues?
17:28:18 <mugsie> i do
17:28:32 <rjrjr> yes.  i'm always on, holiday or not. 8^)
17:28:34 <mugsie> #link https://www.surveymonkey.com/r/FJRBSVF
17:28:38 <Kiall> rjrjr: lol
17:29:10 <timsim> clear
17:29:13 <jmcbride> OK.  Getting the server pools bit finalized is an important milestone for us this year.
17:29:16 <timsim> Wrong window :P
17:29:41 <jmcbride> rjrjr will you be at the IRC next Wednesday?
17:29:46 <rjrjr> yes.
17:29:50 <Kiall> He's here every week :)
17:30:21 <timsim> Next wednesdday is the day before a national holiday for us (Thanksgiving) so some of us may not be here.
17:30:44 <jmcbride> Cool.  OK, just wanted to make sure we could reach out to you.  So I'm assuming after the happy path is posted, we all start pulling it down and testing away, identifying any issues, right?
17:30:52 <mugsie> +1
17:31:18 <Kiall> Lazy b******* not coming into work, should we skip next weeks meeting? ;)
17:31:48 <timsim> Nah, I'm sure someone will be around.
17:31:52 <mugsie> I saw go ahead
17:31:55 <betsy> I’ll be here
17:31:56 <mugsie> say*
17:32:00 <vinod> We could have a quick check on server pools
17:32:05 <vinod> I'll be here
17:32:06 <Kiall> Okay.. Quorum will be here, that'll work.
17:32:06 <jmcbride> I'd like to keep it on the calendar.
17:32:09 <ekarlso-> btw, for you that would like to test, secondary zone stuff is up and v2 client :)
17:32:13 <mugsie> :)
17:32:28 <jmcbride> cool, ok, I'm good.  Thanks for the hard work, rjrjr.
17:32:40 <ekarlso-> cloudistic.net/blog/drafts/designate-secondary-zones.html < see that for how to setup :)
17:32:42 <betsy> ekarlso: +1
17:32:47 <rjrjr> np.  you can test now, but only zone add and delete is working.
17:32:51 <Kiall> "You don't have permission to access /blog/drafts/designate-secondary-zones.html on this server." ;)
17:33:00 <ekarlso-> rly
17:33:11 <timsim> same for me ^
17:33:14 <ekarlso-> whaaat :p
17:33:38 * Kiall loves how tech just randomly breaks itself ;)
17:33:44 <ekarlso-> :p
17:33:51 <mugsie> has everyone filled the survey in for different meeting times?
17:33:57 <vinod> i did
17:34:03 <mugsie> to see if moving is a good idea...
17:34:07 <Kiall> I've not, every time I look at my calendar I get upself.
17:34:10 <Kiall> upset*
17:34:14 <betsy> try this: https://cloudistic.net/blog/drafts/designate-secondary-zones.html
17:34:14 <mugsie> #link https://www.surveymonkey.com/r/FJRBSVF
17:34:39 <ekarlso-> https://www.cloudistic.net/blog/drafts/designate-secondary-zones.html < that sorry ;)
17:34:41 <ekarlso-> ya ^
17:35:05 <nibalizer> u
17:35:20 <nibalizer> erp ww
17:35:23 <vinod> ekarlso-: you now have the bar raised on documentation :-)
17:35:30 <rjrjr> just finished the survey.
17:35:35 <ekarlso-> vinod: ? ;P
17:36:00 <Kiall> vinod: lol, just need to port it to docs.openstack.org ;)
17:36:03 <vinod> i mean you have done a good job
17:36:10 <timsim> nibalizer: wat
17:36:20 <Kiall> Yep, spec+post+code is looking good :)
17:36:33 <Kiall> Okay, Any other topics or shall we call it a day?
17:36:38 <mugsie> I am good
17:36:40 <vinod> whoever gets to try the same thing on server pools - it would be good to have a similar page - so that it would be helpful or others
17:36:47 <timsim> I'm good.
17:36:48 <vinod> s/or/to
17:36:55 <Kiall> vinod: ++, any
17:36:58 <rjrjr> good.
17:36:59 <betsy> vinod: +1
17:37:27 <rjrjr> everyone's typing has been gibberish today.
17:37:30 <ekarlso-> :P
17:37:54 <ekarlso-> if anyone would like, gimme feedback on the post ^ by 21:00 UTC today and i'll post it up to twitter :P
17:38:18 <Kiall> ekarlso-: looked good to me when I read yesterday :)
17:38:34 <Kiall> Okay, let's call it then.. I'm starving and dinner needs to be cooked :)
17:38:55 <timsim> Cool. See ya!
17:38:56 <Kiall> Thanks all, esp rjrjr for the mid cycle venue and all the pools work :)
17:39:02 <Kiall> #endmeeting