17:02:58 <mugsie> #startmeeting Designate
17:03:01 <openstack> Meeting started Wed Feb 11 17:02:58 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:05 <openstack> The meeting name has been set to 'designate'
17:03:15 <mugsie> #topic Action Items from last week
17:03:57 <mugsie> both seem to have been done - we met last firday, and bug triage is on the agenda :)
17:04:29 <mugsie> #topic Kilo Release Status
17:04:34 <mugsie> #link https://launchpad.net/designate/+milestone/kilo-3
17:05:03 <mugsie> anything that should not be there / should be there / issues with the current milestone?
17:05:39 <mugsie> also, Kiall is currently on his way home - we were on the West coast of Ireland for meetings the last 3 days
17:05:49 <mugsie> so he may join in a bit, if he gets home in time
17:06:16 <timsim> Probably nothing yet to add to k3. I
17:06:32 <timsim> If you're working on something that's not in there, add it yeah?
17:06:41 <rjrjr> paul_glass: did you get a chance to open a bug on your issue last week?
17:06:43 <mugsie> timsim: +1
17:07:52 <mugsie> anything else on this?
17:08:02 <paul_glass> rjrjr: I couldn't reproduce it.
17:08:05 <paul_glass> so no
17:08:14 <rjrjr> okay.
17:08:19 <timsim> We're good then.
17:08:29 <mugsie> #topic Pools - Where are we?
17:09:03 <timsim> I was wondering about the database stuff that got started at the mid-cycle. Where's that at?
17:09:08 <mugsie> i think we are in a simliar place as last week - anyone have anything pressing for this? I saw patches from rjrjr
17:09:18 <mugsie> timsim: same as the mid cycle :(
17:09:27 <mugsie> this is on my list for this / early next week
17:09:36 <mugsie> myself and Kiall are finally back in an office
17:09:49 <timsim> Cool. Is that patch for resiliency ready to review/merge rjrjr ?
17:09:53 <rjrjr> i have 2 bugs i'll be working on early next week.  looks like vinod1 also has some bugs.
17:10:04 <rjrjr> that patch has been ready for almost 2 weeks now.
17:10:06 <mugsie> (i have spend more time in hotels than my own house in the last 6 weeks :( )
17:10:07 <rjrjr> :(
17:10:11 <timsim> That's what I thought.
17:10:18 <mugsie> rjrjr: I will add it to my list for the morning
17:10:25 <mugsie> what is the review number?
17:10:29 <vinod1> rjrjr: I will look at it later today
17:10:40 <timsim> #link https://review.openstack.org/#/c/149428/
17:10:41 <vinod1> https://review.openstack.org/#/c/149428/
17:11:06 <vinod1> mugsie: while you are in the review mode - could you also review - https://review.openstack.org/#/c/148779/
17:11:14 <mugsie> #action cores: (mugsie,Kiall,vinod1): get https://review.openstack.org/#/c/149428/ merged
17:11:21 <mugsie> vinod1: +1
17:11:24 <vinod1> That is for Adding a new API for abandoning a zone from storage
17:11:34 <mugsie> yeah, definitly
17:11:55 <mugsie> that looked good the last time, I just hadn;t tested it locally yet :)
17:12:14 <mugsie> anything else outstanding on this?
17:12:23 <timsim> Not from me.
17:12:29 <rjrjr> i'm good.
17:12:36 <mugsie> cool
17:12:50 <mugsie> #topic Next sprint
17:12:56 <mugsie> #link https://etherpad.openstack.org/p/designate-documentation-sprint
17:13:11 <timsim> We should probably start claiming stuff on that, yeah?
17:13:20 <timsim> That's this Friday
17:13:21 <mugsie> this is next friday, so can people please claim areas this week, so we can get moving stright away
17:13:26 <mugsie> shit
17:13:29 <mugsie> it is this friday
17:13:40 * mugsie has no concpet of time anymore
17:13:56 <mugsie> so, yes, please claim areas today / tomorrow
17:14:36 <mugsie> any questions on ^ ?
17:14:44 <vinod1> I added some more areas to that doc
17:14:47 <timsim> Will everyone be there?
17:14:59 <mugsie> everyone is free to join - old and new contributors alike :)
17:15:04 <mugsie> I know I will be
17:15:18 <mugsie> not sure about ekarlso , and I think Kiall should be
17:15:19 <vinod1> i will be there
17:15:25 <rjrjr> i will be there.
17:15:40 <mugsie> cool. so a reasonably full house
17:15:43 <vinod1> mugsie - do you plan to send an email to the openstack-dev mailing list?
17:15:57 <mugsie> i hadn't, but that is a good idea
17:16:16 <mugsie> #action mugsie email -dev list about sprint
17:16:54 <mugsie> anyone who has input about our docs feel free to jump on and give feedback as wll
17:17:15 <mugsie> even if you are not comfortable about contributing changes to them
17:17:42 <mugsie> anything else on the sprint?
17:17:53 <timsim> Nope. :)
17:18:03 <rjrjr> i'm good.
17:18:24 <mugsie> #topic Elect another core member
17:18:47 <mugsie> so, as people may have seen in the dns channel betsy has resigned from core
17:18:57 <vinod1> In case anybody missed - Betsy left for another group in Rackspace
17:19:07 <mugsie> that leaves us with a spot on designate-core
17:19:38 <mugsie> the traditional openstack way of replacing cores is for someone to send an email to the -dev list nomintating someone
17:19:45 <vinod1> I would like to propose Tim for that spot. He has been reviewing code a lot lately
17:19:54 <mugsie> and the rest of the cores reply +/-1
17:20:02 <mugsie> vinod1: cool
17:20:17 <mugsie> can you send a nomination email to the list?
17:20:19 <vinod1> So do we want to do it the traditional way?
17:20:29 <vinod1> Okay I will send a nomination to the list
17:20:46 <mugsie> I think that as we get more part of openstack we should abide by the forms
17:20:57 <mugsie> it also makes the whole thing transparent :)
17:21:14 <mugsie> is that OK with everyoine?
17:21:30 <rjrjr> sounds good.
17:21:33 <timsim> Sounds good.
17:21:35 <vinod1> #agreed
17:21:42 <mugsie> OK, cool :)
17:22:01 <mugsie> #topic Bug triage (timsim-recurring)
17:22:28 <mugsie> ok, let me get a URL for the bug list
17:22:55 <mugsie> #link https://bugs.launchpad.net/designate/+bugs?search=Search&field.status=New
17:23:21 <mugsie> how do we want to do this?
17:23:32 <rjrjr> start at the top, one at a time?
17:23:39 <mugsie> we divide the bugs up? or do we want to run down through each of them?
17:23:55 <mugsie> ok
17:23:59 <mugsie> #link  https://bugs.launchpad.net/designate/+bug/1289444
17:23:59 <openstack> Launchpad bug 1289444 in Designate "Designate with postgres backend is having issues" [Medium,New]
17:24:00 <timsim> I think usually this would be a smaller list, so going through them one by one is probably fine.
17:24:40 <mugsie> i think this can move to Triaged
17:25:04 <mugsie> (can someone else change the status - I don't have my 2 factor token on me right now)
17:25:15 <rjrjr> #agreed
17:25:21 <timsim> Done.
17:25:37 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1412431
17:25:37 <openstack> Launchpad bug 1412431 in Designate "handling format with a display_name containing underscore" [Undecided,New]
17:26:09 <timsim> This seems like a bug in the example sink handler?
17:26:20 <mugsie> yup
17:26:28 <mugsie> not sure if a bug, or a doc issue
17:26:45 <mugsie> as you are not nessiarly supposed to use the example ;)
17:26:48 <timsim> Yeah
17:26:59 <timsim> If you're not supposed to use that, it's probably fine not to fix that.
17:27:16 <mugsie> we could triage it and mark it as wishlist
17:27:24 <timsim> If that's an issue for you using it, you should solve that issue however you want.
17:27:47 <mugsie> or close it as won't fix - with a description of ^
17:27:58 <rjrjr> i like that approach.
17:27:59 <mugsie> opinions?
17:28:02 <vinod1> I am leaning towards won't fix
17:28:10 <mugsie> cool - wont fix it is
17:28:12 <rjrjr> #agreed.
17:28:13 <timsim> Either one. If you wishlist it, that seems to indicate to me that we're going to supply a handler to use by default.
17:28:20 <timsim> So I like won't fix.
17:28:30 <mugsie> timsim: care to do the honours?
17:28:33 <timsim> Sure
17:29:01 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1413806
17:29:01 <openstack> Launchpad bug 1413806 in Designate "desigate.plugin.DriverPlugin Hides Errors from Developers" [Undecided,New]
17:29:01 <vinod1> timsim: could you add some reasoning too?
17:29:07 <timsim> vinod1: Yep
17:29:26 <mugsie> ^ needs to be triaged, and marked as med IMHO
17:29:31 <mugsie> medium*
17:29:44 <rjrjr> #agreed
17:30:04 <vinod1> #agreed
17:30:16 <vinod1> milestone - kilo3?
17:30:16 <timsim> #agreed
17:30:25 <mugsie> yup
17:30:54 <timsim> Done
17:30:57 <mugsie> cool
17:31:02 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1416263
17:31:02 <openstack> Launchpad bug 1416263 in Designate "Pool Manager's Periodic Sync Needs to Regress States" [Undecided,New]
17:31:06 <rjrjr> agreeable group today.
17:31:10 <mugsie> :)
17:31:34 <rjrjr> high or critical probably.  definitely kilo-3.
17:31:47 <mugsie> high - k3 IMHO
17:31:55 <timsim> So this is basically, zone is out of sync, periodic sync calls update_status?
17:32:13 <timsim> k3 high works for me
17:32:13 <rjrjr> correct.
17:32:36 <timsim> We agreed on k3-high?
17:32:39 <mugsie> vinod1: k3 - high ok with you?
17:32:42 <rjrjr> #agreed
17:32:43 <vinod1> yes
17:32:46 <mugsie> done
17:32:55 <mugsie> * not by my
17:32:58 <mugsie> me*
17:33:00 <timsim> Done.
17:33:00 <mugsie> gah
17:33:17 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1416264
17:33:17 <openstack> Launchpad bug 1416264 in Designate "Pool Manager Needs to Recover from Backend Changes" [Undecided,New]
17:33:22 <rjrjr> high or critical - kilo-3
17:33:47 <mugsie> C - K3
17:33:51 <timsim> k3 - high
17:34:09 <timsim> I'm cool with Critical too.
17:34:14 <vinod1> Ron - is this when a domain is being updated and pool manager discovers that the domain does not exist on the backend
17:34:21 <rjrjr> correct.
17:34:32 <mugsie> or sync finds its not on the backend as well right?
17:34:42 <rjrjr> either case.
17:34:52 <vinod1> C - K3
17:35:02 <timsim> Alright, Critical - K3 it is
17:35:07 <rjrjr> #agreed
17:35:10 <mugsie> :)
17:35:17 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1416337
17:35:17 <openstack> Launchpad bug 1416337 in Designate "Designate server create with concurrent request is not listing all servers even after successful creation." [Undecided,New]
17:35:26 <mugsie> this needs investigation
17:35:38 <mugsie> it was said it was intermitent
17:35:50 <mugsie> has anyone tried to re-create?
17:35:52 <rjrjr> it underscores our need for more integration testing too. :(
17:36:15 <timsim> So maybe we leave this one new?
17:36:31 <mugsie> timsim: yup, thats what I am thining
17:36:37 <mugsie> until we confirm
17:36:42 <mugsie> rjrjr: 100%
17:37:01 <timsim> Alright, hopefully someone takes a look at it in the next week and we can revisit.
17:37:08 <mugsie> cool
17:37:12 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1418156
17:37:12 <openstack> Launchpad bug 1418156 in Designate "Policy definition (policy.json) is not honored for admin tenant " [Undecided,New]
17:37:37 <mugsie> this one is not a bug in my opinion - it is lack of docs about the all_tenants flag for the API
17:37:45 <timsim> #agreed mugsie
17:38:06 <rjrjr> #agreed
17:38:17 <rjrjr> this looks like an eBay reported bug too.
17:38:22 <mugsie> :)
17:38:36 <timsim> So 'Not A Bug' and a short explanation that the all tenants flag needs to be used there. And we note that on the docs sprint page?
17:38:51 <mugsie> +1
17:38:56 <vinod1> +1
17:38:58 <mugsie> any issues with ^ ?
17:39:28 <mugsie> ok, that seems like consensuious
17:39:43 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1420359
17:39:43 <openstack> Launchpad bug 1420359 in Designate "Deleting a recordset returns 204 (Deleted) even though it is async" [Undecided,New] - Assigned to Vinod Mangalpally (vinod-mang)
17:39:54 <mugsie> vinod1: you have a patch for ^ do you not?
17:40:00 <vinod1> not yet
17:40:12 <mugsie> oh
17:40:18 <mugsie> i thought i saw a patch
17:40:20 <mugsie> ok.
17:40:24 <rjrjr> high - kilo-3
17:40:38 <mugsie> med - k3
17:40:43 <timsim> med k3
17:40:56 <vinod1> med k3
17:41:03 <mugsie> med - k3
17:41:04 <rjrjr> med works
17:41:06 <mugsie> it is then*
17:41:07 <timsim> Done
17:41:23 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1420399
17:41:23 <openstack> Launchpad bug 1420399 in Designate "A zone's status needs to be updated when its recordsets are updated" [Undecided,New] - Assigned to Vinod Mangalpally (vinod-mang)
17:41:46 <mugsie> med - k3 / k-rc1
17:42:11 <mugsie> if we can get it done in k3 great, but not sure if the time will allow for it
17:42:18 <vinod1> med k3
17:42:21 <mugsie> opinions?
17:42:23 <rjrjr> med - k3
17:42:31 <rjrjr> these are pretty simple fixes IMHO
17:42:45 <mugsie> ok, cool - if it can be done - 100% med - k3
17:42:47 <vinod1> i hope to have a patchset up today
17:42:54 <mugsie> :D
17:42:54 <timsim> Cool. M K3 it is.
17:43:01 <rjrjr> #agreed
17:43:03 <mugsie> and that is the list :)
17:43:26 <mugsie> #topic Open Discussion
17:43:27 <rjrjr> quick and painless.  like the idea of doing these in this meeting.
17:43:32 <mugsie> rjrjr: me too
17:43:42 <mugsie> any one have anthong out of band?
17:44:20 <vinod1> none from me
17:44:21 <timsim> Not me.
17:44:23 <mugsie> going...
17:44:25 <rjrjr> just a comment - we will be live on Designate for some AZs on Monday.
17:44:37 <rjrjr> Icehouse though. :(
17:44:37 <mugsie> rjrjr: congrats :D
17:44:43 <mugsie> thats OK
17:44:48 <timsim> Cool!
17:44:56 <mugsie> another live install is still cool
17:45:43 <mugsie> anything else?
17:45:59 <rjrjr> after that, i'll be able to devote more time to PM and other tasks again.
17:46:04 <rjrjr> i'm good.
17:46:21 <mugsie> I think we can all agree on saying thanks to betsy for all her work - if the RAX people can pass it along :)
17:46:32 <timsim> Absolutely :)
17:46:43 <vinod1> will do
17:47:05 <mugsie> ok - thanks everyone!
17:47:09 <mugsie> #endmeeting