17:00:52 <Kiall> #startmeeting Designate
17:00:53 <openstack> Meeting started Wed May 27 17:00:52 2015 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:56 <openstack> The meeting name has been set to 'designate'
17:01:05 <Kiall> Hey folks, sorry.. forgot the time ;)
17:01:10 <Kiall> Who's about?
17:01:11 <timsim> o?
17:01:13 <elarson> o/
17:01:14 <pglass> o/
17:01:16 <mugsie> o/
17:01:18 <ducttape_> o/
17:01:21 <johnbelamaric> o/
17:01:23 <mlavalle> hi, attending my first designate meting
17:01:30 <Kiall> hey mlavalle, welcome :)
17:01:47 <mlavalle> Kiall: just in case  you don't know, this is Miguel
17:01:56 <Kiall> Aha! I was about to ask :)
17:02:04 <johnbelamaric> Thanks for merging the IB backend!
17:02:12 <Kiall> johnbelamaric: no worries :)
17:02:16 <rjrjr> o/
17:02:36 <Kiall> Okay, So.. I suspect we'll keep this meeting short today :)
17:02:53 <Kiall> No agenda items (as the agenda hasn't been updated since right before VC!)
17:03:19 <Kiall> And, no actions from our previous meet. Right..
17:03:27 <Kiall> #topic Bug triage (timsim - recurring)
17:03:41 <timsim> Just a couple....
17:03:41 <jmcbride> o/
17:03:46 <timsim> https://bugs.launchpad.net/designate/+bug/1458945
17:03:46 <openstack> Launchpad bug 1458945 in OpenStack Compute (nova) "Use graduated oslo.policy instead of oslo-incubator code" [Undecided,New]
17:03:58 <Kiall> Wait - We don't already do that?
17:04:13 <timsim> I believe so
17:04:16 <Kiall> https://github.com/openstack/designate/blob/master/requirements.txt#L40
17:04:18 <mugsie> i think we do
17:04:26 <mugsie> this bug was opened against all the projects
17:04:30 <timsim> Yeah
17:04:37 <timsim> So we just need to mark that it no longer affects us
17:04:42 <Kiall> Ah, someone opened it against every project. Okay, Close + Done  ;)
17:04:52 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1455083
17:04:52 <openstack> Launchpad bug 1455083 in python-designateclient "record create call ignores 'description' param" [Undecided,Incomplete] - Assigned to DIV (div-unknown)
17:05:17 <mugsie> high - l1 ?
17:05:31 <timsim> Has anyone confirmed that
17:05:35 <Kiall> Humm, I saw that one land.. I actually think it's a bug in the V1 API. Let's move to designate and yea.. High.. Anyone able to try tackle it?
17:05:46 <mugsie> i will
17:05:50 <Kiall> I haven't, but looking at it, I can bet I know what it is.
17:06:06 <mugsie> mark it as triaged, and assign to me
17:06:11 <mugsie> I will dig into it this week
17:06:15 <timsim> Alright. I'll move it to Designate and mark it l1 - high, and assign to mugsie
17:06:23 <mugsie> :)
17:06:28 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1458130
17:06:28 <openstack> Launchpad bug 1458130 in python-designateclient "Missing Logger Handler" [Undecided,New]
17:06:38 <mugsie> wishlist
17:06:49 <Kiall> Actually, Not a bug
17:06:58 <mugsie> well, it is a bug
17:07:06 <Kiall> if there using the bindings directly, it up to their app to configure logging.
17:07:22 <mugsie> it shows for all CLI operations as well
17:07:28 <Kiall> That's a different one ;)
17:07:49 <Kiall> No handlers could be found for logger "keystoneclient.auth.identity.base" vs the client wich gives out about oslo.config, which is one we need to fix..
17:08:35 <mugsie> ok, then close with some description of ^?
17:08:44 <Kiall> Gah - 4 different chat programs beeping at once..
17:08:54 <Kiall> Yea, I think so..
17:09:18 <Kiall> timsim: was that the last new one to review?
17:09:22 <timsim> Alright, will do.
17:09:23 <timsim> Yep
17:09:26 <johnbelamaric> Sorry folks, I have to drop off, I just found out I need to pick my son up from school - he missed the bus!
17:09:34 <Kiall> johnbelamaric: emjoy :)
17:09:36 <Kiall> enjoy*
17:09:40 <johnbelamaric> thanks
17:09:50 <Kiall> Okay, since the agenda was empty and recurring stuff is done...
17:09:53 <Kiall> #topic Open Discussion
17:10:22 <Kiall> So - mlavalle - I had some Q's re the Designate/Neutron stuff..
17:10:46 * mlavalle listening
17:10:46 <Kiall> Specifically around cleaning up the specs and getting those merged, should one of us take them over from Carl and start that?
17:11:03 <Kiall> (obv, checking with carl_baldwin first ;))
17:11:04 <mlavalle> Kiall: I will be taking care of both
17:11:26 <Kiall> Okay, excellent - Wanted to make sure it wasn't dropped or done twice :)
17:11:28 <mlavalle> actually the Neutron side was approved this morning by the Neutron drivers
17:11:39 <Kiall> Oh nice, I missed that :)
17:11:41 <mlavalle> I'll clean it up and get it merged
17:11:52 <carl_baldwin> +1
17:12:24 <mlavalle> on the nova side, I went to this session after our meeting in Vancouver: https://etherpad.openstack.org/p/YVR-nova-network
17:13:08 <mlavalle> if you got to the end, the Priority section, you will see our project listed in number 4
17:13:24 <mlavalle> the nova PTL commited during that session to get it done
17:13:35 <Kiall> Excellent.. We may actually pull this heist off.
17:13:37 <mlavalle> he asked me to ping him this week
17:14:07 <mlavalle> and I am starting to work on the code
17:14:23 <Kiall> Okay, so I know for me, getting all this done this cycle is #1 for me.. We've talked about it for SO long, and people keep asking for it.
17:14:50 <Kiall> I'll grab Sean if he's around today to talk DevStack stuff.. See if I can get our devstack plugin merged, so it's easier to work with it.
17:14:59 <mlavalle> great, I can report weekly on progress
17:15:06 <Kiall> Thanks :)
17:15:27 <Kiall> Okay - So, for those who didn't make it to the summit! Did anyone have concerns after reading the specs?
17:15:41 <rjrjr> i am good.
17:16:24 <Kiall> rjrjr: Q - You guys implemented something like this with sink, does the proposed solution cover your use cases?
17:16:45 <Kiall> (It may not, and I guess I consider this a first step towards allowing more complex stuff down the line)
17:17:12 <rjrjr> i'll have to look specifically at how cells are handled.
17:17:46 <rjrjr> but the rest seems okay.
17:18:23 <Kiall> cool :) Ping me or mlavalle if you spot any concerns, your deploy is probably about as complex as OpenStack deploys can get ;)
17:18:50 <rjrjr> will do.
17:19:11 <Kiall> Okay.. Moving on.. I had one other thing I wanted to quicky discuss.. Before I do, since it'll take me a min or two to write... Anyone else have off-agenda items?
17:19:20 <elarson> if folks have a minute: https://review.openstack.org/#/c/164748/
17:19:38 <elarson> hook points ^^^
17:20:09 <timsim> Should we make sure that someone is assigned to write up all the sessions that need writing up from last week?
17:21:00 <Kiall> Yes, if etherpad wasn't disconnecting me I was starting to fill https://etherpad.openstack.org/p/designate-vancouver out
17:21:14 <Kiall> (I totally got the days confused, so had no prep done for this meet ;))
17:21:37 <rjrjr> i also need to review 3 specifications (hopefully for liberty) with the group.  when would be a good time for that?
17:21:43 <mugsie> i think we handed out write ups to people on the day didnt we?
17:22:03 <Kiall> Yea, I'm writing the names I remember down ;)
17:22:56 <mugsie> rjrjr: are they all final now?
17:23:05 <rjrjr> yes.
17:23:18 <rjrjr> barring changes from the team of course. :)
17:23:40 <mugsie> I think we should aim to have everyone do reviews this week, then re-cap either next week or the week after (next was supposed to be a recap of the summit)
17:23:53 <Kiall> rjrjr: the summit ended up with either full slots, or too tired to move! I think we should find a slot early next week (Mon/Tue) to dicuss those ..
17:24:35 <rjrjr> okay.  i can work with mugsie on setting something up early next week.
17:24:52 <rjrjr> (if he is available.)
17:24:54 <Kiall> or what mugsie said.. next weeks meet we intend to review all the summit sessions etc, not sure we'll be able to squeeze 3x BPs in there too :)
17:25:15 <Kiall> (and I'm still catching up from getting back, so couldn't discuss them with any real insight today)
17:25:31 <timsim> Early next week sounds good.
17:25:41 <rjrjr> video conference for the session review?
17:26:08 <mugsie> rjrjr: I am availible - ping me later on
17:26:15 <mugsie> VC might be a good Idea
17:26:16 <rjrjr> thx mugsie.
17:26:37 <Kiall> rjrjr: Yea, I suspect that's going to be easier than the IRC meet for the review.. It's mostly a "Did we really agree on this? Do we still agree to this?" session ;)
17:27:18 <Kiall> rjrjr: So, you can fire out an email to everyone re a meet on Mon/Tue for those 3 specs?
17:27:39 <rjrjr> yes.  i'll work with mugsie on that since he has most of the contacts.
17:27:44 <Kiall> mugsie: can you do the usual GH invite? mlavalle: have you got Google Hangouts?
17:27:52 <mugsie> yup
17:28:09 <mlavalle> mlavalle: no, I don't
17:28:27 <mugsie> I might look at getting bluejeans though - we might be over the limit of Hangouts
17:28:40 <Kiall> Humm.. Okay.. Let's start with the Nova/Neutron one IRC then :)
17:28:58 <mugsie> #action mugsie look at VC sollution for review
17:29:13 <mlavalle> Kiall: we use something called Vydio internally. Let me find out if I can use that with external people. I'll get back to you
17:29:34 <Kiall> mlavalle: I don't think I have your email, could you PM me your email? :)
17:29:45 <Kiall> Okay, Let's move on mugsie and rjrjr will organize the rest OOB.
17:29:50 <Kiall> Any other off-agenda topics?
17:30:34 <timsim> nope
17:30:43 <rjrjr> i'm good.
17:31:47 <Kiall> Okay, I knew it would be a short meeting :)
17:32:03 <rjrjr> kiall: you had something, correct?
17:32:22 <Kiall> it was the writeup owners.. I was filling them out as tim asked about it ;)
17:32:56 <Kiall> (BTW - Write up can be a full spec, which is needed anyway, or a new etherpad with the description/list of things etc agreed..)
17:33:21 <Kiall> Okay - Thanks all, Same time here next week.. We'll move to VC after the Nova/Neutron piece.. or straight away if mugsie finds something that works for everyone!
17:33:45 <Kiall> #endmeeing
17:33:52 <Kiall> #endmeeting