17:01:09 <mugsie> #startmeeting Designate
17:01:10 <openstack> Meeting started Wed Jun  3 17:01:09 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:14 <openstack> The meeting name has been set to 'designate'
17:01:21 <mugsie> hey - whos here?
17:01:24 <ducttape_> yo
17:01:25 <mlavalle> hi
17:01:36 <Kiall> o/ .. 2 mins, wrapping up another call
17:01:40 <timsim> o/
17:01:57 <jmcbride> o/
17:02:16 <mugsie> #topic Action Items
17:02:32 <mugsie> there was one - for me, which I did for the Hangout on monday
17:02:53 <mugsie> #topic Design Summit Review
17:03:23 <mugsie> we said before the summit we would circle back this week on the decissions made at the summit
17:03:31 <mugsie> so, to start:
17:03:41 <mugsie> #topic Session 2 (Workroom) - Database Interaction Rework - https://etherpad.openstack.org/p/designate-vancouver-session-2
17:03:48 <mugsie> Kiall: all yours
17:04:19 <Kiall> Hah, you had to start with that one. I'm afraid I didn't get time to write that one up, can we circle back next week?
17:04:39 <mugsie> #action Kiall finish the write for DB Re-Work
17:04:52 <mugsie> #topic Session 4 (Workroom) - ALIAS Records - https://etherpad.openstack.org/p/designate-vancouver-session-4
17:05:00 <Kiall> #link http://docs-draft.openstack.org/19/188019/1/check/gate-designate-specs-docs/d8a8a97//doc/build/html/specs/liberty/alias-records.html
17:05:01 <mugsie> hah - Kiall you again :p
17:05:31 <Kiall> Spec went up ealier today .. The intent of todays meet is to review, make sure it's what we agreed with nothing missed.. So, let's take 5 min now to review pls
17:06:20 <Kiall> (I've intentionally avoided getting into too much implemetation detail, wanted to keep them as high-ish level.
17:06:29 <Kiall> Also.. This builds on the other spec. lol -_-
17:06:59 <Kiall> The other spec being http://docs-draft.openstack.org/19/188019/1/check/gate-designate-specs-docs/d8a8a97//doc/build/html/specs/liberty/zone-exists-event.html
17:07:04 <Kiall> Which has some the groundwork in it.
17:07:06 <elarson> o/
17:07:32 <mugsie> hey elarson re are reviewing http://docs-draft.openstack.org/19/188019/1/check/gate-designate-specs-docs/d8a8a97//doc/build/html/specs/liberty/zone-exists-event.html
17:07:41 <mugsie> we*
17:08:17 <Kiall> Kinda.. That's different to the #topic, the specs don't build on each other in the same order as the summit sessions ;')
17:08:46 <Kiall> Okay.. Let's circle back. Start with zone-exists-event.html .. that latest link ;)
17:09:07 <mugsie> #topic Session 7 (Workroom) - Ceilometer Integration - https://etherpad.openstack.org/p/designate-vancouver-session-7
17:09:08 <elarson> mugsie: thx!
17:09:17 <mugsie> #link http://docs-draft.openstack.org/19/188019/1/check/gate-designate-specs-docs/d8a8a97//doc/build/html/specs/liberty/zone-exists-event.html
17:09:53 <Kiall> timsim/jmcbride/ducttape_/mlavalle/anyone else who didn't say o/ .. in case your buried in a browser reading and confused ^
17:10:15 <timsim> 👍
17:10:25 * timsim doesn't know if emoji thumbs up will come through for everyone :P ^
17:10:49 <mugsie> nope
17:10:52 <ducttape_> ack
17:12:06 <timsim> :(
17:12:34 <Kiall> Re-reading it myself, I see the first gap.. jbratton was very very keen on "Ability to stagger start times throughout the hour."
17:13:41 <Kiall> Anyone found any other gaps or mistakes in understading / memory?
17:14:00 <ekarlso> o/
17:14:01 <elarson> fwiw s/events/eventsm
17:14:14 <ekarlso> sorry but had to help wife with baby :)
17:14:16 <ducttape_> seems reasonable, but Clayton from our side would be the best reviewer
17:14:21 <mugsie> #chair Kiall
17:14:22 <openstack> Current chairs: Kiall mugsie
17:14:47 <Kiall> ducttape_: more the merrier.. We have have missed important detail during the session
17:15:14 <Kiall> elarson: I'm not sure I follow? replace events with eventsm>?
17:15:19 <Kiall> ah
17:15:22 <Kiall> other way around ;)
17:15:32 <Kiall> #link https://review.openstack.org/#/c/188018/
17:15:36 <Kiall> ^ actual gerrit review for the spec
17:15:38 <elarson> yup
17:16:23 <Kiall> Any other gaps, anyone still reading / wrapping their head around it?
17:16:31 <timsim> Seems to capture the spirit of what we talked about.
17:17:09 <Kiall> timsim: great!
17:17:10 <mugsie> yeah - I look at specs as a "general sprirt" of what the implementations should try and end up like
17:17:26 <mugsie> so, with the stagared start, i thinkit covers what we talked about
17:17:27 <Kiall> mugsie: ++ I avoided implemetation detail, because that always changes when you go to actually do it.
17:17:47 <Kiall> Okay.. Let's move to the next one, which builds on this..
17:17:51 <Kiall> #topic Session 4 (Workroom) - ALIAS Records - https://etherpad.openstack.org/p/designate-vancouver-session-4
17:17:59 <Kiall> #link http://docs-draft.openstack.org/19/188019/1/check/gate-designate-specs-docs/d8a8a97//doc/build/html/specs/liberty/alias-records.html
17:18:07 <Kiall> #link https://review.openstack.org/#/c/188019/
17:19:44 <timsim> So ALIAS records are pseudo, and the associated A records are hidden.
17:20:10 <Kiall> timsim: exactly, that came from trying to figure out where to keep both the set's of values
17:20:16 <timsim> I like that.
17:20:22 <Kiall> (e.g. the ALIAS target, and the target's A/AAAA's)
17:21:21 <Kiall> Honestly, as we get more pseudo RRtypes (e.g. Geo) - I kinda expect that to fall over.. But it should work for Failover stuff too, which is shorter-term than Geo
17:21:49 <timsim> I wondered if, in terms of work items, we could start with hidden/pseudos, and then just let alias records be created, but not polled by zone-manager, and then eventually add polling, and then eventually eventually add the optimization to figure out if the CNAME is in Designate, and not have to poll
17:21:53 <Kiall> But - Without knowing what that really ends up looking like implementation wise, I figured keep it simple for now
17:22:29 <timsim> How would that work with failover?
17:22:45 <timsim> Oh, literally a FAILOVER record type?
17:22:52 <Kiall> FAILOVER pseudo RR ;)
17:22:57 <mugsie> yeah
17:23:09 * mugsie is personally not sold on that particular usecase
17:23:21 <timsim> Yeah I don't know about that...need a think
17:23:26 <mugsie> but it could be adapted for it iof needed
17:23:36 <mugsie> I like the implementation for tbh
17:23:46 <mugsie> for ALAIS *
17:23:52 <Kiall> timsim: it feels better when we finally bother to do structured rdata.. That way, the failover sets aren't crammed into a single string
17:23:54 <timsim> I love it for ALIAS.
17:24:25 <Kiall> Okay - So, any gaps?
17:24:36 <mugsie> nah - it captures the spirit
17:24:46 <timsim> I suppose we can talk about failover more later. I think I see how it could work.
17:25:08 <mugsie> ++
17:25:09 <timsim> But yeah, this spec is good imo
17:25:12 <Kiall> timsim: I added that comment to the review.
17:25:41 <Kiall> Anyone else have comments on this one, is it what we agreed at the summit, is it sane, etc?
17:26:37 <mugsie> last chance!
17:26:38 <mugsie> :P
17:26:46 <Kiall> Okay.. Moving on
17:26:47 <mugsie> #topic Session 5 (Workroom) - Horizon Integration - https://etherpad.openstack.org/p/designate-vancouver-session-5
17:26:58 <Kiall> #link http://docs-draft.openstack.org/73/188073/1/check/gate-designate-specs-docs/aeba007//doc/build/html/specs/liberty/horizon-integration.html
17:26:59 <mugsie> #link https://review.openstack.org/#/c/188073/
17:27:00 <Kiall> #link https://review.openstack.org/#/c/188073/
17:27:28 <mugsie> So, this is not so much a spec as a over spec of the discussion
17:27:41 <mugsie> I would expect more detailed specs for each as we go
17:27:46 * ducttape_ perks up
17:28:05 <mugsie> we left a few as questions in the summit, and I have reflected that here
17:28:48 <ducttape_> that stuff helps me, thanks.  right now I am working on tickets needed for our deployment, but I'd like to do some admin panels for sure
17:28:51 <mugsie> and questions / comments / hatred of all my ideas?
17:29:00 <timsim> so much hatred ;)
17:29:03 <mugsie> ducttape_: np
17:29:19 <mugsie> :)
17:29:33 <mugsie> the repe link is dead, as well, its not in progress
17:29:35 <timsim> We could probably implement discovery ghetto-like with zones?name=blah.com. -H alltenants
17:29:41 <mugsie> but it will be fore the end of day
17:29:45 <timsim> As a start, idk.
17:29:59 <Kiall> timsim: I see that as covererd in admin panel -all zones list
17:30:02 <mugsie> timsim: i figure the all zones page will have filtering
17:30:06 <Kiall> (which would have filters, and paging)
17:30:15 <mugsie> need to add that to the spec
17:30:15 * ducttape_ wonders if dns really can be called gheto-style
17:30:20 <Kiall> mugsie: yea, looks like what I remember. This session was totally open, so no concrete actions out of it other than the rought prioritized list
17:30:30 * timsim wasn't reading good
17:30:49 <timsim> Yeah, looks right to me
17:31:18 <Kiall> Okay - Since this one is so "Open", let's leave it to review comments and specs that build out of it..
17:31:35 <Kiall> Any last comments on .. Maybe "Why on earth isn't X listed as a priority?" etc ;)
17:31:46 <mugsie> ++
17:32:06 <Kiall> #topic Session 8 (Workroom) - Nova/Neutron Integration - https://etherpad.openstack.org/p/designate-vancouver-session-8
17:32:09 <Kiall> #link https://review.openstack.org/#/c/88624/
17:32:09 <Kiall> #link https://review.openstack.org/#/c/88623/
17:32:09 <Kiall> #link https://review.openstack.org/#/c/90150/
17:32:19 <Kiall> 3 specs there, 1 for nova - 2 for Neutron
17:32:48 <mlavalle> Kiall: I clieaned up https://review.openstack.org/#/c/88623/ and https://review.openstack.org/#/c/90150/
17:33:07 <Kiall> mlavalle has updated them over the last few days, can we take a quick review double checking things line up with the discussion - and a full review ASAP ;)
17:33:53 <mlavalle> Kiall: I also followed up with johnthetubaguy today about https://review.openstack.org/#/c/90150/. He is supportive of the effort. He said that he is just catching up with with specs reviews
17:34:17 <mlavalle> johnthetubaguy is the nova ptl, for those who doesn't know
17:34:58 <Kiall> Cool :)
17:35:01 <mlavalle> as far as https://review.openstack.org/#/c/88624, you offered to update it with the details of our Vancouver conversation
17:35:22 <Kiall> Did I? Oh. Right, Okay
17:35:33 <Kiall> #action kiall to update  https://review.openstack.org/#/c/88624 per summit discussion
17:35:43 <mlavalle> Kiall: why don't you take a first stab at it and then I will add my comments in gerrit?
17:35:50 <Kiall> mlavalle: sounds good to me
17:36:19 <mlavalle> I am also starting to write code for https://review.openstack.org/#/c/88623/ this week
17:36:22 <Kiall> I'm guessing people are still reading, there long specs! Anyone seeing anything that conflicts with summit discussion etc?
17:36:31 <Kiall> mlavalle: :D
17:37:15 <mugsie> No - Over they are good
17:37:27 <mugsie> we need to update with the new API / client calls we fleshed out
17:37:35 <mlavalle> also offered to johnthetubaguy to help implement https://review.openstack.org/#/c/88624/
17:37:39 <mugsie> and remoeve the duplicate check
17:37:50 <mugsie> but ++ other wise
17:37:59 <Kiall> Yea, Okay.. Anyone else?
17:38:11 <mlavalle> That's all I have this week
17:39:09 <timsim> Looks like what I remember.
17:39:13 <Kiall> mlavalle: perfect :) Okay, people are silent.. If you're still reading and not watching IRC, say so ;)
17:39:35 <Kiall> timsim: Okay, any more comments - leave them on the spec pls :)
17:40:13 <Kiall> John from InfoBlox had offererd to write up the "Non-AXFR Backends" one, but he's not here today..
17:40:26 <Kiall> #action circle back to Non-AXFR Backends summit review
17:40:58 <Kiall> Okay, that was all the sessions we felt needed a write up.. .
17:41:13 <Kiall> with 2.5 needing be come back to next week
17:41:38 <Kiall> #topic Open Discussion
17:41:45 <Kiall> 20 mins left here, any off agenda items?
17:41:55 <timsim> The HP Helion Cloud cups are a huge hit here.
17:42:07 <Kiall> timsim: awesome :)
17:42:24 <Kiall> Get a photo will ya, our marketing folks would love it!
17:42:36 <Kiall> (Not so sure about yours though ;))
17:42:37 <timsim> Lol, ours probably wouldn't :P
17:42:55 <mugsie> timsim: you think? :P
17:43:25 <mlavalle> Kiall: John from Infoblox is known as johnbelamaric in #openstack-neutron
17:43:51 <Kiall> Yep - He's usually here for this meet, I'm assuming he's busy today as he's here nearly every week
17:44:38 <Kiall> Okay - I guess everyone is out of off-agenda items.
17:44:58 <mugsie> o/
17:45:10 <Kiall> Let's call it a day, power through the last 2.5 specs next week, and actually get some of this stuff done :)
17:45:17 <mugsie> ++
17:45:17 <timsim> o/
17:45:34 <Kiall> cya! Enjoy the 15 mins back ;)
17:45:37 <Kiall> #endmeeting