17:00:36 <Kiall> #startmeeting Designate
17:00:37 <openstack> Meeting started Wed Aug 12 17:00:36 2015 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:40 <openstack> The meeting name has been set to 'designate'
17:00:43 <Kiall> Hey folks - Who's about?
17:00:45 <elarson> o/
17:00:47 <mlavalle> hi
17:00:48 <timsim> o?
17:01:20 <Kiall> will give others a few mins ;)
17:01:21 <mugsie> o/
17:01:59 <mimi> o/
17:02:00 <Kiall> ekarlso / federico3 / jmcbride / etc about?
17:02:02 <federico3> o/
17:02:08 <timsim> No jmcbride
17:02:20 <Kiall> Cheek of him, taking a day off ;)
17:02:35 <Kiall> Okay - Let's get going..
17:02:39 <james_li> james li
17:02:40 <Kiall> #topic Announcements
17:02:56 <Kiall> One - Since the mid cycle is next week, the IRC meet will be cancelled.
17:02:58 <ducttape_> o/
17:03:17 <Kiall> #info Next Weeks IRC meeting cancelled
17:03:30 <Kiall> ^ pretty sure that highlights it in the meeting notes.. I think
17:03:40 <Kiall> #topic Action Items from last week
17:03:46 <Kiall> 2
17:03:50 <Kiall> 1) kiall to BP db6a6b6 + 2c7c03f
17:04:01 <Kiall> I have a feeling I did? But I'm going to be honest - I dont remember
17:04:09 <Kiall> I'll check in a few mins ;)
17:04:15 <Kiall> second was
17:04:15 <Kiall> timsim test out rendering times for stupidly large zones
17:04:33 <Kiall> timsim: want to talk about that under the Zone Export topic later?
17:04:56 <timsim> Kiall: yep
17:05:07 <Kiall> Cool :)
17:05:08 <Kiall> #topic Bug Triage (timsim - recurring)
17:05:11 <Kiall> over to you so
17:05:13 <timsim> https://bugs.launchpad.net/designate/+bug/1483404
17:05:13 <openstack> Launchpad bug 1483404 in Designate "500 on invalid body on a POST /pools" [Undecided,New]
17:05:14 <uvirtbot> Launchpad bug 1483404 in designate "500 on invalid body on a POST /pools" [Undecided,New] https://launchpad.net/bugs/1483404
17:05:15 <uvirtbot> Launchpad bug 1483404 in designate "500 on invalid body on a POST /pools" [Undecided,New]
17:05:32 <mugsie> H, l3, assign to me
17:05:41 <timsim> k
17:05:46 <timsim> That's it :)
17:06:07 <Kiall> Side note - Any of the infra folks about and able to remove uvirtbot? AJaeger / jeblair etc
17:06:28 <Kiall> Moving on so, simple one ;)
17:06:35 <Kiall> #topic Stable Backport Triage (kiall - recurring)
17:06:42 <Kiall> #link http://paste.openstack.org/show/412738/
17:06:57 <Kiall> As usual - please take a few mins to check if there's anything we need to backport etc
17:07:31 <Kiall> (and - These lists are making me want to start -1'ing over bad commit titles ;))
17:07:31 <timsim> "cad363a Fix zone transfer requests + add tempest tests" if it was broken in stable/kilo
17:07:48 <Kiall> mugsie: was ^ broke in Kilo?
17:07:51 <Kiall> or just master?
17:07:54 <mugsie> no idea
17:07:59 <Kiall> K
17:08:08 <mugsie> i think it was just master
17:08:10 <Kiall> #action mugsie to check if "cad363a Fix zone transfer requests + add tempest tests" applies to stable/kilo
17:08:22 <Kiall> 794e679 Provide error messages on CRUD actions <-- Probably?
17:08:31 <mugsie> yeha
17:08:33 <mugsie> its small
17:08:36 <mugsie> 4fb0e91 Add a iteritems = items on DictObjectMixin
17:08:51 <mugsie> if it affects the notification outputs
17:08:59 <Kiall> ^ not needed in Kilo, it was a result of py3 work
17:09:25 <mugsie> k
17:09:53 <Kiall> 23633e4 Merge "Wildcard records"? I think that may affect the V2 API in kilo too?
17:10:05 <Kiall> #action kiall to check on 23633e4 Merge "Wildcard records" for stable/kilo + BP if necessary
17:10:29 <Kiall> Any others not #action'd?
17:10:41 <Kiall> #action kiall to BP 794e679 Provide error messages on CRUD actions
17:11:19 <timsim> I think that's it
17:11:30 <Kiall> K.. Moving on :)
17:11:40 <Kiall> #topic Designate/Neutron Integration Update (mlavalle)
17:11:45 <mlavalle> hi
17:11:50 <Kiall> mlavalle: Hey :)
17:12:02 <mlavalle> great progress with https://review.openstack.org/#/c/200952/
17:12:02 <Kiall> How's progress?
17:12:24 <mlavalle> it got its first +2 yesterday and I expect it to merge today or tomorrow
17:12:41 <mlavalle> so the internal side will be done this week
17:12:45 <Kiall> The hp-neutron-l2-gateway gate is the only (Voting) one still failing - won't that block it?
17:13:09 <mlavalle> I don't think it will
17:13:43 <mlavalle> but i'll keep looking at it until it merges
17:13:45 <Kiall> Ah, right it's not voting -1
17:13:46 <Kiall> OK
17:14:16 <mlavalle> so I am full throttle with the xternal side
17:14:57 <mlavalle> I want to push something tonight or tomorrow, as wip, so I can start gathering early feedback
17:14:59 <Kiall> Cool - Any ideas when you might have an initial review up? :)
17:15:29 <Kiall> lol - asked too soon ;)
17:15:36 <mlavalle> at this point, I mostly want feedback on the interface between neutron and the external dns service
17:16:08 <Kiall> Yea, that's something we can help with :) Neutron code == black magic, interface to designate = something we understand ;)
17:16:13 <mlavalle> the neutron side (floating ips and the rest) I am finding pretty easy, given what I learned with the current patchset'
17:16:33 <Kiall> Any particular issues your hitting etc?
17:16:43 <mlavalle> one question:
17:17:04 <mlavalle> are the instructions in the doc directory for devstack up to date?
17:17:21 <mlavalle> I mean the doc directory in the designate repo
17:17:30 <Kiall> Possibly? I usually just use the vagrant setup in contrib/vagrant
17:17:50 <Kiall> Anyone feel like testing those docs out today and updating them if they are out of date?
17:18:06 <Kiall> (It's near the end of my way, so I won't get the time today!)
17:18:10 <Kiall> my day*
17:18:11 <mlavalle> well, i'll test them anyway. i'll let you know
17:18:41 <mlavalle> i create my devstacks in rackspace public cloud instances
17:18:42 <Kiall> mlavalle: if there wrong, ping me in #openstack-dns.. I'll keep an eye out for messages
17:18:50 <mlavalle> will do
17:18:58 <mlavalle> that's all for today
17:18:59 <Kiall> (and timsim too ;) - he's US, so will be around later
17:19:14 <timsim> :)
17:19:27 <Kiall> Thanks mlavalle - really looking foward to seeing all this wired up together :)
17:19:35 <mlavalle> me too :-)
17:19:42 <Kiall> Okay! Moving on so :)
17:19:43 <Kiall> #topic Zone Export in /v2 (timsim, mimi)
17:19:51 <Kiall> timsim / mimi over to you two
17:19:52 <timsim> So mimi got exports of a 30k record zone to 2-4 seconds (from 400 seconds!!) and a 100k zone to 7-16 seconds synchronously, this was with all the Designate processes on one node, with MySQL. There would probably be some additional latency if those things weren't all on the same box. But I wanted to talk about whether those numbers make us comfortable enough to continue synchronously, or if we want to just have a nice
17:19:53 <timsim> and fast async process in the zone manager.
17:20:37 <mugsie> async present issues with where do we hoist the output
17:20:41 <mugsie> host*
17:20:44 <mugsie> but ...
17:20:46 <timsim> Yup
17:20:53 <Kiall> First .. That's an excellent result / decrease :)
17:20:59 <timsim> I know right!?!
17:21:00 <mugsie> 200K zone might take out an API node
17:21:12 <mugsie> sorry 1mil record zone
17:21:16 <Kiall> Well
17:21:33 <timsim> All the actual computation was moved to central so that the API would just be handling the HTTP bits, but still, probably.
17:21:34 <Kiall> I'd be very interested to know what happens when you have, say a couple of bash while loop quering the API, then start the 200k zone export
17:21:43 <Kiall> 100k*
17:21:47 <mugsie> yeah
17:22:02 <mugsie> on that note - i found a profiler that works with eventlet
17:22:05 <Kiall> If the API process is doing what I think it's going to be doing, no API requests will be served during that 7 or so seconds :(
17:22:17 <mugsie> so I want to run it against this and see.
17:22:19 <timsim> Even if we moved the writing of the template to central?
17:22:21 <mugsie> API does not thing
17:22:27 <mugsie> (just looked)
17:22:45 <timsim> Well...since it's sync...yeah possibly
17:22:46 <mugsie> but the question is then that much data over RMQ could be an issue
17:22:52 <Kiall> timsim: well, we'd be "relocating" the problem there, and central is still in the path of API interactions
17:23:00 <timsim> Yeah
17:23:13 <mugsie> well, the API will switch context right?
17:23:21 <timsim> It should.
17:23:41 <timsim> You'd have to have multple central processes though, I'd bet.
17:23:41 <Kiall> amount of data over RMQ shouldn't be an issue.. it'l probably be faster actually to render in central and return the zone as a blob.. Less JSON encoding / decoding to do..
17:23:44 <mugsie> there will be a block of time serialising / de serialising
17:23:54 <Kiall> mugsie: it context switches around IO, not around CPU
17:24:10 <Kiall> and - rendering 100k records will use a chumk of CPU time
17:24:14 <Kiall> chunk*
17:24:18 <mugsie> yeah - the API will context switch
17:24:24 <timsim> It was taking around half a second I think to render that 100k blob in central.
17:24:29 <ekarlso> sigh, sorry was away with the kid a bit
17:24:31 <mugsie> OK ..
17:24:45 <mugsie> it might be a good topic for the mid cycle
17:24:58 <mugsie> I also think we can merge the current version into the admin API in any case
17:25:06 <mugsie> as it is a massive improvment on whats there
17:25:09 <Kiall> ^ yes
17:25:14 <timsim> Agreed
17:25:25 <elarson> take a bow mimi :)
17:25:28 <mugsie> and then we can fight async vs sync in austin
17:25:35 * mimi takes a bow
17:26:16 <Kiall> Anyway! How do we proceed with the move to the "real" API? Handle it F2F in Austin?  Should we try and verify the behaviour of the API for parallel requests while it's exporting etc before TX?
17:26:23 <mugsie> ++
17:26:32 <Kiall> lol - to what part? ;)
17:26:47 <timsim> Alright, well we can review that once more and get it merged, in the meantime mimi can do a bit more testing and see if we can't get a more complete picture before the mid-cycle and handle it face to face :)
17:26:47 <mugsie> verify
17:27:03 <mugsie> verify paralel requests*
17:27:04 <mugsie> gah
17:27:07 <mugsie> me no english
17:27:12 <mugsie> today*
17:27:16 <Kiall> OK .. Sounds good.  :)
17:27:19 <timsim> Cool.
17:27:32 <Kiall> Moving on so :)
17:27:34 <Kiall> #topic Mid-Cycle Agenda (timsim)
17:27:48 <Kiall> timsim: ... your mic again ;)
17:28:04 <timsim> So this was for jmcbride, he wanted to get some discussion going around possible topics for the mid cycle
17:28:05 <timsim> #link https://etherpad.openstack.org/p/designate_2015_summer_midcycle_meetup
17:28:37 <Kiall> "Topics Please add proposed discussion topics here:" <-- was that always there and we just ignored it?
17:28:51 <timsim> Probably :P
17:28:54 <mugsie> :)
17:29:15 <timsim> I figured the Must Haves section of https://etherpad.openstack.org/p/designate-vancouver-session-1 would be a good place to start
17:29:30 <mugsie> ++
17:29:44 <Kiall> Yea ++
17:30:30 <Kiall> Any others off-hand?
17:30:58 <timsim> We could talk about general format too, in San Jose we did more actual coding, and I think we all liked that.
17:31:18 <Kiall> Yea, that was less draining ;)
17:31:51 <Kiall> I'm easy - I personally think we'll arrive there, find it's 90deg outside, and have no choice but to hide under a cold wet towel all week anyway.
17:32:00 <mugsie> :D
17:32:14 <timsim> hah. Try 105 degrees :P
17:32:20 <elarson> yeah, seriously
17:32:29 <Kiall> oh ffs -_-
17:32:30 <elarson> I'd still be cycling downtown at 90 ;)
17:32:30 <timsim> Or 40.5 for you Europeans
17:32:39 * mugsie might die
17:33:01 <Kiall> High's of 68 here and it's pretty hot at that
17:33:03 <timsim> We've had some fun discussions about Friday activites that we'll fill you in on when you get here too.
17:33:08 <mugsie> oh no
17:33:10 <Kiall> Cool :)
17:33:17 <mugsie> i dont trust timsim
17:33:18 <mugsie> :P
17:33:26 <timsim> As a preview: imagine mugsie falling in a river
17:33:31 <Kiall> YES. DO IT.
17:33:38 <mugsie> well - at 105 I might jump
17:33:48 <mugsie> s/might/totaly will/
17:33:52 <mugsie> :)
17:34:06 <Kiall> Okay, so .. I think we do our usual from here anyway, take the first few hours to scope a tighter agenda etc
17:34:30 <Kiall> Do we have anyone wanting to "Dial in" via Video etc?
17:34:36 <timsim> Yeah for sure. I'll have jmcbride look at that when he gets in, i'm sure he'll have some more things to add.
17:35:06 <timsim> I think Joe was going to set something up for those folks, not sure if anyone responded to the mailing list post.
17:35:07 <Kiall> K - Let's move to Open Discussion so and call this one "done"
17:35:08 <Kiall> #topic Open Discussion
17:35:20 <Kiall> (New keyboard, have to type everything 3 times to get it right -_-)
17:35:26 <mugsie> o/
17:35:59 <Kiall> Any other off-agenda topics? rants? anything at all? ;)
17:36:04 <mugsie> Kosmos has started to ramp up - if anyone wnats to get invovled please join us in #openstack-gslb
17:36:18 * timsim is lurking :)
17:36:21 <mugsie> Kosmos is the new name for the Gloab Load Balancing project
17:36:30 <mugsie> Global*
17:36:45 <mugsie> which will use Designate by default
17:37:34 <Kiall> OK... Any other off-agenda items before we wrap up?
17:38:01 <Kiall> REMINDER - NO MEETING NEXT WEEK DUE TO MID-CYCLE (In case anyone lurking missed it at the start)
17:38:17 <mugsie> might send a mail to the list Kiall ?
17:38:29 <Kiall> Yea, I'll do that
17:39:16 <Kiall> Okay, no takers.. will call it :)
17:39:31 <Kiall> Thanks folks, see "ya'll" in TX next week ;)
17:39:36 <timsim> Yeehaw
17:39:40 <Kiall> lol
17:39:49 <Kiall> #endmeeting