16:59:46 <Kiall> #startmeeting Designate
16:59:48 <openstack> Meeting started Wed Sep  9 16:59:46 2015 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:51 <openstack> The meeting name has been set to 'designate'
16:59:58 <Kiall> Hey folks - whos about?
17:00:13 <timsim> o/
17:00:24 <elarson> o>
17:00:28 <mugsie> o/
17:00:29 <pglass> o/
17:00:29 <mlavalle> ahoy
17:00:34 <ekarlso> oii
17:00:50 <Kiall> Okay, let's get going :)
17:00:51 <Kiall> #topic Announcements
17:01:01 <Kiall> L3 is out :)
17:01:11 <Kiall> That's it from me ;) Anyone else?
17:01:29 <Kiall> Guess not :)
17:01:32 <Kiall> #topic Action Items from last week
17:01:50 <Kiall> No actions from last week - but timsim there's some stable/kilo backports in need of +A from a week or two ago
17:02:22 <Kiall> #topic Bug Triage (timsim - recurring)
17:02:26 <Kiall> over to you timsim :)
17:02:36 <timsim> https://bugs.launchpad.net/designate/+bug/1487934
17:02:37 <openstack> Launchpad bug 1487934 in Designate "500 error returned in List Records in a Domain" [High,New]
17:02:47 <timsim> Might just need "triaged"?
17:02:56 <mugsie> yeah
17:03:02 <mugsie> Kiall: must have missed it last week :P
17:03:06 <Kiall> Yea, I missed that.. whoops.
17:03:12 <timsim> np
17:03:12 <timsim> https://bugs.launchpad.net/designate/+bug/1491248
17:03:13 <openstack> Launchpad bug 1491248 in Designate "Record is not deleted after terminating a VM+duplicate records " [Undecided,New] - Assigned to Graham Hayes (grahamhayes)
17:03:21 <mugsie> same
17:03:24 <timsim> Assigned to mugsie, I assume for verification?
17:03:26 <Kiall> Looks like it might be awkward to reproduce, anyone will to take a stab? (re the first)
17:03:44 <mugsie> timsim: yeah, thats on me for verification
17:04:02 <mugsie> for 1487934 - I am not sure how we would repro
17:04:41 <Kiall> I'll take a stab at repo on 1487934
17:05:04 <Kiall> #action kiall to validate 1487934
17:05:15 <elarson> while True: create(); list(); delete()
17:05:24 <Kiall> elarson: yea, that's what I was thinking ;)
17:05:34 <timsim> Alright, I'll assign that to you.
17:05:59 <timsim> https://bugs.launchpad.net/designate/+bug/1491348
17:06:00 <openstack> Launchpad bug 1491348 in Designate "sql DB is not updated after record creation " [Undecided,New] - Assigned to Graham Hayes (grahamhayes)
17:06:21 <timsim> Same, assigned for verification?
17:06:22 <mugsie> i think it is related to 1491248
17:06:24 <mugsie> yeah
17:06:37 <timsim> Ok, I'll leave those as new until we get some movement
17:06:37 <Kiall> #action mugsie to validate 1491248 and 1491348
17:06:47 <timsim> https://bugs.launchpad.net/designate/+bug/1491981
17:06:48 <openstack> Launchpad bug 1491981 in Designate "Using workers > 1 in mdns and the agent breaks the service " [Undecided,New]
17:07:05 <mugsie> High, RC1
17:07:12 <mugsie> or critical even
17:07:26 <Kiall> ++ to critical.. elarson how far did you get debugging it?
17:07:49 <elarson> Kiall: I was able to reproduce it with mdns and the agent
17:08:03 <elarson> and then james_li found a similar problem solved with glance
17:08:09 <Kiall> Any clues to a fix? I see james_li left something about socket.bind() vs eventlet.listen()
17:08:18 <elarson> yeah, I think that is the fix
17:08:21 <timsim> Could you add the repro instructions to the bug elarson
17:08:36 <elarson> timsim: yeah
17:08:52 <timsim> Cool. I'll go Critical RC1
17:08:55 <Kiall> K - Leave it with you fr now elarson?
17:08:58 <Kiall> for*
17:10:18 <Kiall> will take that as a yes ;) Any others timsim?
17:10:21 <timsim> https://bugs.launchpad.net/designate/+bug/1493001
17:10:22 <openstack> Launchpad bug 1493001 in Designate "Designate_plugin for NSD4 backend not found for devstack environment." [Undecided,New]
17:10:23 <elarson> sounds good
17:10:51 <mugsie> low - triaged - no milestone
17:11:09 <Kiall> Yea, we don't have a NSD devstack plugin
17:11:20 <timsim> Might be a blueprint later.
17:11:24 <Kiall> Yea, exactly..
17:11:25 <timsim> <mugsie> low - triaged
17:11:28 <timsim> ...wut
17:11:33 <timsim> https://bugs.launchpad.net/designate/+bug/1493035
17:11:34 <openstack> Launchpad bug 1493035 in Designate "FloaotingIP entry is not removed after VM delete" [Undecided,New]
17:11:56 <mugsie> assign to me
17:12:09 <Kiall> #action mugsie to validate 1493035
17:12:09 <mugsie> and high - i think its related to the other 2
17:12:23 <timsim> k
17:12:27 <timsim> That's all :)
17:12:28 <mugsie> (i have a sneaking suspission that they are all related to a misconfig)
17:13:38 <Kiall> K :)
17:13:54 <Kiall> #topic Stable Backport Triage (kiall - recurring)
17:13:57 <Kiall> Panic - Haven't done my bp triage paste ..  2 sec
17:14:42 <Kiall> #link http://paste.openstack.org/show/452795/
17:15:21 <Kiall> honestly, none.. other than maybe - 21a7db8 Merge "The address for cloning designate is corrected"
17:15:27 <Kiall> (a README.md update..)
17:15:47 <mugsie> i say none
17:15:53 <timsim> Yeah, none.
17:16:05 <Kiall> Simples..
17:16:07 <Kiall> Moving on :)
17:16:15 <Kiall> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:16:23 <Kiall> mlavalle: hows Neutron treating you?
17:16:42 <mlavalle> so I've been busy finishing the functionality for https://review.openstack.org/#/c/212213/
17:17:16 <mlavalle> patchset I pushed last night has all the functionallity to publish floating ips to designate
17:17:39 <mlavalle> today I will create the allembic script to migrate the database
17:18:12 <Kiall> Cool, it looks like it's starting to make progress - I'm taking a guess it's not going to see much in the way of review before the M cycle starts?
17:18:20 <mlavalle> at that point I will be able to deploy the code to a devstack instance and start creating and updating  neutron floating ips and published to designate
17:19:08 <mlavalle> so, if everything goes well, by the second half of next week we will have full floating ips functionality
17:19:26 <mlavalle> I'm getting reviews.....
17:19:26 <Kiall> Cool :)
17:19:47 <mlavalle> the chellenge is that I don't think designate is part of the Neutron tests in the gate
17:20:02 <mlavalle> so i'll need to work on that if we want to merge this soon
17:20:33 <Kiall> mlavalle: Ah, okat.. Any clue who handles Neutron CI stuff? Anyone specific other than the openstack-infra team?
17:20:44 <Kiall> I'm thinking maybe sdague
17:20:58 <mlavalle> Kiall: I don't know the details...  but i'll find out
17:21:23 <mlavalle> so overall, making solid progress
17:21:28 <Kiall> from a technical POV, I know how to make it happen.. from a policy POV, not sure :)
17:22:07 <mlavalle> that's my report for this week
17:22:14 <Kiall> mlavalle: I've had some conversations with Sean (I think it was sean anyway) around designate+devstack proper - I'll  kick off a email thread between the three of us to figureit out.
17:22:34 <mlavalle> Kiall: perfect, that helps a lot
17:22:54 <Kiall> Okay, Thanks mlavalle :) Awesome to see things come along so fast :)
17:23:17 <Kiall> Moving on so :)
17:23:18 <mlavalle> Kiall: add carl_baldwin to the email to sdague
17:23:22 <Kiall> WIll do.
17:23:27 <Kiall> #topic Liberty RC1 Release
17:23:37 <Kiall> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
17:23:39 * mlavalle going to a F2F meeting
17:23:42 <Kiall> #link https://launchpad.net/designate/+milestone/liberty-rc1
17:23:44 <Kiall> mlavalle: thanks!
17:23:49 <Kiall> #link https://etherpad.openstack.org/p/designate_2015_summer_midcycle_meetup_mcycle
17:23:57 <Kiall> RC1 is Sept 21-25th ish
17:24:25 <Kiall> https://launchpad.net/designate/+milestone/liberty-rc1 shows some outstanding stuff, including some I filed today based on mid-cycle discussions.
17:24:53 <Kiall> First up .. What's missing that we thought needed to be in L?
17:25:27 <Kiall> eriodic Purge of Deleted Domains - just moved to implemented - landed yesterday.
17:26:12 <Kiall> Nobody? :)
17:26:21 <timsim> looking..
17:26:42 <timsim> ALIAS records?
17:27:06 <Kiall> If memory services, we said M for that
17:27:09 <Kiall> serves me*
17:27:18 <Kiall> (can you tell I type services too often? ;))
17:27:29 <Kiall> Notes on L vs M from mid-cycle https://etherpad.openstack.org/p/designate_2015_summer_midcycle_meetup_mcycle
17:27:39 <elarson> yeah, ALIAS was for M
17:28:12 <timsim> ok. How about "Fix zone-manager enabled tasks + sharding combination (need to file a bug..)" ?
17:28:23 <Kiall> #action kiall to file High+RC1 bugs for1) Fix multiple central + TLD caching issues...(need to file a bug for this)  and 2) Fix zone-manager enabled tasks + sharding combination (need to file a bug..)
17:28:35 <timsim> +1
17:28:38 <mugsie> yeah
17:28:38 <Kiall> timsim: lol, I just spotted those! They certainly need fixes before we cut L
17:28:46 <mugsie> RC1 is pretty ful as it is
17:29:02 <Kiall> Well, my next Q is .. Do we push anything? ;)
17:29:32 <mugsie> #1411717Service Fixture in Unit Tests Does not Stop Service
17:29:49 <mugsie> #1437495 sink documenation should explain usage alongside ceilometer
17:29:49 <Kiall> Ideally, we have code landed by next weeks meet for anything. I'm going to get Pool Config -> DB up over the weekend
17:30:08 <mugsie> #1442699 Add admin endpoint to the list of versions
17:30:15 <Kiall> mugsie: are these push items?
17:30:32 <mugsie> yeah
17:30:35 <mugsie> #1459554 X-Auth-Sudo-Tenant-ID header not work for create subdomains
17:30:52 <mugsie> there is no way in hell we are getting that list done
17:31:23 <timsim> Yeah there's definitely going to be some stuff pushed there
17:31:36 <Kiall> Yea, bugs have more time :) About 1 month till release release
17:31:37 <mugsie> ^ are low impact, and potential time sinks
17:31:47 <Kiall> mugsie: agreed on your list BTW
17:32:06 <mugsie> and #1442141 designate-api Throws Error on stop()
17:32:27 <mugsie> i know ^ is really annoying, but that is a rats nest of eventlet vs oslo.service
17:32:34 <Kiall> I'd really really really like to find the cause of that.. It's harmless near as I can tell, but looks AWFUL.
17:32:57 <mugsie> basically, from discussions with glance, we use service + eventlet wrong
17:33:43 <mugsie> (everytime I go to look at it, I end flying somewhere, and forget everything)
17:33:43 <Kiall> mugsie were you going to try and get Pools Scheduler in? (trying to remember)
17:33:52 <mugsie> yeah. we have to
17:33:56 <mugsie> and the DB
17:34:06 <Kiall> Yea, my weekend is consumed by DB one
17:34:30 <Kiall> Okay, So, thoughts from folks on mugsie list?
17:35:00 <timsim> I agree with them.
17:35:17 <elarson> +1
17:35:36 <Kiall> removing the MS from them now
17:36:00 <Kiall> refresh https://launchpad.net/designate/+milestone/liberty-rc1
17:36:24 <Kiall> Thoughts on what's left?
17:36:50 <mugsie> #1412977 RPC code overrides a private method of Oslo's Dispatcher class <- How bad is this one really?
17:37:05 <Kiall> Harmless, not going to hurt us in L - Pushing.
17:37:29 <Kiall> It's annoying the oslo folks rather than us, but at this point in the release, they won't be removing that private symbol in L
17:37:39 <mugsie> https://bugs.launchpad.net/designate/+bug/1432839
17:37:40 <openstack> Launchpad bug 1432839 in Designate "Calling find_domain in any v1 operation is sub-optimal" [Medium,Triaged] - Assigned to Endre Karlson (endre-karlson)
17:37:41 <mugsie> push
17:38:18 <Kiall> Yea, I agree.. others?
17:38:25 <timsim> agreed
17:38:28 <Kiall> (others = other peoples thoughs?)
17:39:40 <Kiall> #1474012 - that's actually a "big"  one
17:39:44 <Kiall> bug 1474012
17:39:45 <openstack> bug 1474012 in Designate "Incorrect length limit for TXT record data" [Medium,Triaged] https://launchpad.net/bugs/1474012
17:40:09 <Kiall> It's about allowing TXT records to be a list of 255 char strings, rather than just 1 255 char string
17:40:33 <Kiall> Which is going to be awkward to fit into the API
17:40:48 <mugsie> i think that should be part of the structured data api
17:41:04 <Kiall> mugsie: possibly - but L or not is the Q? ;)
17:41:08 <mugsie> and then chop + concat the string for the normal API
17:41:18 <mugsie> well, strructuired data is M
17:41:24 <mugsie> so, i say M
17:41:31 <Kiall> Any objections?
17:42:18 <timsim> Nah, that's fine
17:42:41 <elarson> +1
17:42:59 <Kiall> Okay - I think that's about it so? If folks can concentrate on stuff in this list, and obv finding+filing more bugs ;)
17:43:09 <timsim> pglass just filed https://bugs.launchpad.net/designate/+bug/1493942
17:43:10 <openstack> Launchpad bug 1493942 in Designate "API returns incorrect response when a pool has multiple ns records" [Undecided,New]
17:43:18 <mugsie> nope. I want to do private pools tomorrow :)
17:43:38 <Kiall> wha?
17:43:54 <mugsie> (jkj)
17:44:00 <Kiall> ;)
17:44:08 <Kiall> Okay .. Moving o!
17:44:10 <Kiall> #topic Open Discussion
17:44:24 <Kiall> 15 mins before trove come at us with pitchforks.. Any other topics?
17:44:25 <mugsie> timsim: thats a wierd onew
17:44:36 <mugsie> is that only when they have the same priority>?
17:44:43 <timsim> pglass ^
17:44:46 <pglass> let me check...
17:45:49 <Kiall> Yea, that bug looks really weird!
17:45:55 <pglass> no, it happens even if the priorities are different
17:46:16 <Kiall> Heh, Anyone able to dig into that one?
17:46:26 <Kiall> Kinda looks like something we might want to fix
17:46:44 <mugsie> yeah
17:47:13 <timsim> One of us over here will take a peek.
17:47:28 <Kiall> timsim: cool, thanks. Marking RC1 so it's not lost on us.
17:47:37 <timsim> cool
17:48:14 <Kiall> Okay - Anything else, or call it a day?
17:48:19 <timsim> I don't have anything :)
17:48:41 <timsim> Sorry for vacationing right around l3 :P
17:48:48 <elarson> just a FYI, I started working on the ALIAS stuff
17:48:50 <Kiall> timsim: unacceptable ;)
17:49:11 <elarson> I'll plan on updating the spec if necessary
17:49:15 <mugsie> cool
17:49:17 <Kiall> elarson: cool! Looking forward to that one :)
17:49:36 <mugsie> elarson: jmcbride didn;t want to write the code?
17:49:50 <elarson> mugsie: oh no, he did! just way too busy
17:49:52 <elarson> ;)
17:50:09 <elarson> managers got to manage
17:50:39 * elarson needs to grab some food
17:50:49 * timsim is also very hungry
17:50:52 <Kiall> Okay, calling it folks :)
17:50:55 * Kiall needs a pint
17:51:06 <Kiall> Thanks!
17:51:07 <Kiall> #endmeeting