16:59:31 <Kiall> #startmeeting Designate
16:59:31 <openstack> Meeting started Wed Sep 23 16:59:31 2015 UTC and is due to finish in 60 minutes.  The chair is Kiall. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:36 <openstack> The meeting name has been set to 'designate'
16:59:37 <Kiall> Hey Folks, who's about?
16:59:40 <mugsie> o/
16:59:45 <jmcbride> o/
16:59:47 <timsim> o/
16:59:52 <Kiall> (Just wrapping up another meeting so semi distracted ;))
17:00:03 <pglbutt> o/
17:00:10 <Kiall> #topic Announcements
17:00:19 <Kiall> So - Announcements, two from me..
17:00:28 <Kiall> 1) Congrats to the new PTL, mugsie :)
17:00:37 <Kiall> (It's official now ;))
17:00:45 <mlavalle> congrats mugsie !
17:00:47 <timsim> !m mugsie
17:00:51 <openstack> timsim: Error: "m" is not a valid command.
17:01:07 <Kiall> He offificaly "takes over" once we open the M cycle :)
17:01:45 <Kiall> 2) RC1 - Unless we have any blocking issues, we're ready to cut iut
17:01:46 <Kiall> it*
17:02:03 <Kiall> Any other announcements from anyone else?
17:02:39 <mugsie> nope ..  i think
17:02:39 <Kiall> K -  Moving on
17:02:46 <timsim> Nothing here
17:02:53 <Kiall> #topic Action Items from last week
17:03:06 <ekarlso> ... salut
17:03:21 <Kiall> ehh "kiall / mugsie - get actions done done for next week!".... I'm nearly certain neither of us did :(
17:03:36 <Kiall> (We've been having a team gathering in Dublin this last week...)(
17:03:40 <mugsie> ehh ... I had actions?
17:03:41 <Kiall> and second was timsim to backport 746fa57 and eb34b4d
17:04:00 <Kiall> mugsie: from the week before..
17:04:00 <mugsie> ah
17:04:00 <timsim> Kiall: I backported one, and the other didn't need it.
17:04:03 <Kiall> timsim: excellent! Closed :)
17:04:21 <Kiall> #action kiall / mugsie ... actions from 2 weeks back!
17:04:38 <Kiall> Moving on swiftly!
17:04:38 <Kiall> #topic Bug Triage (timsim - recurring)
17:05:14 <timsim> https://bugs.launchpad.net/designate/+bug/1493035
17:05:15 <openstack> Launchpad bug 1493035 in Designate "FloaotingIP entry is not removed after VM delete" [High,New] - Assigned to Graham Hayes (grahamhayes)
17:05:53 <timsim> I think this was one of those that was for mugsie to validate
17:05:56 <Kiall> I think we can skip the assigned to mugsie's - near as we can tell, it's user error. Just haven't prooved it yet.
17:06:02 <mugsie> yeah
17:06:07 <timsim> Cool
17:06:27 <timsim> https://bugs.launchpad.net/designate/+bug/1498432
17:06:28 <openstack> Launchpad bug 1498432 in Designate "Duplicate code" [Undecided,New]
17:06:44 <timsim> Was this federico3 's fix for the MAX thing?
17:06:55 <Kiall> Wishlist, no milestone (as we don't have an M milestone yet)
17:07:07 <Kiall> timsim: code was dup'd as part of the fix
17:07:22 <timsim> https://bugs.launchpad.net/designate/+bug/1498951
17:07:22 <openstack> Launchpad bug 1498951 in Designate "Issue with Floating IPv6 " [Undecided,New]
17:07:38 <mugsie> that just came in
17:07:50 <mugsie> I think it is med:  no milestone
17:08:04 <mugsie> (i didnt know IPv6 had floating IPs in neutron now)
17:08:14 <Kiall> neither did i!
17:08:31 <timsim> Alright then :) that's all
17:08:34 <Kiall> anyway, agreed
17:08:41 <Kiall> Cool
17:08:51 <Kiall> #topic Stable Backport Triage (kiall - recurring)
17:08:53 <Kiall> Lots this week
17:09:02 <Kiall> as usualy.. take a few mins and nominate
17:09:06 <Kiall> #link http://paste.openstack.org/show/473785/
17:09:08 <Kiall> usual*
17:09:36 <mugsie> b153f66 Add Kilo upgrade nodes
17:09:37 <Kiall> 21cec74 Merge "Fix unhandled exceptions in adapters parsing"
17:09:37 <Kiall> 1594913 Merge "Ensure recordset name checking accounts for child domains"
17:09:45 <mugsie> 8277e96 Fix #1494799 handle limit=max on v2 and Admin APIs
17:09:55 <mugsie> eea5c1e Fix race condition in V1 Records API
17:09:56 <Kiall> 9c37d55 Ensure blacklists complete in a reasonable time
17:10:06 <mugsie> 4a68605 Correct a possible DNSService connection leak
17:10:07 <mugsie> 0c034d1 Ensure API workers > 1 starts correctly
17:10:07 <timsim> ad180b4 Merge "Correct a possible DNSService connection leak"
17:10:17 <mugsie> 476980e Ensure CNAME RRSets only have one record
17:10:45 <mugsie> 746fa57 Merge "Replace request.request_mac with request.mac"
17:10:55 <Kiall> eb34b4d Merge "Handling Forbidden Exception" - I'm struggeling to remember what this one was.. but it's probably a candiate
17:11:07 <timsim> Both of those two were the ones for last week
17:11:26 <timsim> that I did.
17:11:27 <Kiall> ah ;) I do 8 days of logs to avoid missing any ;)
17:11:36 <mugsie> :D
17:11:58 <Kiall> Okay - That everything? Let's dole em out.. federico3 - can you tackle a few of these tomorrow?
17:12:15 <federico3> yup
17:13:04 <Kiall> #action federico3 to backport b153f66 / 21cec74 / 1594913 / 8277e96 / eea5c1e
17:13:15 <Kiall> Okay, I'll take a couple..
17:13:33 <federico3> 9c37d55 as well?
17:13:42 <Kiall> #action kiall to backport 9c37d55 / 4a68605 / 0c034d1 (if possible) / ad180b4
17:13:44 <haleyb> mugsie: there is no floating IPv6
17:13:54 <mugsie> haleyb: thats what I though
17:13:56 <mugsie> thought*
17:14:03 <Kiall> Anyone able to take the rest?
17:14:18 <mugsie> eh, yeah - I should have a little bit of time
17:14:25 <Kiall> actually.. only 1 left..  476980e
17:14:30 <mugsie> grand
17:14:31 <Kiall> #action mugsie to backport 476980e
17:14:32 <mugsie> :)
17:14:55 <Kiall> Cool, lots of fixes this week to BP ;)
17:15:08 <Kiall> Anything else, or shall we move on?
17:15:52 <Kiall> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:16:02 <mlavalle> Kiall: hi
17:16:06 <Kiall> mlavalle: hey :)
17:16:35 <mlavalle> the past 2 days I fixed a bug whereby the internal dns integration was slowing down the response time of GET /ports
17:16:45 <mlavalle> the result was https://review.openstack.org/#/c/226581/
17:17:04 <mlavalle> esentially eliminated all the overhead db accesses
17:17:15 <mlavalle> we made Neutron RC1
17:18:20 <mlavalle> today going back to external dns integration. At this point, per our conversation on Monday. floating ips created automatically push their dns information to designate
17:18:37 <mlavalle> both A and PTR records
17:18:59 <mugsie> cool.
17:19:03 <Kiall> mlavalle: cool :) Moved to an admin creds for PTR stuff?
17:19:12 <mugsie> is the PTR stuff behind a feature flag?
17:19:41 <mlavalle> I will change the creation of the PTR records to admin cred between today and tomorrow. So by the end of this week, we will have full functionality for flosting ips
17:20:25 <mlavalle> so we will be in good position to do our demo in Tokyo
17:20:35 <Kiall> mlavalle: awesome, can you drop me an email when you have that piece up? I'll ask some of our folks to test it :) (I'm looking at you ekarlso :D.. )
17:20:50 <mlavalle> Kiall: will do
17:20:53 <ekarlso> Kiall: ..... gonna throw you under the bus soon :p
17:20:54 <mugsie> did we not want PTR creation behind an enable flag?
17:20:57 <Kiall> ekarlso: yep
17:21:17 <mugsie> as we need to sort out the operation with our own implementation
17:21:34 <mugsie> i thought that was dicussed on monday
17:21:36 <Kiall> mugsie: we found a better way.. but a feature flag is probably OK anyway
17:21:47 <Kiall> probably a good thing anyway*
17:21:52 <mlavalle> mugsie: I don't know what that is..... but can ping you later to talk about it
17:22:26 <mlavalle> and that is my report for today
17:22:31 <Kiall> mlavalle: oh, just a "enable_designate_ptr = True / False" conf option ... Some (possibly lots of) folks won't want it ;)
17:22:34 <mugsie> cool - thanks
17:22:52 <Kiall> Anyway - awesome mlavalle :)
17:22:58 <mlavalle> :-)
17:23:16 <Kiall> Okay, let's keep this thing moving ;)
17:23:17 <Kiall> #topic Liberty Release
17:23:22 <Kiall> #link https://launchpad.net/designate/+milestone/liberty-rc1
17:23:28 <Kiall> Currently nothing assigned to RC1 + Open.
17:23:41 <Kiall> Are we happy to cut RC1?
17:24:15 <Kiall> ...
17:24:26 <timsim> Hell yeah
17:24:26 <mugsie> yeah
17:24:35 <mugsie> I cant see anything else that we need
17:24:39 <Kiall> That's what I wanted to hear ;)
17:25:01 <Kiall> pglbutt: what about you? Yay or Nay? I think you have found more bugs recently than anyone else..
17:25:19 <Kiall> You haven't been holding some in reserve to file moments after we cut RC1, have you? ;)
17:25:27 <pglbutt> umm
17:25:34 <pglbutt> I don't have any others right now
17:25:58 <pglbutt> just some things I found in the client
17:26:14 <pglbutt> so
17:26:15 <Kiall> Cool, client can be realeased as often as we like :)
17:26:16 <pglbutt> yay
17:26:55 <Kiall> Okay +A'd https://review.openstack.org/#/c/226673/
17:27:10 <Kiall> Once it lands, Mitaka is open and RC1 is cut.
17:27:13 <Kiall> And mugsie is PTL
17:27:34 <timsim> Let his reign of terror begin :)
17:27:41 <ekarlso> everyone ready for the end of the reign of terror from Kiall ? :P
17:27:41 <mugsie> mwahahahahaha
17:27:43 <Kiall> timsim: you have no idea what we're in for.
17:28:39 <Kiall> #topic Open Discussion
17:28:53 <Kiall> Okay, thats the end of the agenda for today :) Any other business?
17:29:11 <mugsie> http://giphy.com/gifs/7tKEfRjktJ2MM/html5
17:29:53 <mugsie> we need topics for tokyo
17:30:14 <mugsie> can people think of what they want to talk about over the next few days>?
17:30:37 <timsim> You betcha
17:30:51 <mugsie> #link https://etherpad.openstack.org/p/designate-design-summit-tokyo
17:30:51 <Kiall> Yea, start an etherpad?
17:30:53 <Kiall> heh
17:31:05 <mugsie> any and all ideas welcome
17:31:18 <mugsie> Kiall: we had a few slots didnt we?
17:31:28 <Kiall> lol "#operationimpeachmugsie"
17:31:34 <timsim> ;)
17:31:53 <Kiall> mugsie: Right now - I've totally forgot. I think they are still being doled out
17:31:59 <Kiall> But - You'll find out rather than me ;)
17:32:15 <mugsie> :) I thought we got the allocations
17:32:22 <mugsie> cool. will look into it
17:32:38 <mugsie> [18:32]            --- | Users on #operationimpeachmugsie:
17:32:38 <mugsie> [18:32]            --- | [@mugsie]
17:32:42 <mugsie> :(
17:33:02 <Kiall> Okay - Anything else, or shall we all go for a Beer to celebrate Liberty RC1 and prepare ourselves for mugsie's RoT (Reign of Terror)
17:33:32 * timsim needs lunch
17:33:50 <Kiall> Okay - Thanks all :)
17:33:58 <Kiall> Cya :)
17:34:02 <timsim> o/
17:34:02 <Kiall> #endmeeting