17:02:25 <timsim> #startmeeting designate
17:02:25 <openstack> Meeting started Wed Sep 30 17:02:25 2015 UTC and is due to finish in 60 minutes.  The chair is timsim. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:29 <openstack> The meeting name has been set to 'designate'
17:02:38 <timsim> Hey, who's here?
17:02:41 <jmcbride> o/
17:02:46 <mugsie> o/
17:02:46 <elarson> o/
17:02:47 <pglass> o/
17:02:53 <ram_att> o/
17:03:01 <james_li> james li
17:03:01 <timsim> #chairs mugsie
17:03:10 * timsim doesn't know if that worked
17:03:24 <timsim> #topic Annoucements
17:03:24 <mugsie> #topic Action Items from last week
17:03:30 <mugsie> nope
17:03:36 <timsim> #chair mugsie
17:03:37 <openstack> Current chairs: mugsie timsim
17:03:38 <mugsie> go for it timsim
17:03:40 <timsim> aha
17:03:49 <timsim> Anyone have any annoucements?
17:04:04 <Kiall> o/
17:04:17 <mpbnka> o/
17:04:28 * elarson holds off his announcment he uses emacs until next week...
17:04:36 <timsim> Silence means no :P
17:04:46 <Kiall> Yep :)
17:04:48 <timsim> #topic action items from last week
17:04:56 <timsim> kiall / mugsie ... actions from 2 weeks back!
17:05:22 <mugsie> push from me
17:05:28 <Kiall> Still not yet :( Sorry, been literally mad here
17:05:41 <timsim> yeah I think those are the bug validations
17:05:51 <mugsie> they are
17:06:00 <timsim> #action Kiall / mugsie to do actions from http://eavesdrop.openstack.org/meetings/designate/2015/designate.2015-09-09-16.59.log.html
17:06:04 <mugsie> kiall to validate 1487934
17:06:04 <mugsie> mugsie to validate 1491248 and 1491348
17:06:04 <mugsie> mugsie to validate 1493035
17:06:05 <mugsie> kiall to file High+RC1 bugs for1) Fix multiple central + TLD caching issues...(need to file a bug for this) and 2) Fix zone-manager enabled tasks + sharding combination (need to file a bug..)
17:06:10 <timsim> federico3 to backport b153f66 / 21cec74 / 1594913 / 8277e96 / eea5c1e
17:06:23 <timsim> federico3: about?
17:06:45 <timsim> kiall to backport 9c37d55 / 4a68605 / 0c034d1 (if possible) / ad180b4
17:06:54 <timsim> mugsie to backport 476980e
17:06:57 <Kiall> he's probably just off the last call and not on IRC
17:06:59 <mugsie> mine is done
17:07:12 <Kiall> I totally forgot :(
17:07:16 <timsim> Just saw him in the other room
17:07:20 <mugsie> i think federico3 did ^^
17:08:06 <timsim> alright
17:08:07 <federico3> timsim: yep, the CRs are out
17:08:18 <timsim> #action kiall to backport 9c37d55 / 4a68605 / 0c034d1 (if possible) / ad180b4
17:08:24 <timsim> Ok. so mugsie and federico3 did those.
17:08:25 <mugsie> #action cores to review backports
17:08:30 <timsim> moving on
17:08:42 <timsim> #topic Bug Triage (timsim - recurring)
17:08:50 <timsim> https://bugs.launchpad.net/designate/+bug/1500867
17:08:50 <openstack> Launchpad bug 1500867 in Designate "Designate installation in Devstack results in Error" [Undecided,New]
17:09:05 <mugsie> that looks weird
17:09:24 <Kiall> A quick suggests user error?
17:09:29 <mugsie> yeah
17:09:43 <Kiall> (We do this many times a day in CI etc, it certainly works on master..)
17:09:47 <timsim> Looks like it
17:09:48 <mugsie> incomplete at the very least - need more info
17:09:52 <Kiall> Incomplete / need ..
17:09:54 <Kiall> beat me to it ;')
17:10:01 <timsim> Yeah, I''ll do that and ask him to give it another go
17:10:05 <mugsie> OS / how devstack is running / etc
17:10:11 <timsim> https://bugs.launchpad.net/designate/+bug/1501221
17:10:11 <openstack> Launchpad bug 1501221 in Designate "using TokenEndpoint with the V1 client is broken" [Undecided,New] - Assigned to Endre Karlson (endre-karlson)
17:10:31 <mugsie> H
17:11:07 <mugsie> (no milestone)
17:11:32 <timsim> https://bugs.launchpad.net/designate/+bug/1501392
17:11:32 <openstack> Launchpad bug 1501392 in Designate "Not able to add dns name when a new port is attached to existing Instance" [Undecided,New]
17:11:43 <timsim> This is the start of some interesting ones that seem to reference incomplete neutron work
17:11:44 <mpbnka> hi I added this bug
17:12:01 <mugsie> mpbnka: is this from sink?
17:12:05 <mpbnka> yes
17:12:26 <mugsie> ok, we will need the sink handlers you are using.
17:12:42 <ram_att> I looked into the code with mpbnka
17:12:53 <ram_att> this is nova.py
17:12:56 <mugsie> ah
17:12:57 <mugsie> yeah
17:13:00 <ram_att> we have to add another event to this
17:13:04 <ram_att> port.update.end
17:13:20 <ram_att> and handle it
17:13:33 <Kiall> ram_att: ah - makes sense, is that something you guys are going to add?
17:13:35 <mugsie> can you update the ticket with details of what you found?
17:13:42 <ram_att> yes
17:13:46 <mpbnka> ok
17:13:48 <ram_att> yeah sure
17:13:49 <mugsie> and if you are going to add the code, we can assign it to you
17:14:01 <ram_att> I am going to add the code for this
17:14:09 <ram_att> please assign this to me
17:14:14 <mugsie> ram_att: what is your launchpad name?
17:14:26 <ram_att> ramsateesh-talari
17:14:43 <timsim> Cool. ram_att: Would you like similar treatment for the other two bugs filed?
17:14:56 <ram_att> yes
17:15:03 <ram_att> for detach bug I am still debugging it
17:15:12 <ram_att> neutron doesn't post port.update events
17:15:17 <ram_att> it directly goes for delete
17:15:25 <ram_att> we probably have to look fro something in nova
17:15:39 <timsim> Cool, I'll mark those as needing more info pending your updates, and we can revisit.
17:15:49 <ram_att> ok
17:15:50 <mugsie> ++
17:16:04 <ram_att> I'll keep adding the comments as I find something useful on the bugs
17:16:14 <timsim> Moving on to the client
17:16:15 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1499539
17:16:15 <openstack> Launchpad bug 1499539 in python-designateclient "No output on certain v2 commands" [Undecided,New]
17:16:31 <mugsie> H
17:16:36 <mugsie> triaged
17:16:48 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1499541
17:16:48 <openstack> Launchpad bug 1499541 in python-designateclient "The v2 zone transfer request create command should not require the target project id" [Undecided,New]
17:16:53 <mugsie> same
17:17:04 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1499867
17:17:06 <openstack> Launchpad bug 1499867 in python-designateclient "Remove the name argument for recordset updates" [Undecided,New]
17:17:21 <mugsie> same
17:17:22 <mugsie> :)
17:17:34 <mugsie> pglass is good at finding little annoying things
17:17:37 <timsim> andd https://bugs.launchpad.net/python-designateclient/+bug/1500604
17:17:38 <openstack> Launchpad bug 1500604 in python-designateclient "Pattern argument is required on updating a blacklist" [Undecided,New]
17:17:53 <mugsie> as above
17:18:15 <Kiall> Side Bar - I should have mentioned this earlier. Use the "liberty-rc-potential" label on bugs we want to fix in L! https://bugs.launchpad.net/designate/+bugs?field.tag=liberty-rc-potential
17:18:16 <timsim> done :)
17:18:33 <mugsie> :)
17:18:45 <timsim> #topic Stable Backport Triage (kiall - recurring)
17:18:57 <Kiall> #link http://paste.openstack.org/show/474896/
17:19:13 <Kiall> Slight twist this time and from now on
17:19:18 <Kiall> we have Kilo and Liberty backports ;)
17:19:38 <Kiall> Anyway - Take a few, nominate anything in need of a backport - including to what releases
17:19:52 <Kiall> 6e45b7c Ensure recordset name checking accounts for child domains
17:19:52 <Kiall> 9c37d55 Ensure blacklists complete in a reasonable time
17:20:00 <Kiall> ^ both of those to KIlo
17:20:08 <mugsie> abfc3c0 Merge "Fix #1494799 handle limit=max on v2 and Admin APIs"
17:20:25 <Kiall> I *think* federico3 already BP'd that... I think
17:20:35 <federico3> checking
17:20:42 <Kiall> thanks
17:21:00 <Kiall> Okay - Any others?
17:21:07 <mugsie> dont think so
17:21:21 <Kiall> Any takers to BP ^ 2 (or 3)?
17:21:22 <federico3> (yes it is)
17:22:09 <federico3> o/
17:22:12 <Kiall> mugsie: how about you? I already have a list from last week to do ;)
17:22:19 <mugsie> K - federico3 it is
17:22:21 <mugsie> :)
17:22:25 <federico3> 6e45b7c, 9c37d55, abfc3c0 to Kilo
17:22:35 <timsim> #action federico3 one to backport 6e45b7c 9c37d55 abfc3c0 to Kilo
17:22:44 <timsim> don't know how "one" snuck in there
17:22:50 <mugsie> whats a federico3 one ?
17:22:55 <mugsie> :D
17:22:57 <Kiall> lol
17:23:01 <Kiall> thanks federico3
17:23:03 <timsim> #action mugsie to suck it
17:23:06 <timsim> #topic assert:follows-standard-deprication
17:23:08 * federico3 looks around
17:23:11 <timsim> over to mugsie :)
17:23:16 <Kiall> timsim: you don't get "power" much, do you? ;)
17:23:20 <mugsie> #link http://governance.openstack.org/reference/tags/assert_follows-standard-deprecation.html
17:23:20 <timsim> :P
17:23:33 <mugsie> basically - do we want to sign up as doing this
17:23:41 <mugsie> and have it recorded
17:24:11 <mugsie> it is very close to what we do now to be honest
17:24:29 <Kiall> "It uses an automated test to verify that configuration files are forward-compatible from release to release and that this policy is not accidentally broken (for example, a gating grenade test)."
17:24:39 <Kiall> That's one we don't, but probably should do..
17:24:43 <mugsie> yeah
17:24:55 <Kiall> And, will take us a while to do + get right..
17:25:05 <timsim> Esp with pool -> db stuff
17:25:16 <mugsie> I think if we are bound by ^ it will not allow us to let things fall through the cracks
17:25:30 <mugsie> we dont have to decide right now
17:25:40 <mugsie> I just wanted it on peoples radar
17:26:07 <Kiall> makes sense
17:26:16 <mugsie> so, if everyone can have a read, we can come back to it in a few weeks
17:26:25 <timsim> Cool.
17:26:27 <mugsie> I will send a ML email as well
17:26:38 <timsim> #action Everyone read/understand http://governance.openstack.org/reference/tags/assert_follows-standard-deprecation.html
17:26:38 <Kiall> folks, I've got to run to another call - will be multitasking the rest of the meet
17:27:06 <timsim> #action mugsie to add assert:follows-standard-deprication to a future agenda
17:27:17 <timsim> #topic Designate/Neutron Integration Update
17:27:24 <timsim> I believe mugsie has this update
17:27:31 <mugsie> yup
17:28:02 <mugsie> no patch was pushed last night, with reverse IPs in the correct tenant
17:28:09 <mugsie> new patch*
17:28:52 <mugsie> the requirements for the Tokyo demo are in place. there is a new patch coming that will add the ablity to turn the FIP stuff on and off
17:29:08 <mugsie> FIP reverse IPs even
17:29:16 <mugsie> that is the update :)
17:29:35 <timsim> Sounds pretty good
17:29:43 <timsim> #topic Liberty Release
17:29:57 <mugsie> eh - Kiall ?
17:30:30 <mugsie> OK
17:30:37 <mugsie> he is not multitasking :)
17:30:40 <mugsie> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
17:31:00 <mugsie> #link https://bugs.launchpad.net/designate/+bugs?field.tag=liberty-rc-potential
17:31:16 <mugsie> any one know of any other bugs that should be added to that list ?
17:32:04 <mugsie> ....
17:32:06 <mugsie> ?
17:32:11 <ram_att> please add 1501392
17:32:24 <ram_att> 1501394  and 1501396
17:32:54 <mugsie> ram_att: I am not sure that is not an RC worthy bug
17:32:58 <mugsie> Kiall: ^
17:33:04 <ram_att> ok
17:33:12 <mugsie> seen as this is still under your PTL ship :)
17:33:39 <timsim> We can probably decide RC-worthiness when it's confirmed
17:33:45 <mugsie> yeah
17:33:57 <timsim> I don't think there are any others to add to rc-potential right now
17:34:07 <mugsie> I don't know of any personally
17:34:37 <mugsie> I think we are done with Liberty (and that old lame duck PTL :P )
17:34:48 <timsim> But we should be testing the RC when we can to see if there's anything else :)
17:34:52 <mugsie> yeah
17:35:08 <timsim> #topic Open Discussion
17:35:09 <mugsie> can everyone test the current RC1 build?
17:35:37 <mugsie> Tokyo - can everyone update the etherpad?
17:35:46 <Kiall> I'm useless at multitasking - still need an answer? ;)
17:35:51 <timsim> #link https://etherpad.openstack.org/p/designate-design-summit-tokyo
17:35:56 <mugsie> Kiall: no
17:35:57 <mugsie> :D
17:35:58 <timsim> Nah we moved on without you Kiall
17:36:02 <Kiall> Good!
17:36:27 <mugsie> cool - I think we should review the list this meeting next week?
17:36:31 <mugsie> so you have 7 days
17:36:33 <mugsie> :D
17:36:39 <timsim> Cool :)
17:36:48 <mugsie> and talk + workshop - timsim elarson we should sync up
17:37:06 <mugsie> thats all I have
17:37:16 <elarson> indeed!
17:37:30 <timsim> We should have some time next week, hopefully :)
17:37:36 <mugsie> cool
17:37:44 <mugsie> I will shoot an email
17:37:54 <timsim> Does anyone else have anything they'd like to discuss?
17:38:19 <mugsie> 3
17:38:20 <mugsie> 2
17:38:23 <mugsie> 1
17:38:34 <federico3> .5
17:38:41 <mugsie> 0
17:38:41 <timsim> #endmeeting