17:00:12 <mugsie> #startmeeting Designate
17:00:13 <openstack> Meeting started Wed Oct 14 17:00:12 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:16 <openstack> The meeting name has been set to 'designate'
17:00:28 <mugsie> #topic Roll Call
17:00:34 <mugsie> so, who is around?
17:00:42 <Kiall> Heya
17:00:49 <pglass> o/
17:01:21 <pglass> timsim is not at his desk
17:01:28 <mugsie> tut tut
17:01:37 <Kiall> Guess we give folks a few mins?
17:01:46 <mugsie> yeah, say another 2-3 mins
17:03:16 <mugsie> OK...
17:03:35 <mugsie> I think we should start
17:03:47 <mugsie> #topic Announcements
17:04:05 <mugsie> any one have any announcements?
17:04:23 <Kiall> Nope, none from me
17:04:34 <mugsie> OK then
17:04:37 <elarson> o/
17:04:48 <mugsie> #topic Action Items from last week
17:04:56 <mugsie> kiall backport 0c034d1
17:05:05 <Kiall> done +  up for review
17:05:07 <mugsie> mugsie finish investigations on his bugs
17:05:15 <mugsie> not done
17:05:27 <mugsie> #action mugsie finish investigations on his bugs
17:05:29 <mugsie> Kiall sync with rel-man for backports of 94dfad3 and c59a2a0
17:05:38 <Kiall> done, not in
17:05:48 <mugsie> all to test https://review.openstack.org/#/c/212213/
17:06:09 <mugsie> did anyone get a chance to look at it?
17:06:18 <Kiall> looked, not tested yet
17:06:49 <mugsie> timsim: elarson - did yoiu have a chance?
17:07:01 <timsim> Nope
17:07:09 <pglass> haven't touched it
17:07:22 <mugsie> #topic Bug Triage (timsim - recurring)
17:07:28 <mugsie> timsim: over to you :)
17:07:50 <timsim> https://bugs.launchpad.net/designate/+bug/1505605
17:07:50 <openstack> Launchpad bug 1505605 in Designate "Designate setup error" [Undecided,New]
17:08:17 <mugsie> hummm
17:08:19 <Kiall> Looks like user error?
17:08:38 <mugsie> i think so
17:08:47 <mugsie> can someone try and replicate?
17:08:53 <mugsie> if we can't just close
17:09:34 <Kiall> I will
17:09:47 <mugsie> #action Kiall investiagte 1505605
17:09:50 <timsim> cool. I'll assign it to Kiall then
17:09:53 <mugsie> ++
17:09:59 <Kiall> (sorry - someone who used to be here in this office arrived in, now a pile of people chatting to / around us.. heh)
17:10:16 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1504494
17:10:16 <openstack> Launchpad bug 1504494 in python-designateclient "Remove name argument from zone update " [Undecided,New]
17:10:55 <mugsie> is this a duplicate?
17:10:58 <Kiall> High - no MS on client stuff
17:11:08 <timsim> I think the recordset one happened. but not this one
17:11:12 <mugsie> ah
17:11:18 <mugsie> then H
17:11:21 <timsim> Triaged M
17:11:22 <timsim> ?
17:11:22 <Kiall> Oh, I'll ask ekarlso to look at it tomorrow.
17:11:35 <ekarlso> eyey
17:11:37 <ekarlso> :p
17:11:43 <ekarlso> what's up ? :p
17:11:58 <Kiall> can you dig into https://bugs.launchpad.net/python-designateclient/+bug/1504494 tomorrow? Should be a 10 min fix :)
17:11:58 <openstack> Launchpad bug 1504494 in python-designateclient "Remove name argument from zone update " [High,Triaged]
17:11:58 <mugsie> ekarlso: scrollback :p
17:12:08 <timsim> Alright, cool. That's it for bugs :)
17:12:09 <Kiall> (if even)
17:12:13 <mugsie> cool
17:12:23 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:12:32 <Kiall> #link http://paste.hpcloud.net/show/4935/
17:12:46 <Kiall> As usual, take a few nominate for K / L
17:13:03 * timsim waits for paste.hpcloud.net
17:13:20 <mugsie> #action mugsie update review dashboard to show Kilo / Liberty
17:13:23 <Kiall> To K and L?
17:13:23 <Kiall> a0496ab Merge "Clear out pyc files before a tox run"
17:13:23 <Kiall> 1b44c45 Merge "retry creates/deletes in the pool manager" <-- Not 100% sure on this one
17:13:29 <Kiall> mugsie: lol
17:13:39 <timsim> Kiall: Why not?
17:13:43 <Kiall> OH
17:13:45 <Kiall> lol
17:13:48 <Kiall> I used paste.hpcloud.net
17:14:01 <timsim> Yeah, that's not working :)
17:14:07 <Kiall> Are you on the HP VPN?
17:14:13 <Kiall> #link http://paste.openstack.org/show/476291/
17:14:14 <mugsie> timsim: yeah, I really hope it wouldnt
17:14:24 <timsim> Sorry, dropped vpn for a minute there :P
17:14:37 <mugsie> just those 2
17:14:43 <mugsie> has been a quite week
17:14:46 <mugsie> quiet*
17:14:56 <Kiall> RC/L release week, always is :)
17:15:20 <mugsie> OK, any voulenteers for ^
17:15:51 <timsim> I spose I can do mine.
17:15:54 <mugsie> :)
17:16:00 <mugsie> Kiall: want to do yours?
17:16:06 <Kiall> Sure.. Why not
17:16:10 <mugsie> :)
17:16:12 <Kiall> (I had typed something longer...)
17:16:22 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:16:32 <mugsie> mlavalle is not here today
17:16:37 <mugsie> but, he said .....
17:17:20 <mugsie> <   mlavalle> | mugsie: https://review.openstack.org/#/c/212213/ is passing the Jenkins tests now. I even got a +1
17:17:23 <mugsie> <   mlavalle> | mugsie: I also coded the first version of the change in Nova. It is working fine in my sandbox. I will push to Gerrit this week to start the review cycle. But here you can find an example that I executed yesterday: http://paste.openstack.org/show/476210/
17:17:40 <mugsie> so, to re-iterate - we need to test that patch :)
17:18:29 <mugsie> unfortunatly our workshop will overlap with the nova + neutron + designate talk, so me, timsim and elarson wont get to see the live demo
17:18:41 <Kiall> I think most everyone is in some form of rush at the moment, with the tokyo week squashing all the other deadlines ;)
17:18:48 <Kiall> mugsie: get it moved!
17:18:51 <mugsie> (we will just be doing 50 - 60 live demos simultaniously)
17:19:10 <timsim> Yeah I'd love to heckle Kiall from the audience.
17:19:24 <mugsie> Kiall: yeah, I know I am, but if anyone has a spare hour or so it would be good
17:20:16 <Kiall> Okay, will do what I can :)
17:20:18 <mugsie> timsim: I watched the video of our workshop in VA last week - you managed to heckle Kiall during a talk you were giving :p
17:20:53 <mugsie> any questionns on this should probably go to the mailing list / irc room
17:20:58 <mugsie> #topic The big refactor: Domain -> Zone (mugsie)
17:21:09 <mugsie> so. the time is close.
17:21:45 <mugsie> I propose that for the week after Tokyo, we freeze development on master
17:21:52 <mugsie> and do the re name
17:21:57 <mugsie> and just the rename
17:22:26 <timsim> It has to be one monster patch, yeah?
17:22:29 <Kiall> I'd have said 1 more week after that, giving time for ant L bug reports and so on to trickle in, so we can BP patches easily.
17:22:39 <Kiall> timsim: yea, I think it has to be 1 monster patch.
17:22:46 <mugsie> Kiall: we have said that for 2 releasaes now
17:23:02 <mugsie> back ports are going to be a pain
17:23:05 <Kiall> mugsie: set a date, do it.. I'm not saying "Wait until forever"
17:23:14 <mugsie> but we just need to bite the bullet
17:23:17 <Kiall> Just, 7 days post tokyo is short..
17:23:30 <timsim> Kiall will still be deathly ill by that point
17:23:39 <Kiall> timsim: ++
17:23:53 <timsim> I'd give it another week too mugsie
17:24:07 <Kiall> timsim: +++ again
17:24:19 <mugsie> and ... back
17:24:19 <Kiall> mugsie:'s PC just froze
17:24:29 <Kiall> (he's talking over the desk @ me)
17:24:45 <mugsie> so Nov 10th -> 13th ?
17:25:17 <timsim> seems legit.
17:25:22 <Kiall> Yea, that works.
17:25:24 <mugsie> I highly doubt that it will make any difference, but if thats what people want :)
17:25:49 <mugsie> #action mugsie email the ML about the freeze for master from 10th Nov -> 13th Nov
17:26:14 <mugsie> that means that Monday 9th is monster merge day :D
17:26:33 <mugsie> so we can try and have as little patches as possible in flight
17:26:46 <Kiall> Ah - I was getting confused there ;)
17:26:56 <Kiall> Right, land everything and anything we can pre-rename,.
17:27:02 <mugsie> yeha
17:27:27 <mugsie> #topic Skip Meetings for 2 weeks
17:27:57 <mugsie> so, with the amount of travelling that is going to be going on, and all the other stuff around a a summit, I suggest we skip the next 2 meetings
17:28:10 <timsim> +1
17:28:10 <mugsie> #startvote Skip Next 2 Weeks?
17:28:11 <openstack> Begin voting on: Skip Next 2 Weeks? Valid vote options are Yes, No.
17:28:12 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:28:19 <timsim> #vote Yes
17:28:20 <Kiall> I think we should all join this meet at 2am local in Tokyo.
17:28:28 <Kiall> #vote Yes
17:28:28 <Kiall> ;)
17:28:39 * timsim hopes he's not awake for that, but has a feeling he will be
17:28:46 <Kiall> (Effectivly nobody made it today ;))
17:28:50 <mugsie> #endvote
17:28:51 <openstack> Voted on "Skip Next 2 Weeks?" Results are
17:29:03 <mugsie> wow the bot is slow
17:29:05 <timsim> Nice openstack
17:29:08 <Kiall> or broke
17:29:15 <timsim> WHAT ARE THE RESULTS?!?!?
17:29:16 <Kiall> I think we can take a guess ;)
17:29:25 <mugsie> #topic Open Discussion
17:29:30 <Kiall> With what, 3-5 people in attendance today ;)
17:29:34 <mugsie> any off agenda items?
17:29:39 <Kiall> Most of them distracted and /or lurking
17:29:41 <timsim> Review pls https://review.openstack.org/#/c/230770/
17:29:46 <mugsie> http://i.imgur.com/Bawecyo.jpg
17:29:55 <timsim> Those are sexy ^
17:29:59 <mugsie> timsim: will do after this :)
17:30:15 * timsim hopes he ends up with like 10 flash drives in his pocket this year.
17:30:18 <mugsie> jmcbride will wantr a few methinks :)
17:30:34 <Kiall> I may pike most of them before we even get to tokyo
17:30:49 <mugsie> mid cycle
17:30:54 <timsim> "Sorry guys we've only got ten flash drives for this workshop, they've all disappeared"
17:31:03 <mugsie> I knoiw it very early to think about it
17:31:04 <Kiall> :D
17:31:26 <timsim> Ireland in January. brrrr
17:31:30 <mugsie> but - I may be floating a few possible dates / places over the next few weeks
17:31:53 <mugsie> just as a heads up
17:32:00 <mugsie> timsim: its not *that* bad
17:32:08 <mugsie> you may freeze to death
17:32:11 <Kiall> lol
17:32:21 <mugsie> OK,. anything else ?
17:32:22 * timsim will be on the lookout for dates
17:32:45 <mugsie> 3
17:32:48 <mugsie> 2
17:32:51 <Kiall> YES!
17:32:58 <Kiall> Actually, no.
17:32:59 <mugsie> 1
17:32:59 <Kiall> ;)
17:33:02 <timsim> :troll:
17:33:04 <mugsie> #endmeeting