16:59:28 <mugsie> #startmeeting Designate
16:59:28 <openstack> Meeting started Wed Nov  4 16:59:28 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:32 <openstack> The meeting name has been set to 'designate'
16:59:33 <mugsie> #topic Roll Call
16:59:39 <pglass> o/
16:59:45 <mugsie> hey :)
16:59:54 <federico3> o/
16:59:54 <Kiall> o/
17:00:14 <mugsie> timsim ekarlso : courtesy ping
17:00:15 <timsim> o/
17:00:36 <mugsie> #topic Announcements
17:00:49 <mugsie> None, bar 12 hours flights really really suck
17:00:59 <mugsie> anyone else have anything to announce?
17:01:22 <mugsie> #topic Action Items from 3 weeks ago
17:01:30 <jmcbride> o/
17:01:33 <mugsie> mugsie finish investigations on his bugs
17:01:38 <mugsie> #action mugsie finish investigations on his bugs
17:01:44 <mugsie> Kiall investiagte 1505605
17:01:56 <mugsie> Kiall: ?
17:02:06 <Kiall> summit and internal releases has meant - no, not yet
17:02:17 <mugsie> #action Kiall investiagte 1505605
17:02:19 <mugsie> mugsie update review dashboard to show Kilo / Liberty
17:02:25 <mugsie> need to push as well
17:02:31 <mugsie> #action mugsie update review dashboard to show Kilo / Liberty
17:02:37 <mugsie> mugsie email the ML about the freeze for master from 10th Nov -> 13th Nov
17:02:41 <mugsie> done
17:02:50 <mugsie> #topic Bug Triage (timsim - recurring)
17:03:04 <mugsie> timsim: over to you
17:03:34 <timsim> Looks like there's some main Designate stuff that should go in the client. Starting with: https://bugs.launchpad.net/designate/+bug/1506310
17:03:35 <openstack> Launchpad bug 1506310 in Designate "Designate quota commands should be checked against invalid tenant id" [Undecided,New]
17:04:01 <elarson> o/
17:04:08 <mugsie> humm. not sure if that is even the place
17:04:16 <timsim> I'm not sure that's a bug tbh.
17:04:20 <rsyed> o/
17:04:33 <mugsie> ]do nova / neutron / etc check tenant id's before seting quotas?
17:04:35 <Kiall> Yea, we have no way to know if a tenant id is valid or not
17:04:41 <timsim> Yeah that's exposing the fact that the default quotas get returned for any tenant.
17:04:48 <Kiall> the best we could do is, check if that tenant has stuff in designate already
17:04:59 <mugsie> ok, invalid - with a description saying ^ ?
17:04:59 <Kiall> but that would make quota setting for new tenants really odd
17:05:12 <timsim> Sure, I can do that.
17:05:27 <timsim> https://bugs.launchpad.net/designate/+bug/1506751
17:05:27 <openstack> Launchpad bug 1506751 in Designate "'openstack zone abandon ' command does not remove the zone from designate's storage" [Undecided,New]
17:05:33 <timsim> Needs more info.
17:05:37 <mugsie> yeah
17:05:51 <timsim> Same here: https://bugs.launchpad.net/designate/+bug/1506757
17:05:51 <openstack> Launchpad bug 1506757 in Designate "'openstack zone delete' command does not remove zone information from designate's storage." [Undecided,New]
17:05:57 <Kiall> Sounds like it *may* be marking it deleted, but not issueing a SQL DELETE?
17:06:01 <timsim> I think he may just mean that it's deleted. yeah.
17:06:09 <mugsie> i think this is the soft delete thiong alright
17:06:17 <timsim> Yeah. I'll comment on those.
17:06:18 <rsyed> wasn't there a question in irc a couple weeks back about a zone file not being removed?  perhaps that's unrelated
17:06:22 <mugsie> maybe a pointer to the zonemanager task
17:06:24 <Kiall> Yea, ask for more info.. and mention the deleted column?
17:06:37 <Kiall> rsyed: I think that's a different issue
17:06:39 <Kiall> bind specific?
17:06:40 <timsim> rsyed: Unrelated.
17:06:40 <mugsie> rsyed: yeah, that is a separate issue afiak
17:06:51 <mugsie> wow, we all piled on :)
17:06:57 <Kiall> :D
17:06:59 <timsim> !m rsyed
17:07:00 <openstack> timsim: Error: "m" is not a valid command.
17:07:06 <timsim> shut up openstack
17:07:08 <rsyed> haha THANKS EVERYONE i got it
17:07:10 <Kiall> It came up at the summit, so we all remember it ;)
17:07:19 <timsim> https://bugs.launchpad.net/designate/+bug/1507965
17:07:19 <openstack> Launchpad bug 1507965 in Designate "Email is set to some default value for secondary zones." [Undecided,New]
17:07:29 <timsim> Same https://bugs.launchpad.net/designate/+bug/1507971
17:07:29 <openstack> Launchpad bug 1507971 in Designate "ttl for secondary zones is set to some default values." [Undecided,New]
17:07:50 <Kiall> Both by design, we get the real values from the upstream nameserver
17:08:16 <mugsie> yeah. convert to a docs bug saying that while we are waiting for info from the Upstream sever we have placeholders
17:08:43 <timsim> K. Will do.
17:08:51 <timsim> https://bugs.launchpad.net/designate/+bug/1512237
17:08:51 <openstack> Launchpad bug 1512237 in Designate "'designate server-create' command gives output with incorrect field-value pair." [Undecided,New]
17:09:19 <mugsie> OK, that needs to be investiagted, but it is a client bug
17:09:30 <timsim> Will move it over to the client.
17:09:50 <Kiall> | created_at | 2015-11-02T06:05:14.000000 |
17:09:50 <Kiall> | updated_at | b0917d6e-1916-47c2-94c1-46d691ee9c54 |
17:09:50 <Kiall> ^ really? wow how did we manage that :(
17:10:04 <mugsie> yeah
17:10:14 <timsim> I'd have thought we'd have noticed that in the workshop :P
17:10:17 <Kiall> LOL
17:10:20 <mugsie> would we?
17:10:22 <mugsie> :D
17:10:32 <timsim> lol. Too busy installing virtualbox on windows.
17:10:33 <mugsie> oh, it kinda worked, thank god
17:10:44 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1511230
17:10:44 <openstack> Launchpad bug 1511230 in python-designateclient "'openstack recordset delete ' command should provide meaningful exception message." [Undecided,New] - Assigned to megha (tmegha247)
17:11:03 <Kiall> "Managed records may not be updated"
17:11:03 <Kiall> vs
17:11:07 <Kiall> "Managed records may not be deleted"
17:11:14 <Kiall> is I guess the request?
17:11:24 <timsim> Yep
17:11:30 <timsim> That  message probably comes straight from the API
17:11:31 <mugsie> that is a designate bug - confirmed low in the main project
17:11:32 <Kiall> makes sense, valid issue
17:12:16 <timsim> Cool
17:12:23 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1512647
17:12:23 <openstack> Launchpad bug 1512647 in python-designateclient "--log-file LOG_FILE option does not work with designate cli commands" [Undecided,New]
17:12:56 <Kiall> mmm... if --debug or --verbose is supplied, I believe it does have all the log messages?
17:13:14 <mugsie> needs to be investigated
17:13:16 <Kiall> (there's no logs at INFO+ unless it fails)
17:13:24 <mugsie> ah
17:13:39 <timsim> I'll ask for more info with that insight.
17:13:39 <Kiall> otherwise, every command would have logs around the output
17:13:54 <Kiall> then again, the reported might be expecting the output to go to the logfile?
17:14:03 <Kiall> reporter*
17:14:04 <mugsie> thats what I think is the intention
17:14:20 <Kiall> Yea, I'd disagree with it doing that
17:14:23 <mugsie> so, we need to update the ticket and point out what logs it is for
17:14:42 <timsim> Kiall, would you do that?
17:14:48 <Kiall> Sure
17:15:15 <mugsie> that all the bugs?
17:15:19 <timsim> That's everything
17:15:31 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:15:42 <Kiall> $ git log --oneline --since="3 weeks ago" | grep -v "Updated from global" | grep -v "Transifex"
17:15:42 <Kiall> b5b5433 Merge tag '1.0.0'
17:15:47 <Kiall> I vote for no backports ;)
17:15:52 <mugsie> yup :)
17:15:55 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:16:11 <Kiall> mlavalle isn't about - I'll fill in
17:16:12 <mugsie> mlavalle seems to afk
17:16:17 <mugsie> great
17:16:26 <Kiall> So, not much of an update re code / reviews
17:16:37 <Kiall> we demo'd at the summit to around ~80 people
17:16:48 <Kiall> lots of interest, a bunch of Q's etc
17:16:49 <mugsie> :D
17:16:57 <Kiall> seems like people are v.interested :)
17:17:01 <federico3> oh - are there summit videos that could be included in the meeting minutes?
17:17:05 <mugsie> i can imagine
17:17:11 <mugsie> federico3: eh, let me look
17:17:15 <federico3> (or slides)
17:17:18 <timsim> #link https://www.youtube.com/watch?v=AZbiARM9FPM
17:17:43 <Kiall> video will have to do .. don't have the slides anywhere public
17:18:05 <Kiall> Anyway - That's about it.. mlavalle will hopefully get the rest merged to Neutron ASAP :)
17:18:11 <mugsie> great :)
17:18:17 <mugsie> #topic The big refactor: Domain -> Zone (mugsie)
17:18:40 <mugsie> basically - can cores spend some time over the next few days to merge as many patches as possible?
17:18:51 <mugsie> so we have very little in the review queue for next tuesday?
17:18:57 <Kiall> ++ there's a backlog and a half.
17:19:02 <mugsie> yeah
17:19:10 <mugsie> and the refactor will break 99% of them
17:19:18 <Kiall> 100%
17:19:24 <mugsie> so Kiall timsim we need to dig in. :)
17:19:36 <timsim> Will do
17:19:40 <Kiall> I'd argue that we land everything that isn't  fundamentially wrong.. a typo or something? merge it.
17:20:03 <mugsie> yeah - we can do a clean up commit on tuesday morning
17:20:06 <Kiall> It's not "fair" to force the rename pain on the random contributers based on silly things like typos
17:20:20 <mugsie> sounds like a plan
17:20:26 <mugsie> #topic Summit Recap
17:20:34 <mugsie> #link https://etherpad.openstack.org/p/mitaka-designate-summit-roadmap
17:20:50 <mugsie> at the bottom of that etherpad is our plan for the next 3-4 months
17:21:17 <mugsie> if you are named as doing something, but will not be able to do it, please shout :)
17:22:12 <mugsie> is there any questions / problems with that list?
17:22:49 <mugsie> OK then :)
17:23:00 <mugsie> #topic Open Discussion
17:23:08 <mugsie> any off agenda items?
17:23:16 <Kiall> jmcbride: I hear you had USB key envy? ;)
17:23:30 * mugsie does the happy dance
17:23:40 <johnbelamaric> mugsie: any status on the plugin framework for primary that we discussed at the summit?
17:23:56 <mugsie> johnbelamaric: not yet.
17:24:07 <mugsie> I am still mulling it over in my head
17:24:09 <johnbelamaric> mugsie: ok, figured it's too soon :)
17:24:31 <Kiall> I've managed to keep mugsie busy enough with internal work since we got back from the summit - probably my fault ;)
17:24:39 <mugsie> 100%
17:24:45 <mugsie> its always Kiall's fault
17:25:04 <mugsie> OK, last chance!
17:25:14 <elarson> mugsie: would it be reasonable for johnbelamaric to write a blueprint?
17:25:25 * elarson hadn't heard about a plugin framework
17:25:34 <mugsie> elarson: I took on that job
17:25:47 <johnbelamaric> mugsie, elarson: lucky me ;)
17:25:51 <elarson> mugsie: you are a wonderful person :)
17:25:53 <mugsie> I will be pinging people with info over the next few weeks
17:25:58 <mugsie> elarson: I know, right?
17:26:06 <elarson> for realz
17:26:14 <johnbelamaric> agreed
17:26:31 <mugsie> OK - are we all OK to wrap up there?
17:26:58 <mugsie> #endmeeting