16:59:34 <mugsie> #startmeeting Designate
16:59:35 <openstack> Meeting started Wed Dec  2 16:59:34 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:38 <openstack> The meeting name has been set to 'designate'
16:59:43 <mugsie> #topic Roll Call
16:59:47 <mugsie> whos here?
17:00:38 <mugsie> o/
17:00:44 <timsim> o/
17:00:54 <mugsie> #chair timsim
17:00:55 <openstack> Current chairs: mugsie timsim
17:01:09 <mugsie> (I am in a meeting, so may be distracted)
17:01:38 <timsim> Kiall ekarlso federico3 elarson pglass rsyed_away james_li jmcbride
17:01:42 <elarson> o/
17:02:14 <mugsie> #Action Items from last week
17:02:19 <mugsie> #topic Action Items from last week
17:02:20 <mugsie> -_-
17:02:31 <mugsie> Kiall investiagte 1505605
17:02:39 <mugsie> Kiall bp e6adbb9
17:02:54 <mugsie> He is presentign
17:02:58 <mugsie> so I will push
17:03:05 <mugsie> #action Kiall investiagte 1505605
17:03:13 <mugsie> #action Kiall bp e6adbb9
17:03:16 <mugsie> timsim bp ed2861a to L + K
17:03:40 <mugsie> timsim: ?
17:03:55 <timsim> done
17:04:06 <mugsie> #topic Bug Triage (timsim - recurring)#
17:04:12 * mlavalle sneaks in silently
17:04:30 <timsim> https://bugs.launchpad.net/designate/+bug/1516350
17:04:30 <openstack> Launchpad bug 1516350 in Designate "500 Internal Server Error while trying to update NS Pool" [Undecided,New]
17:04:53 <timsim> Looks like a bug, probably needs verification
17:05:16 <mugsie> not
17:05:27 <mugsie> was missing the priority fiedl in the API requst
17:05:46 <timsim> It shouldn't 500 though.
17:05:50 <mugsie> no
17:05:53 <mugsie> damn
17:05:55 <mugsie> valid
17:06:03 <mugsie> H - M
17:06:06 <mugsie> M2 *
17:06:09 <timsim> k
17:06:18 <timsim> https://bugs.launchpad.net/designate/+bug/1516355
17:06:18 <openstack> Launchpad bug 1516355 in Designate ""RecordSet not found" while trying to update NS Pool" [Undecided,New] - Assigned to megha (tmegha247)
17:06:27 <timsim> Could have sworn we fixed this.
17:07:15 <mugsie> yeah, I think so
17:07:31 <mugsie> mark it as a duplicate
17:07:44 <timsim> k, I'll find the old bug
17:08:00 <timsim> https://bugs.launchpad.net/designate/+bug/1517739
17:08:00 <openstack> Launchpad bug 1517739 in Designate "Designate services failed to start due to 'PortOpt' attribute" [Undecided,New]
17:08:11 <mugsie> invalid
17:08:21 <timsim> If you had an existing devstack, and didn't update requirements, but updated designate code this would happen. yeah
17:08:34 <timsim> https://bugs.launchpad.net/designate/+bug/1518266
17:08:34 <openstack> Launchpad bug 1518266 in Designate "Domains is not found in report in admin API" [Undecided,New]
17:08:44 <mugsie> h, m2
17:08:54 <timsim> https://bugs.launchpad.net/designate/+bug/1519456
17:08:54 <openstack> Launchpad bug 1519456 in Designate "Wrong packaging on openstack-designate + EL7" [Undecided,New]
17:09:12 <timsim> Wouldn't you install that with pip rather than a package?
17:09:17 * timsim knows nothing about CentOS
17:10:11 <mugsie> hum
17:10:26 <mugsie> this needs to be filed downstream
17:10:31 <mugsie> I will do it, assign it to me
17:10:39 <elarson> yeah, that sounds like a packaging issue
17:10:46 <timsim> Alrighty
17:11:01 <timsim> https://bugs.launchpad.net/designate/+bug/1519872
17:11:01 <openstack> Launchpad bug 1519872 in Designate "Database performance improvement" [Undecided,New]
17:11:03 <timsim> H M2?
17:11:19 <mugsie> assign it to federico
17:11:35 <timsim> k
17:11:48 <timsim> https://bugs.launchpad.net/designate/+bug/1520523
17:11:48 <openstack> Launchpad bug 1520523 in Designate "ZoneManager "DeletedDomainsPurgeTasks" failing" [Undecided,New]
17:12:22 <mugsie> h, m2, assign to me
17:12:28 <mugsie> I have a patch on the way
17:12:36 <timsim> cool
17:12:37 <timsim> https://bugs.launchpad.net/designate/+bug/1520638
17:12:38 <openstack> Launchpad bug 1520638 in Designate "domain serial number mismatch would lead to all subsequent domain operation fail" [Undecided,New]
17:13:39 <mugsie> need to dig in
17:14:03 <timsim> Looks like Kiall is going back and forth with the reporter
17:14:09 <mugsie> yeah
17:14:11 <timsim> I'll leave it as is, it's more of a question it looks like
17:14:18 <timsim> https://bugs.launchpad.net/designate/+bug/1521080
17:14:18 <openstack> Launchpad bug 1521080 in Designate "replace host name of instance" [Undecided,New] - Assigned to Hiroyuki Eguchi (h-eguchi)
17:14:41 <mugsie> invalid
17:14:51 <mugsie> we can only use the data we get from nova
17:15:30 <mugsie> that it?
17:15:53 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1512237
17:15:53 <openstack> Launchpad bug 1512237 in python-designateclient "'designate server-create' command gives output with incorrect field-value pair." [Undecided,New] - Assigned to Tim Simmons (timsim)
17:15:53 <timsim> almost
17:16:13 <mugsie> med
17:16:15 <mugsie> whenever
17:16:21 <timsim> lol
17:16:37 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1512647
17:16:37 <openstack> Launchpad bug 1512647 in python-designateclient "--log-file LOG_FILE option does not work with designate cli commands" [Undecided,New]
17:16:48 <mugsie> invlaid
17:16:49 * timsim thinks this is a dup
17:17:01 <mugsie> log does not do the the think he thinks it does
17:17:11 <timsim> cool
17:17:13 <timsim> Alright, that's it :)
17:17:19 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:17:38 <mugsie> #link http://paste.openstack.org/show/480638/
17:18:07 <mugsie> nominate the patches
17:18:41 <mugsie> I do not see anything
17:19:05 <timsim> 3898da8 Merge "Adds api_export_size attribute to admin  API" to L maybe
17:19:27 <mugsie> oh, yeah
17:19:28 <mugsie> ++
17:19:46 <federico3> is HTTP_X_FORWARDED_PROTO a bugfix?
17:19:49 <timsim> #action timsim to bp 3898da8 to L
17:20:01 <timsim> bollocks, though I could do that
17:20:05 <mugsie> federico3: no, i would nto class it as one
17:20:15 <mugsie> timsim: yuo can
17:20:22 <mugsie> ok, any more?
17:20:34 <timsim> oh duh, it didn't hell at me.
17:20:40 <mugsie> :D
17:20:45 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:20:46 <timsim> s/hell/yell
17:20:52 <mugsie> mlavalle:
17:20:56 <mlavalle> hi there
17:20:58 <mugsie> the floor is yours :)
17:21:35 <mlavalle> the week beofre the holidays I finished coding all the functionality in https://review.openstack.org/#/c/212213/
17:22:10 <mlavalle> that includes support for floating-ips as demoed in Tokyo, plus port on provider networks
17:22:16 <mugsie> sweet
17:22:42 <mlavalle> Very quickly I got feedback and based on that had to change some of my implementation approach
17:22:50 <mugsie> ok
17:23:16 <mugsie> so is there a new change coming?
17:23:16 <mlavalle> I was using a "light extension" approach and was asked to implement all the functionality in a full extension
17:23:39 <mlavalle> I did that last week and pushed the refactored code this past Sunday
17:23:44 <mugsie> ok.
17:24:05 <mlavalle> right now I am debugging carefully all the functionality under the new approach
17:24:28 <mlavalle> obvously I am finding a few bugs, but am making solid progress
17:24:44 <mlavalle> if everything goes well, I think I will finish debuging this week
17:24:52 <mugsie> great. anything you want us to do, please shout.
17:25:12 <mlavalle> just take a look on my designate driver
17:25:22 <mugsie> ok
17:25:33 <mlavalle> https://review.openstack.org/#/c/212213/31/neutron/services/externaldns/drivers/designate/driver.py
17:25:45 <mugsie> have it booked marked
17:25:54 <mlavalle> to make sure I am not doing something stupid. But it is working fine in my testing
17:26:21 <mugsie> ok, any questions for mlavalle ?
17:26:25 <mlavalle> don't look at it until I tell you. The version in Gerrit is a little stale after 2 days of debuging
17:26:45 <mlavalle> also, we merged the nova side spec
17:26:51 <mlavalle> last week
17:27:04 <mugsie> i saw :)
17:27:21 <mlavalle> I'll get to start implementing that as soon as the neutron side debbuging subsides
17:27:33 <mugsie> ok, sounds like solid progress
17:27:44 <mlavalle> that's it for me
17:27:52 <mugsie> cool
17:27:58 <mugsie> #topic Designate Chef Cook Books (j^2)
17:28:09 <mugsie> j^2: around?
17:28:22 <mugsie> #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/080266.html
17:29:07 <mugsie> OK, will push it till next week
17:29:18 <mugsie> #topic Mid Cycle
17:29:38 <mugsie> so
17:29:54 <elarson> ... so
17:29:59 <mugsie> I have provisional plans for mid cycle in Galway, Ireland in early feb
17:30:22 <mugsie> is that still OK?
17:30:41 <mugsie> Feb 8 - 10 / 11
17:31:23 <mugsie> can people let me know this week if there is issues with travel for those dates / location?
17:31:44 <mugsie> I am in Galway this week, so will be booking things today  / tomrrow
17:31:49 <timsim> Sure
17:31:59 <johnbelamaric> I would just have to come up with a reason that can convince my manager so I can visit Ireland ;)
17:32:17 <timsim> That _should_ work for at least some of us.
17:32:42 <mugsie> jmcbride: welcome
17:32:54 <jmcbride> howdy, sorry for my delay
17:32:54 <mugsie> Galway, Ireland Feb 8 - 10 / 11
17:33:02 <mugsie> Mid Ccyle
17:33:08 <mugsie> johnbelamaric: I am sure you can find somethign
17:33:20 <mugsie> any customers near here?
17:33:22 <mugsie> :D
17:33:30 <johnbelamaric> Hmm. Have to check :)
17:33:32 <jmcbride> mugsie: right now it will be a challenge for us (rackspace) to send full representation
17:33:59 <jmcbride> We are looking at the potential to send 1, remote chance for 2 folks.
17:34:10 <mugsie> OK, please let me know asap
17:35:24 <mugsie> #Open Discussion
17:35:28 <mugsie> #topic Open Discussion
17:35:45 <johnbelamaric> So…RFC 2317…reverse lookups for network prefixes on non-octet boundaries (CIDR). Have a customer that wants to do this in Designate but validation doesn't allow / in the name. (this is Kilo to be clear). Thoughts on relaxing that?
17:35:53 <johnbelamaric> Zones look like:
17:36:06 <mugsie> johnbelamaric: eh. we can definitly look at it
17:36:07 <johnbelamaric> 0/28.10.0.10.in-addr.arpa.
17:36:25 <mugsie> if there is an RFC it is easier
17:36:27 <johnbelamaric> Then you put a CNAM in 10.0.10.in-addr.arpa. pointing
17:36:37 <johnbelamaric> to that zone
17:36:38 <johnbelamaric> OK
17:36:54 <j^2> hy!
17:36:56 <j^2> hi!
17:37:26 <johnbelamaric> mugsie: great
17:37:38 <mugsie> johnbelamaric: file a spec at least
17:37:48 <johnbelamaric> mugsie: will do
17:37:51 <j^2> mugsie: sorry, i was caught in a meeting
17:37:57 <mugsie> I have just heard over the desk that it "doesn't really work very well"
17:38:06 <mugsie> but we an definitly experiment
17:38:10 <mugsie> j^2: np
17:38:18 <mugsie> you want to go throught the chef stuff?
17:38:22 <j^2> sure
17:38:24 <mugsie> through*
17:38:25 <j^2> if we have time
17:38:31 <mugsie> yeah, we do
17:38:48 <j^2> awesome
17:41:01 <mugsie> what do you need from us?
17:41:17 <j^2> so the short of it, is a cookbook to build out an envenironment up
17:41:28 <j^2> i'd love some people to help, sanity check the cookbook
17:41:42 <j^2> i'm assuming most don't know chef so i'm willing to help however i can
17:41:51 <mugsie> sure. I have a little bit of expeirence with chef, 3 years ago
17:41:58 <mugsie> but I knwo a few people
17:42:05 <timsim> Most of the rax folks use Chef for Designate internally.
17:42:10 <j^2> and when it "builds" everything out successfully were moving it to the openstack/ namespace
17:42:24 <timsim> So we should be able to help out :)
17:42:42 <j^2> timsim: nice
17:42:55 <mugsie> j^2: cool - also ping simonmc
17:43:03 <j^2> awesome
17:43:12 <mugsie> he used ot do the designate cookbooks in hp public cloud
17:43:28 <mugsie> I justv shouted at him to do it :)
17:43:34 <j^2> nice
17:43:52 <j^2> i want it in my namespace till we get everything together
17:44:00 <mugsie> yeah, sounds good
17:44:13 <j^2> prs are faster then reviews till we get "1.0.0" if you catch my drift
17:44:50 <mugsie> :)
17:44:54 <j^2> but my goal is `chef exec kitchen verify` will get us an all in one tested build of designate
17:45:08 <j^2> and it should take less then 10 mins
17:45:40 <mugsie> great.
17:45:45 <mugsie> any more questions?
17:45:50 <j^2> i figured that would be nice, without the overhead of devstack ;)
17:45:54 <mugsie> yeaj
17:46:57 <j^2> cool, so please take a look at the repo, and open issues or ping me
17:47:08 <j^2> i'm more then willing to pair or work; just hit me up
17:47:40 <mugsie> cool. will do
17:47:53 <mugsie> any other topics before we head off?
17:48:52 <mugsie> ok, everyone gets 10 mins back
17:48:55 <mugsie> #endmeeting