17:01:44 <mugsie> #startmeeting Designate
17:01:48 <rkukura> bye
17:01:51 <openstack> Meeting started Wed Dec  9 17:01:44 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:55 <openstack> The meeting name has been set to 'designate'
17:02:07 <mlavalle> mugsie: can I give my update now so I can gop to another meeting?
17:02:15 <mugsie> sure
17:02:31 <mugsie> #topic Nova / Neutron Integration
17:02:45 <mlavalle> mugsie: I finished debugging all the functionality over the weekend. It is now complete and free of bugs
17:03:25 <mlavalle> mugsie: this week I am cleaning up the tests in Jenkins that I broke. I am also adding docs and unit tests
17:03:30 <mugsie> cool
17:03:43 <mlavalle> mugsie: I expect this to merge soon
17:04:21 <mlavalle> mugsie: Jankins testa are almost clean as of this morning
17:04:33 <mlavalle> only a copuple more to fix
17:04:43 <mlavalle> and that's my report for this week
17:04:48 <mugsie> great
17:04:52 <j^2> o/
17:04:54 <mlavalle> :-)
17:05:12 <mugsie> OK, any questions for mlavalle ?
17:05:39 <mugsie> OK, moving on
17:05:47 <mugsie> #topic Roll Call
17:05:53 <mugsie> so whos here?
17:06:06 <timsim> o./
17:06:14 <j^2> o/
17:06:16 <rsyed> o/
17:06:18 <elarson> o/
17:06:25 <jet-rongl> o/
17:06:33 <mugsie> OK
17:06:40 <mugsie> #topic Action Items from last week
17:07:03 * mugsie Kiall investiagte 1505605
17:07:11 * mugsie Kiall bp e6adbb9
17:07:29 <mugsie> Seen as Kiall is on leave, I think we need to push these again
17:07:36 <mugsie> #action Kiall bp e6adbb9
17:07:44 <mugsie> #action Kiall investiagte 1505605
17:07:54 <mugsie> #topic Announcements
17:08:05 <mugsie> mid cycle is ready
17:08:07 <mugsie> https://ti.to/designate/mitaka-mid-cycle
17:08:26 <mugsie> please register there if you are coming, so I can make sure the room is big enough
17:08:41 <mugsie> topics here please - https://etherpad.openstack.org/p/designate_2016_winter_midcycle_meetup
17:09:18 <mugsie> it is Feb 8 - 10 in Galway, ireland
17:09:32 <pglass> is `removing eventlet, use gevent` an option?
17:09:53 <mugsie> yeah
17:09:54 <j^2> mugsie: would you like a chef representive there? if so i may be able to swing it
17:10:17 <j^2> in other words would it help to have me there for yall?
17:10:18 <mugsie> yeah, it is open to everyone :)
17:10:37 <mugsie> defineitly - more perspectives are alway better
17:10:56 <j^2> ok, cool, i'll talk to my management chain
17:11:01 <mugsie> great
17:11:16 <mugsie> #topic Bug Triage (timsim - recurring)
17:11:26 <timsim> https://bugs.launchpad.net/designate/+bug/1516355
17:11:26 <openstack> Launchpad bug 1516355 in Designate ""RecordSet not found" while trying to update NS Pool" [Undecided,New] - Assigned to megha (tmegha247)
17:11:29 * elarson just envisioned a big gold chain with a diamond chef logo
17:12:44 <mugsie> huh
17:12:48 <mugsie> we need to triage
17:13:13 <j^2> elarson: ;)
17:13:42 <timsim> mugsie: I'll assign it to me to investigate
17:13:48 <mugsie> timsim: cool
17:13:53 <timsim> There's three of these doc bugs:
17:13:56 <timsim> https://bugs.launchpad.net/designate/+bug/1522517
17:13:56 <openstack> Launchpad bug 1522517 in Designate "[Docs] /v2/tsigkeys is undocumented" [Undecided,New]
17:13:58 <timsim> https://bugs.launchpad.net/designate/+bug/1522518
17:13:59 <openstack> Launchpad bug 1522518 in Designate "[Docs] /v2/limits is undocumented" [Undecided,New]
17:14:02 <mugsie> h1, m2
17:14:03 <timsim> https://bugs.launchpad.net/designate/+bug/1522519
17:14:03 <openstack> Launchpad bug 1522519 in Designate "[Docs] /v2/reverse is undocumented" [Undecided,New] - Assigned to Ian Brown (ianbrown78)
17:14:11 <mugsie> high, m2 for all of them
17:14:14 <timsim> actually four https://bugs.launchpad.net/designate/+bug/1522952
17:14:14 <openstack> Launchpad bug 1522952 in Designate "designate devstack docs out of date" [Undecided,New]
17:14:23 <timsim> Cool
17:14:25 <timsim> https://bugs.launchpad.net/designate/+bug/1523691
17:14:25 <openstack> Launchpad bug 1523691 in Designate "Unhandled exception in periodic_sync/recovery halts the process" [Undecided,New]
17:14:39 <mugsie> critical, m2
17:15:02 <timsim> agreed
17:15:13 <timsim> That's all :)
17:15:40 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:15:51 <mugsie> http://paste.openstack.org/show/481344/
17:15:56 <mugsie> please look and nominate
17:16:26 <timsim> ed2ba15 Merge "Check TXT record length limit" ?
17:16:53 <mugsie> yeah thats it
17:16:57 <mugsie> i can do it
17:17:11 <mugsie> #action mugie bp ed2ba15 Merge "Check TXT record length limit"
17:17:41 <mugsie> #topic Blueprint for dynamic pool management: https://review.openstack.org/#/c/252745/
17:18:13 <mugsie> jet-rongl: do you want to say a few things about this?
17:18:46 <jet-rongl> Yes.
17:19:43 <jet-rongl> I proposed private pool in this blueprint, which could be used for future split DNS.
17:21:15 <mugsie> ok, this looks good. It is quite a large section of work
17:21:36 <elarson> is it dependent on the pool manager bits going into the database?
17:21:41 <jet-rongl> Yes. So need you review and comments.
17:21:42 <timsim> It's probably depends on a couple bits right?
17:21:52 <timsim> What elarson said plus the scheduler?
17:22:27 <mugsie> high, m2 for all of them
17:22:29 <mugsie> gah
17:22:31 <mugsie> yes
17:22:33 <jet-rongl> I expect to use a single pool manager to manage all pools in this blueprint.
17:22:44 <mugsie> config -> DB & schedualer
17:22:59 <mugsie> ok, then that will also be a requirement
17:23:11 <mugsie> we currently do not support this
17:23:29 <jet-rongl> scheduler is also need to delegate zones to pools, but not documented in this blueprint.
17:24:30 <mugsie> OK. can everyone please review this spec?
17:24:37 <timsim> sure
17:24:41 <elarson> yup!
17:24:45 <mugsie> jet-rongl: looks like you have some invalid syntax as well
17:25:20 <mugsie> #topic Open Discussion
17:25:28 <mugsie> any other topics?
17:26:58 <mugsie> OK, last chance in 3
17:27:00 <mugsie> 2
17:27:03 <mugsie> 1
17:27:11 <mugsie> #endmeeting