17:02:46 <mugsie> #startmeeting Designate
17:02:47 <openstack> Meeting started Wed Dec 16 17:02:46 2015 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:51 <openstack> The meeting name has been set to 'designate'
17:02:54 <mugsie> #topic roll Call
17:03:02 <rsyed> o/
17:03:02 <pglass> o/
17:03:06 <mugsie> sorry - got distracted
17:03:11 <timsim> o?
17:03:29 <mugsie> #topic Announcements
17:03:31 <elarson> o/
17:03:33 <Kiall> o/
17:03:59 <mugsie> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/082256.html
17:04:11 <mugsie> The Designate mid cycle has been set for the HPE Offices, in Galway,
17:04:14 <mugsie> Ireland [0] from the 08th to the 10th of February.
17:04:22 <mugsie> #link https://ti.to/designate/mitaka-mid-cycle
17:04:29 <mugsie> if you are joining us ^
17:04:37 <Kiall> Woo to no travel for me :)
17:04:39 <mugsie> please fill in that form
17:04:52 <mugsie> yay
17:05:05 <mugsie> #topic Action Items
17:05:25 <mugsie> Kiall bp e6adbb9
17:05:31 <mugsie> Kiall investiagte 1505605
17:05:42 <mugsie> Kiall: ^
17:06:03 <Kiall> Humm, not that I know of. Havent looked in ~2 week
17:06:13 <mugsie> #action Kiall investiagte 1505605
17:06:16 <Kiall> 1505605 doine
17:06:19 <Kiall> done*
17:06:21 <Kiall> as won't fix
17:06:24 <mugsie> #action Kiall bp e6adbb9
17:06:32 <mugsie> #action mugie bp ed2ba15 Merge "Check TXT record length limit"
17:06:38 <mugsie> I forgot about ^
17:06:48 <mugsie> #topic Bug Triage (timsim - recurring)
17:06:52 <Kiall> I also think the BP is done.. need to check to
17:06:56 <Kiall> tho*
17:07:07 <timsim> https://bugs.launchpad.net/designate/+bug/1525019
17:07:07 <openstack> Launchpad bug 1525019 in Designate "mdns.get_serial_number retries for no reason" [Undecided,New]
17:07:18 <Kiall> Yea, it was done.
17:07:32 <timsim> I still need to investigate 1516355
17:08:02 <mugsie> 1525019 - not sure
17:08:19 <mugsie> I am not 100% what that function is supposed to do
17:08:32 <mugsie> Kiall: you any idea?
17:08:45 <timsim> My impression was that it was a sync version of the async poll_for_serial number.
17:08:48 <Kiall> I believe timsim's comments in the ticket are correct, it should be just getting the current number
17:09:03 <timsim> Which, if that's the case, it shouldn't be retrying waiting for anything, just getting the current value.
17:09:17 <timsim> That's getting called a lot during `update_status` in the pool manager.
17:09:28 <mugsie> in that case H - M2
17:09:30 <Kiall> retrying, sure, if it fails to get a response.. but retrying because it's an unexpected serial number seems wrong
17:09:33 <timsim> Basically whenever the first poll_for_serial comes back from mdns, pool manager goes and calls get_serial for every other target.
17:09:42 <timsim> That isn't in the cache
17:09:52 <Kiall> timsim: oo, that also sounds like a bug
17:10:19 <Kiall> since we'll get those numbers back from the initial calls to poll for serial, we don't want to ask for it twice
17:10:46 <timsim> If it didn't do that, and the last of the poll for serials gets lost, then the zone stays PENDING forever.
17:10:53 <timsim> The way it works now, anyway.
17:11:03 <Kiall> Yea, I get that.. Still feels wrong!
17:11:15 <timsim> No arguments here :P
17:11:28 <timsim> That's a much trickier fix than this one.
17:11:30 <Kiall> Okay, well.. let's leave that issue for now ;)
17:11:33 <mugsie> yeah
17:11:38 <timsim> https://bugs.launchpad.net/designate/+bug/1525199
17:11:38 <openstack> Launchpad bug 1525199 in Designate "designate-dashboard: clear "Create Record" form fields" [Undecided,New]
17:11:48 <mugsie> should be in progress
17:11:52 <mugsie> assigned to federico3
17:11:56 <Kiall> #action kiall to file bug re update_status unnecessarily calling out to get_serial (see IRC meeting logs)
17:12:16 <Kiall> 1525199 should be done, it failed gate due to a tox upgrade, but it otherwise +A'd
17:12:30 <timsim> Kiall: I go more in detph about that here: https://github.com/TimSimmons/poolmanageroops#update_status
17:12:43 <Kiall> timsim: I've seen that doc, and mostly like ;)
17:12:53 <Kiall> 1525199 might be a duplicate
17:13:04 <Kiall> federico3: about?
17:13:10 <timsim> Gerrit appears to be down so we can't check the review :P
17:13:27 <Kiall> Nope, it's not - checked our JIRA and he refs that #
17:13:35 <timsim> Ah "Gerrit is offline for a software upgrade from 17:00 to 21:00 UTC. "
17:13:36 <Kiall> It's in-progress, high, m2
17:13:41 <timsim> cool
17:13:53 <timsim> That's it
17:14:00 <mugsie> sweet
17:14:11 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:14:14 * Kiall panics.. 2 sec
17:14:38 <mugsie> http://replygif.net/i/1534.gif
17:14:49 <Kiall> mugsie: can you get the list? I actually don't have anything cloned, wiped PC yesterday.
17:15:14 <Kiall> nvm - got it
17:15:26 <Kiall> http://paste.openstack.org/show/482107/
17:15:49 <Kiall> (0f5fd24 Fix tox ValueError: No closing quotation <-- hasn't landed yet, but it needs  a backport as otherwise the gate is wedged)
17:16:02 <Kiall> ee5efbf Object model: require "priority" field
17:16:15 <mugsie> 937e6dd Set zone in ERROR status on periodic sync fail
17:16:17 <mugsie> ee5efbf Object model: require "priority" field
17:16:25 <timsim> Yep, all of those.
17:16:31 <Kiall> any others?
17:16:45 <Kiall> actually - that's all bar the setup.cfg one
17:16:45 <mugsie> anyone want to sign up to do these?
17:17:10 <Kiall> I'll ask federico3 to do em in the morning
17:17:17 * mugsie is on holidays from tomrrow
17:17:19 <mugsie> OK, cool
17:17:28 <mugsie> #action federico3 to do backports
17:17:43 <mugsie> #topic Unhandled exception during periodic
17:17:47 <mugsie> #topic Unhandled exception during periodic sync
17:18:09 <mugsie> this was federico3 as well, so we may push this for a week or so
17:18:18 <mugsie> / past the holidays
17:18:32 <mugsie> #topic Designate/Neutron Integration Update
17:18:49 <mugsie> mlavalle seems to be off ...
17:18:55 <mugsie> we will get an update post holidays
17:19:06 <mugsie> #topic Open Discussion
17:19:15 <mugsie> anything of agenda?
17:19:19 <mugsie> off*
17:19:32 <Kiall> Next week cancelled?
17:19:47 <mugsie> yeah - everyone OK skipping the meeting next week?
17:19:55 <mugsie> and the week after?
17:19:56 <timsim> Yep, everyone's off here i think.
17:19:58 <timsim> Same.
17:20:17 <Kiall> Okay, next meeting is... Jan 6th|?
17:20:24 <mugsie> #action mugsie Cancel meetings for 2 weeks
17:20:32 <mugsie> we will resume on the 6th
17:20:35 <mugsie> of Jan
17:20:38 <mugsie> 2016
17:20:50 <mugsie> anything else?
17:20:53 <timsim> I put up a pretty crazy spec here: https://review.openstack.org/258621 (https://gist.github.com/TimSimmons/510ae418de6804f5e5da while gerrit is down). It'd be a big change, but I think it'd be pretty cool. Give it a look and shout at me (and pglass) if you think we're mental.
17:21:17 <mugsie> http://replygif.net/i/1528.gif
17:21:25 <timsim> Started from some elarson ideas, although I'm not sure how on board he is with the current state ;)
17:21:42 <Kiall> timsim: yea, I had a quick read of the doc on GH yesterday.. ++ to most of it :)
17:21:46 <elarson> timsim: nah, I'm just thinking about the extreme cases of the design. not important
17:22:12 <elarson> taking a trip to mars on my architect astronaut space ship :P
17:22:16 <timsim> Well, I'd love to hear people's thoughts on the bits that they don't ++ :)
17:22:18 <mugsie> elarson: alwayts going to the extreme
17:22:19 * Kiall would like to see any "worker" service be TaskFlow based :)
17:22:30 <mugsie> which means ZK, basically
17:22:36 <mugsie> sorry timsim
17:22:38 * timsim would not like to see that at all
17:22:43 <Kiall> lol - why?
17:22:59 <Kiall> not like ZK or TF?
17:23:02 <timsim> Both lol
17:23:09 <timsim> What's wrong with RPC casts?
17:23:53 <timsim> I'm not psyched about using another Openstack "NIH" type project (although I'll admit I don't know a ton about TaskFlow, other than knowing one of the OG people who started it, and has long since left it)
17:23:55 * mugsie thinks this will be a hot topic on Galway
17:24:19 <Kiall> TaskFlow enforces a nice structuring, and gives us stuff for "free".. e.g. define a flow for checking the status.. Flow(WaitForSerial(server1, expected=123, retries=10),WaitForSerial(server2, expected=123, retries=10), onfail=RollBackChange(change))
17:24:20 <Kiall> etc
17:24:33 <kobis> anyone able to reach gerrit?
17:24:35 * timsim will look into it
17:24:38 <mugsie> kobis: its down
17:24:47 <mugsie> they are upgrading it today
17:24:49 <timsim> kobis: down for maint from 17:00 to 21:00 UTC
17:24:49 <Kiall> [17:08:32] [openstackstatus] NOTICE: Gerrit is offline for a software upgrade from 17:00 to 21:00 UTC. See: http://lists.openstack.org/pipermail/openstack-dev/2015-December/081037.html
17:24:49 <elarson> !blame rsyed
17:24:50 <openstack> elarson: Error: "blame" is not a valid command.
17:24:56 <rsyed> nice try
17:24:58 <elarson> :)
17:25:03 <kobis> thanks
17:25:18 <mugsie> elarson: http://replygif.net/i/1501.gif
17:25:49 <mugsie> OK, everyoine look at the outstanging specs (when gerrit is back)
17:26:03 <elarson> mugsie is on :fire: with the giffage today
17:26:04 <Kiall> timsim: anyway, taskflow is nice, even if it's an OS NIH project..
17:26:19 <mugsie> until then, unless there is anything else - lets call it a day?
17:26:19 * timsim has PTSD from oslo_*
17:26:25 <Kiall> might try convince one of the Cue folks to talk about it at the mid-cycle (via video..) ;)
17:27:03 <mugsie> timsim looking at olso_* code  - http://replygif.net/i/961.gif
17:27:11 <mugsie> and on that note
17:27:17 <mugsie> #endmeeting