17:01:20 <mugsie> #startmeeting Designate
17:01:21 <openstack> Meeting started Wed Jan 6 17:01:20 2016 UTC and is due to finish in 60 minutes. The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:24 <openstack> The meeting name has been set to 'designate'
17:01:32 <mugsie> #topic Roll Call
17:01:37 <rsyed> o/
17:01:39 <timsim> o/
17:01:40 <mugsie> so, whos here?
17:01:42 <mlavalle> o/
17:01:53 <mugsie> Kiall: ekarlso courtesy ping
17:01:59 <Kiall> o/
17:02:16 <mugsie> #topic Announcments
17:02:23 <pglass> o/
17:02:27 <mugsie> any have anything to share here?
17:02:37 <Kiall> Happy New Year :)
17:02:42 <mugsie> ok, then :)
17:02:47 <mlavalle> yeah happy 2016!
17:02:56 <mugsie> #topic Action Items from 3 weeks ago
17:03:05 <mugsie> Kiall investiagte 1505605
17:03:16 <Kiall> done
17:03:25 <Kiall> (was done last time, I just thought it wasn't until you added it again ;))
17:03:30 <mugsie> Kiall bp e6adbb9
17:03:35 <Kiall> same as ^
17:03:40 <mugsie> mugie bp ed2ba15 Merge "Check TXT record length limit"
17:03:43 <mugsie> done
17:03:49 <mugsie> kiall to file bug re update_status unnecessarily calling out to get_serial (see IRC meeting logs)
17:03:59 <Kiall> Not done, will file after the meet
17:04:06 <mugsie> #action kiall to file bug re update_status unnecessarily calling out to get_serial (see IRC meeting logs)
17:04:09 <mugsie> federico3 to do backports
17:04:19 <mugsie> I think he did
17:04:28 <mugsie> mugsie Cancel meetings for 2 weeks
17:04:31 <mugsie> done
17:04:46 <mugsie> #topic Bug Triage (timsim - recurring)
17:04:58 <timsim> https://bugs.launchpad.net/designate/+bug/1531049
17:05:00 <openstack> Launchpad bug 1531049 in Manila "Devstack stop supporting Tempest deprecated cred options" [Critical,In progress] - Assigned to Valeriy Ponomaryov (vponomaryov)
17:05:02 <timsim> Looks like is being worked
17:05:08 <mugsie> yup
17:05:15 <mugsie> m2
17:05:27 <timsim> https://bugs.launchpad.net/designate/+bug/1528546
17:05:28 <openstack> Launchpad bug 1528546 in Designate "[Docs] No upgrade notes and/or changelogs for Kilo -> Liberty" [Undecided,New]
17:05:44 <mugsie> hum
17:06:04 <timsim> I think someone started a Liberty install guide
17:06:13 <mugsie> we really should have them
17:06:19 <mugsie> yeah, I saw a patch
17:06:31 <mugsie> but that was clean install
17:06:57 <mugsie> ok, med, m3
17:07:01 <timsim> Yeah. We should have upgrade notes and stuff.
17:07:12 <timsim> https://bugs.launchpad.net/designate/+bug/1529558
17:07:13 <openstack> Launchpad bug 1529558 in Designate "There is no install.sh file in designate directory , may be documentation issue" [Undecided,New]
17:07:33 <timsim> Probably changed when the devstack plugin stuff landed?
17:07:48 <mugsie> that is in progress, assign to ekarlso , med, m2
17:08:01 <mugsie> he has a patch up to fix the devstack docs
17:08:08 <timsim> https://bugs.launchpad.net/designate/+bug/1531294
17:08:09 <openstack> Launchpad bug 1531294 in Designate "periodic_sync_seconds cannot be set to None (in order to sync everything)" [Undecided,New]
17:08:13 <Kiall> I thought that landed? (the DS docs)
17:08:23 <mugsie> Kiall: not yet afaik
17:08:26 <Kiall> K
17:08:31 <timsim> https://review.openstack.org/#/c/255338/
17:08:35 <timsim> Not yet
17:08:59 <Kiall> re sync.. sounds like a bug, we're assuming int somewhere
17:08:59 <mugsie> hum. should we be setting it to None ?
17:09:27 <federico3> there's no CR out for 1531294?
17:09:39 <Kiall> I think it's probably a bad idea to always leave on.. but.. useful as a once off maybe?
17:09:50 <Kiall> e.g. recover from OH CRAP EVERYTHING BROKE etc
17:10:05 <mugsie> yeah, true
17:10:10 <mugsie> federico3: not yet
17:10:11 <timsim> I'm fine with None=infinity seconds
17:10:31 <federico3> I have a CR out for periodic_sync so I'll take it
17:10:37 <Kiall> Anyway, medium -> m2... it's a crash bug so we should just fix it
17:10:41 <mugsie> #action federico3 look at 1531294
17:10:49 <timsim> cool
17:10:51 <timsim> That's it
17:10:54 <timsim> :)
17:11:00 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:11:03 <Kiall> #link http://paste.openstack.org/show/483148/
17:11:13 <Kiall> as usual, take a few min, nominate for backporting
17:11:31 <mugsie> None imho
17:11:41 <Kiall> f59a573 Merge "Deprecated tox -downloadcache option removed"
17:12:23 <mugsie> is that it?
17:12:28 <Kiall> I think so.. anyone else?
17:12:38 <timsim> Yeah that's goo.
17:12:42 <timsim> s/goo/good
17:12:58 <mugsie> cool - who wants to do it?
17:13:12 <Kiall> i'll do it now..
17:13:14 <mugsie> not everyone at once
17:13:16 <mugsie> :D
17:13:19 <mugsie> #topic Old Patches (mugsie)
17:13:38 <mugsie> so - we have a lot of old patches
17:13:59 <mugsie> I am suggesting that any patch that has not been updated in 28 days be "abandoned"
17:14:05 <mugsie> this day next week
17:14:15 <mugsie> this does not stop anyone un abandoning it
17:14:35 <mugsie> but wilkl clear out the queue a fair bit
17:14:49 <mugsie> the patches that would be abandoned are here - http://paste.openstack.org/show/483147/
17:14:57 <Kiall> Yea, is a once off cleanup rather than a general 28 day policy.. right?
17:15:02 <mugsie> any comments / questions?
17:15:08 <mugsie> yeah, once off to start the year
17:15:47 <Kiall> OpenStack Proposal Bot | https://review.openstack.org/#/c/258328 | Updated from global requirements <-- we should, um, merge that?
17:15:59 <mugsie> yes
17:16:06 <mugsie> when the gate is working :)
17:16:18 <timsim> I suppose so.
17:16:25 <timsim> 28 days might be a bit eager
17:16:56 <timsim> But if it's just a one-off, no big.
17:17:12 <Kiall> yea, given the holidays, it's probably going to catch a few.. but.. those can be restored :)
17:17:18 <timsim> A few patches there that'd get unabandoned (alias) but it's cool.
17:17:27 <Kiall> (or, we merge useful ones in the next 7 days ;))
17:17:40 <mugsie> yeah. the major problem is that they were all updated in Nov
17:17:45 <mugsie> when the big rename happened
17:18:22 <mugsie> #link http://paste.openstack.org/show/483150/
17:18:31 <mugsie> this is the list for 42 days
17:18:40 <mugsie> that look better?
17:19:00 <Kiall> No diff? ;)
17:19:27 <timsim> Yeah that looks better to me
17:19:32 <mugsie> sure, let me get the "you lazy **" tool out
17:19:46 <timsim> But ¯\_(ツ)_/¯
17:19:51 <mugsie> ok, so - 42 days sounds good then.
17:19:56 <Kiall> yea, that seems like a better cut, save restoring a bunch
17:20:08 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:20:20 <mlavalle> hi
17:20:25 <Kiall> hey :)
17:20:43 <mlavalle> Before the holidays I submitted a patch for review https://review.openstack.org/#/c/212213/
17:21:42 <mlavalle> It got good feedback from the Neutron PTL. He asked me, though, to move the REST calls to designate out of Neutron core plugin db transactions out of performance considerations
17:22:07 <mlavalle> I coded those changes right before leaving for the holidays
17:22:43 <mlavalle> and since comin back on Monday I've been testing it. It is going very well, so I expect to push the next revision today or tomorrow
17:22:56 <Kiall> Cool, if the comments are now focusing on perf etc, that's a great sign it's really close :)
17:23:05 <mugsie> great
17:23:11 <mugsie> thanks mlavalle :)
17:23:29 <mlavalle> yeah, I agree. the other thing is that I got the attetion of the PTL. He seems to want this merged
17:23:45 <Kiall> Who's the M cycle neutron PTL?
17:23:52 <mlavalle> armax
17:24:03 <mlavalle> Armando Migliaccio
17:24:28 <Kiall> Cool, I was trying to do the IRC -> Gerrit translation ;)
17:24:39 <mlavalle> :-)
17:24:42 <mugsie> anyone any questions for mlavalle before we move on?
17:25:12 <mugsie> #topic sonuk: Blueprint for designate-bandit: https://review.openstack.org/#/c/26092
17:25:14 <Kiall> none from me
17:25:32 <Kiall> Bump stable/grizzly next version to 2013.1.1 ?
17:25:54 <mugsie> #link https://review.openstack.org/#/c/260925
17:26:05 <Kiall> I had made it to adding a 4 on the end ;)
17:26:05 <mugsie> looks like a char was missed when it was added
17:26:21 <mugsie> sonu doesnt seem to be here
17:26:46 <Kiall> You familar with it already?
17:26:51 <mugsie> nope
17:26:59 <mugsie> I know bandit is for security testing
17:27:23 <federico3> (very basic one)
17:27:30 <Kiall> Sounds like nobody is qualified to discuss this one then?
17:27:33 <mugsie> no
17:27:41 <mugsie> will push the nexty item as well then
17:27:49 <mugsie> as it is sonu as well
17:27:56 <mugsie> #topic Open Discussion
17:28:07 <mugsie> any off agenda items?
17:28:19 <Kiall> The next was about tempest-plugin, ekarlso - might be relavant?
17:28:22 <Kiall> http://docs.openstack.org/developer/tempest/plugin.html
17:28:40 <mugsie> yeah, I assume sonuk had a topic in mind
17:28:47 <mugsie> will wait for them to be online
17:28:58 <Kiall> Sounds like they made a proper plugin interface, which would be nice :)
17:29:32 <mugsie> oh, cool
17:30:08 <Kiall> So - Yea, it might solve the current tempest changed again issue in a way that lasts months between breakage ;)
17:30:08 <mugsie> any other topics?
17:30:17 <Kiall> Not from me..
17:30:22 <timsim> plz review https://review.openstack.org/#/c/258621/
17:30:25 <mugsie> Kiall: whole months?
17:30:28 <mugsie> wow
17:30:35 * mugsie would be living the dream :P
17:31:09 <Kiall> timsim: was thinking about that on my way in today
17:31:09 <mugsie> timsim: http://replygif.net/i/957.gif
17:31:25 <timsim> Kiall: It's so good right?
17:31:34 <Kiall> ideally, if we make changes like this again, we should understand the upgrade path before coding ;)
17:31:42 <Kiall> we've messed that one up a few times!
17:31:59 <mugsie> just a few
17:32:17 <timsim> Yeah true dat
17:32:24 <mugsie> #action all review https://review.openstack.org/#/c/258621/
17:32:35 <federico3> yep, upgrading is not going to be easy but the idea is very nice
17:32:41 <Kiall> actually, can we add "Upgrade Implications" to the spec template.
17:32:48 <mugsie> ++
17:33:08 <timsim> Sure
17:33:52 <mugsie> OK, does everyone want 25 mins back?
17:34:11 <Kiall> Sounds good to me :)
17:34:11 <mugsie> taking that as a yes :)
17:34:15 <mugsie> #endmeeting