17:03:47 <mugsie> #startmeeting Designate
17:03:48 <openstack> Meeting started Wed Jan 20 17:03:47 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:52 <openstack> The meeting name has been set to 'designate'
17:04:01 <mugsie> #topic Roll Call
17:04:06 <timsim> o/
17:04:07 <mugsie> whos here?
17:04:12 <sonuk> o/
17:04:18 <james_li> james li
17:04:19 <jmcbride> o/
17:04:35 <pglbutt> o/
17:04:52 <mlavalle> o/
17:05:06 <mugsie> #topic Action Items from last week
17:05:27 <mugsie> kiall to file bug re update_status unnecessarily calling out to get_serial (see IRC meeting logs)
17:05:49 <federico3> o/
17:05:54 <mugsie> ok, kiall seems to be afk
17:06:10 <mugsie> #action kiall to file bug re update_status unnecessarily calling out to get_serial (see IRC meeting logs)
17:06:12 <venkat> o/
17:06:20 <mugsie> cores review bandit patch
17:06:34 <mugsie> that was done, afaik
17:06:43 <mugsie> federico3 backpoort 6fa134a and 51b4869
17:07:03 <mugsie> federico3: was that done?
17:07:05 <federico3> nope :)
17:07:21 <mugsie> #action federico3 backpoort 6fa134a and 51b4869
17:07:39 * mugsie is typing on a new laptop, so excuse the slowness
17:08:00 <mugsie> #topic Bug Triage (timsim - recurring)
17:08:06 <mugsie> timsim: over to you :)
17:08:28 * timsim didn't investigate his bug...
17:08:34 <timsim> federico3 is working on one of them...
17:08:43 <timsim> https://bugs.launchpad.net/designate/+bug/1534848
17:08:44 <openstack> Launchpad bug 1534848 in Designate "Make the supported recordset types configurable" [Undecided,New] - Assigned to James Li (james-li-3)
17:09:04 <mugsie> saw that one. I am not sure if it is a bug or a new feature
17:09:06 <timsim> Not really a bug. I think there's already a bp for it.
17:09:20 <mugsie> definitly needs to happen,  but I think as a feature
17:09:28 <mugsie> can you close it and link to the bp?
17:09:33 <timsim> Can't find the bp
17:09:50 <timsim> But anyway, not a bug, file a blueprint/spec it up james_li :)
17:10:03 <ekarlso> hola :o
17:10:06 <timsim> https://bugs.launchpad.net/designate/+bug/1535249
17:10:07 <openstack> Launchpad bug 1535249 in Designate "Notify port of NSD4 backend" [Undecided,New]
17:10:13 <ekarlso> littlebit late to the party :)=
17:10:48 <mugsie> i think we need to see the config
17:11:27 <timsim> yeah, need more info
17:11:36 <mugsie> we send control messages to that port
17:11:38 <timsim> https://bugs.launchpad.net/designate/+bug/1536128
17:11:39 <openstack> Launchpad bug 1536128 in Designate "Installation guide(docs) of liberty release missing for ubuntu in docs(Designate)" [Undecided,New]
17:12:19 <mugsie> ok - weird
17:12:22 <timsim> lol https://github.com/openstack/designate/commit/320dec24f57cea682b00fe55dd0a5ce1e3f417b3
17:12:23 <mugsie> they should be up
17:12:26 <timsim> Doesn't change the index?
17:12:48 <mugsie> yup
17:12:59 <mugsie> stick it as H,m3 and assign it to me
17:13:04 <timsim> k
17:13:12 <timsim> That's it :)
17:13:41 <mugsie> #topic Stable Backport Triage
17:14:38 <mugsie> #link http://paste.openstack.org/show/484438/
17:14:55 <mugsie> have a look and nominate patches for backport
17:15:12 <mugsie> 320dec2 Merge "[docs] Create installing Liberty on Ubuntu"
17:15:46 <timsim> 8b761de Add retry logic on periodic_sync ?
17:16:11 <timsim> I guess that'd conflict pretty hard with the rename
17:16:15 <mugsie> yeah
17:16:33 <federico3> https://review.openstack.org/#/c/264891/
17:16:40 <federico3> ^^^ Add retry logic on periodic_sync to stable/liberty
17:16:58 <mugsie> federico3: do you think you couod backport, even with the rename
17:17:00 <mugsie> ?
17:17:09 <timsim> Looks like he already did
17:17:16 <federico3> that's the backport CR :D
17:17:20 <mugsie> -_-
17:17:22 <mugsie> ah
17:17:23 <federico3> it has been merged already
17:17:48 <mugsie> ok, then just 320dec2 to bp
17:17:59 <federico3> (and yes it had fun confilcts with the rename)
17:18:07 <mugsie> #action mugsie backport 320dec2
17:18:28 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:18:36 <mlavalle> hi there
17:18:54 <federico3> ...unless we also want to backport "Use tmpfs on /dev/shm for database if available"
17:19:03 <mlavalle> So I addressed all the remaining concerns in https://review.openstack.org/#/c/212213
17:19:21 <mlavalle> I also re-tested after addressing those concerns
17:19:44 <mlavalle> pushed new revision Monday morning and I hit a global requirements update
17:20:16 <mlavalle> so I am waiting for the bot patchset to merge and I will rebase and re-submit again
17:20:39 <mlavalle> I feel comfortable that I addressed all of carl_baldwin's concern from the last review
17:20:49 <mugsie> great
17:20:50 <mlavalle> so I think it is close
17:21:29 <mlavalle> No more rest calls in any core plugin or service plugin transaction
17:21:32 <carl_baldwin> mlavalle: I owe you another review today.
17:21:32 <mugsie> ok hten. is there anything you need us to do?
17:21:52 <mlavalle> mugsie: nope, I am good on this side
17:22:08 <mugsie> great - any questions for mlavalle ?
17:22:54 <mugsie> ok, then - thanks mlavalle :)
17:23:00 <mlavalle> :-)
17:23:04 <mugsie> #topic Open Discussion
17:23:14 <mugsie> any out of agenda items?
17:23:27 <mugsie> timsim: did you get anything for the ttl bug / feature?
17:23:37 <timsim> No :( sorry
17:23:39 <timsim> Need to write a spec
17:23:46 <timsim> Meeting snuck up on me
17:23:52 <mugsie> you an me both
17:23:57 <sonuk> https://bugs.launchpad.net/designate/+bug/1518266
17:24:01 <openstack> Launchpad bug 1518266 in Designate "Domains is not found in report in admin API" [High,In progress] - Assigned to sonu (sonu-bhumca11)
17:24:31 <sonuk> as  domain has been renamed to zone
17:25:11 <sonuk> so do i need to to show domain count along with zone
17:25:33 <mugsie> they should be the same count
17:25:38 <mugsie> https://github.com/openstack/designate/blob/master/designate/api/v1/extensions/reports.py#L65
17:25:46 <mugsie> it looks like it is there :/
17:25:49 <timsim> admin/reports counts works for me
17:25:57 <timsim> sorry
17:26:16 <sonuk> so this is a bug right
17:26:26 <timsim> What's the bug?
17:26:44 <sonuk> Domains is not found in report in admin API
17:26:53 <sonuk> https://bugs.launchpad.net/designate/+bug/1518266
17:26:54 <openstack> Launchpad bug 1518266 in Designate "Domains is not found in report in admin API" [High,In progress] - Assigned to sonu (sonu-bhumca11)
17:26:58 <timsim> Should it?
17:26:58 <mugsie> I am not sure. are the reports extentions enabled in the config file?
17:27:14 <timsim> It should just be zones now
17:27:26 <mugsie> yeah - in the v1 API, it should still be domains
17:27:37 <mugsie> oh
17:27:39 <mugsie> hang on
17:27:43 <mugsie> this is the admin api
17:27:46 <timsim> yeah
17:27:47 <mugsie> yeah, not a bug
17:28:02 <sonuk> then it should be closed
17:28:07 <mugsie> yup
17:28:16 * timsim does that
17:28:51 <mugsie> OK, any other toics for discussion?
17:28:57 <mugsie> topics*
17:29:29 <mugsie> going once
17:29:33 <mugsie> twice
17:29:39 <mugsie> and ...
17:29:44 <sonuk> https://bugs.launchpad.net/designate/+bug/1525019
17:29:45 <openstack> Launchpad bug 1525019 in Designate "mdns.get_serial_number retries for no reason" [High,Triaged] - Assigned to sonu (sonu-bhumca11)
17:31:28 <mugsie> sonuk: what about it?
17:31:49 <sonuk> so as we get serial no it should be retried if server fails
17:32:31 <sonuk> right
17:32:48 <timsim> If there's some problem contacting the server, it should retry.
17:33:04 <timsim> If it gets a valid answer with a serial number that's not right, it should not retry.
17:33:43 <sonuk> ok
17:33:56 <mugsie> yeah
17:35:03 <mugsie> ok - thanks everyone!
17:35:08 <mugsie> #endmeeting