17:00:55 <mugsie> #startmeeting Designate
17:00:56 <openstack> Meeting started Wed Jan 27 17:00:55 2016 UTC and is due to finish in 60 minutes. The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:00 <openstack> The meeting name has been set to 'designate'
17:01:29 <mugsie> #topic Roll Call
17:01:32 <Kiall> o/
17:01:33 <rsyed> o/
17:01:35 <timsim> o/
17:01:36 <james_li> james li
17:01:54 <mugsie> #topic Action Items from last week
17:02:00 * Kiall hides
17:02:08 <mugsie> kiall to file bug re update_status unnecessarily calling out to get_serial (see IRC meeting logs)
17:02:32 <Kiall> Nope, doing it righjt now
17:02:35 <Kiall> right*
17:02:37 <mugsie> :)
17:02:39 <mugsie> federico3 backpoort 6fa134a and 51b4869
17:02:46 <Kiall> (that was my third attept at right, and it was still wrong)
17:03:08 <mugsie> federico3: you around?
17:03:24 <mugsie> #action federico3 backpoort 6fa134a and 51b4869
17:03:24 <mugsie> mugsie backport 320dec2
17:03:29 <mugsie> #action mugsie backport 320dec2
17:03:34 <federico3> o/
17:03:47 <mugsie> ah - did ^ get backported?
17:03:56 <federico3> mugsie: the backport CRs are out
17:04:00 <mugsie> great
17:04:13 <mugsie> #topic Bug Triage (timsim - recurring)
17:04:35 <timsim> Alright...
17:04:43 <timsim> There's one I still haven't looked at :D
17:04:46 <timsim> https://bugs.launchpad.net/designate/+bug/1534490
17:04:47 <openstack> timsim: Error: malone bug 1534490 not found
17:05:03 <Kiall> "The information on this page is private."
17:05:04 <timsim> federico3 is on that one, but it's private
17:05:13 * timsim seems to remember that it need not be anymore
17:05:15 <timsim> anyway
17:05:24 <timsim> https://bugs.launchpad.net/designate/+bug/1535249
17:05:24 <Kiall> it's private as the guy has TONNES of logs uploaded, not because it's a sec issue
17:05:25 <openstack> Launchpad bug 1535249 in Designate "Notify port of NSD4 backend" [Undecided,New]
17:05:31 <federico3> it contains logs sent by the requester
17:06:01 <Kiall> that feels like user error at a glance
17:06:21 <Kiall> he's not included the relavant config snippet to know
17:06:50 <timsim> Yeah, I'll ask for more config. Or spelunk his ansible.
17:06:56 <elarson> o/
17:06:58 <Kiall> request pool_nameserver and Incomplete?
17:07:05 <timsim> yep
17:07:14 <timsim> https://bugs.launchpad.net/designate/+bug/1536464
17:07:15 <openstack> Launchpad bug 1536464 in Designate "Unit test failure when buildnig debian package for Mitaka b2: testtools.matchers._impl.MismatchError in PoolManagerInitTest.test_init_no_pool_targets" [Undecided,New]
17:07:25 <mugsie> did that get fixed?
17:07:38 <mugsie> i thought it was part of the pecan fix
17:07:43 <timsim> Did we start skipping that unit test?
17:07:59 <Kiall> we did
17:08:00 <federico3> yep, since a good while
17:08:12 <timsim> Maybe not by m2?
17:08:19 <mugsie> not by m2
17:08:25 <Kiall> though, I wonder if it's related to the other mock issues.. prob worth turning it back on to see
17:08:39 <federico3> Kiall: tried, still failed
17:08:42 <mugsie> mark as fix released, m3 ?
17:08:45 <Kiall> federico3: thanks
17:08:47 <Kiall> mugsie: +
17:08:47 * mlavalle quetly joins the meeting hoping nobody notices he is late ;-)
17:08:53 <timsim> Cool.
17:08:56 <Kiall> mlavalle: we all noticed now ;)
17:09:02 <timsim> https://bugs.launchpad.net/designate/+bug/1536932
17:09:03 <openstack> Launchpad bug 1536932 in Designate "[Docs] /v2/zones/tasks/transfer_requests/<id> is undocumented for PATCH and DELETE call." [Undecided,New] - Assigned to sonu (sonu-bhumca11)
17:09:18 <mugsie> med - m3
17:09:33 <Kiall> I feel like ekarlso may have done that one..
17:09:56 <timsim> https://bugs.launchpad.net/designate/+bug/1537688
17:09:57 <openstack> Launchpad bug 1537688 in Designate "domain-create never succeed in NSD4" [Undecided,New]
17:10:01 <timsim> Same guy with the nsd backend
17:10:23 <Kiall> View a Transfer Request
17:10:23 <Kiall> ^^^^^^^^^^^^^^^^^^^^^^^
17:10:23 <Kiall> .. http:get:: /zones/tasks/transfer_requests/(uuid:id)
17:10:29 <Kiall> yep, done
17:10:44 <mugsie> Kiall: not patch and delete ;)
17:10:51 <Kiall> oh
17:10:53 <Kiall> oh well
17:10:58 <Kiall> timsim: Med,m3
17:11:11 <Kiall> looks like a trivial fix to strip that
17:11:18 <mugsie> ++
17:11:20 <timsim> Agreed
17:11:30 <timsim> That's it :)
17:12:00 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:12:03 <Kiall> #link http://paste.openstack.org/show/485171/
17:12:15 <Kiall> As usual, take a few, nombinate anything that warrants backporting
17:12:37 <Kiall> 282635b Merge "Fix _assert_exception()"
17:12:48 <mugsie> e2061af Merge "Rename zone > domain for errors in V1"
17:12:51 <Kiall> 1a6a6fb Fixes wording of exceptions for delete maybe
17:12:53 <mugsie> oh
17:12:54 <mugsie> wait
17:12:56 <mugsie> ignore me
17:13:05 <Kiall> Yea, thats not one to do IMO
17:13:16 <mugsie> well, there was no rename in L
17:13:33 <mugsie> 1a6a6fb Fixes wording of exceptions for delete
17:13:43 <Kiall> any others? and takers for doing the BP?
17:14:13 <timsim> So just:
17:14:13 <mugsie> I will do it when I do my one from last week
17:14:14 <timsim> 282635b Merge "Fix _assert_exception()"
17:14:22 <timsim> and
17:14:24 <Kiall> and e2061af Merge "Rename zone > domain for errors in V1" I guess
17:14:25 <timsim> 1a6a6fb Fixes wording of exceptions for delete
17:14:26 <timsim> ?
17:14:27 <Kiall> yea
17:14:45 <timsim> zone > domain shouldn't be necessary because no rename
17:14:49 <mugsie> yeah
17:15:08 * Kiall takes 1a6a6fb
17:15:09 <mugsie> just ã282635b and 1a6a6fb
17:15:26 <mugsie> Kiall: want to do both :)
17:15:31 <mugsie> you do
17:15:34 <elarson> mugsie: I can one
17:15:47 <mugsie> OK, then elarson you get 282635b
17:15:55 <elarson> I can't seem to type today... but I can backport something ;)
17:15:57 <elarson> got it
17:16:05 <Kiall> both are done and uploading ;)
17:16:10 <elarson> DONE!
17:16:13 <Kiall> trivial ones
17:16:18 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:16:27 <mugsie> mlavalle: well done :)
17:16:31 <Kiall> (cake)
17:16:36 <mugsie> fyi - the patch merged
17:16:40 <mlavalle> mugsie: thanks....... :-)
17:16:46 <mugsie> after much hard work and repeated patchsets
17:16:59 <mlavalle> this is what is left:
17:17:07 <Kiall> http://i.imgur.com/oTGwt1u.webm
17:17:20 <mlavalle> The Nova side: https://review.openstack.org/#/c/271578/
17:17:46 <mlavalle> patchset is up for review. The change is a lot simpler than we expected in the spec
17:18:11 <Kiall> It looks it, -1 for lack of tests, but, no CI fails .. so, nothing was totally broke ;)
17:18:18 <Kiall> That should be easy to get landed :)
17:18:25 <mugsie> yeah
17:18:34 <mlavalle> we spent a lot of lines in the spec worrying about re-attempting the port operation if neutron wasn't upgraded yet
17:19:13 <mlavalle> it turns out the neutron api in nova keeps a cache of the neutron extensions enebled, that is updated periodically (every 10 minutes by default)
17:19:30 <mugsie> cool - this looks a lot simpler that I thought it was going to be alright
17:19:50 <mugsie> mlavalle: when you get tests give me a shout, and I will start pinging people
17:19:53 <mlavalle> so no need of retries logic.... just check if our extension is enabled and in that case send dns_name o the port
17:20:10 <Kiall> Next up.. Get trove / octavia / cue / etc to "dup" the Nova patch for each of there services :)
17:20:20 * Kiall will bug them today
17:20:40 <mlavalle> the other piece I am working on is operators documentation in the networking guide
17:20:55 <mugsie> ah - one step ahead of us :)
17:21:03 <mlavalle> I am adding a chapter for the Nuetron, Nova, Designate integration
17:21:21 <mlavalle> the patchset should be up for review in a few days
17:21:45 <mugsie> great
17:21:52 <mlavalle> I strongly recommend that you take a look at it and create its counterpart in the Designate docs
17:22:01 <mugsie> any questions for mlavalle ?
17:22:13 <Kiall> Nope, I left mine in the review :)
17:22:16 <mlavalle> that's it from me this week
17:22:22 <mugsie> mlavalle: ++ - we need to do a docs day before the end of cycle
17:22:31 <mugsie> great - thanks again!
17:22:37 <mlavalle> mugsie: if you invite me, i'll help
17:22:58 <mugsie> will do!
17:23:04 <mugsie> #topic OpenStack Summit Call for Speakers Ends Feb 1 https://t.co/FYXvNL2wfv (timsim)
17:23:14 <timsim> #link https://www.openstack.org/summit/austin-2016/call-for-speakers/
17:23:29 <timsim> So the Austin Summit call for speakers deadline is coming fast.
17:23:33 <mugsie> it is
17:23:36 <timsim> If we want to submit talks, we better do it :)
17:23:42 <Kiall> pretty sure they keep moving that date up
17:23:59 <mugsie> do we want to do the "Hello, I am giving this talk for the 6/7th time" talk?
17:24:08 * Kiall suggests we C+P the workshop from last year, and add mlavalle's work
17:24:14 <mugsie> ++
17:24:20 <mugsie> I like the workshops
17:24:22 <mlavalle> ++
17:24:32 <mugsie> timsim: we will not be making USBs the night before
17:24:39 <timsim> preach
17:24:39 <Kiall> Oh, go on.
17:24:42 <mugsie> never again
17:24:45 <Kiall> do it the night before ;)
17:24:49 * mlavalle enjoys the cakes sent by Kiall :-)
17:24:56 <timsim> Kiall you went and partied that night
17:25:03 <Kiall> I know :)
17:25:06 <timsim> :P
17:25:07 <mugsie> so, who would like to get in on doing the workshop?
17:25:16 <mugsie> timsim: we ate raw chicken instead :)
17:25:27 * elarson is happy to do it
17:25:33 <timsim> haha.
17:25:37 <Kiall> Happy to.. Don't mind if that's helper or speaker ;)
17:25:48 <timsim> Yeah I'm happy to join in as a helper/speaker/whatever
17:25:56 <timsim> Our whole team will be there.
17:26:06 <Kiall> WS with too little helpers == painful.
17:26:09 <timsim> So we should have plenty of helpers.
17:26:14 <mugsie> OK - Kiall, timsim, elarson, mugsie - anyone else?
17:26:17 <Ram_> if anything can be done remotely I can contribute as well
17:26:21 <Kiall> K - mlavalle - you in austin? :)
17:26:32 <Kiall> at the summit that is, not right now
17:26:53 <mlavalle> Kiall: yes.... I live in San Antonio. it's just 1 hour driver form my house
17:27:07 <mugsie> Ram_: it is touch and go if the internet works for these things - so we generally need to be in the venue :(
17:27:21 <Ram_> when is it?
17:27:32 <mugsie> want to show your work off in a live workshop mlavalle ?
17:27:49 <timsim> Ram_: https://www.openstack.org/summit/austin-2016/
17:28:27 <mlavalle> mugsie, Kiall: I am going to submit a talk proposal to do a specific hands on session on using and configuring this integration
17:28:34 <Kiall> cool :)
17:28:56 <mlavalle> mugsie, Kiall: but I would also participate in your workshop if you invite me
17:29:17 <mugsie> OK then. - I will C+P the proposal from Tokyo, and add this integration in as one of the items, and add us to the speakers list
17:29:20 <Kiall> For those wondering what the WS format usually is - https://www.openstack.org/summit/vancouver-2015/summit-videos/presentation/designate-interactive-workshop-install-and-operate-2
17:29:30 <mugsie> mlavalle: very happy to :)
17:29:32 <mlavalle> mugsie, Kiall: this way we do an overview in the workshop and an in depth session
17:30:00 <mugsie> I will send out an email later in the week to organise syncing up for it
17:30:01 <Kiall> Sounds good :)
17:30:16 <mugsie> #action mugsie arrange sync re workshop
17:30:25 <mugsie> any other talks we should do?
17:30:35 <Ram_> https://review.openstack.org/#/c/272081/
17:30:45 <Ram_> Added a new specification for Tenant domainID for Designate Sink
17:31:20 <Ram_> can you guys take a look at it?
17:31:21 <mugsie> Ram_: OK, we will move to that in one second, after the talks item :)
17:31:24 <Ram_> review
17:31:30 <Ram_> ok
17:31:33 <timsim> mugsie: We'll probably come up with some good ones after the mid-cycle >:D
17:31:42 <mugsie> true :)
17:31:51 <timsim> For Barcelona, I suppose.
17:31:59 <mugsie> OK - if that is it ?
17:32:08 <mugsie> #topic https://review.openstack.org/#/c/272081/
17:32:12 <mugsie> #link https://review.openstack.org/#/c/272081/
17:32:43 <mugsie> Ram_: the only issue I have seen wiht that spec is it uses the V1 API
17:32:44 <Ram_> right now we have a hardcoded domainid in sink handlers
17:32:56 <Ram_> I'll update that to v2 api
17:33:01 <mugsie> sorry, the main issue - we would need to dig in a bit more
17:33:25 <Ram_> when we create records in this domain
17:33:27 * Kiall is having a quick read
17:33:32 <Ram_> generally tenants won't be able to look at the them
17:33:46 <mugsie> i would prefer something like https://review.openstack.org/89689
17:33:46 <Ram_> as they won't have access to this domain
17:33:59 <mugsie> #link https://review.openstack.org/89689
17:34:38 <mugsie> ( I am not keen on creating a column for -sink, when it is being superceeded by the work mlavalle is currently doing )
17:34:56 <Ram_> ok
17:35:03 <mugsie> but, I will leave comments in the review
17:35:20 <mugsie> timsim: Kiall elarson federico3 ekarlso etc - can you re3view it as well?
17:35:33 <timsim> Sure
17:35:44 <Ram_> do you have a spec for 89689?
17:35:53 <federico3> yup
17:36:00 <mugsie> Ram_: no - it was a crazy idea I came up with
17:36:04 <mugsie> as a POC
17:36:04 <Kiall> Ram_: Yea, I think I agree with mugsie.. we may not want something as generic as mugsie's patch he linked, but having it somewhat separate to the main domain table / API feels better
17:36:37 <mugsie> yeah, mine was a little too abstracted
17:36:59 <Ram_> ok
17:37:11 <Kiall> i.e. mugsie's was a giant generic works for all the $things, vs keeping the concept (API) and the internals being a little hardcoded for each option type, which simplifies it a chunk and keeps the "clean" API
17:37:53 <Ram_> I'll give it a thought and see if I can come up with something new
17:37:58 <mugsie> great :)
17:38:04 <mugsie> #topic sonuk: tempest plugin implementation
17:38:18 <mugsie> sonuk does not seem to be here - will push for a week
17:38:35 <mugsie> #topic Open Discussion
17:38:42 <mugsie> anything off agenda/
17:38:44 <mugsie> ?*
17:38:52 <timsim> I wrote up some quick options for exposing the inherited TTL on recordsets: https://review.openstack.org/#/c/273148/
17:38:58 <mugsie> i saw that pop in
17:39:07 <timsim> Like 5 minutes before the meet
17:39:31 <timsim> So, if people want to leave their thoughts on there, that'd be swell
17:39:57 <elarson> we have an issue where mdns is going catatonic. I mention just in case anyone experiences something similar and finds any insights
17:40:48 <timsim> catatonic == not responding on TCP
17:40:52 <mugsie> elarson: not that I have seen ...
17:40:55 <Kiall> federico3: ^
17:41:00 <mugsie> what about UDP?
17:41:05 <timsim> UDP is fine
17:41:08 <Kiall> the bug federico3's been digging into sounds familar.
17:41:16 * elarson hopes so
17:41:17 <mugsie> huh
17:41:26 <timsim> We only use TCP though
17:41:42 <mugsie> ah
17:42:28 <mugsie> OK, federico3 and elarson do you want to sync later and see if they are related?
17:42:39 <federico3> that was pool manager tho. timsim, can you provide some logs?
17:42:57 <federico3> sure
17:43:01 <mugsie> cool.
17:43:02 <elarson> yeah
17:43:04 <timsim> Yeah, we can. I think we found some useful ones.
17:43:32 <mugsie> timsim: useful logs? in openstack? wut? :P
17:43:39 <timsim> oh jk
17:43:58 <mugsie> :)
17:44:05 <mugsie> OK - anything else for today?
17:44:07 <timsim> Looks like mostly kernel logs :P
17:44:12 <mugsie> ah
17:44:19 <timsim> I put up https://review.openstack.org/#/c/272316
17:45:02 <timsim> During tests when things go wrong, we've seen zones that either stay in Error forever, or pending forever. Hopefully this might fix that.
17:45:12 <mugsie> timsim: more that 72 chars on a line in the commit msg
17:45:15 <mugsie> tut tut tut
17:45:27 <timsim> -_-
17:45:32 <timsim> Nto more than 80
17:45:34 <mugsie> cool - will look at that soon
17:45:42 <mugsie> 72 on the body
17:45:47 <timsim> kill me
17:45:48 <mugsie> 79 for the title
17:46:17 <mugsie> Kiall: ^ needs review as well
17:46:32 <Kiall> sortty, distracted by some internal stuff.
17:46:40 <mugsie> sortty?
17:46:50 <timsim> Kiall-speak for sorry, I'm guessing :P
17:46:57 <mugsie> maybe
17:47:00 <mugsie> who knows
17:47:10 <mugsie> OK - we good to call it then?
17:47:16 <timsim> Sure
17:47:25 <mugsie> #endmeeting