16:59:24 <mugsie> #startmeeting Designate
16:59:25 <openstack> Meeting started Wed Feb 24 16:59:24 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:29 <openstack> The meeting name has been set to 'designate'
16:59:34 <mugsie> #topic Roll Call
16:59:41 <rsyed> o/
16:59:47 <federico3> o/
17:00:11 <mugsie> timsim: elarson ekarlso- Kiall courtesy ping
17:00:18 <pglass> o/
17:00:20 <Kiall> o/
17:00:28 <pglass> timsim is ooo today
17:00:30 <mugsie> give people a few mins to file in
17:00:32 <mugsie> useless
17:00:35 <mugsie> :)
17:00:38 <elarson> o/
17:00:44 <ekarlso-> pooong
17:00:55 <elarson> pooooooo
17:00:59 <mugsie> #topic Action Items
17:01:10 <mugsie> kiall to BP 0022fd8 Ensure ZoneManager emits valid objects
17:01:20 <Kiall> Still TODO
17:01:28 <mugsie> #action kiall to BP 0022fd8 Ensure ZoneManager emits valid objects
17:01:32 <mugsie> #action mugsie bp 24c957b
17:01:41 <mugsie> #action mugsie to look at bug/1546437
17:01:47 <mugsie> a bad week for it
17:01:55 <mugsie> Bug Triage (timsim - recurring)
17:01:58 <mugsie> #topic Bug Triage (timsim - recurring)
17:02:09 <mugsie> I suppose I should do this :)
17:02:27 <mugsie> https://bugs.launchpad.net/designate/+bug/1516355
17:02:27 <openstack> Launchpad bug 1516355 in Designate ""RecordSet not found" while trying to update NS Pool" [Undecided,New] - Assigned to Tim Simmons (timsim)
17:02:40 <mugsie> ah, tim was looking at this
17:02:59 <mugsie> https://bugs.launchpad.net/designate/+bug/1548331
17:02:59 <openstack> Launchpad bug 1548331 in Designate "The zone records quota are not enforced" [Undecided,New] - Assigned to Eric Larson (eric-larson)
17:03:09 <Kiall> Was ^ not fixed?
17:03:15 <mugsie> yeah
17:03:31 <mugsie> we had a CVE for that afaik
17:03:35 <mugsie> elarson: ?
17:03:36 <Kiall> elarson: is that still active?
17:04:32 <mugsie> ok - we can come back to it when elarson is backj
17:04:34 <elarson> Kiall:
17:04:36 <elarson> yes!
17:04:37 <elarson> geez
17:04:38 <Kiall> lol
17:04:39 <Kiall> triming
17:04:41 <Kiall> timing*
17:04:43 <elarson> can't type
17:04:54 <mugsie> :)
17:05:02 <elarson> yeah, I have some patches I'm  getting sorted out now
17:05:07 <mugsie> ok, then this is a critical , m3
17:05:24 <Kiall> ++
17:05:28 <elarson> basically we check zone recordsets but not the zone records
17:05:44 <mugsie> I could have sworn we fixed that
17:05:57 <mugsie> ok - cool that is all the bugs
17:06:00 <elarson> part of it yes, but not all recordsets
17:06:14 <mugsie> -_-
17:06:16 <mugsie> #topci Stable Backport Triage (kiall - recurring)
17:06:22 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:06:31 <mugsie> me no typy well today
17:06:35 <Kiall> http://paste.openstack.org/show/488053/ - as usual, take a few mins and nominate for backporting
17:06:35 <mugsie> Kiall:
17:07:06 <mugsie> b79cb7b Update Bind 9 backend and other documentation
17:07:10 <Kiall> be9d280 Merge "Fix V1 Quotas API Extension" - if it applies
17:07:16 <mugsie> its part of the rename
17:07:19 <federico3> mugsie: backporting those docs?
17:07:25 <mugsie> yeah, they apply
17:07:25 <Kiall> do we backport docs? they don't publish anywhere?
17:07:37 <mugsie> they can be built by distros
17:07:42 <Kiall> We've never considered them for backport before ;)
17:07:46 <mugsie> who can build from the stable branch
17:07:51 <federico3> also, they would not be accurate for some stable branches
17:07:57 <mugsie> we are now :)
17:08:07 <mugsie> federico3: they would be acurate for liberty
17:08:37 <federico3> ok, I can do the backport for libert
17:08:40 <mugsie> k
17:08:41 <federico3> -y
17:08:44 <mugsie> any others?
17:08:58 <Kiall> nope, not that I can see
17:09:03 <mugsie> #action federico3 bp b79cb7b Update Bind 9 backend and other documentation
17:09:15 <mugsie> #topic Core Membership
17:09:50 <mugsie> ok - we are running on a low amount of cores right now, and we need to increase the numbers
17:10:14 <mugsie> I was going to do it all in meeting, but as one of rthe cores is not here I am going to send a mail to the -ml
17:10:30 <mugsie> but I would like to nominate elarson as our 4th
17:10:55 <mugsie> http://graham.hayes.ie/listings/designate-reviewstats.txt shows he has been an active reviewer, and the quality has been very good
17:11:04 <mugsie> #link http://graham.hayes.ie/listings/designate-reviewstats.txt
17:11:09 <Kiall> ++ good reviews, sane code, but.. drives the wrong kinda fan
17:11:10 <mugsie> elarson: you ok with that?
17:11:11 <Kiall> van*
17:11:12 * elarson would love to be a core :)
17:11:19 <mugsie> cool
17:11:31 <mugsie> #action mugsie sent core nominiation to the -ml
17:11:49 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:11:55 <mugsie> mlavalle: around?
17:11:56 <mlavalle> hi there
17:12:01 <mugsie> hello :)
17:12:32 <mlavalle> over the past few days I added dns integration support to the neutron client: https://review.openstack.org/#/c/282588/
17:13:03 <mlavalle> I am attending the Neutron mid-cycle, so I have a lot of cores around me. We should merge this patchset this week
17:13:16 <mugsie> sweet
17:13:51 <mlavalle> and I continue responding to reviews to the networking guide chapter: https://review.openstack.org/#/c/280957/
17:13:55 <Kiall> Cool, now if only I could find the star button on the new gerrit UI to come back to this later this eve -_-
17:14:12 <mugsie> Kiall: use gertty
17:14:15 <mugsie> :D
17:14:18 <mlavalle> same thing.... we should merge it soon
17:14:51 <mlavalle> and that is all I have this week. We are getting to the end of this project :-)
17:14:53 <mugsie> great
17:15:00 <mugsie> it has been a long road
17:15:13 <mugsie> any questions?
17:15:31 <mugsie> OK then
17:15:32 <Kiall> going to be at aUSTIN SUMMIT?
17:15:38 <mlavalle> yes
17:15:38 <Kiall> (so I can buy uou a beer or 3 ;))
17:15:43 <Kiall> wow, I can't typo
17:15:46 <Kiall> type
17:15:48 <mlavalle> looking forward to it
17:15:56 <mlavalle> :-)
17:15:58 <mugsie> Kiall: you can definitly typo ;)
17:16:04 <Kiall> I'm going to shutup now.. lol
17:16:06 <mugsie> #topic sonuk: tempest plugin implementation
17:16:16 <mugsie> sonuk seems to be afk
17:16:22 <mugsie> but there is a review
17:16:42 <mugsie> #link https://review.openstack.org/#/c/283511/
17:17:04 <mugsie> can people review that - so we can let sonuk progress?
17:17:19 <mugsie> I would be lookig at pglass and ekarlso- mainly
17:17:29 <mugsie> I would like your input
17:17:30 <ekarlso-> ofc :)o
17:17:49 <pglass> sure
17:17:59 <mugsie> #topic pglass: tempest-lib being integrated back into tempest
17:18:08 <mugsie> #link http://specs.openstack.org/openstack/qa-specs/specs/tempest/reintegrate-tempest-lib.html
17:18:15 <mugsie> pglass: you have the floor :)
17:18:17 <Kiall> LOL. Really?
17:18:34 <pglass> they went through and -2'd all the reviews to tempest-lib today
17:18:41 <Kiall> (facepalm)
17:18:59 <Kiall> (all the work of moving to it, now back .. oh well)
17:18:59 <pglass> there's nothing immediate we have to do, because the pypi packages will stay there
17:19:07 <pglass> mostly just for awareness
17:19:32 <mugsie> cool. so new features will be landing in tempest.lib from now on?
17:19:49 <pglass> yeah
17:19:55 <pglass> and if we're moving those functional tests over to a tempest plugin, then eventually we'll stop using tempest-lib anyway
17:20:15 <mugsie> OK.
17:20:32 <mugsie> i feel like this should have been more of a cross project thing, but I may have missed it
17:20:42 * mugsie will look in his email
17:20:59 <pglass> i only found out from the email notification from a -2
17:21:03 <pglass> on a tempest-lib review
17:21:10 <mugsie> nice
17:21:24 <mugsie> #topic Open Discussion
17:21:32 <mugsie> any off agenda items?
17:22:01 <mugsie> going once
17:22:05 <mpbnka> I would like to have this reviewed https://blueprints.launchpad.net/designate/+spec/different-format-for-ipv4-and-ipv6
17:22:05 <Kiall> None from me
17:22:23 <mpbnka> I have spec defined for this
17:22:38 <mpbnka> https://review.openstack.org/#/c/278999/
17:23:35 <mugsie> OK, I can review this week
17:23:58 <elarson> fwiw, I looked at that but wasn't sure the status of the sink.
17:24:10 <mugsie> for this cycle unchanged
17:24:23 <mpbnka> I would like to target this in m3
17:24:26 <mugsie> we my see if there is a change in newton
17:24:54 <mugsie> ok
17:24:58 <mpbnka> the change I suggest are only in designate.conf and sink code
17:24:59 <mugsie> then we need to revie asap
17:25:18 <mugsie> I may be able to grant a FFE for this as well, if needed
17:25:48 <mugsie> can everyone have a look today / tomorrow?
17:25:56 <Kiall> Sure
17:26:07 <mugsie> ok, anything else?
17:26:19 <mpbnka> thanks
17:26:46 <mugsie> OK - thanks everyone!
17:26:50 <mugsie> #endmeeting