17:07:31 <timsim> #startmeeting Designate
17:07:32 <openstack> Meeting started Wed Mar  2 17:07:31 2016 UTC and is due to finish in 60 minutes.  The chair is timsim. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:07:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:36 <openstack> The meeting name has been set to 'designate'
17:07:52 <timsim> Hello! Who's here?
17:07:56 <rsyed> o/
17:08:07 <elarson> o/
17:08:15 <pglass> o/
17:08:24 <venkat> o/
17:08:45 <Kiall> kinda, stuck on a call.. expect little more than a drive by comment or two from me ;)
17:08:51 <timsim> ping ekarlso- federico3
17:09:15 <Kiall> ekarlso is on paternity leave :)
17:09:21 <timsim> awww
17:09:23 <timsim> babies
17:09:23 <elarson> ah!
17:09:26 <elarson> cool
17:09:26 <timsim> #topic Announcements
17:09:53 <timsim> Besides ekarlso-'s fatherhood, any other announcements?
17:10:05 <timsim> Probably not
17:10:09 <timsim> #topic Action Items from last week
17:10:34 <timsim> kiall to BP 0022fd8 Ensure ZoneManager emits valid objects
17:10:41 <timsim> mugsie bp 24c957b
17:10:45 <timsim> mugsie to look at bug/1546437
17:10:59 <timsim> #action mugsie to look at bug/1546437
17:10:59 <federico3> hi
17:11:02 <timsim> p sure that didn't happen
17:11:27 <elarson> timsim: yeah no backports it seems
17:11:37 * elarson making sure he read the dashboard correctly
17:11:47 <timsim> emits objects went to liberty.
17:11:55 <timsim> I'll just reaction them for next week :P
17:12:04 <elarson> :coolio:
17:12:05 <timsim> federico3 bp b79cb7b Update Bind 9 backend and other documentation
17:12:15 <timsim> That's up right federico3 ?
17:12:17 <timsim> Or merged
17:12:30 <timsim> #action mugsie sent core nominiation to the -ml
17:12:35 <timsim> I didn't see that come by ^
17:12:52 <Kiall> I think he forgot
17:13:09 <Kiall> but only your vote was missing tim.. so can just wrap it up with your vote right now ;)
17:13:12 <federico3> that should be out
17:13:23 <federico3> I'll chase it
17:13:25 <timsim> Kiall: Alright, I'll hit that on the topic.
17:13:33 <timsim> Alright.
17:13:41 <timsim> #action mugsie bp 24c957b
17:13:52 <timsim> Moving on
17:14:02 <timsim> #topic Bug Triage
17:14:12 <timsim> https://bugs.launchpad.net/designate/+bug/1549960
17:14:13 <openstack> Launchpad bug 1549960 in Designate "Add memcached documentation" [Undecided,New] - Assigned to Federico Ceratto (federico-ceratto)
17:14:56 <timsim> m3 is pretty much right now
17:15:11 <timsim> I guess I'll assign it there anyway
17:15:23 <timsim> m - m3 unless anyone objects
17:15:36 <elarson> seems doable (not knowing the end of m3 or federico3's work load ;) )
17:16:00 <timsim> https://bugs.launchpad.net/designate/+bug/1551836
17:16:01 <openstack> Launchpad bug 1551836 in OpenStack Compute (nova) "CORS middleware's latent configuration options need to change" [High,In progress] - Assigned to Michael (krotscheck)
17:16:01 <federico3> m3 should do
17:16:33 <timsim> I think I'm just going to let that one mellow for a bit
17:16:45 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1550532
17:16:46 <openstack> Launchpad bug 1550532 in python-designateclient "V2 zone import/export are not implemented" [Undecided,New]
17:16:50 <krotscheck> Okies
17:17:08 <timsim> This seems like a pretty big deal ^ Kiall
17:17:34 <Kiall> timsim: whoops, we should do that one soon
17:17:45 <timsim> It looks like the work was started but not finished, I'm going Critical
17:17:49 * elarson wonders if rsyed might be able to do it?
17:17:50 <Kiall> client can ship on it's own schedule, we should do a full review of APIs to CLIs
17:17:58 <rsyed> elarson i was wondering the same thing
17:18:08 * rsyed was poking around
17:18:12 <timsim> Congrats rsyed it's all yours
17:18:15 <rsyed> yay
17:18:16 <elarson> badoosh!!!!
17:19:06 <timsim> That's it
17:19:08 <timsim> #topic Stable Backport Triage
17:19:28 * timsim is trying to get the things
17:19:31 <Kiall> Still on that call, could you gather the list real quick timsim?
17:19:31 <Kiall> thanks
17:20:18 <timsim> http://paste.openstack.org/show/489014/
17:20:27 <timsim> Take a look and nominate any BPs
17:20:36 <timsim> d5d0706 Improve error handling for TCP connections
17:20:37 <timsim> obvi
17:20:44 <timsim> b89a05e Ensure the zone records quota is enforced
17:21:05 <rsyed> i believe federico3 took care of d5d0706 Improve error handling for TCP connections
17:21:21 <rsyed> https://review.openstack.org/#/c/286555/
17:21:21 * elarson was just goign to mention that one
17:21:22 <Kiall> ++ on both of those, I BP'd the TCP oneto L and K - pending reviews
17:21:28 <rsyed> https://review.openstack.org/#/c/286557/
17:22:02 <elarson> those are the only two that seem necessary IMO
17:22:06 <federico3> the CRs are still not merged
17:22:39 <timsim> cool. I'm sure we'll get them in very soon.
17:22:48 <timsim> Anyone want to volunteer for b89a05e Ensure the zone records quota is enforced
17:22:56 <elarson> +1
17:22:59 <timsim> Volunteer or you'll be voluntold
17:23:01 <timsim> Thanks elarson
17:23:15 <timsim> #action elarson to bp b89a05e Ensure the zone records quota is enforced
17:23:41 <timsim> #topic Core Membership
17:23:57 <timsim> Ok, I was the only one absent last week to vote for elarson's coreness.
17:24:03 <timsim> Obviously I +1
17:24:16 <elarson> thanks timsim :)
17:24:39 <timsim> I don't know who actually has the powers to make that happen, but I'm sure we'll get it done soon. It might just be mugsie
17:24:57 <timsim> #action mugsie / someone to give elarson +2 powers
17:25:05 <timsim> # topic Designate/Neutron Integration Update (mlavalle - recurring)
17:25:15 <timsim> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:25:15 <mlavalle> timsim: hi
17:25:21 <timsim> hi mlavalle :)
17:25:57 <mlavalle> timsim: last week we merged the dns integration support for the Neutron client: https://review.openstack.org/#/c/282588/
17:26:39 <mlavalle> I have continued working in the DNS integration chapter to the Networking Guide: https://review.openstack.org/#/c/280957/
17:26:53 <timsim> Cool!
17:27:10 <mlavalle> I am getting reviews and I think we will merge it soon. so, all in all, in good shape
17:27:25 <mlavalle> that is where we stand this week
17:27:37 <timsim> Good stuff. Thanks mlavalle
17:27:44 <mlavalle> :-)
17:27:56 <timsim> I think the other bits on the agenda have been discussed already...
17:28:00 <timsim> #topic Open Discussion
17:28:08 <timsim> Anyone have anything they'd like to discuss?
17:28:25 <elarson> https://review.openstack.org/#/c/283855/ would be helpful
17:28:29 <elarson> to review
17:28:53 <elarson> it would make testing ALIAS changes easier to rebase
17:28:56 <elarson> fwiw
17:29:12 <timsim> Cool, will do.
17:29:23 <federico3> also,  https://bugs.launchpad.net/designate/+bug/1436210
17:29:25 <openstack> Launchpad bug 1436210 in Designate "Multiple serial update notifications are not buffered " [High,In progress] - Assigned to Federico Ceratto (federico-ceratto)
17:29:31 <Kiall> I'll have a look tomorrow too..
17:29:33 <rsyed> i haven't looked through https://review.openstack.org/#/c/283784/ yet but need to dig into it!
17:29:54 <timsim> I'd love it if some more folks reviewed https://review.openstack.org/#/c/283784/ (WIP Worker Model)
17:30:10 <elarson> yeah, timsim and I had a pretty epic thread ;)
17:30:14 <timsim> Some of the rax folks have gone around on it a bit, would love more eyes.
17:30:17 <timsim> Yep :)
17:30:47 <timsim> It's not as big as it looks, it's really only 500-600 lines.
17:31:24 <timsim> Anything else?
17:32:28 <timsim> Going once
17:32:33 <timsim> twice
17:32:42 <timsim> #endmeeting