17:00:26 <mugsie> #startmeeting Designate
17:00:27 <openstack> Meeting started Wed Mar  9 17:00:26 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:30 <openstack> The meeting name has been set to 'designate'
17:00:31 <mugsie> #topic Roll Call
17:00:42 <Kiall> o/
17:00:43 <timsim> o/
17:00:47 <pglbutt> o/
17:00:53 <federico3> o/
17:01:09 <mugsie> courtesy ping: Kiall federico3 ekarlso- timsim sonuk elarson pglbutt
17:01:37 <federico3> courtesy pong
17:01:55 <Kiall> ICMP Prohibited ;)
17:01:55 <mugsie> #topic Action Items
17:01:59 <mugsie> mugsie to look at bug/1546437
17:02:24 <elarson> o/
17:02:29 <mlavalle> o/
17:02:33 <mugsie> done
17:02:40 <mugsie> mugsie sent core nominiation to the -ml
17:02:42 <mugsie> done
17:02:47 <mugsie> mugsie bp 24c957b
17:02:52 <mugsie> #action mugsie bp 24c957b
17:02:59 <mugsie> elarson to bp b89a05e Ensure the zone records quota is enforced
17:03:04 <mugsie> done - i think?
17:03:07 <elarson> done!
17:03:13 <mugsie> mugsie / someone to give elarson +2 powers
17:03:15 <mugsie> done :)
17:03:31 <mugsie> all hail elarson - the new +2/-2 holder :)
17:03:36 <rsyed> o/
17:03:38 <elarson> :)
17:03:48 <mugsie> #topic Bug Triage (timsim - recurring)
17:03:57 <mugsie> timsim: over to you
17:04:25 <timsim> https://bugs.launchpad.net/designate/+bug/1546437
17:04:25 <openstack> Launchpad bug 1546437 in Designate "Unable to restart the keystone services" [Undecided,New] - Assigned to Graham Hayes (grahamhayes)
17:04:28 <timsim> Probably needs a status update
17:04:52 <mugsie> yeah - will do that now
17:05:03 <timsim> cool
17:05:13 <timsim> https://bugs.launchpad.net/designate/+bug/1554130
17:05:13 <openstack> Launchpad bug 1554130 in Designate "Zone imports are incredibly slow" [Undecided,New]
17:05:43 <timsim> Seems pretty important to me.
17:05:49 <mugsie> yeah.
17:06:03 <mugsie> H - RC1
17:06:07 <Kiall> Slow sucks, but not it's not exactly a regression..
17:06:14 <Kiall> but it's not*
17:06:30 <mugsie> i did think it was faster
17:06:31 <timsim> It used to be wayyyy faster
17:06:44 <Kiall> Did it? Fair enough then!
17:06:46 <elarson> timsim: do we know when it changed?
17:06:47 <timsim> 400-500 record zones were done in seconds.
17:06:51 <timsim> elarson: nope
17:06:56 <elarson> bummer
17:06:57 <timsim> I don't think it was very recent
17:07:05 <timsim> I'm going to assign to myself
17:07:10 <mugsie> OK. We need to try and track down roughly when it got soo bad
17:07:13 <elarson> sounds like a good reason to learn git bisect :)
17:07:19 <timsim> https://bugs.launchpad.net/designate/+bug/1555063
17:07:19 <openstack> Launchpad bug 1555063 in Designate "Delayed deletion of records" [Undecided,New]
17:07:19 <mugsie> cool - thanks timsim
17:07:50 <Kiall> I think this is a bug.. But  I've been disagreed with last time I chatted with mugsie about it ;)
17:08:12 <Kiall> V1 API needs to filter out "PENDING DELETE"
17:08:24 <timsim> But what if it doesn't delete?
17:08:30 <mugsie> I do not have that strong feelings about it, but I prefer to show it
17:08:48 <mugsie> if someone deletes a record, then trys to recreate it, they will get a conflict
17:08:48 <Kiall> That's the argument he had :) filter PENDING DELETE, but not ERROR DELETE?
17:08:50 <timsim> I guess it should go to error/delte eh
17:08:59 <Kiall> It's "reappear" and cause someone to go asking?
17:09:04 <Kiall> It would*
17:09:39 <mugsie> I suppose it is along the line of managed records....
17:09:46 <mugsie> why did we not have a status in the v1 api
17:09:48 <mugsie> -_-
17:10:08 <timsim> Anyway
17:10:19 <mugsie> we can add the filter if needs be. I just don't like messing with the v1 api at all these days
17:10:19 <Kiall> Because we didn't!.. SO, is it something we can fix by filtering?
17:10:23 <Kiall> If so, H RC1
17:10:49 <mugsie> this would then have to be backported to Kilo before we release Mitaka
17:10:54 <timsim> Yeah, it's probably a really small fix.
17:10:57 <mugsie> as Kilo will be EOL'd then
17:11:37 <mugsie> OK, sure v1 will go bye bye soon, right? :P - Med - RC
17:11:43 <timsim> Alright
17:11:44 <mugsie> and mark it for Liberty + Kilo
17:12:01 <timsim> https://bugs.launchpad.net/designate/+bug/1554476
17:12:01 <openstack> Launchpad bug 1554476 in Designate "Designate CLI - No message on deletion or listing" [Undecided,New] - Assigned to Preeti (pandey-preeti1)
17:12:13 <mugsie> duplicate
17:12:17 <Kiall> I think there's reviews up for that one?
17:12:19 <mugsie> let me dig out the client one
17:12:53 <mugsie> https://bugs.launchpad.net/python-designateclient/+bug/1323294
17:12:53 <openstack> Launchpad bug 1323294 in python-designateclient "CLI does not give any mesage on successful deletes" [Wishlist,In progress] - Assigned to sonu (sonu-bhumca11)
17:13:33 <mugsie> mark as duplicate, and link to ^ ?
17:13:37 <Kiall> Yah
17:13:40 <timsim> k
17:13:49 <timsim> That's it :)
17:14:11 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:14:19 <Kiall> #link http://paste.openstack.org/show/489885/
17:14:33 <Kiall> Not that many thius week, I'm wondering if I messed up somehow? lol
17:14:40 <mugsie> bb10715 Merge "Fix for TCP connections not sending full content"
17:14:47 <Kiall> +500
17:14:58 <federico3> +infinity
17:14:59 <elarson> +1
17:15:01 <mugsie> i can do that today
17:15:16 <mugsie> #action mugsie backport bb10715 Merge "Fix for TCP connections not sending full content"
17:15:36 <mugsie> #topic Designate/Neutron Integration Update (mlavalle - recurring)
17:15:39 <mugsie> mlavalle: around?
17:15:45 <mlavalle> mugsie: hi
17:16:20 <mlavalle> I have continued working on the chapter for the Networking guide
17:16:36 <mugsie> yeah - just one more +2 needed  :)
17:16:41 <mlavalle> Yesterday we got a +2 from one of the docs core reviewers
17:16:58 <mlavalle> and armax, the Neutron PTL, gave us a +1
17:17:06 <mlavalle> so it should merge any time now
17:17:14 <mugsie> cool
17:17:19 <mugsie> nearly there :)
17:17:23 <mugsie> any questions?
17:17:26 <mlavalle> Almost there
17:17:40 <Kiall> Cool, Neutron - Check, Nova - Check, Neutron Client - Check, Docs - 90% :)
17:18:05 <mugsie> our intergration with neutron will have better docs than designate itself -_-
17:18:11 <mugsie> :)
17:18:13 <mlavalle> LOL
17:18:20 <mugsie> OK - thanks mlavalle !
17:18:26 <mlavalle> and btw, our presentation for the summit got approved
17:18:32 <mlavalle> yay!
17:18:40 <Kiall> :)
17:18:52 <mugsie> #topic sonuk: tempest plugin implementation
17:19:02 <mugsie> sonuk seems to be afk
17:19:11 <mugsie> #topic FFEs
17:19:24 <mugsie> I am looking at what can land before RC
17:19:33 <mugsie> (feature wise)
17:19:37 <mugsie> and I have this list:
17:19:46 <mugsie> Pools (Config + Scheduler)
17:19:51 <mugsie> ALIAS
17:20:03 <mugsie> Service Status (maybe)
17:20:13 <mugsie> any objections, or additions?
17:20:26 <mugsie> it needs to land this week if it is going to be in Mitaka
17:20:42 <mugsie> elarson: do you think you can get ALIAS in in time?
17:20:57 <timsim> I'm not sure that's enough testing time for alias
17:21:01 <elarson> mugsie: not sure, we're working towards a release and I'm going to have to refactor some tests
17:21:10 <elarson> so it doesn't look like
17:21:14 <elarson> like it*
17:21:17 <mugsie> OK.
17:21:26 <Kiall> .. yea, we have a feature complete deadline in a few hours for our next release too ;)
17:22:02 <mugsie> so, our FFEs are Pools Additions, + Service Status (maybe)
17:22:19 <mugsie> everyone ok with them?
17:22:30 <Kiall> yah.
17:22:37 <mugsie> timsim: elarson ?
17:22:38 * timsim doesn't know what an ffe is, but yeah
17:22:41 <mugsie> sorry
17:22:42 <timsim> :P
17:22:48 <mugsie> Feature Freeze Exception
17:22:59 <timsim> Flat Face Excitement
17:22:59 <timsim> ok
17:23:09 <timsim> Sounds like fun!
17:23:21 <mugsie> Feature Freeze was last week for mitaka :)
17:23:52 <rsyed> would zone import/export support in designate-client be a candidate for FFE?  how critical is it
17:24:12 <elarson> +1
17:24:25 <mugsie> The client is frozen, as we cannot do a release of it right now.
17:24:27 <Kiall> the client has a different release schedule, we can add stuff there anytime we like
17:24:34 <rsyed> gotcha, thanks for the clarification
17:24:44 <mugsie> it will have to wait utill the stable/mitaka branch is cut
17:24:53 <mugsie> and the library freeze is removceed
17:25:04 <mugsie> but we can cut a new one really quick after that
17:25:11 <rsyed> excellent!
17:25:15 <Kiall> yea, but it doesn't need to wait for the next 6 month release :)
17:25:16 <mugsie> so it will be aroundf the mitaka release data
17:25:31 <mugsie> OK, any other questions?
17:25:51 <mugsie> #topic Open Discussion
17:26:01 <mugsie> any off agenda items?
17:26:24 <Kiall> None from me..
17:26:48 <timsim> plz review worker model :|
17:27:34 <Kiall> Sorry, it's been a hellish few weeks for me free time wise! It being a post-Mitaka thing, it's just not got anywhere high enough on my list :(
17:27:39 <mugsie> Yup - once we get the stuff in for mitaka - will be all ove that.
17:28:20 <mugsie> anything else?
17:28:32 <mugsie> going once
17:28:35 <mugsie> twice
17:28:41 <mugsie> gone
17:28:44 <Kiall> cya :)
17:28:46 <mugsie> #endmeeting