16:59:21 <mugsie> #startmeeting Designate
16:59:21 <openstack> Meeting started Wed Apr 13 16:59:21 2016 UTC and is due to finish in 60 minutes. The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:24 <openstack> The meeting name has been set to 'designate'
16:59:29 <mugsie> #topic Roll Call
16:59:44 <pglass> o/
17:00:08 <sonuk_> o/
17:00:08 <james_li> james li
17:00:08 <rsyed> o/
17:00:26 <mugsie> timsim: elarson Kiall ekarlso ping
17:00:54 <Kiall> o/
17:02:04 <mugsie> OK, we should get started :)
17:02:14 <mugsie> #topic Action Items from last week
17:02:29 <mugsie> there was none :)
17:02:56 <mugsie> #topic Bug Triage (timsim - recurring)
17:03:07 <mugsie> I think timsim is afk
17:03:29 <mugsie> so, no bugs to triage
17:03:31 <Kiall> lol
17:03:41 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:03:44 <Kiall> #link http://paste.openstack.org/show/493969/
17:03:54 <timsim> o/
17:04:06 <Kiall> 2 weeks of BPs to eyeball, as usual, take a few mins and nominate anything in need of backporting
17:04:13 <Kiall> timsim: you're late ;)
17:04:26 <rsyed> 5104e6e Merge "Give proper ERROR for too large exports" ?
17:04:38 <timsim> :P
17:04:55 <Kiall> 979b67d Partitoner references invalid exception class <-- Already done I think
17:05:17 <Kiall> (ignore the first 2 - those are my WIP's ;))
17:05:30 <Kiall> 909cc5d Handle async Tooz calls appropriately
17:05:32 <mugsie> :)
17:05:54 <mugsie> ab1639c Give better error messages for zone imports
17:06:18 <mugsie> I need to look at teh 2 Error ones to make sure we dont violate the stable backport rules
17:06:27 <rsyed> ah
17:06:29 <mugsie> but those 3 look like candidates
17:06:35 <Kiall> Any others we need to handle?
17:06:37 <pglass> yeah, i don't know what we're allowed to backport or not
17:06:42 <pglass> w.r.t stability
17:06:59 <mugsie> only bugs, and no api changes
17:07:13 <timsim> I think the first one would be good, second one "makes things better" so probably not.
17:07:19 <Kiall> well - if the bug is an API explodes rather than shows an error - that's a candiate IMO
17:07:30 <mugsie> #link http://docs.openstack.org/project-team-guide/stable-branches.html#appropriate-fixes
17:07:48 <timsim> 5104e6e Merge "Give proper ERROR for too large exports" just makes it not stay in PENDING forever
17:08:13 <timsim> ab1639c Give better error messages for zone imports - gives better error messages than "an undefined error occured"
17:08:36 <mugsie> OK. I will ask about those 2 and do them if they are allowed
17:09:03 <mugsie> #action mugsie investiagte if 5104e6e and ab1639c are acceptable
17:09:12 <elarson> o/
17:09:13 <mugsie> who wants to backport ab1639c ?
17:09:28 <Kiall> you just #action'd yourself ;)
17:09:39 <mugsie> bah
17:09:40 <mugsie> 909cc5d
17:10:05 <Kiall> I can do it.. you checked into the new lib issue already, so should be a simple cherry pick
17:10:16 <mugsie> grand
17:10:21 <mugsie> #action Kiall backport 909cc5d
17:10:30 <mugsie> #topic Open Discussion
17:10:42 <mugsie> so, the agenda is now live for the summiyt
17:11:12 <elarson> ah cool
17:11:19 * elarson checks when he workshop is
17:11:23 <timsim> woo
17:11:31 <mugsie> and, if the webapp would work I would link to it
17:11:38 <mugsie> #link https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=Designate%3A
17:11:54 <Kiall> Cool
17:12:00 <Kiall> App wont load for me tho ;)
17:12:06 <mugsie> this does not bode well
17:12:27 <mugsie> any other topics?
17:12:35 <Kiall> Tempest plugin stuff
17:12:49 <mugsie> Kiall: sure - go for it
17:12:54 <Kiall> So - there are new experimental jobs running the new plugin the "right way" - they don't run the old tests at all
17:13:05 <Kiall> http://logs.openstack.org/04/305104/4/experimental/gate-tempest-dsvm-designate-powerdns/72feace/ is example output
17:13:11 <Kiall> logs/testr_results.html.gz - is likely the most interesting770098
17:13:37 <elarson> Kiall: is that the experimental bit you've been commenting on in CRs?
17:13:56 <Kiall> for now, you can run with a "check experimental" comment.. But as it gets to a point where there are more tests moved in it, we'll want to make it run for everything
17:14:04 <Kiall> and finally, when all tests are moved - remove the old jobs.
17:14:28 <Kiall> #link https://etherpad.openstack.org/p/designate-tempest-plugin-migration has a list of the main areas in the old tests
17:14:44 <Kiall> and if there's a name beside it, it's because someone is activly working to port the tests.
17:15:10 <Kiall> Some docs @ http://docs.openstack.org/developer/designate/tempest.html
17:15:16 <Kiall> elarson: yes, that's exactly what it is
17:15:55 <Kiall> Anyway, consider it a heads up as you'll notice things changing over the week or two - any if anyone wants to help get tests moved, go for it :)
17:16:02 <Kiall> Any questions?
17:16:32 <elarson> sounds good!
17:16:38 <mugsie> why haven't you ported it all alrieady? :P
17:16:51 <Kiall> Been working through the framework pieces ;)
17:17:00 <pglass> i was actually waiting to work on those because i thought Kiall might have done it all already
17:17:03 <Kiall> sonuk_'s got some reviews up for a few groups of tests :)
17:17:34 <mugsie> :)
17:17:49 <mugsie> oh - the OpenStack User Survey is out - http://www.openstack.org/assets/survey/April-2016-User-Survey-Report.pdf
17:17:59 <Kiall> Also - docs are being updated - https://review.openstack.org/#/c/305144/
17:18:13 <Kiall> That contains some important info around where tests should land and what should be tested etc
17:18:27 <Kiall> So - Read after that lands and is published ;)
17:18:44 <elarson> someone might have mentioned this already but is the dev guide updated with the pools.yml info?
17:19:20 <mugsie> kinda
17:19:22 <mugsie> #link http://docs.openstack.org/developer/designate/upgrade/mitaka.html
17:19:32 <mugsie> and
17:19:34 <mugsie> #link http://docs.openstack.org/developer/designate/pools.html
17:19:44 <Kiall> docs.openstack.org/developer/designate/pools.html and the backends section includes details
17:20:28 * elarson might try to update that when going through the workshop install this afternon
17:20:31 <elarson> afternoon
17:20:38 <mugsie> elarson: please do :)
17:20:47 <rsyed> i've found it very useful so far, been messing with multiple pools and the pool_id_attribute filter (eventually i'd be interested in use of the attribute filter)
17:20:58 <mugsie> rsyed: yeah, I need to write that
17:22:36 <mugsie> OK, does anyone have anything else?
17:22:47 <Kiall> Not from me
17:23:02 <timsim> Aww jeeze mugsie we'e got to build the packer image from the austin branch, yeah?
17:23:19 <Kiall> lol (facefalm-gif-here)
17:23:23 <Kiall> facepalm*
17:23:24 <mugsie> timsim: yeah. but that needs you and elarson to upload your bits :)
17:23:43 * timsim just spent 30 minutes building from master like a doof
17:23:46 <mugsie> also, delete the old box
17:23:48 <timsim> good thing it's lunchtime
17:23:51 <timsim> yeah
17:24:09 <mugsie> OK then
17:24:12 <mugsie> #endmeeting