17:05:29 <timsim> #startmeeting designate
17:05:30 <Kiall> timsim: can you do that honours?
17:05:30 <openstack> Meeting started Wed Jun 15 17:05:29 2016 UTC and is due to finish in 60 minutes.  The chair is timsim. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:34 <openstack> The meeting name has been set to 'designate'
17:05:43 <timsim> #topic Annoucements
17:05:49 <timsim> anyone have any announcements?
17:06:49 <timsim> I'm guessing not
17:06:52 <timsim> #topic Action Items from last week
17:07:23 <timsim> mugsie 8ea6e36 Merge "Catch all exceptions in PM's call to get_pool()"
17:08:04 <Kiall> I didn't see that one, I'm guessing punt to next week.
17:08:15 <timsim> looks like that happened? https://github.com/openstack/designate/commit/8ea6e36850fe70a7950a6c6549b226ac46f95ed4
17:08:24 <elarson> o/
17:08:47 <Kiall> Ah :)
17:08:52 <timsim> mugsie list missing / incorrect docs
17:09:01 <mugsie> done
17:09:03 <timsim> #link https://bugs.launchpad.net/designate/+bug/1590937
17:09:03 <openstack> Launchpad bug 1590937 in Designate "Docs - Areas needing improvement" [Undecided,New]
17:09:04 <mugsie> bug fied
17:09:07 <timsim> eyyy mugsie
17:09:07 <mugsie> filed*
17:09:15 * mugsie is still on customer call
17:09:33 <timsim> #topic Bug Triage (timsim - recurring)
17:09:51 <timsim> https://bugs.launchpad.net/designate/+bug/1579844
17:09:52 <openstack> Launchpad bug 1579844 in OpenStack Search (Searchlight) "Designate created_at mapping parser exception" [Critical,New] - Assigned to Steve McLellan (sjmc7)
17:10:39 <timsim> neato
17:10:40 <Kiall> mugsie is working on that
17:10:51 * timsim changes to triaged
17:10:59 <Kiall> Our timestamp formatting in the API changed -_-
17:11:05 <timsim> https://bugs.launchpad.net/designate/+bug/1590937
17:11:05 <openstack> Launchpad bug 1590937 in Designate "Docs - Areas needing improvement" [Undecided,New]
17:11:23 <timsim> n2 or n3?
17:11:30 <Kiall> Feels like it should be split into a bug on each item for people to grab
17:11:31 <timsim> high?
17:11:42 <timsim> I think he wanted to do a "docs day"
17:11:51 <timsim> Then maybe if we don't finish all the things then we can do that?
17:11:59 <Kiall> Makes sense :)
17:12:14 <Kiall> Yea, let's call it n2 then I guess
17:12:35 <timsim> Alright
17:12:37 <timsim> https://bugs.launchpad.net/designate/+bug/1592462
17:12:37 <openstack> Launchpad bug 1592462 in Designate " Add "project-id" to rrset API output" [Undecided,New]
17:12:42 <timsim> "fix committed"?
17:12:49 <Kiall> Yea, and n2
17:12:55 <timsim> cool
17:13:05 <timsim> Stable Backport Triage (kiall - recurring)
17:13:09 <timsim> Need me to grab that Kiall ?
17:13:22 <Kiall> Yea, cell phone is hard enough already -_-
17:13:25 <timsim> k
17:13:34 <timsim> http://paste.openstack.org/show/516318/
17:13:53 <timsim> go through and nominate things for bp
17:13:54 <timsim> 60816df Merge "Ensure HTTP 204 responses have 0 Content-Length"
17:14:22 <timsim> I think that's it?
17:14:44 <mugsie> 765039f Merge "Only load Suds when using Akamai backend"
17:15:09 <elarson> if we don't have a bug report for the 204 then I'd skip it
17:15:15 <timsim> We do
17:15:18 <Kiall> Yea, just 204
17:15:21 <elarson> then +1 !
17:15:35 <timsim> Alright I'll do that one
17:15:40 <Kiall> Suds isn't critical, just clears a warning for folks.
17:15:56 <timsim> Alright, if mugsie feels differently he can do the bp
17:16:01 <timsim> #action timsim to bp the 204 fix
17:16:19 <timsim> #topic Midcycle
17:16:44 <timsim> Looks like this was postponed last week
17:16:51 <elarson> it was
17:16:55 <timsim> Now mugsie is semi-here
17:17:01 <mugsie> i can follow
17:17:07 <mugsie> and add suggestions
17:17:15 <mugsie> but, virtual looks mostv likely
17:17:17 <timsim> I think we're leaning toward a virtual mid-cycle? As it's unlikely everyone will be able to get to one place?
17:17:19 <timsim> yeah
17:17:33 <mugsie> I am not sure I can even get funding for me at this point
17:17:56 <elarson> was there anyone else that wanted to come that would travel?
17:18:12 <mugsie> good questtion elarson
17:18:23 <timsim> Maybe send something to the ML mugsie?
17:18:28 <mugsie> yeah
17:18:31 <mugsie> if we do virtual
17:18:35 <timsim> So I suppose we can go forward with that tenative (but probable) and work out the details of a virtual cycle in the coming weeks.
17:18:49 <mugsie> when do we want to do it?
17:19:06 <elarson> if it is virtual we'd need to make an effort to coordinate over time zones for folks
17:19:47 <timsim> Probably august?
17:19:52 <mugsie> yeah.
17:20:05 <mugsie> and I would imagine it would be later EU / Earlier US time?
17:20:11 <mugsie> unless that rules out anyone
17:20:36 <timsim> Probably, we can get our arses out of bed earlier so that we can start at a reasonable EU time
17:20:57 <Kiall> Lol, or you just stay up real late.
17:21:03 <mugsie> I we can stay a bit late, so it is not stupid early
17:21:33 <elarson> we could also spread it out to get more time
17:21:48 <timsim> Alright, so maybe we check schedules and stuff and come up with some preferred dates for next week?
17:22:11 <mugsie> yeah - I will send a ML email, with options
17:22:16 <mugsie> and time options as well
17:22:16 <elarson> ie 4 hours over 8 days vs. 8 over 4
17:22:17 <timsim> dope
17:22:37 <elarson> timsim: I say nope to dope
17:22:51 <timsim> #action mugsie to send ML email re: virtual midcycle + options
17:23:07 <timsim> #topic Open Discussion
17:23:32 <elarson> mugsie: thanks for taking a peak at the worker model review!
17:23:40 * timsim was just typing that
17:24:11 * timsim has a big addition to that patch coming soon
17:24:26 <timsim> Which addresses most of mugsie's feedback
17:24:29 <elarson> :badoosh:
17:24:53 <timsim> Does anyone have anything else they want to talk about?
17:25:03 <elarson> my feelings
17:25:32 <Kiall> Anything besides elarson's feelings?
17:25:42 <elarson> I feel good :)
17:25:59 <Kiall> Lol, well.. I'm good on topics toda.
17:26:04 <Kiall> Today*
17:26:10 <timsim> Alright then, going once...
17:26:21 <timsim> twice...
17:26:35 <timsim> #endmeeting