17:01:25 <timsim> #startmeeting designate
17:01:25 <openstack> Meeting started Wed Jun 22 17:01:25 2016 UTC and is due to finish in 60 minutes. The chair is timsim. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:28 <openstack> The meeting name has been set to 'designate'
17:01:41 <timsim> Hello folks, who's here?
17:01:47 <rsyed> o/
17:01:53 <sonuk_> o/
17:02:09 <timsim> elarson pglass rsyed james_li benji jmcbride
17:02:23 <timsim> Kiall, mugsie, and federico3 are unable to join us today
17:02:38 <timsim> But hopefully mugsie's watch just vibrated during his meeting
17:02:45 <timsim> #topic Annoucements
17:03:34 <timsim> I'm guessing nobody wants to announce anything
17:03:50 <timsim> #topic Action Items from last week
17:03:56 <timsim> I had a bp that I did
17:04:08 <timsim> #topic Bug Triage (timsim - recurring)
17:04:22 <timsim> https://bugs.launchpad.net/designate/+bug/1594951
17:04:22 <openstack> Launchpad bug 1594951 in Designate "No recordset notifications emitted for nameserver changes" [Undecided,New]
17:04:28 <timsim> Looks high n2 to me
17:04:52 <timsim> and that's it lolz
17:04:58 <timsim> Anyone think differently?
17:05:48 <pglass> no but i have a new bug
17:05:58 <pglass> which is the txt length limit of 255 is too small
17:06:25 <timsim> Did I miss that..
17:06:38 <pglass> well i didn't put anything in launchpad
17:06:41 <pglass> there is this: https://bugs.launchpad.net/designate/+bug/1474012
17:06:41 <openstack> Launchpad bug 1474012 in Designate "Incorrect length limit for TXT record data" [Medium,Fix committed] - Assigned to Federico Ceratto (federico-ceratto)
17:07:00 <pglass> but the fix is not really a fix
17:07:17 <pglass> it just ensures the that designate reject txt records over 255 chars
17:07:53 <timsim> Alright, can you file a new bug for that?
17:08:52 <elarson> pglass: the bug should probably mention the dB constraints
17:09:14 <pglass> there shouldn't be db constraints
17:09:18 <elarson> rsyed mentioned them the other day
17:09:25 <pglass> the record data is stored in a text type column
17:09:31 <pglass> which has arbitrary length
17:09:47 <rsyed> yeah elarson i was referring to a different datatype (varchar). didn't realize it was already type text
17:09:58 <elarson> Ah ok.
17:10:07 <elarson> Nvmd then!
17:10:21 <timsim> Alright, moving on
17:10:36 <timsim> #topic Stable Backport Triage
17:10:41 <timsim> #link http://paste.openstack.org/show/521241/
17:10:55 <timsim> Probably just a6d7ee9 Fix output of datetime objects in API ?
17:11:18 <timsim> That fixed something in this: https://github.com/openstack/designate/commit/7abae80c61f5c6779357c8bcf7e9dcaaa4ed20a3 so it'll need BP to mitaka I believe
17:11:34 <elarson> +1
17:12:21 <timsim> #action mugsie to bp a6d7ee9
17:12:27 <timsim> That's what he gets for not being here
17:12:33 <elarson> Nice
17:12:34 <timsim> (and it was his fix)
17:12:46 <timsim> #topic Open Discussion
17:12:52 <mpbnka> I have a bp https://blueprints.launchpad.net/designate/+spec/different-format-for-ipv4-and-ipv6 which needs a review
17:13:01 <mpbnka> https://review.openstack.org/#/c/322936/ is the spec
17:13:31 <elarson> mpbnka: I can take look
17:14:12 <mpbnka> I have added all four of you core members in it :)
17:14:37 <mpbnka> this will be my first bp so ...
17:14:52 <timsim> Cool! We'll take a look
17:14:55 <elarson> mpbnka: sorry I haven't taken a look yet. I've had other priorities.
17:15:12 <mpbnka> np i can understand
17:15:42 <elarson> I was going to bring up the midcycle, but with mugsie et la out, we can push it until later or at least in irc.
17:16:02 <timsim> Yeah for sure, there's some uncertainty there on our part anyway at the moment
17:16:22 <timsim> For the folks reading later, I proposed https://review.openstack.org/#/c/331853/ as a small change in the powerdns plugin I was running into testing with worker model, it seems so obvious that I must be doing something wrong, but it's a six line diff, take a look.
17:17:19 <timsim> Also, worker model is passing the bind9 gates now https://review.openstack.org/#/c/283784/, I think the lack of eventlet is causing problems in the powerdns plugin, that's why it's failing those gates.
17:17:36 <timsim> http://logs.openstack.org/84/283784/22/check/gate-tempest-dsvm-designate-powerdns/4a72e81/logs/screen-designate-worker.txt.gz if you're curious
17:17:51 <timsim> Does anyone have anything else they want to talk about?
17:18:01 <elarson> Not me
17:18:08 <timsim> Alright going once...
17:18:18 <timsim> twice..
17:19:01 <timsim> #endmeeting designate