17:01:37 <mugsie> #startmeeting Designate
17:01:38 <openstack> Meeting started Wed Jun 29 17:01:37 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:42 <openstack> The meeting name has been set to 'designate'
17:01:42 <mugsie> #topic Roll Call
17:01:59 <Kiall> o/ mugise over the partition, just now, "oh s***" ;)
17:02:08 <sonuk> o/
17:02:47 <timsim> o/
17:02:48 <mugsie> timsim: elarson pglass rsyed federico3 : courtesy ping
17:02:54 <federico3> pong
17:03:37 <mugsie> timsim: rest of RAX joining?
17:03:56 <timsim> Yeah they should be aroundish
17:04:04 <mugsie> 'ISH' :P
17:04:08 <mugsie> - caps
17:04:35 <mugsie> OK
17:04:41 <mugsie> #topic Announcements
17:04:48 <pglass> o/
17:05:10 <mugsie> n-2 is in 2 weeks
17:05:24 <mugsie> tahts all I have
17:05:32 <mugsie> anyone else have any announcements?
17:06:01 <mugsie> take that as no :)
17:06:10 <mugsie> #topcu Action Items
17:06:14 <mugsie> #topic Action Items
17:06:20 <mugsie> I see I got actioned
17:06:29 <mugsie> #action mugsie to bp a6d7ee9
17:06:38 <mugsie> thats is it
17:06:50 <mugsie> #topic bug triage
17:07:19 <timsim> https://bugs.launchpad.net/designate/+bug/1595265
17:07:19 <openstack> Launchpad bug 1595265 in Designate "TXT record data length limit is too short" [Undecided,New]
17:07:40 <Kiall> I think we already have a bug for that
17:07:44 <mugsie> its closed
17:07:50 <Kiall> No, a diff one
17:07:52 <Kiall> 1 sec
17:07:52 <mugsie> oh
17:08:32 <Kiall> https://bugs.launchpad.net/designate/+bug/1474012 is closed alright
17:08:32 <openstack> Launchpad bug 1474012 in Designate "Incorrect length limit for TXT record data" [Medium,Fix committed] - Assigned to Federico Ceratto (federico-ceratto)
17:09:03 <mugsie> I think this is more of a feature req ?
17:09:06 <federico3> since quite a while
17:09:08 <Kiall> So - I think it's a rather large change to make it work with longer than 255 chars
17:09:13 <mugsie> yeah
17:09:26 <timsim> Kiall: We don't use a varchar(255) col for it
17:09:29 <Kiall> Technically, we support only single part TXT recrods, where each part is at most 255 charas
17:09:31 <mugsie> as it will change who it is stored, and how we conncatinate it in mdns
17:09:55 <Kiall> anything more needs to be split in the DNS wire format response... but.. where do we split?
17:10:23 <Kiall> i.e. TXT is defined as an array of strings, each up to 255 chars long.
17:10:30 <Kiall> we don't have it modeled as an array
17:10:58 <timsim> So we'd have to split it every 255 into multiple records?
17:11:09 <timsim> oh i see
17:11:15 <mugsie> I dont think we can target this to a particular relase anyway
17:11:21 <mugsie> we can mark it as low ?
17:11:21 <Kiall> Not multiple records, just in the TXT's rdata
17:11:37 <mugsie> and if someone has cycles, propose a spec to show how we can fix it?
17:11:40 <Kiall> i.e. foo.com. IN TXT "255 chars" "255 chars" "255 chars"
17:11:40 <timsim> pglass what was the thing that made us run into this?
17:12:08 <pglass> uhh, it's not big enough for spf records or something
17:12:23 <Kiall> <sidenote>Use SPF inclides</sidenote>
17:12:26 <Kiall> includes*
17:12:40 <Kiall> We *may* be able to hard split on 255, or split on word boundaries, or something.. but I've no clue how valid that is
17:13:00 <mugsie> Kiall: can you dump ^ into the bug?
17:13:14 <mugsie> and say we will want a spec for any fix
17:13:16 <Kiall> <sidenode> SPF includes look like this.... _spf.google.com.	295	IN	TXT	"v=spf1 include:_netblocks.google.com include:_netblocks2.google.com include:_netblocks3.google.com ~all"</sidenote>
17:13:31 <timsim> Yeah looks like some research needs to be done, if it's an important thing for us we can pick it up and spec it out.
17:13:40 <mugsie> cool. triaged, low
17:13:42 <mugsie> imo
17:13:45 <pglass> yeah, we didn't have concrete examples when someone brought this up in one of our meetings
17:14:01 <timsim> Fair enough, works fo rme
17:14:07 <Kiall> notes dumped
17:14:18 <mugsie> ty
17:14:38 <timsim> That's all :)
17:14:42 <mugsie> cool
17:14:53 <mugsie> #topic Stable Backport Triage
17:14:56 <mugsie> Kiall:
17:14:58 <Kiall> 424ebf3 Catch duplicate db inserts in powerdns plugin
17:15:03 <Kiall> That's all.
17:15:24 <Kiall> (and our backport finding command is busted! It didn't even find that.. derp)
17:15:38 <mugsie> :/
17:15:39 <Kiall> Anyway,  yea.. That should be backported IMO
17:15:42 <mugsie> ++
17:15:46 <mugsie> timsim: ?
17:15:56 <mugsie> you vouleneer?
17:16:07 <Kiall> It's going based off the "commit date" which is the date the commit was first made, and doesn't change when amended, or merged etc
17:16:08 <timsim> Yeah fo sho. I thought I might have actioned myself to do that last week
17:16:26 <Kiall> #action kiall to figure out a better BP finding command ;)
17:16:47 <timsim> oh that was the http 204 thing
17:16:48 <timsim> ok
17:17:06 <mugsie> #topic Open Discussion
17:17:15 <mugsie> any off agenda topics?
17:17:16 <mpbnka> https://review.openstack.org/#/c/322936/2/specs/newton/naming-convention-for-records.rst
17:17:18 <mugsie> I have oine
17:17:26 <timsim> I have a couple
17:17:34 <mpbnka> changed this according to suggestion
17:18:09 <mugsie> OK - we still have the new "formatv4" option
17:18:17 <mpbnka> yes
17:18:29 <mpbnka> but will give support for both format and formatv4
17:18:30 <Kiall> mpbnka: based entirely on memory (which is often wrong), we do support multiple formats, but don't split on v4 vs v6, right?
17:18:32 <mugsie> we willneed to keep use the "format" or at least allow it to be used
17:18:39 <mugsie> yup
17:18:52 <mpbnka> yes
17:19:30 <mugsie> OK, I am ok with ^ then
17:19:40 <Kiall> I don't see any issues, so long as format_v4/v6 being unset causes it to .. ehh .. fallback to "fallback"
17:19:43 <Kiall> bah
17:19:48 <mugsie> anyone have objections ?
17:19:57 <Kiall> I don't see any issues, so long as format_v4/v6 being unset causes it to fallback to "format"
17:20:02 * Kiall minced his words
17:20:36 <mugsie> if not, can someone +A
17:20:37 <mugsie> ?
17:21:06 <mugsie> timsim: Kiall you have the power :P
17:21:10 <Kiall> Yea, I'll re-read before tho :) Unless tim etc get to it
17:21:27 <mugsie> OK mpbnka - do you have any more questions for us?
17:21:36 <timsim> it appears that I don't
17:21:40 <mpbnka> not for now :)
17:21:41 <Kiall> lol - really?
17:21:43 <mpbnka> thank you
17:21:47 <timsim> oh jk im dumb
17:21:58 <mugsie> timsim: well, i didnt want to say it ....
17:22:02 <timsim> :P
17:22:13 <Kiall> mpbnka: +A :)
17:22:22 <mugsie> OK - https://bugs.launchpad.net/designate/+bug/1590937
17:22:22 <openstack> Launchpad bug 1590937 in Designate "Docs - Areas needing improvement" [High,Triaged]
17:22:26 <Kiall> timsim: patchset 2? ;)
17:22:43 <timsim> yep lol
17:22:47 <mugsie> can we agree for poeple to take bits of this bug, and work on them?
17:22:48 <Kiall> got me too ;)
17:22:51 <Kiall> (hence re-reading ;))
17:23:07 <timsim> mugsie: Seems legit
17:23:10 <Kiall> mugsie: was the plan to try do a docs-bash?
17:23:13 <mugsie> yeah
17:23:22 <mugsie> but I am not sure we can .... find time
17:23:36 <mugsie> but if people think we can I am 100% up for docs day
17:24:03 <Kiall> Yea, always the fun part ;) Docs day is harder than say, docs 3hrs (which will still kock out a pile)
17:24:22 <timsim> We have an intern, we can give him some
17:24:34 <mugsie> wednesday 2 weeks suit people? 16:00 UTC - 20:00 UTC ?
17:24:44 <mugsie> or is that too late Kiall / federico3  ?
17:24:50 <mugsie> timsim: be nice :)
17:25:05 <Kiall> mugsie: works
17:25:13 <mugsie> we let you write the agent afair when you were the intern :P
17:25:31 <mugsie> timsim: that suit you?
17:25:45 <mugsie> july 13th
17:25:49 <mugsie> 16:00 UTC
17:26:10 <timsim> Yeah sure, we can do it earlier too
17:26:48 <mugsie> 14 / 15:00 ?
17:26:57 <elarson> o/
17:27:04 <elarson> sorry folks, had a family lunch go long
17:27:11 <mugsie> sshshhh everyone stop talking about him
17:27:21 <timsim> 14:30 :P
17:27:25 <mugsie> done
17:27:47 <mugsie> #info Doc Smash - 13th July 2016 @ 14:30 UTC
17:28:00 <elarson> ah cool
17:28:02 <mugsie> #action mugsie mail the ML with ^
17:28:15 <mugsie> timsim: you had "a few items"
17:28:22 <timsim> Oh yeah
17:28:25 * Kiall blocks his calendar out before it's too late.
17:28:35 <timsim> https://review.openstack.org/#/c/283784/
17:28:38 <timsim> Worker Model
17:28:40 <mugsie> Kiall: add me as an attendee
17:28:44 <timsim> Passes the gate
17:28:57 <timsim> I had to change the pdns plugin a bit
17:29:02 <mugsie> is it on when it passes?
17:29:08 <timsim> Yessir
17:29:33 <timsim> But really, it's ready to review for realsies
17:29:46 <mugsie> sweet
17:29:55 <timsim> It's kind of at a point where if we're going to change anything big about it, it's getting late
17:30:05 <mugsie> OK. what I want to do, is have grenade run on it
17:30:18 <elarson> timsim: I don't have much experience with the sqlalchemy session + eventlet and its threadpool to know whether dropping the threadlocal is problem
17:30:19 <mugsie> but if I can't get grenade written in time, I wil have to do manual
17:30:52 <timsim> mugsie: I can try and do that if you'd like
17:31:01 <elarson> ok, what is a grenade?
17:31:31 <mugsie> timsim: yeah - I can push a 1/2 finished one up
17:31:31 <timsim> "Grenade is an OpenStack test harness to exercise the upgrade process between releases"
17:31:35 <elarson> I mean, I know what a grenade is but it sounds like there is an openstack meaning I don't know about
17:31:38 <elarson> ah ok
17:31:39 <elarson> cool
17:31:41 <timsim> mugsie: That'd be helpful
17:31:49 <mugsie> elarson: it takes the last stable release, and then installs the new patch
17:31:53 <elarson> !m opaque code names
17:31:54 <openstack> elarson: Error: "m" is not a valid command.
17:31:55 <mugsie> then restarts everything
17:32:12 <Kiall> timsim: the pdns changes look fine at a glance, threadlocal was replaced with a local var in the methods + passing it around, so same deal in the end.
17:32:26 <mugsie> eh
17:32:32 <mugsie> http://logs.openstack.org/84/283784/27/check/gate-designate-dsvm-powerdns/98d165c/logs/testr_results.html.gz
17:32:42 <mugsie> is tempest running?
17:33:15 <Kiall> yea, console log shows a pass
17:33:16 <mugsie> oh
17:33:21 <mugsie> ignore me
17:33:31 <timsim> silly
17:33:38 <mugsie> wrong friking job
17:33:48 <mugsie> http://logs.openstack.org/84/283784/27/check/gate-tempest-dsvm-designate-powerdns/ce9cc52/logs/testr_results.html.gz
17:33:55 <timsim> Kiall: It creates a new session per pdns "operation"
17:34:39 <Kiall> timsim: I believe that results in the same behaviour as before, I believe?
17:34:45 <timsim> Kiall: I thought so
17:34:55 <timsim> But I wasn't sure how you'd feel about it
17:35:03 <timsim> It seems to work alright with these small tests
17:35:42 <Kiall> will double check the callers aren't expecting to make use of the methods in a nested transaction, which would be my only worry.
17:36:15 <timsim> I've run performance tests for the worker+agent stuff with 8 nameservers on pretty high load with brilliant success, but I haven't done it like 100 times.
17:36:36 <mugsie> cool
17:36:47 <mugsie> can you dump out metrics from that?
17:37:33 <timsim> Sure.
17:37:47 <mugsie> OK - what is the next item ? :)
17:37:52 <timsim> I'll post them in #openstack-dns or the commit msg later.
17:37:55 <mugsie> ++
17:37:57 <timsim> Mid cycle dates
17:38:11 <mugsie> mid aug me thinks
17:38:22 <timsim> If we can get those solid, we can start booking
17:38:28 <Kiall> mugsie: mmmm... our end of July thing may be pushed 1-2 weeks
17:39:11 <timsim> Aug 15-19 would be nice for me personally :P
17:39:23 <timsim> or 16-19
17:39:39 <mugsie> timsim: I need to wait on managment
17:39:43 <timsim> I think there's a Neutron thing going on in Cork around that time, not that it really matters
17:39:49 <mugsie> there is
17:40:01 <timsim> mugsie: Alright, well, sooner the better, cuz flights and stuff
17:40:07 <mugsie> yeah
17:40:09 <mugsie> I know
17:40:10 <timsim> Also, Dublin/Galway?
17:40:23 <mugsie> most likely Dublin
17:40:26 <timsim> k
17:40:35 <timsim> When do you think you can get us a date?
17:40:42 <federico3> good question
17:40:52 * timsim Management is breathing down timsim's neck
17:40:54 <Kiall> As soon as a certain mgr gets us dates
17:41:25 <timsim> I'll have mejoe send him a fruit basket :P
17:41:35 <Kiall> :D
17:41:39 <mugsie> :)
17:41:56 <timsim> Alright, cool. That's all I had.
17:42:00 * mugsie remembers this is a logged room, and says nothing :)
17:42:05 <mugsie> oh - https://review.openstack.org/#/q/project:openstack/python-designateclient+status:open
17:42:24 <mugsie> top 3 there - can people review them?
17:43:13 <mugsie> anyone else have anything?
17:43:25 * timsim adds them to his list
17:43:30 <mugsie> 3
17:43:33 <mugsie> 2
17:43:36 <mugsie> 1
17:43:41 <mugsie> #endmeeting