16:56:21 <mugsie> #startmeeting Designate
16:56:22 <openstack> Meeting started Wed Jul 27 16:56:21 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:56:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:56:25 <openstack> The meeting name has been set to 'designate'
16:56:32 <mugsie> #topic Roll Call
16:57:11 <mugsie> o/
16:58:13 <elarson> mugsie: I thought you were going to be late?
16:58:14 <mugsie> timsim: pglass Kiall federico3 rsyed - courtesy ping
16:58:18 <elarson> o/
16:58:21 <mugsie> i though I was
16:58:22 <rsyed> o/
16:58:29 <rsyed> we're...early?
16:58:32 <timsim> o/
16:58:40 <federico3> pong o/
16:58:48 <elarson> mugsie is throwing curveballs to keep us on our toes
16:58:49 <mugsie> I have 18:00
16:58:50 <sonuk> o/
16:59:02 <mugsie> but that might be this pc's clock
16:59:03 <timsim> I have 11:59
16:59:12 <mugsie> actually, as does IRC
16:59:15 <mugsie> my bad
16:59:21 <timsim> how will we survive
16:59:28 <mugsie> :)
16:59:56 <mugsie> what I need to do is get a list of issue with each component, and then try and fix them all
17:00:24 <mugsie> I *think* Kiall is afk
17:02:24 <mugsie> OK
17:02:45 <mugsie> i think we can start
17:02:46 <mugsie> :)
17:02:59 <timsim> do it
17:03:01 <mugsie> #topic Action Items from last week
17:03:11 <mugsie> Kiall to figure out a better BP finding command ;)
17:03:16 <mugsie> #action Kiall to figure out a better BP finding command ;)
17:03:26 <mugsie> mugsie bp 1687df2 Don't hardcode options we pass to oslo.context
17:03:32 <mugsie> #action mugsie bp 1687df2 Don't hardcode options we pass to oslo.context
17:03:42 <mugsie> all review https://review.openstack.org/#/c/341398/1/specs/newton/tenant-domainid-for-designate-sink.rst
17:03:48 <mugsie> did everyone look at ^ ?
17:04:18 <federico3> for small values of "everyone"
17:04:23 <mugsie> :)
17:04:52 <mugsie> yeah - everyone in the meeting is a better description
17:05:28 <mugsie> anyone?
17:05:37 <timsim> I did not
17:05:42 <mugsie> OK, we should try and get this merged this week
17:05:47 <timsim> Doesn't seem like a bad idea though
17:05:47 <mugsie> if we want it
17:05:50 <mugsie> no
17:06:02 <timsim> I thought we kind of wanted to kill sink dead forever :P
17:06:15 <mugsie> just interested to see how the domain is formated :)
17:06:15 <elarson> yeah that was my thought as well
17:06:23 <mugsie> there has been ... push back
17:06:45 <mugsie> there is enough people using it, and a few with custom handlers
17:06:59 <mugsie> so, we are stuck with it
17:07:09 <timsim> I could argue that, but I won't ;)
17:07:14 <mugsie> :)
17:07:17 <mugsie> so could i
17:07:44 <mugsie> its not a big enough problem (as far as I see it) to warrent the effort of removing it
17:08:03 <mugsie> I also had an item to find a room an hour earlier
17:08:17 <mugsie> I am trying to, but we may have to move day
17:08:28 <mugsie> I will send out the options when I have htem
17:08:38 <mugsie> OK
17:08:39 <timsim> cool
17:08:46 <mugsie> #topic Bug Triage (timsim - recurring)
17:08:58 <timsim> https://bugs.launchpad.net/designate/+bug/1605331
17:08:58 <openstack> Launchpad bug 1605331 in Designate "Designate v2 API fails to JSONify an designate.objects.validation_error.ValidationErrorList object in e.errors when recordset creation fails, due to circular reference" [Undecided,New]
17:08:58 <mugsie> wouldnt want to make TX miss lunch ;)
17:09:05 <timsim> lunch is important
17:09:07 <mugsie> i saw that
17:09:32 <mugsie> that is H, N3
17:09:41 <mugsie> and quite defnititly a bug
17:09:48 <timsim> woohoo
17:09:50 <timsim> https://bugs.launchpad.net/designate/+bug/1605336
17:09:50 <openstack> Launchpad bug 1605336 in neutron "Neutron loadbalancer VIP port fails to create" [Medium,In progress] - Assigned to Graham Hayes (grahamhayes)
17:09:59 <mugsie> patch up
17:10:01 <timsim> This is just in ours but you have a patch up for neutron right
17:10:02 <timsim> yeah
17:10:06 <mugsie> yeah
17:10:14 <timsim> ok
17:10:16 <timsim> That's it
17:10:21 <mugsie> it is invalid for us actually
17:10:46 <mugsie> the problem is on the other side, so mark it invalid for designate
17:10:52 <timsim> Ok fair enough
17:11:19 <timsim> done :)
17:11:19 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:11:23 <mugsie> Kiall: ?
17:11:25 <mugsie> damn
17:11:40 <mugsie> one min
17:13:04 <mugsie> http://paste.openstack.org/show/542668/
17:13:32 <mugsie> I got to step away for 2 mins, can people read ^ and nominate?
17:13:44 <mugsie> #link http://paste.openstack.org/show/542668/
17:14:05 <timsim> I don't see anything there worth bp'ing
17:14:28 <federico3> nope
17:14:30 <elarson> me neither
17:14:38 <mugsie> nope
17:14:44 <federico3> the iteritem bug is only py3 so...
17:14:48 <mugsie> yeh
17:15:07 <mugsie> #topic Open Discussion
17:15:09 <mugsie> brb
17:16:31 <timsim> So patch bomb incoming sometime today hopefully, but I want to make the notifications designate can emit pluggable.
17:16:48 <elarson> :badoosh:
17:16:54 <mugsie> back
17:16:57 <mugsie> wut?
17:17:01 <mugsie> how plugable>
17:17:03 <mugsie> #?*
17:17:23 <elarson> we're talking 120V/220V pluggable
17:17:23 <timsim> Basically the "payload" that gets emitted would come from a plugin
17:17:33 <timsim> omg dadjoke elarson over here
17:17:42 <mugsie> OK, cool
17:17:50 <timsim> So the default plugin would just return the result of the function called, which is what it does right now
17:17:51 <mugsie> is there a reason?
17:18:04 <timsim> but if you wanted to go pull out more fields or something, you could.
17:18:09 <mugsie> OK
17:18:18 <timsim> I'm trying to use them for that crazy change log thing that we have to have.
17:18:27 <mugsie> i see
17:18:34 <mugsie> that could work alright
17:18:37 <timsim> Yep
17:18:49 <mugsie> cool. I am open to makeing ours better#
17:18:49 <timsim> obj.changes is useful (when they work)
17:18:55 <mugsie> :)
17:19:13 <timsim> Nothing else from me :)
17:19:21 <mugsie> cool
17:19:38 <mugsie> nothing from me either
17:19:47 <mugsie> who wants 40 mins back?
17:19:52 <elarson> I do!
17:19:54 <timsim> lunch plz
17:19:58 <federico3> <-
17:19:59 <mugsie> :)
17:20:04 <timsim> The whole office smells like food
17:20:06 <mugsie> #endmeeting