16:59:52 <mugsie> #startmeeting Designate
16:59:53 <openstack> Meeting started Wed Aug 17 16:59:52 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:58 <openstack> The meeting name has been set to 'designate'
17:00:00 <mugsie> #topic Roll Call
17:00:18 <elarson> o/
17:00:44 <mugsie> Kiall: timsim pglass rsyed federico3 ping
17:00:53 <timsim> o/
17:00:55 <rsyed> o/
17:01:06 <mugsie> that ping person never shows up
17:01:41 <elarson> nice
17:01:53 <mugsie> #topic Action Items from last week
17:02:01 <mugsie> there was none \o/
17:02:08 <Kiall> o/
17:02:15 <mugsie> #topic Bug Triage (timsim - recurring)
17:02:28 <timsim> https://bugs.launchpad.net/designate/+bug/1612288
17:02:28 <openstack> Launchpad bug 1612288 in Designate "For Horizon: designate_policy.json needs to be simpler to work" [Undecided,New]
17:02:58 <mugsie> tag as docs, medium, ?
17:03:05 <Kiall> but - isn't it simple already?
17:03:19 <mugsie> the rules we have do not work in the horizon policy module
17:03:37 <mugsie> (they do not send the tenant ID in)
17:03:51 <elarson> mugsie: they don't keep their own set of rules?
17:03:51 <mugsie> so you have to change the rules
17:03:55 <federico3> o/
17:04:04 <mugsie> elarson: for horizon?
17:04:11 <elarson> yeah
17:04:13 <Kiall> mugsie: shouldn't they send tenantId?
17:04:34 <mugsie> the idea is that you would have the same policy file in both horizon and designate for the DNS actions
17:04:42 <mugsie> Kiall: maybe
17:04:46 <mugsie> but right now they dont
17:04:55 <timsim> I guess we should document it anyway.
17:05:01 <mugsie> yeah
17:05:07 <timsim> Alright, med +docs tag
17:05:11 <Kiall> Yea, can't argue with that
17:05:17 <timsim> That's it, (There was also this one, which I think mugsie was going to close out https://bugs.launchpad.net/designate/+bug/1609576)
17:05:17 <openstack> Launchpad bug 1609576 in Designate "v1 API always gives null for record descriptions, despite v2 recordset having a description?" [Undecided,New]
17:05:20 <elarson> it if doesn't hurt for our standard to be like horizon's then I'd say do that, but whatever ;)
17:05:56 <mugsie> timsim: damn. will do it now
17:06:09 <Kiall> I have a feeling it would break things for us elarson - as in allow everyone access to everything
17:06:14 <mugsie> #action mugsie close http://bugs.launchpad.net/designate/+bug/1609576
17:06:42 <mugsie> elarson: yeah, we have some rules that pass in the parent zone, and compare owners
17:07:13 <Kiall> #topic ... ;)
17:07:29 <elarson> mugsie: ah ok, that makes sense
17:07:36 <elarson> thanks for explaining!
17:07:39 <mugsie> was seeign if elarson had any more questions Kiall ....
17:07:43 <mugsie> sheesh
17:07:47 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:07:49 * Kiall missed that ;)
17:07:50 <mugsie> :)
17:07:54 <Kiall> #link http://paste.openstack.org/show/559072/
17:07:54 <Kiall> As usual. take a few mins and nominate anything in need of backporting....
17:08:04 <mugsie> has anything merged?
17:08:26 <Kiall> 028c9bf Fix SSHFP validation for ECDSA, ED25519, and SHA256 <-- feels like we SHOULD backport that, but policy around that kinda thing is probably weird
17:08:31 <mugsie> nothing from me
17:08:34 <Kiall> and no - there's a CRAPLOAD in the gate
17:08:39 <mugsie> yeah, was debating that
17:08:58 <mugsie> it could be argues that it is a feature
17:09:10 <Kiall> Yea... I think supporting those kinda things in stable branches is OK, and is us fixing compat with DNS vs adding a new Designate feature
17:09:23 <Kiall> But current policy is a "Nope, don't do that"..
17:09:45 <mugsie> timsim: elarson thoughts ^?
17:10:17 <timsim> Feels like it should be BP'd to me if it's fixing something
17:10:38 <Kiall> It's fixing something, or adding something, depending on which way you approach it ;)
17:10:40 <elarson> that is my thought as well, but I can also see that it is a feature
17:10:45 <timsim> But if it's not allowed (eyeroll) then I don't care.
17:10:55 <elarson> +1 on not caring ;)
17:10:59 <mugsie> wanna call it a fix?
17:11:04 <Kiall> +1
17:11:12 <mugsie> ok, bp it then
17:11:18 <mugsie> who wants to do it?
17:11:34 <Kiall> #action mugsie to BP 028c9bf Fix SSHFP validation for ECDSA, ED25519, and SHA256
17:11:37 <Kiall> voulentold
17:11:40 <Kiall> deal with it ;)
17:11:41 <mugsie> #undo
17:11:41 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f5bbdaf98d0>
17:11:50 <Kiall> -_-
17:11:54 <mugsie> boom
17:12:14 <timsim> omg i'll do it lol
17:12:18 <Kiall> #action kiall to BP 028c9bf Fix SSHFP validation for ECDSA, ED25519, and SHA256
17:12:24 <mugsie> heh
17:12:25 <timsim> nvm :x
17:12:49 <mugsie> #topic Mid Cycle Agenda
17:13:15 <mugsie> #link https://etherpad.openstack.org/p/designate-mid-cycle-newton
17:13:44 <mugsie> so, can people put ideas there ^ ?
17:13:54 <timsim> Yeah
17:14:26 <mugsie> and we will review it on friday
17:14:36 <mugsie> we can add more as the week goes on if needed
17:14:59 <elarson> mugsie: yeah, IMO it would be good to try to hack on things
17:15:04 <mugsie> yeah
17:15:05 <elarson> so keeping the agenda small makes sense
17:15:06 <mugsie> I agree
17:15:08 <Kiall> +1 :)
17:15:39 <Kiall> elarson / timsim: when do you two arrive/
17:15:40 <Kiall> ?*
17:15:47 * elarson checks
17:16:00 <timsim> Me: Sunday morning ~10:30
17:16:14 <mugsie> timsim: you are going to be soooo sleepy :)
17:16:14 <elarson> monday at 7:50am...
17:16:18 <mugsie> elarson: ouch
17:16:24 <timsim> Yeah not as bad as elarson
17:16:29 <Kiall> Different flights? Wanted to guarantee you werent stuck beside each other?
17:16:35 <elarson> yeah, I had a show saturday evening and had to fly sunday
17:16:40 <timsim> He has to be a rockstar on saturday.
17:16:51 <Kiall> lol
17:16:51 <mugsie> so where is the jet?
17:16:53 <timsim> We're on the same ones going back I think
17:17:03 <mugsie> all rockstars have jets right?
17:17:05 * elarson expects some good coffee recommendations when he arrives
17:17:11 <mugsie> heh
17:17:12 <timsim> yeah you need one of these http://static.independent.co.uk/s3fs-public/thumbnails/image/2016/03/13/12/Iron-Maiden-plane3.jpg
17:17:22 <elarson> mugsie: yes, but mine is in the shop...
17:17:30 <mugsie> :)
17:17:39 <mugsie> when do you leave?
17:17:57 <timsim> Saturday 12:25
17:18:02 <elarson> me too
17:18:18 <mugsie> k, so I will find a thing to do on friday :)
17:18:19 <timsim> Late enough not to ruin friday :P
17:18:47 <mugsie> #topic Open Discussion
17:18:53 <mugsie> anyt off agenda items?
17:19:26 <mugsie> going once
17:19:32 <mugsie> twice
17:19:40 <mugsie> going ....
17:19:48 <Kiall> cyas :)
17:19:49 <mugsie> #endmeeting