17:01:41 <mugsie> #startmeeting Designate
17:01:42 <openstack> Meeting started Wed Sep 14 17:01:41 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:46 <openstack> The meeting name has been set to 'designate'
17:01:50 <mugsie> #topic Roll Call
17:02:03 <mugsie> timsim: :)
17:02:05 <timsim> o/
17:02:20 <elarson> o/
17:02:25 <sonuk_> o/
17:02:51 <mugsie> Kiall_: ?
17:03:10 <mugsie> #topic Announcements
17:03:44 <mugsie> We got the following allocations for Designate in Barcelona
17:03:45 <mugsie> Designate: 1fb 5wr
17:03:53 <Kiall_> o/
17:03:53 <mugsie> no community meetup
17:04:09 <mugsie> (I said only to give us one if there was space)
17:04:24 <mugsie> We also have to have an RC1 this week
17:04:44 <mugsie> so if anyone knows of any blocking bugs, please shout
17:05:02 <mugsie> I will need some cores to approve release notes, etc
17:05:16 <mugsie> #topic Action Items
17:05:23 <mugsie> kiall to BP 028c9bf Fix SSHFP validation for ECDSA, ED25519, and SHA256
17:05:52 <Kiall> I submitted that from memory
17:05:56 <mugsie> timsim to start convo on bug 1617454
17:05:57 <openstack> bug 1617454 in Designate "Changes do not propagate to downed/recovered nameservers, depending on threshold percentage" [Undecided,Opinion] https://launchpad.net/bugs/1617454
17:06:13 <timsim> oh yeah I didn't do that
17:06:18 <mugsie> :)
17:06:19 <mugsie> cool
17:06:23 <mugsie> #action timsim to start convo on bug 1617454
17:06:32 <mugsie> #action mugsie bp 97c5ab3 Merge "Use upper constraints for all jobs in tox.ini"
17:06:38 <mugsie> I did not do ^ either
17:06:58 <mugsie> #topic Bug Triage (timsim - recurring)
17:07:08 <timsim> https://bugs.launchpad.net/designate/+bug/1621388
17:07:09 <openstack> Launchpad bug 1621388 in Designate "In devstack, installing DNSaaS fails as there is no /etc/powerdns/pdns.d directory created" [Undecided,New] - Assigned to Koteswara Rao Kelam (koti-kelam)
17:07:37 <mugsie> eh
17:07:44 <mugsie> seems to be still missing info
17:07:51 <Kiall> distro?  ubuntu 14.04.1
17:08:17 <mugsie> and the lines above error line
17:08:44 <mugsie> I am confused though
17:08:50 <mugsie> the gate job is passing
17:09:04 <mugsie> and so is the vagrant image based devstack
17:09:34 <mugsie> any ideas?
17:09:55 <timsim> Wouldn't our plugin, or apt-get installing pdns create that dir?
17:09:57 <Kiall> https://github.com/openstack/designate/blob/master/devstack/designate_plugins/backend-powerdns#L51
17:10:04 <timsim> Like maybe he's got some sort of weird permissions thing goin gon
17:10:24 <mugsie> but that is after the pdns install command
17:10:26 <Kiall> We explicitly remove that dir
17:10:39 <mugsie> so, apt shouldnt explode on it
17:10:58 <timsim> Maybe if he's restacking?
17:11:26 <mugsie> maybe ... but I have restacked before, and not had the issue ... might be a new thing in the pdns package
17:12:00 <timsim> Should we tell him to use a newer ubuntu or something?
17:12:14 <mugsie> OK, should I ask for the 100 lines preceding the error message?
17:12:18 <Kiall> mugsie: +
17:12:20 <Kiall> timsim: - ;)
17:12:22 <mugsie> timsim: newer wont work
17:12:32 <mugsie> pdns4.0 is not workiong with designate
17:12:35 * timsim shrugs
17:12:41 <timsim> Alright cool
17:12:47 <timsim> That was the only untriaged bug
17:13:19 <mugsie> sweet
17:13:24 <mugsie> #topic Backport - Kiall
17:13:35 <Kiall> You know the drill .. http://paste.openstack.org/show/576301/
17:13:43 <Kiall> (is 3 weeks enough?)
17:13:50 <mugsie> shouod be
17:13:52 <mugsie> I think
17:14:13 <Kiall> 9822121 Merge "Infoblox backend:Fixed sslverify value from option" - though it went back already
17:14:19 <mugsie> it did
17:14:23 <Kiall> 0a74abe Merge "Fix ZTA API to prevent HTTP 500 upon empty body" - also went back already
17:14:24 <mugsie> It just merged
17:14:42 <Kiall> dff1c37 Merge "Worker Model"
17:14:49 <timsim> obvs
17:14:52 <Kiall> ;)
17:14:55 <mugsie> heh
17:15:00 <Kiall> So - All done?
17:15:07 <mugsie> #topic Open Discussion
17:15:48 <mugsie> OK, so I am going to email the maintainers of drivers that are not tested in the gate - and ask for them to verify the driver works in newton
17:16:05 <timsim> cool
17:16:17 <mugsie> if they do not get back to me I will be proposing that we drop the status of them to "untested"
17:16:31 <mugsie> timsim: that includes bind9 agent :P
17:17:16 <timsim> That's at least in devstack kinda
17:17:16 <mugsie> and if people can start random testing from now on, to find bugs in the RC1 builds, that would be great
17:17:39 <mugsie> timsim: yup - just need a tempest result with a pass :)
17:17:53 <timsim> I can provide that
17:18:08 <mugsie> anything else off topic?
17:18:10 <mugsie> oh
17:18:18 <mugsie> yeah - PTL nominations are open
17:18:29 <mugsie> so anyone who is interested in running, now is the time
17:18:43 <timsim> gl hf mugsie
17:18:45 <mugsie> I can answer any questions people have abnout the job
17:18:59 <mugsie> as can Kiall I would imagne :)
17:19:30 <mugsie> so, I think that is it!
17:19:40 <mugsie> anyone else?
17:19:58 <mugsie> once
17:20:01 <mugsie> twice
17:20:05 <Kiall> gone :)
17:20:07 <mugsie> gone
17:20:11 <mugsie> #endmeeting