17:01:02 <mugsie> #startmeeting Designate
17:01:03 <openstack> Meeting started Wed Oct  5 17:01:02 2016 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:06 <openstack> The meeting name has been set to 'designate'
17:01:09 <mugsie> #topic Roll Call
17:01:11 <timsim> o/
17:01:12 <rsyed2> o/
17:01:14 <elarson> O/
17:01:16 <sonuk_> o/
17:01:34 <mugsie> Kiall: federico3 pglass ping
17:01:57 <mugsie> #topic Announcemnets
17:02:42 <mugsie> so, RC2 was tagged, and will be the release arifact
17:03:06 <mugsie> #topic Action items from last week
17:03:12 <mugsie> Kiall timsim - review https://review.openstack.org/#/c/374308/
17:03:19 <mugsie> done
17:03:32 <mugsie> mugsie bp ae6e84810033a02a8c4e6d729958333c682e8b4a Resolve description parameter in v2:set floating ip
17:03:35 <mugsie> #action mugsie bp ae6e84810033a02a8c4e6d729958333c682e8b4a Resolve description parameter in v2:set floating ip
17:03:46 <mugsie> #topic Bug Triagge
17:03:59 <Kiall> o/
17:04:03 <mugsie> timsim:  :)
17:04:05 <timsim> https://bugs.launchpad.net/designate/+bug/1627941 I think is waiting on mugsie
17:04:07 <openstack> Launchpad bug 1627941 in Designate "Zone transfer accept is forbidden for the non admin users " [Undecided,New] - Assigned to Graham Hayes (grahamhayes)
17:04:22 <timsim> Now for actual new ones:
17:04:23 <timsim> https://bugs.launchpad.net/designate/+bug/1630666
17:04:24 <openstack> Launchpad bug 1630666 in Designate "monasca-statsd is a non-optional import even when disabled" [Undecided,New]
17:04:47 <mugsie> yeah
17:04:55 <mugsie> I saw that just before the meeting
17:05:12 <mugsie> I kinda think not installing our requirements.txt is bad
17:05:37 <timsim> Yeah isn't it better to instal something you don't need then to not have a thing you might need and have to go hunt it down?
17:05:55 <mugsie> I would have thought so
17:05:57 <Kiall> Yea, but it probably should be optional.. kinda like pymysql is
17:06:02 <timsim> I've had to do that for some memcached thing before.
17:06:06 <timsim> and that
17:06:09 <timsim> and it suckss
17:06:20 <timsim> Because they you have to explicitly spell it out and pin a version in automation
17:06:29 <mugsie> Yeah
17:06:49 <mugsie> dmsimard: is the reporter
17:06:55 <Kiall> Yea ... We could use setup.cfg optional requirement groups.. but openstack infra isn't set up to handle them
17:07:03 <Kiall> e.g. no auto updates as requirements versions change
17:07:26 <dmsimard> hey, just joined
17:07:30 <dmsimard> I don't have much time, have to step away
17:07:38 <mugsie> yeah - I perfer to have this in requirements, as it is under development, and not as an option
17:07:38 <dmsimard> I'm just saying this sounds like it should be an optional backend.. just like when I install Glance, it doesn't require me to install Ceph or Swift because my choice is the file backend.
17:07:47 <mugsie> as we dont have anything else that can slot in there right now
17:07:48 <dmsimard> Pretend designate implements metrics collections with, I don't know, gnocchi/ceilometer and such. Will you require that as well ?
17:07:56 <timsim> It's not really requiring that you install that hough, just a client?
17:08:24 <Kiall> dmsimard: Yea, makes sense... We do the same with e.g. mysql. But.. Trying to find a balance between just works, works with -infra tools, and least footprint is .. yea ;)
17:08:59 <timsim> Same with keystoneauth1/keystonemiddleware, python-memcached
17:09:07 <elarson> One danger with the extra req is the extra deps it might bring with it
17:09:08 <dmsimard> I'll leave that up to you, just user/developer/deployer feedback :)
17:09:30 <dmsimard> I have to step out for now but I'll be available to discuss later if you have any questions
17:09:36 <Kiall> For me, I'd love to see the requirements process handle optional requirement groups - that solves this problem "the right way"
17:09:39 <mugsie> OK, thanks dmsimard
17:09:41 <elarson> But generally, adding clients doesn't bother me, especially if it keeps deps out config management
17:10:13 <timsim> Plus, it's currently required in the code. So it's not really optional. That should probably change, but still.
17:10:13 <mugsie> yeah - I can see both sides
17:10:46 <Kiall> Why don't we tag this low, no release, and see if requirements folks have plans around optional groups
17:10:48 <mugsie> what do we think? move the bug to "this should be optional" ?
17:10:55 <mugsie> Kiall: +1
17:11:01 <timsim> Yeah +1 Kiall
17:11:24 <elarson> +1
17:11:29 <timsim> Who wants to do that?
17:11:34 <mugsie> OK, - do what Kiall suggested
17:11:37 <timsim> Give them an action
17:11:41 <mugsie> I can talk to -requrements
17:11:55 <timsim> Alright
17:11:56 <mugsie> #action mugsie talk to requirements team about optional requireemtns
17:12:03 <timsim> I closed this out before the meeting https://bugs.launchpad.net/designate/+bug/1628800
17:12:05 <openstack> Launchpad bug 1628800 in Designate "Designate Blacklist :Blacklisted zones patterns are not checked while create zone using admin." [Undecided,Invalid]
17:12:20 <mugsie> +1
17:12:22 <timsim> https://bugs.launchpad.net/python-designateclient/+bug/1630186
17:12:23 <openstack> Launchpad bug 1630186 in python-designateclient "'openstack zone list --all-projects' failing with unexpected exception." [Undecided,New]
17:12:28 <timsim> Seems legit
17:12:28 <Kiall> policy allows it, you can customize if needs be
17:12:29 <mugsie> -_-
17:12:54 <mugsie> tahts new
17:13:05 <Kiall> and legit, as timsim says.
17:13:06 <mugsie> high, triaged
17:13:19 <Kiall> Though - I'm nearly sure we've seen that one before and fixed it.
17:13:23 <timsim> cool. That's it
17:13:25 <mugsie> did we ?
17:14:15 <Kiall> I think so - but I don't remember what  we were talking about 5mins ago, so.....
17:14:20 <mugsie> #topic Backports - Kiall
17:14:26 <Kiall> #link http://paste.openstack.org/show/584510/
17:14:32 <Kiall> Does ^ look complete?
17:14:40 <mugsie> yeah
17:14:42 <mugsie> its been slow
17:14:43 <Kiall> As usual, take a few, nominate backports
17:14:52 <Kiall> 277dcae Merge "Infoblox: Reverse lookup zone creation fails"
17:14:55 <Kiall> (already done)
17:15:00 <mugsie> I think that ios back
17:15:07 <timsim> Yeah, and that's probably it, yeah?
17:15:08 <mugsie> thats it really
17:15:23 <Kiall> Yep - I think that's it, nothing else warrants a backport in that list./
17:15:36 <mugsie> #topic Design Summit
17:15:42 <mugsie> #link https://docs.google.com/spreadsheets/d/1TQ-RSlbiBBEclkonIbfUP7R1ExZSJylF1uiEKV2G_Cw/pubhtml?gid=1107826458&single=true
17:15:53 <mugsie> this is the allocation of rooms
17:15:55 <mugsie> we have 6
17:16:01 <mugsie> one is a big room
17:16:13 <mugsie> so the usual "meet DNS team"
17:16:20 <mugsie> and then we have 5 40 mins slots
17:16:32 <mugsie> #link https://etherpad.openstack.org/p/designate-ocata-summit-planning
17:16:39 <mugsie> ^ is pretty light
17:17:17 <mugsie> We can nominate them as "Working Sessions" - I saw a few teams do that last time
17:17:27 <mugsie> but I would like a few named sessions
17:17:39 <mugsie> there is on for the NS propegation
17:17:41 <mugsie> one*
17:17:45 <elarson> One thing that might be cool is queuing work outside of retries
17:18:21 <timsim> That was kind of in the worker spec, being able to queue different types of things independently and have logic to work on them
17:18:28 <timsim> But there wasn't a simple solution
17:18:43 <mugsie> yeah. it is also a bigger change than I would like to see in Ocata
17:18:49 <elarson> Yeah, worker model enables it. The job spec further enables it as well
17:19:10 <elarson> Just throwing it out there!
17:19:25 <mugsie> :)
17:19:46 <mugsie> any other suggestions?
17:20:20 <elarson> Beer!
17:20:27 <mugsie> OK, if people think of them, ping me with them
17:20:29 <mugsie> soon
17:20:30 <mugsie> :)
17:20:38 <timsim> What's the deadline mugsie ?
17:20:42 <mugsie> I will be setting the schedule real soon
17:20:42 * elarson isn't going to be there so don't listen
17:20:56 <mugsie> friday AFAIK
17:21:00 <timsim> cool
17:21:04 <timsim> I'll try and think of more things
17:21:07 <mugsie> ++
17:21:46 <mugsie> #topic Pike PTG (Project Teams Gathering)
17:22:04 <mugsie> We have been asked if we will be attending the first PTG
17:22:10 <mugsie> it will be in Austin
17:22:12 <mugsie> nope
17:22:17 <mugsie> Atlanta
17:22:28 <mugsie> Feb 20-24
17:22:44 <mugsie> it is envisaged that this will replace Mid Cycles
17:23:06 <timsim> Hm. I'm betting you guys would have a hard time getting there?
17:23:20 <mugsie> If I go, I will be paying my own way
17:23:52 <mugsie> go, talk to people internally, and find out if you can go
17:24:05 <mugsie> I need to give the foundation an answer by the 16th
17:24:21 <mugsie> so I will be pinging you about it
17:24:43 <timsim> Alright, we'll give it a shot.
17:25:01 <mugsie> cool
17:25:06 <mugsie> #topic Open Discussion
17:25:14 <mugsie> any off agenda items?
17:25:28 <mugsie> going once
17:25:33 <mugsie> twice
17:25:41 <mugsie> thrice
17:25:45 <mugsie> gone!
17:25:48 <mugsie> #endmeeting