17:00:34 <mugsie> #startmeeting Designate
17:00:35 <openstack> Meeting started Wed Jan 25 17:00:34 2017 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:39 <openstack> The meeting name has been set to 'designate'
17:00:41 <mugsie> #topic Roll Call
17:00:53 <timsim> o/
17:00:54 <mugsie> ping timsim Kiall
17:01:02 <mugsie> ping sonu
17:01:15 <mugsie> timsim: too quick for me this week :P
17:01:25 <timsim> pew pew
17:01:43 <mugsie> #topic Announcements
17:01:51 <mugsie> O-3 is this week
17:02:01 <timsim> I put my candidacy in for Pike PTL: https://review.openstack.org/#/c/422765/
17:02:09 <mugsie> I saw :D
17:02:36 <mugsie> if there is any outstanding patches, please let me know
17:02:55 <mugsie> I wanted to get sonu's YADIFA patch in but, its not ready
17:03:04 <mugsie> so it will have to wait till Pike probably
17:03:17 <mugsie> #topic Action Items
17:03:31 <mugsie> nothing from last week as nothing happened :)
17:03:36 <mugsie> timsim backport 7b9c6ce Merge "[backend:akamai] fix retrieval of tsig_key_name"
17:03:42 <mugsie> that was done, right?
17:04:03 <timsim> yeah but failed postgres https://review.openstack.org/#/c/419050/
17:04:14 <mugsie> -_-
17:04:42 <timsim> Probably because this failed https://review.openstack.org/#/c/398749/
17:05:03 <mugsie> shoot
17:05:06 <mugsie> my bad
17:05:28 <mugsie> #action mugsie look at gate failures in stable/newton + pgSQL
17:05:40 <mugsie> #topic Bug Triage (timsim - recurring)
17:06:12 <timsim> This is the only new one https://bugs.launchpad.net/designate/+bug/1658974 and it's on my list to look at today https://bugs.launchpad.net/designate/+bug/1658974
17:06:12 <openstack> Launchpad bug 1658974 in Designate "project_id and zone_transfer_request_id are coming blank when you do openstack zone transfer accept list" [Undecided,New] - Assigned to Tim Simmons (timsim)
17:06:16 <mugsie> ++
17:06:26 <mugsie> that looks wierd
17:06:42 <mugsie> #topic Stable Backport Triage (kiall - recurring)
17:06:47 <mugsie> one sec
17:07:38 <mugsie> #link http://paste.openstack.org/show/596488/
17:08:04 <timsim> 184544e Use the oslo_utils address parser?
17:08:18 <timsim> Although you'd probably get into requirements hell
17:08:39 <mugsie> I think it has been in there for a while
17:08:45 <mugsie> I think it is worth it
17:09:05 <timsim> cool
17:09:11 <mugsie> #action mugsie backport 184544e Use the oslo_utils address parser
17:10:06 <mugsie> #topic Open Discssion
17:10:19 <mugsie> any off agenda items
17:10:20 <mugsie> ?
17:10:30 <mugsie> I am looking at refreshing our core list
17:10:39 <mugsie> if anyone has suggestions could they send them on?
17:10:48 <timsim> Yeah gotta pop ol' elarson off there
17:10:52 <mugsie> :(
17:10:58 <timsim> :'(
17:11:40 <mugsie> cool, I think that is it
17:11:41 <timsim> So we are going to be at the PTG after all
17:11:46 <mugsie> yeah
17:11:55 <mugsie> but not enough to take a room
17:11:58 <timsim> Yeah.
17:12:08 <mugsie> but there is a few free ones up for booking
17:12:15 * timsim just puts that out into the universe so that maybe someone reads that and decides they want to come talk to us
17:12:41 <mugsie> good call timsim
17:13:01 <mugsie> OK - that it for this wek?
17:13:03 <mugsie> week*
17:13:13 <timsim> hm
17:13:20 <timsim> Can I talk about osa with you for a sec?
17:13:24 <mugsie> sure
17:13:51 <timsim> So I'm trying to think about use cases for how you'd want to deploy a dns server there
17:14:21 <mugsie> OK
17:14:34 <timsim> I think some people would actually just want one in the Designate container, and they might just do some internal addressing and use that container ip for resolving things
17:14:51 <timsim> Others are probably going to want to have Dyn or Akamai or something
17:15:01 <timsim> Someone might want a full production dns server in their cloud
17:15:11 <timsim> I think those people can sod off.
17:15:34 <mugsie> well, there is more people than you would expect want DNS hosted in cloud
17:15:58 <mugsie> it is an important step
17:16:01 <timsim> Like Dyn? or like Designate 2 designate?
17:16:19 <mugsie> (if you think back to kialls phased deployment talk in barcellona)
17:16:31 <mugsie> no, just bind / pdns in cloud
17:16:40 <mugsie> and pointing some subdomains at it
17:17:07 <timsim> Right, so my thought there is: is Bind running next to Designate good enough for that?
17:17:11 <timsim> Probably not...
17:17:11 <mugsie> as well as the neutron integration, creating PTR + records for ports
17:17:15 <mugsie> is it?
17:17:38 <timsim> I mean would you want at least two nameservers? Preferably not running in a container?
17:17:57 <mugsie> people might want 3/4 large containers just to run bind
17:18:06 <mugsie> s/containers/instances/ or nodes
17:18:11 <timsim> yeah.
17:18:23 <timsim> So I guess the right thing is to maybe leave that up to the deployer.
17:18:26 <mugsie> yeah
17:18:38 <timsim> But what's missing from the role now is a way to drive pools.yaml with attributes.
17:18:39 <mugsie> unfortunatly they all want random stuff
17:18:44 <mugsie> ah
17:18:50 <mugsie> OK. that would be nice to have alright
17:19:22 <mugsie> hum - I got to bounce real quick - can I ping you in #-dns in a few ?
17:19:30 <timsim> Sure
17:19:33 <mugsie> k
17:19:36 <mugsie> #endmeeting