16:59:41 <mugsie> #startmeeting Designate
16:59:41 <openstack> Meeting started Wed Feb  1 16:59:41 2017 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:45 <openstack> The meeting name has been set to 'designate'
16:59:47 <mugsie> #topic Roll Call
16:59:53 <Kiall> o/
16:59:59 <sonuk> o/
17:00:09 <mugsie> timsim: ping
17:00:13 <timsim> o/
17:00:28 <timsim> holy crap it's a Kiall siting
17:00:30 <mugsie> #topic Announcements
17:00:38 <Kiall> ;)
17:00:39 <mugsie> So RC1 is tomorrow
17:00:41 <timsim> sighting
17:00:50 <mugsie> and I will be creating the ocata branch then
17:01:03 <mugsie> so, please have a look at outstanding patches
17:01:12 <mugsie> and get stuff merged :)
17:01:25 <timsim> It's kind of come together well these last couple days.
17:01:32 <mugsie> I have a bit of bug bash day yesterday, so the was a lot to merge
17:01:41 <mugsie> and I cleaned up launchpad + gerrit
17:01:53 <mugsie> (appolgies to anyone I offended by abandoning patches / bugs)
17:02:03 <mugsie> #topic Action Items
17:02:24 <mugsie> mugsie look at gate failures in stable/newton + pgSQL
17:02:30 <mugsie> mugsie backport 184544e Use the oslo_utils address parser
17:02:33 <mugsie> both done
17:02:50 <mugsie> #topic Bug Triage (timsim - recurring)
17:03:14 <timsim> mugsie: There's this old thing https://bugs.launchpad.net/designate/+bug/1627941
17:03:14 <openstack> Launchpad bug 1627941 in Designate "Zone transfer accept is forbidden for the non admin users " [Undecided,New] - Assigned to Graham Hayes (grahamhayes)
17:03:22 <timsim> and this https://bugs.launchpad.net/designate/+bug/1660942
17:03:22 <openstack> Launchpad bug 1660942 in Designate "There is no "test_recordset.py" at master branch for functionaltests" [Undecided,New]
17:03:23 <mugsie> I was trying to recreate it yestday
17:03:48 <mugsie> the bug fix for ^ is to delete the page
17:04:20 <Kiall> yea, it's replaced by http://docs.openstack.org/developer/designate/tempest.html
17:04:36 <timsim> So someone just needs to kill http://docs.openstack.org/developer/designate/functional-tests.html
17:04:41 <mugsie> so, triaged, taggged with "docs" and "low hanging fruit" and a direction to delete the page
17:04:49 <mugsie> someone can get a free ticket that way :)
17:04:58 <timsim> Cool
17:05:01 <mugsie> and maybe not get -2'd for correcting the akamai driver
17:05:49 <mugsie> that it?
17:05:50 <timsim> Alright, that's all of them
17:05:52 <mugsie> cool
17:06:00 <mugsie> #topic Back Port Triage
17:06:10 <mugsie> Kiall: over to you
17:06:20 * Kiall doesn't have them handy -_-
17:06:38 <mugsie> :)
17:07:35 <Kiall> #link http://paste.openstack.org/show/597242/
17:08:14 <mugsie> dc34ed4 Fix noop metrics timed decorator
17:08:29 <mugsie> c135dc7 Validate NS records on a pool during an update ?
17:09:01 <Kiall> yea, both seem like issues BP worthy
17:09:17 <Kiall> f6ba5c2 Use exit code 1 for failed designate-manage pool commands <-- might be considered an "API" change though
17:09:25 <mugsie> yeah
17:09:28 <timsim> I'd say all three of those
17:09:35 <timsim> That aint no API
17:10:09 <timsim> If it'd change anything it would be to expose failures in people's automation
17:10:16 <mugsie> true
17:10:19 <Kiall> yea, true...
17:10:20 <mugsie> ah, go for it
17:10:29 <mugsie> who wnats the honour?
17:11:05 <timsim> I can do the pool commands one
17:11:25 <mugsie> cool. I can take the other 2
17:11:43 <mugsie> #action timsim bp f6ba5c2 Use exit code 1 for failed designate-manage pool commands
17:11:59 <mugsie> #action mugsie bp NoOp + NS record patches
17:12:20 <mugsie> #topic Open Discussion
17:12:30 <mugsie> this should have been in announcements
17:12:34 <mugsie> but
17:12:45 <mugsie> #info all hail our new PTL - timsim
17:12:52 <Kiall> \o/
17:12:54 <mugsie> congrats tim
17:13:01 <timsim> Thanks :)
17:13:03 <sonuk> congrats tim
17:13:05 <timsim> We'll see how it goes ¯\_(ツ)_/¯
17:13:12 <mugsie> :)
17:13:48 <timsim> Don't anybody go running away now that they aren't PTL mugsie
17:14:01 <mugsie> sonuk: I am not sure if we can get your backend merged in time for ocata - but I will review it today
17:14:16 <mugsie> it is a tight window
17:14:25 <mugsie> timsim: me? run?
17:14:25 <sonuk> <mugsie> ok sure.
17:14:44 * mugsie deletes his freenode account
17:15:06 <mugsie> timsim: can you look at https://review.openstack.org/#/c/422376/ as well ?
17:15:09 <timsim> I have your phone number
17:15:11 <timsim> sure
17:15:12 <mugsie> damn
17:15:25 <mugsie> OK, anyone have anything else?
17:15:46 <mugsie> going once
17:15:48 <mugsie> twice
17:15:54 <mugsie> thrice
17:15:59 <mugsie> .... gone
17:16:01 <timsim> o/
17:16:02 <mugsie> #endmeeting