14:00:59 <mugsie> #startmeeting Designate
14:01:04 <openstack> Meeting started Wed Apr 18 14:00:59 2018 UTC and is due to finish in 60 minutes.  The chair is mugsie. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:07 <openstack> The meeting name has been set to 'designate'
14:01:11 <mugsie> #topic Roll Call
14:04:23 <mugsie> frickler: daidv bnemec meeting ping
14:05:11 <bnemec> o/
14:05:29 <frickler> oh, a meeting o/
14:05:55 <mugsie> I have put 4 reminders in my calander to make sure :)
14:06:46 <mugsie> #topic Bug Triage
14:07:13 <mugsie> #link https://bugs.launchpad.net/designate/+bug/1758013
14:07:14 <openstack> Launchpad bug 1758013 in Designate ""also_notifies" section is not purged by designate when removing it from "pools.yaml" file" [Undecided,New]
14:07:31 <mugsie> this looks like a legitimate bug
14:07:59 <mugsie> I think the object changes tracking thing is not fully working
14:08:37 <mugsie> or we are doing a merge, and not taking the lack of a key to be empty
14:08:45 <mugsie> ]but a real bug non the less
14:08:56 <frickler> deleting from hashes is always difficult, maybe the workaround is indeed the correct solution
14:09:03 <frickler> but I didn't look in detail yet
14:09:23 <mugsie> yeah
14:09:35 <mugsie> that is all the new untriaged bugs
14:10:26 <mugsie> #topic Backports
14:10:29 <mugsie> #link http://paste.openstack.org/show/719477/
14:11:05 <mugsie> the only one may be bba6022a Update auth_uri option to www_authenticate_uri ? but I am not sure if that is worth it
14:11:20 <mugsie> the d72c6520 Ensure we do not pass invalid data for A records patch only applied to rocky
14:11:32 <frickler> that doesn't look suitable for a backport, too (the auth_uri)
14:12:13 <mugsie> it does change the api actually, so no
14:12:51 <mugsie> #topic Open Discussion
14:13:15 <mugsie> any off agenda items - I know daidv wanted to talk about rolling upgrsdes, but I dont see them
14:13:32 <frickler> just fyi I started rewriting our jobs in zuul v3 native https://review.openstack.org/561194
14:13:41 <mugsie> i saw that work starting - thanks :)
14:13:43 <frickler> but seems that will still take a bit of work
14:14:09 <mugsie> yeah - if you need any help let me know - I think it is a good thing to get done
14:15:05 <mugsie> it looks like the pdns server is not being configured for some reason
14:15:32 <frickler> yes, I didn't have time to look into it because of pip 10 yet
14:15:44 <frickler> maybe I should start with bind9 instead
14:16:08 <mugsie> it looks like the pdns server is not being configured for some reason
14:16:09 <mugsie> It may be easier alright, as bind is a simpler config
14:16:31 <mugsie> my damn internet is soooooo flaky today :/
14:17:05 <frickler> another topic is https://review.openstack.org/556158 "use http code constant instead of int" - do you agree that if we do this, we should change all constants?
14:17:16 <mugsie> If we do it, yes
14:17:35 <mugsie> I am not convinced of the value personally
14:18:12 <frickler> yes, I wouldn't push it myself, but I won't object if it is done properly, too
14:18:26 <mugsie> yea - that is ny feeling
14:19:03 <frickler> also just noting that the ReviewPriority thing seems to be working fine so far. not sure though how to integrate that in the dashboard
14:19:16 <mugsie> the dashboard should be updated with it
14:20:02 <mugsie> graham.hayes.ie/designate/dashboard has 2 sections on top, Urgent and Priority Fixes
14:21:11 <frickler> oh, you added that already, now I need to update my copy of that ;)
14:21:39 <mugsie> it is just the start to be fair, and if anyone has idea about how to change how we do things with it let me know
14:22:20 <mugsie> there is also https://review.openstack.org/#/c/561654/2/dashboards/designate-ptl-overview.dash
14:22:29 <mugsie> which might be useful for some people
14:22:46 <mugsie> http://graham.hayes.ie/designate/ptl-dashboard is the link i will keep updated
14:23:28 * frickler likes the classification: small/big/aging ;)
14:23:52 <mugsie> yeah, i need to tweek the aging one a bit, but it is important
14:25:28 <frickler> o.k., so then there is the topic of changing the meeting time. I think we discussed this earlier already, but I don't remember the outcome. I guess eanderson would also like to attend
14:25:37 <mugsie> Yeah
14:25:51 <mugsie> I think office hours may suit better
14:25:56 <mugsie> any other topics?
14:26:06 <mugsie> ignore ^
14:26:21 <mugsie> (my internet lagged and nothing was showing -_-)
14:26:27 <bnemec> FWIW, Oslo has a wayward changes section in its dash: https://github.com/openstack/gerrit-dash-creator/blob/master/dashboards/oslo.dash#L47
14:26:53 <bnemec> Although I'm amused its set at 2 days.
14:27:05 <mugsie> There is no time that suits everyone unfortunately
14:27:13 <mugsie> bnemec: from a different time? :P
14:27:31 <mugsie> frickler: you are UTC-1 right?
14:27:53 <frickler> UTC+2 right now, UTC+1 in the winter
14:28:15 <mugsie> bnemec: is -5, and eanderson is -8
14:28:48 <bnemec> Is he in Hawaii or something?
14:28:54 * bnemec would like to be in Hawaii right now
14:28:55 <mugsie> I can try another doodle, or just say x day is in the morning UTC and y day is in the evening UTC
14:29:04 <mugsie> west coast of the US
14:29:33 <frickler> probably -7 then with dst currently?
14:29:34 <bnemec> Oh, that should only be 2 hours off of me.
14:29:51 <bnemec> Yeah
14:29:56 <mugsie> #action mugsie mail the -dev list with options, and get feedback
14:30:02 <mugsie> frickler: yeah
14:30:12 <mugsie> bnemec: oh, you are central? I thought you were eastern
14:30:50 <bnemec> Yep, Minnesota.  Where we are about to get our third spring blizzard of the year.
14:31:13 <frickler> oh, I saw pictures from Lambeau field
14:31:23 <mugsie> weather is wild right now, eh?
14:31:40 * mugsie is happy - dublin is 19C right now :)
14:31:44 <bnemec> I was actually pretty lucky.  Some places got 18 inches of snow last weekend.
14:32:10 <mugsie> ouch
14:32:39 <frickler> berlin has 23C, so I'm also not complaining. except not being able to be in the sun ;)
14:32:55 <mugsie> :)
14:33:28 <bnemec> It's Minnesota, so we'll go from freezing and snow to hot and humid in the space of about three days. :-)
14:34:12 <mugsie> we do that, just not usually with snow
14:34:19 <mugsie> apart from that one time ...
14:34:23 <mugsie> :D
14:34:28 <bnemec> Heh
14:34:44 <mugsie> OK, any other topics? or will we call it for today?
14:35:14 <bnemec> I guess a quick update on TripleO integration:
14:35:22 <mugsie> oh - yes please
14:35:27 <bnemec> My patches have started to merge, so we should have Designate in TripleO for Rocky.
14:35:36 <mugsie> \o/
14:35:55 <bnemec> I still have more work to do to configure pools correctly, but I should be able to get that done this cycle.
14:36:20 <mugsie> sweet
14:36:50 <bnemec> And I'm sure dozens of other little things that I haven't considered, but at least the base will be there. :-)
14:37:11 <mugsie> yeah, there is always one more little thing around the corner
14:37:42 <bnemec> Otherwise that's it for me.  Oslo PTLing is still eating a lot of time, so we'll see how that shakes out over time.
14:38:37 <mugsie> cool - as always, if you need anything from us, shout :)
14:39:13 <mugsie> thanks all! have a good day
14:39:22 <mugsie> #endmeeting