20:01:09 <cinerama> #startmeeting diskimage-builder
20:01:10 <openstack> Meeting started Thu Sep 15 20:01:09 2016 UTC and is due to finish in 60 minutes.  The chair is cinerama. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:11 <bkero> hi
20:01:14 <openstack> The meeting name has been set to 'diskimage_builder'
20:01:32 <cinerama> our agenda is here
20:01:36 <cinerama> #link https://wiki.openstack.org/wiki/Meetings/diskimage-builder
20:01:56 <cinerama> #topic Bugs process
20:02:23 <cinerama> so greghaynes wanted to talk about the bugs process - whether we should use launchpad or not & cleaning it up
20:02:36 <cinerama> i closed out ~25 bugs last week when i had a look
20:02:46 <ianw> is there really any other option than launchpad?
20:02:51 <bkero> storyboard
20:03:06 <bkero> aiui there is a migration process that can be done
20:03:14 <cinerama> i haven't looked in on storyboard in a while but my impression is that it's more suitable for some kinds of tasks than others
20:03:20 <cinerama> s/is/was/
20:03:51 <bkero> we also have influence on what it is suitable for since we have the principle authors as part of the project
20:03:59 <cinerama> i think the main point was really that if we're going to continue to use this we need to clean up any old-n-crusty stuff
20:04:02 <cinerama> this is tru
20:04:35 <ianw> an auto-close of old bugs might be ok?  i know devstack amongst others has done that periodically
20:04:37 <cinerama> even if we do import we still need to cleanup
20:04:50 <bkero> i can do some bug triage
20:05:04 <cinerama> that seems reasonable
20:05:11 <cinerama> bkero, that would be great if you want to pitch in
20:05:13 <bkero> I'm sure there will be some things in there that I can't handle myself, but can always ask in channel.
20:05:20 <cinerama> bkero, please do
20:06:09 <cinerama> i had thought about having a more organized bug scrub day but i don't think that's going to work with people's schedules and/or primary responsibilities
20:06:33 <cinerama> anyone have any other thoughts on bug tracker?
20:07:25 <ianw> not really, i think the honest fact is that if anyone is reporting a bug and expecting someone else to fix it, their odds of that happening are very low
20:08:09 <ianw> but i don't think that is a dib exclusive problem
20:08:53 <cinerama> this is true. i'm not sure what we can do about that aside from recruiting more people to work on the project, marking bugs as lhf, etc
20:09:47 <cinerama> the other part of the bugs agenda item, which might help with this, is whether we should add a bugs section to the meeting.
20:09:59 <cinerama> i'm broadly in favor of this but not sure exactly what form it should take
20:10:24 <cinerama> possibly discuss new or important in-progress bugs?
20:10:48 <bkero> add it to the agenda once its identified to be important?
20:11:37 <cinerama> could be good, then folks will have an opportunity to review them prior to the meeting
20:12:28 <cinerama> anyone have any other thoughts on that?
20:12:50 <ianw> yes, if we have a list before we start, that seems to bound the time we would spend on it
20:13:47 <cinerama> which is probably a good thing
20:14:07 <cinerama> i'm going to say
20:14:31 <cinerama> #agreed Add key bugs discuss to meeting agenda
20:14:47 <cinerama> ok next main topic
20:14:54 <cinerama> #topic Dib 2.0
20:15:16 <cinerama> so we have the feature branch now
20:15:32 <cinerama> the main topic proposed was whether we should cut an RC
20:15:37 <cinerama> thoughts?
20:15:37 <ianw> yes i merged most of our things from the 2.0 list in there
20:15:53 <ianw> there's still something wrong with tripleo i haven't got to the bottom of
20:16:22 <ianw> and i want to merge the "put elements under python package" + "diskimage-builder as entry-point" changes
20:16:26 <ianw> the "pythonic dib" stuff
20:16:41 <cinerama> that sounds good
20:16:48 <ianw> i'm trying to figure out how i can do that without causing very annoying merge issues
20:17:16 <ianw> but so far, trying to use symlinks fails -- something in setuptools/pbr/... doesn't like it
20:17:48 <ianw> https://review.openstack.org/#/c/367156/ is what i'm talking about
20:17:56 <cinerama> hmm
20:18:14 <cinerama> btw might be good if we can update the etherpad
20:18:23 <cinerama> #link https://etherpad.openstack.org/p/dib2.0
20:18:25 <ianw> also i don't think i pushed it, but i have a similar change to remove the dependency for dib-utils
20:18:29 <cinerama> with the current status of the branch
20:18:48 <ianw> last i spoke to greghaynes & spamaps both were in favour of removing our dependency on that
20:19:20 <ianw> *but*, in a world where people know to "pip install" dib, it's also less of an issue
20:19:30 <cinerama> right
20:19:34 <cinerama> makes sense
20:19:41 <ianw> yeah, i can update etherpad
20:20:06 <cinerama> thanks
20:20:53 <cinerama> any other thoughts on 2.0
20:21:40 <ianw> not really from me
20:22:32 <cinerama> ok
20:22:56 <cinerama> #topic Open discussion
20:23:01 <cinerama> ok it's all you
20:23:12 <ianw> just on release notes
20:23:22 <cinerama> good topic
20:23:29 <ianw> generally before a release i've been backtracking and adding something with important changes
20:23:38 <ianw> obviously the idea of reno is to add notes to changes as they come in
20:23:50 <ianw> so i think it's fair enough to request them in reviews
20:23:53 <ianw> for sufficient changes
20:24:05 <cinerama> yes, it looks like we've done per-release ones in the past but we should possibly move away from that
20:24:14 <cinerama> makes it easier when we go to release i think
20:25:02 <cinerama> things that change the behaviour of elements, scripts etc seems like a good bar
20:25:33 <ianw> yep, or significant bugs fixed, that people might google for and hit the relnotes
20:27:24 <cinerama> #agreed Move to request release notes to be submitted with review
20:28:10 <cinerama> anyone have any reviews that want special attention at the moment? i've been working on other projects this week so i haven't looked much
20:32:01 <cinerama> okay
20:32:12 <cinerama> shall we wrap up for now?
20:32:28 <ianw> that's all from me
20:32:49 <cinerama> bkero: unless you have anything, we'll close
20:33:46 <cinerama> ok thanks everyone
20:33:50 <cinerama> #endmeeting