20:02:51 <greghaynes> #startmeeting diskimage-builder
20:02:51 <openstack> Meeting started Thu Sep 29 20:02:51 2016 UTC and is due to finish in 60 minutes.  The chair is greghaynes. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:54 <openstack> The meeting name has been set to 'diskimage_builder'
20:02:57 <greghaynes> tada
20:03:03 <cinerama> thanks for starting the meeting
20:03:27 <greghaynes> I dont really have much of anything, havent been able to work on dib much the past couple weeks
20:03:40 <greghaynes> mostly trying to figure out the state of the v2 branch
20:03:59 <greghaynes> #link https://review.openstack.org/#/q/project:openstack/diskimage-builder+branch:feature/v2
20:04:51 <greghaynes> looks like ianw has a couple large ones which are merge conflicted and andreas has a couple of the block device patches
20:05:11 <cinerama> yeah i noticed the merge conflicts as well
20:05:21 <pabelanger> o/
20:05:26 <cinerama> looks like many other things are all set to go
20:05:32 <greghaynes> so yea, I think the big action item for next two weeks is get those merged
20:06:26 <greghaynes> #action try to prioritize reviewing patches to the v2 branch
20:06:47 <greghaynes> The other big thing I noticed when reviewing the block device patches is it would be really nice to add some functional testing for them
20:06:49 <cinerama> i can rebase some stuff if folks are busy
20:06:53 <greghaynes> so I think I am going to take that as part of my action item
20:06:56 <cinerama> i think that's a great idea
20:06:57 <greghaynes> cinerama: that'd be awesome
20:07:31 <greghaynes> #action greghaynes to add some functional testing for the new block device interface
20:07:47 <greghaynes> #action cinerama to rebase the merge conflicted v2 patches which need it
20:07:55 <greghaynes> coolio
20:08:25 <greghaynes> The only other thing I can think of is the bug tracker - I failed at finding some time to close more bugs, I know cinerama did a ton
20:08:30 <cinerama> rebase party!
20:08:42 <greghaynes> so hopefully folks can cull some more of the oudated launchpad bugs
20:08:43 <cinerama> yeah i did some around our last meeting, but i haven't revisited since then
20:08:50 <greghaynes> awesome
20:09:05 <greghaynes> in theory ill have time the next two weeks so I'll try and prioritize that
20:09:29 <greghaynes> #action Try to continue culling old/stale launchpad bugs until we get them all cleaned up
20:10:11 <greghaynes> so, any other topics / things from previous meetings you think we should hit on?
20:10:52 <greghaynes> We missed a couple meetings so I suspect we dont have much of a following here ATM :/
20:11:05 <cinerama> looks like the v2 stuff is progressing, though i know ianw is on top of that more
20:11:16 <cinerama> we're biweekly right?
20:11:20 <greghaynes> Yes to both
20:11:24 <cinerama> i ran the previous meeting
20:11:37 <cinerama> what else
20:11:47 <cinerama> review activity has been a bit slow
20:12:15 <greghaynes> yea :( I had been pulled in to some internal stuff so my time was basically 0 for the past couple weeks, in theory thats over now though
20:12:55 <greghaynes> I think the big thing is just to make sure we keep momentum on v2 at this point - otherwise well end up with a pile of unmerged code that is forever diverging from master
20:13:00 <cinerama> right
20:13:06 <greghaynes> and the sooner we can merge it in the better
20:13:54 <cinerama> agreed
20:14:02 <greghaynes> ok, well, last call if anyone wants to beg for review / help with something :)
20:14:11 <pabelanger> yes
20:14:12 <greghaynes> otherwise 15min meeting (which is awesome)
20:14:20 <greghaynes> pabelanger: ohai
20:14:39 <pabelanger> So, could use some eyes on https://review.openstack.org/#/c/378985/ and hopefully a 1.20.1 release. Found some issues with the new runtime-ssh-host-key elements
20:14:54 <greghaynes> aha
20:14:55 <pabelanger> basically, stop using ssh-keygen -A and adds a script to do each key
20:16:11 <greghaynes> pabelanger: ok, I'll have a look. Is that release needed ASAP to fix things or?
20:16:37 <pabelanger> 2nd, is more a design question for DIBs. I want to see how I can add the ability to have disk-image-create launch ansible-playbook before the chroot is converted to an image (ansible would use the connection=chroot).  The reason for this, is we'd like to break stop using puppet inside of DIB and move to ansible external of DIB, so we don't need to create virtualenvs in the image
20:16:52 <pabelanger> greghaynes: doesn't have to be ASAP, but soonish would be nice
20:18:31 <greghaynes> pabelanger: hrm. I dont know a lot about connectoin=chroot - does that just need a path and sufficient binaries in the path and itll handle all the chrooting aspects?
20:18:50 <greghaynes> trying to figure out what kind of environment dib would need to set up for ansible to make use of
20:19:20 <pabelanger> greghaynes: Right, I haven't tested yet but it would be: https://coderwall.com/p/_lpf1g/run-a-playbook-chrooted-in-a-local-dir
20:19:38 <pabelanger> setup the path to chroot in your inventory file, and ansible_connection=chroot
20:19:43 <cinerama> yeah i haven't looked at the chroot stuff in ansible yet myself
20:19:49 <greghaynes> gotcha
20:19:58 <pabelanger> so, in this case, ansible is running outside of DIB, which is something we'd like for openstack-infra
20:20:08 <pabelanger> to help remove our configuration bits from test images
20:20:51 <greghaynes> So one idea is we should make an api infront of where we call our phases (right now we just have a bash function called run_d) that allows people to plug out the dib 'runner'
20:20:54 <pabelanger> I haven't started down the path of hacking yet, but wanted to bring up the topic since we talked about it recently at our infra mid-cycle
20:21:22 <greghaynes> I'm basically thinking theres a larger thing here of 'users want to be able to have a custom runner'
20:22:27 <greghaynes> yea, its a neat idea - I think itd also help out a lot with the puppet use case as well if we made the interface more clear
20:22:33 * greghaynes will think on it
20:22:38 <pabelanger> cool
20:22:43 <cinerama> nice
20:23:24 <greghaynes> ok, well I think thats it
20:23:27 <greghaynes> #endmeeting