15:02:55 <Swami> #startmeeting distributed-virtual-router
15:02:56 <openstack> Meeting started Wed Mar 26 15:02:55 2014 UTC and is due to finish in 60 minutes.  The chair is Swami. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:59 <openstack> The meeting name has been set to 'distributed_virtual_router'
15:03:23 <Swami> #topic Agenda
15:03:33 <Swami> DVR Progress
15:03:50 <Swami> DVR Design Docs
15:04:02 <Swami> DVR HA
15:04:16 <Swami> Distributed DHCP
15:04:23 <Swami> Open Discussion
15:04:38 <Swami> Is there any other agenda items that you need to add.
15:04:47 <Swami> Is Vivek in here.
15:05:11 <Swami> If vivek is here we can also discuss about the L2 issue that we ran with the DVR implementation.
15:06:04 <Swami> #topic DVR Progress
15:06:27 <Swami> As mentioned in the previous meeting the DVR work is in progress.
15:06:35 <Swami> vivek: hi
15:07:06 <Guest70967> hi
15:07:24 <Swami> With respect to the East-West implementation we have completed 90% of the work.
15:07:55 <Swami> We had some issues with the L2Pop and also have some issues with how the portbindings are handled in the L2.
15:08:43 <Swami> But we are trying to work it out, once we have the details we will share it with the DVR team and the ML2 Team.
15:09:33 <Swami> Last week we brought up an issue with the L2Pop and the MAC Learning that was both having the mac entries ( duplicate MAC learning).
15:09:51 <Swami> I spoke to Sylvain about the issue and he created a patch to fix that issue.
15:10:14 <Swami> #link https://review.openstack.org/#/c/83053/1
15:10:52 <Swami> Hope that Duplicate MAc issue is resolved.
15:11:07 <xuhanp> Swami, thanks for sharing. will take a look
15:11:12 <Swami> Sylvain: may not join today's meeting since he had another meeting to attend.
15:11:35 <Swami> xuhanp: welcom
15:11:44 <VivekNarasimhan> Swami, this is duplicate mac occuring in L2-Pop entries is it?
15:11:53 <Swami> vivek: Yes
15:12:06 <Swami> This is a WIP patch.
15:12:43 <Swami> So we can review it, test it and make sure that the duplicate mac issue is resolved.
15:12:44 <VivekNarasimhan> I have not seen dup MACs occuring after patching teh two gerrits available off Hvana stable
15:12:56 <VivekNarasimhan> is this for a specific case where the MAC appears?
15:13:39 <Swami> vivek: This is a patch that has a "config" flag to turn on or turn off the MAC learning. Please make sure if it compliments our work.
15:13:50 <VivekNarasimhan> that is good
15:14:02 <Swami> vivek: can you check it this patch does not affect our work.
15:14:09 <VivekNarasimhan> yes, will verify
15:14:14 <VivekNarasimhan> the patch passed all tests?
15:14:39 <Swami> #action Vivek will verify the Duplicate Mac learning patch with DVR
15:15:07 <VivekNarasimhan> sure
15:15:27 <Swami> #topic L3 Plugin Extension for DVR
15:16:15 <Swami> The work on L3 Plugin Extension for DVR is proceeding. Fixed the Unit test issues that was causing problem. I might still need to do some refactoring to the Icehouse latest master branch.
15:16:45 <Swami> Once done, will be pushing the Plugin code as WIP for review to the team.
15:16:56 <Swami> #topic L3 Agent
15:17:12 <Swami> mrsmith: Any updates on the L3 Agent
15:17:31 <mrsmith> we have started work on supported FIPs in the code
15:17:35 <mrsmith> distriubuted FIPs
15:17:48 <mrsmith> flushing out the details for centralized SNAT
15:17:52 <mrsmith> good progress
15:18:02 <Swami> any issues so far with the East-West.
15:18:08 <mrsmith> nope
15:18:18 <Swami> mrsmith: Thanks for the update.
15:18:23 <mrsmith> probably start merging in icehouse-2 soon
15:18:25 <mrsmith> np
15:18:42 <Swami> #topic L2 Plugin/Agent
15:19:03 <Swami> vivek: How is your work with the L2 Agent/Plugin coming up
15:19:11 <VivekNarasimhan> coming up good
15:19:21 <VivekNarasimhan> good progress for the port binding issue
15:19:24 <VivekNarasimhan> hpn-dvr succeeds
15:19:39 <VivekNarasimhan> DHCP IP obtaining by VM fails due to L2-Pop rule corruption in NN
15:19:42 <VivekNarasimhan> analysing the same
15:20:11 <VivekNarasimhan> teh IP obtaining fails only at times, figuring out the root-cause in teh L2-Pop module
15:21:25 <Swami> vivek: You mentioned that you had some issues with the port binding issue, do you have a handle on it.
15:21:57 <VivekNarasimhan> yes, basically having a pport-binding table specifically for only DVR Ports
15:22:15 <VivekNarasimhan> the original Port Binding will continue to carry VM port bindings and Centralized NN port bindings
15:22:47 <VivekNarasimhan> Still work there to get Unit Tests to run and ensure that other verndor-specific code not broken
15:23:14 <Swami> vivek: Thanks for the information. If you have any questions on portbinding just bring it up to the team.
15:23:33 <Swami> Is murali in here
15:24:07 <Swami> #topic DVR Design Docs
15:24:07 <VivekNarasimhan> basically there were a few approaches we thought on like I said yesterday
15:24:30 <VivekNarasimhan> a. Representing all teh DVR Ports as basic tenant ports
15:24:49 <VivekNarasimhan> this option will not ensure transparency of DVR operation
15:24:58 <Swami> DVR design docs are out for review, and we have been addressing the comments. If anyone felt that the comments are not been addressed please bring it up to my notice.
15:25:31 <Swami> #link https://docs.google.com/document/d/1depasJSnGZPOnRLxEC_PYsVLcGVFXZLqP52RFTe21BE/edit#heading=h.5w7clq272tji
15:25:31 <VivekNarasimhan> b. Shadow port-binding table. main port updated based on bucket result (AND/OR) of shadow table
15:25:46 <Swami> #link https://docs.google.com/document/d/1jCmraZGirmXq5V1MtRqhjdZCbUfiwBhRkUjDXGt5QUQ/edit
15:26:01 <Swami> vivek: we are on a different topic now,
15:26:27 <VivekNarasimhan> guess murali din't join yet
15:26:42 <VivekNarasimhan> he has got the delete router namespace working today, when I met him in evening
15:28:04 <Swami> Both design documents will be updated if there are any new changes.
15:28:33 <Swami> xuhanp: Have your concerns in the design doc been addressed.
15:29:02 <xuhanp> Swami, thanks for asking. Yes, they are
15:29:33 <Swami> xuhanp: Sorry I knew that you are listening, but if you have any topics to discuss please feel free to add in yur topic.
15:29:52 <xuhanp> Swami, sure. still processing your conversation :-)
15:30:51 <Swami> xuhanp: Thanks
15:31:12 <Swami> #topic DVR L3 HA
15:31:54 <Swami> Sylvain is out today as well. I need to discuss this with Sylvain and see if the current L3-VRRP patch can be utilized for the Service Node SNAT service.
15:32:26 <xuhanp> Swami, I am actually trying to test out Sylvain's 4 patches for HA now
15:32:33 <Swami> Because we are planning to use the same L3 Agent in a context driven mode, this should not break.
15:33:10 <Swami> xuhanp: Good, please let us know how it goes.
15:33:40 <Swami> Once we have the Service Node North-South running we need to evaulate this.
15:33:48 <xuhanp> Swami, sure. So far it works well and I plan to cover more scenarios
15:33:53 <Swami> sorry: evaluate.
15:34:22 <Swami> xuhanp: The L3 VRRP today is just Active/Passive, am I right.
15:34:36 <xuhanp> yes. It's master  and backup
15:35:07 <Swami> I knew that Amuller was trying to push his thoughts on the Active/Active model.
15:35:43 <carl_baldwin> Swami: The active/active work is on hold and not progressing at the moment.
15:35:59 <Swami> For HA i was also thinking should be file a blueprint for some sort of Loadbalancing the service node routers dynamically based on the load.
15:36:17 <Swami> carl_baldwin: Thanks for the information.
15:36:25 <xuhanp> carl_baldwin, because the DVR decreases the requirement of active/active HA?
15:37:30 <Swami> xuhanp: The use case for dvr on the L3 VRRP will be little bit different than what is currently been proposed.
15:37:55 <carl_baldwin> xuhanp: Basically, yes.
15:38:05 <Swami> For DVR it can be utilized for the Service Node, but for all other nodes it might not make a lot more sense.
15:38:42 <xuhanp> Swami, OK. that makes sense
15:40:05 <Swami> #topic Distributed DHCP
15:40:53 <xuhanp> Swami, I actually have a question about redundant DHCP configuration in current code
15:41:06 <Swami> Since we have been talking about the DVR HA, the only service component left out in the Service node will be the DHCP.
15:41:13 <Swami> But it is maintained by a different agent.
15:41:33 <Swami> xuhanp: Yes tell me what you think
15:41:44 <xuhanp> there is a configuration in neutron.conf
15:41:47 <xuhanp> # Number of DHCP agents scheduled to host a network. This enables redundant
15:41:47 <xuhanp> # DHCP agents for configured networks.
15:41:47 <xuhanp> # dhcp_agents_per_network = 1
15:41:59 <xuhanp> so when that number is more than 1
15:42:30 <xuhanp> there are more than one DHCP agents for each network
15:43:11 <xuhanp> does that kind of meeting the requirement of having more than 1 DHCP replying to DHCP request from a network?
15:43:15 <mrsmith> each agent takes a seperate IP tho right?
15:43:21 <Swami> mrsmith: Do you have any comments on this.
15:43:50 <mrsmith> yes, redundant dhcp is supported but each server/agent takes an IP from the network
15:43:52 <xuhanp> mrsmith, I am not sure about that. but I think the agent shares the same host file for the network.
15:44:02 <mrsmith> yes
15:44:25 <mrsmith> but I believe each dhcp server takes an IP from the hosted network
15:44:37 <xuhanp> mrsmith, what do you mean by "takes an IP"?
15:44:56 <mrsmith> one of the VM ips hosted on a network
15:45:06 <mrsmith> like .2
15:45:24 <Swami> mrsmith: from the VMs subnet
15:45:30 <mrsmith> I think that is the current complaint about redundant DHCP
15:45:37 <mrsmith> Swami: yes
15:45:58 <xuhanp> mrsmith, so you mean there is no same mac and IP pair in two dhcp's host file?
15:46:23 <xuhanp> I think I can simply test it some time to confirm it.
15:46:27 <mrsmith> sure
15:46:43 <VivekNarasimhan> if it hs the same, there will two responses for the VM
15:46:49 <VivekNarasimhan> during DHCP Discover, right?
15:46:50 <mrsmith> I think you will find the DHCP servers all take a neutron port and IP per node
15:47:56 <xuhanp> mrsmith, so by distributed DHCP, you want to change that?  to have many distributed DHCP server to provide one IP?
15:48:29 <mrsmith> I think there are some in the community who want that
15:48:43 <mrsmith> carl_baldwin: any comments?
15:49:04 <xuhanp> are there any protocol to support that?
15:49:11 <Swami> xuhanp: Since we are distributing the routers, it would make sense to also distribute the DHCP
15:49:14 <carl_baldwin> I hope that distributed DHCP will use one port.
15:49:16 <mrsmith> well, we are doing something similar for dvr
15:49:32 <Swami> There was patch earlier for Multihost by gongyish that addressed this issue.
15:49:38 <mrsmith> for each router on the CNs - we are trying to share the router-interface ports
15:49:47 <Swami> Because of refactor issues, it did not get through during the Grizzly time frame.
15:50:20 <xuhanp> Great. maybe I can find his patch and have a look.
15:51:00 <Swami> xuhanp:thanks
15:51:12 <xuhanp> Swami, thank you for the information!
15:51:38 <Swami> #topic Open Discussions
15:51:58 <Swami> Is there any other open items or topics that we need to discuss today
15:53:03 <Swami> If there are no other topics for discussion I will give you back 5 mins
15:53:15 <Swami> Thank you all for attending the meeting.
15:53:20 <Swami> Meet you all next week.
15:53:29 <Swami> #endmeeting