18:00:09 <eglute> #startmeeting diversity
18:00:13 <openstack> Meeting started Thu Nov 12 18:00:09 2015 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:17 <openstack> The meeting name has been set to 'diversity'
18:00:40 <eglute> Hello Everyone! Raise your hand if you are here for the diversity meeting o/
18:00:54 <eglute> #link https://etherpad.openstack.org/p/OpenStackDiversity.16
18:01:55 <rolandchan> I am
18:02:09 <eglute> Hello rolandchan!
18:02:21 <Dan_Fineberg> good morning
18:02:22 <rolandchan> Hiya
18:02:29 <spotz> Hey guys
18:02:32 <eglute> Hello Dan_Fineberg!
18:02:43 <eglute> Everyone: please review the agenda: https://etherpad.openstack.org/p/OpenStackDiversity.16
18:03:42 <eglute> #topic work plan
18:04:22 <eglute> when we started this working group, we came up with a work plan, and now we need to re-evaluate it and see if it needs updating
18:04:46 <eglute> #link https://docs.google.com/presentation/d/1I0KJEzqdpwFMWPX-G7H-Arx4uCHDkR7E76kttlZfNZU/edit#slide=id.p3
18:05:28 <eglute> we have done some of the things on the plan, mainly we sent out the survey.
18:06:45 <Dan_Fineberg> Are the categories and preiorities agreed by the key decision makers?
18:06:46 <eglute> the survey showed us some common issues, but of course it was not quite what we were expecting
18:06:48 <spotz> eglute We discussed resending the survey out at summit, should we maybe schedule doing that as the next step?
18:07:50 <eglute> spotz i dont think it would be good to resend it soon after the summit. Perhaps before the next one? unless you have good reasons for sending it out again?
18:07:59 <eglute> Dan_Fineberg yes, they were
18:08:29 <Dan_Fineberg> cool--then I presume the survey did not generate sufficient response?
18:08:39 <rolandchan> I don't think we need as much detail as we got from the survey very often
18:08:54 <spotz> eglute mainly to see if we get more responses. There was one person atleast in the working session that said they didn't get it
18:09:00 <eglute> We got enough responses, they were not what were expecting :)
18:09:20 <Dan_Fineberg> can we set the base lines from the data we got back?
18:09:51 <eglute> we can set some. Also, we got some clear blockers for people to participate in the community
18:10:14 <eglute> but they are not specific to any particular group, besides being new to openstack
18:10:45 <Dan_Fineberg> perhaps that should be dealt with after the base lines are set, when we consider the "desired state"...
18:11:01 <eglute> spotz i dont think that would work, the system said it went to 32K people. A lot of people filter their emails, so we have no way of knowing what really happened to that particular person
18:11:12 <spotz> ok
18:11:41 <eglute> Dan_Fineberg I agree, we should come up with desired state :)
18:12:38 <Dan_Fineberg> an analysis of the base lines for each category would be a good start
18:13:29 <eglute> Agreed, we need to share the results of the survey. I will take that as an action item
18:13:36 <rolandchan> There are two sides to desired state: population distribution, and the satisfaction rating.
18:13:50 <eglute> #action eglute will work on sharing the survey results with the community
18:14:11 <Dan_Fineberg> agree that "quantity" and "quality" metrics make sense...
18:15:20 <rolandchan> On the population side: we need to work on getting a more diverse overall population and also on enabling that population to "progress though the ranks", ie into leadership positions.
18:15:58 <eglute> right, so how do work on outreach?
18:16:52 <Dan_Fineberg> a PR effort would be a good start, getting feature stories in the Foundation blog and magazine, for example...
18:17:46 <rolandchan> For geographic diversity, we need the diversity message to be the first thing anyone says. We have lots of events going on all the time, but the "join the community" message is not the highest priority
18:18:09 <eglute> rolandchan what is the first message people hear now?
18:18:51 <Dan_Fineberg> can you clarify the audience you're referring to?  New recruits?  Existing members?  Other?
18:18:59 <rolandchan> Depends: meetup groups talk about different thingsneach meeting. The regional meetings have different tracks.
18:20:30 <spotz> So something like pictures of a diverse group of people and then a tag line to encourage joining?
18:20:34 <Dan_Fineberg> Maybe we should take an audience-by-audience approach:  existing members; prospective members; by-geo?
18:21:06 <rolandchan> eglute: something like that. We probably need a guide for them  to use
18:21:08 <eglute> for new people, the ramp up to use/code/run openstack is also challenging, that is something that needs closing
18:21:41 <eglute> rolandchan what do you mean by a guide
18:22:37 <Dan_Fineberg> Is there any meaningful info to offer besides goals on how diverse we want the community to be?  Maybe social gatherings?  Dispute resolution channels?
18:22:37 <rolandchan> Something asking them to deliver a particular message, and some content. Slides etc.
18:23:26 <eglute> I would also propose that when there is something like OpenStack Day, the organizers offer some number of free diversity passes
18:23:36 <rolandchan> Basically some marketing collateral.
18:24:22 <eglute> rolandchan can you work with the foundation on getting some marketing collateral done?
18:24:22 <rolandchan> Yes! Any hints we can provide as well.
18:24:29 <rolandchan> Sure.
18:25:02 <eglute> #action rolandchan will work with the foundation on getting some marketing collateral done
18:25:26 <eglute> the next big issue is onboarding new people
18:25:43 <eglute> not enough to join the community, need to enable ways to participate.
18:25:49 <eglute> this is larger than this WG though
18:26:08 <Dan_Fineberg> maybe a way to get more "cores"?
18:27:01 <rolandchan> We need to liaise with the TC on mentoring. What is/isn't possible etc.
18:27:21 <eglute> more cores too, but even getting started is a big issue
18:27:35 <Dan_Fineberg> a step-by-step training offering for becoming a core reviewer would be good for may reasons...
18:27:50 <Dan_Fineberg> many reasons, that is..
18:27:50 <eglute> yes, we do have someone from TC we can work with. Need to make sure he knows about these meetings :)
18:28:12 <eglute> #action eglute to talk to Flavio about diversity meetings
18:29:20 <rolandchan> I think we need to get detail from the foundation on what their plans are. There is a lot of money set aside for "technical work", we need to ensure that the feedback from the survey is included in the requirements for that work.
18:29:35 <eglute> Dan_Fineberg I agree! however, people need help just getting started too. For example, Nova has a really good guide on how to get started and their whole process. the difficulty there is the size of the project and people not knowing where to start/find the start guides
18:29:50 <eglute> rolandchan +1
18:30:27 <Dan_Fineberg> maybe we have more than one offering:  getting started for newbies, and moving up for older hands...
18:30:50 <spotz> +1 dan_fineberg I like that
18:30:51 <rolandchan> Yep. Need both.
18:31:11 <eglute> yes, all levels could use more help + clarity
18:31:57 <Dan_Fineberg> perhaps a 3rd would be "leadership" for senior folks...
18:32:41 <eglute> so the question is, how much should the Diversity Working Group drive of this? This is such a huge area, and way more than we can do.
18:33:09 <Dan_Fineberg> can we piggy-back existing HR programs for training and onboarding?
18:33:19 <rolandchan> It needs to be a distributed system :)
18:33:35 <rolandchan> There's no HR for members
18:34:10 <Dan_Fineberg> Do we have a list of exosting programs that we could influence?
18:34:52 <eglute> i think we would need to work with the foundation here. there are some programs,
18:34:54 <spotz> I can see us providing overall guidance and suggestions like the 'come join the community' mentioned earlier and working to come up with guides?
18:34:54 <rolandchan> Perhaps we take the best of what is out there (Nova perhaps) and ask all the projects to aim at that level.
18:34:59 <Dan_Fineberg> I'm thinking we could target whatever  existing programs there are for onboarding, training, and executive development...
18:35:07 <eglute> one is Outreachy, but it cannot support a lot of people
18:36:56 <Dan_Fineberg> maybe we recruit a member from that program to join us, and then extend our efforts through their program...
18:37:42 <eglute> we can look into it. also, see what else has been successful
18:37:53 <rolandchan> Training is a good one: there is training on being a contributor. Maybe it should be run through i18n.
18:38:30 <eglute> rolandchan do you have a link to that?
18:38:36 <rolandchan> Um..
18:39:30 <rolandchan> https://wiki.openstack.org/wiki/OpenStack_Upstream_Training
18:39:43 <rolandchan> There were some sessions at summits
18:40:08 <rolandchan> But perhaps a webinar format
18:40:38 <spotz> From talking to folks I think the upstream training was held on Sunday before summit
18:40:58 <eglute> right, looks like it is before summit next time as well.
18:41:02 <Dan_Fineberg> If we had a member from the training team in this team, they could help us understand what format works best.  Then we could pur in the content...
18:41:08 <eglute> not sure if it can be scaled
18:41:44 <rolandchan> It we can convert it to a youtube video it'll scale :)
18:42:00 <rolandchan> I haven't actually seen the content though
18:42:07 <eglute> right, i meant in-person at the summit
18:42:12 <Dan_Fineberg> then send an email to the community with the YouTube link...
18:42:28 <eglute> here is the outline: http://docs.openstack.org/upstream-training/
18:42:59 <eglute> one thing that we saw from the survey is that people have hard time finding the information, even when it is available
18:43:43 <eglute> so to address that issue, we would need to talk to the docs/foundation people see what can be done to make it easier for people find the info
18:44:05 <rolandchan> This sort of thing should be part of the guides we send out in the previous action point
18:44:06 <eglute> i think the issue is that there is the openstack site, teh wiki, mailing lists, IRC. lots of different channels
18:44:20 <eglute> yes.... but how will they find it :)
18:44:32 <eglute> if they are not on the mailing list, or filter and dont read everything?
18:45:11 <Dan_Fineberg> if we use existing online repositories like the Foundation's online slide index, then we can send links to people via multiple channels:  email, IRC chats, etc.
18:45:12 <spotz> Yeah not sure I would have thought to search for upstream training to get how to contribute
18:46:05 <rolandchan> So we need to look at rationalising the user experience.
18:46:27 <Dan_Fineberg> We should do this as an active campaign rather than a pssive posting of content, in my humble opinion...
18:46:48 <rolandchan> Organising the content to have a simple entry point and then pushing that entry point out all the channels
18:47:01 <Dan_Fineberg> yes!
18:47:05 <rolandchan> And do that push repeatedly
18:47:10 <eglute> +1
18:47:22 <spotz> +1
18:47:24 <eglute> so, who would like to take this as an action item?
18:47:41 <eglute> though we might all need to own it
18:48:02 <rolandchan> First step would be to identify all the bits of content.
18:48:10 <Dan_Fineberg> I can help with content editing, wordsmithig, etc.
18:48:30 <eglute> thanks Dan_Fineberg that would be helpful
18:48:39 <rolandchan> I think that can be a shared task. If we have an etherpad to list it all out, we can all do it.
18:48:41 <eglute> rolandchan that is a huge task
18:49:20 <rolandchan> Yep. That's basically the core of problem.
18:49:24 <eglute> also, we need to make sure we dont loose track that we are trying to increase diversity... ideally, we work with the community/foundation to help us
18:50:02 <rolandchan> I think we can work on the common stuff. Each project has their own content.
18:50:23 <rolandchan> And we are starting to build a list of thing we need from each project.
18:50:31 <eglute> true
18:50:45 <eglute> the last item on today's agenda is the code of conduct updates.
18:51:00 <eglute> spotz do you remember who owned that as an action item? was it you?
18:51:15 <spotz> cpallares
18:51:39 <eglute> ah ok
18:51:54 <eglute> would you be able to work with her on it?
18:51:58 <spotz> I just tend to know what's going on with it:) She was going to get with Carol last I heard
18:52:06 <cpallares> o/
18:52:09 <eglute> Jonathan Bryce has asked for more context behind the proposed changes. He would like to understand what's behind the change, so he can both understand and determine if there are other places changes are needed related to the code of conduct change.
18:52:12 <spotz> sweet!
18:52:15 <eglute> oh hi Cindy!
18:52:32 <cpallares> How do I contact Jonathan?
18:52:34 <eglute> you are here just in time, to do work! :D
18:52:39 <cpallares> Through the mailing list?
18:52:40 <cpallares> haha
18:52:42 <eglute> email! I will get it to you
18:52:49 <cpallares> Ok
18:53:16 <rolandchan> We're clear on what needs to be said to him? AFAIK its pretty straightforward
18:53:56 <cpallares> rolandchan: Yeah
18:54:05 <rolandchan> Ok cool
18:54:09 <cpallares> rolandchan: I think I have an email on my drafts somewhere
18:55:29 <eglute> cool! thank you cpallares
18:55:48 <eglute> we have 5 more minutes, anything else?
18:56:28 <rolandchan> I'll take an action to start on listing the onboarding content. Will distribute a link to the etherpad
18:56:36 <eglute> thank you rolandchan!
18:56:50 <eglute> #action rolandchan will take an action to start on listing the onboarding content. Will distribute a link to the etherpad
18:57:32 <eglute> #action cpallares will email jbryce regarding code of conduct
18:58:19 <eglute> Thanks everyone! we have a lot to do...
18:58:39 <spotz> rolandchan if you need a hand just ping me
18:58:51 <eglute> #endmeeting