17:02:20 <spotz> #startmeeting diversity-wg
17:02:20 <openstack> Meeting started Mon Jun  3 17:02:20 2019 UTC and is due to finish in 60 minutes.  The chair is spotz. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:24 <openstack> The meeting name has been set to 'diversity_wg'
17:02:26 <diablo_rojo> o/
17:02:29 <spotz> #topic Roll Call
17:02:30 <cmurphy> o/
17:02:47 <spotz> Agenda:
17:02:56 <spotz> #link https://etherpad.openstack.org/p/diversity-wg-agenda
17:03:02 <fungi> "roll call" makes me feel like i'm a mouseketeer
17:03:20 * SWDevAngel waves
17:03:21 <spotz> And while it's in the agenda the link for the CoC discussion is https://etherpad.openstack.org/p/diversity-wg-coc
17:03:40 <spotz> fungi I used to have ears:)
17:04:08 <spotz> We'll get going even if more people show up today
17:04:19 <spotz> #topic Summit
17:05:08 <spotz> Overall I think we had a good summit as far as attendance at sessions and some really good conversations.
17:05:45 <SWDevAngel> Agreed. But I was only there for the last day and a half.
17:06:00 <fungi> was good seeing everyone nonetheless
17:06:11 <spotz> From the mentoring BoF we had 2 people interested in helping petevg and megheisler. And then one of Martial's coworkers
17:06:11 <SWDevAngel> Agreed. Great community.
17:06:18 <fungi> yes, new faces!
17:06:47 <spotz> @action spotz to email the interested folks to make introduction, including diablo_rojo to assist
17:06:52 <spotz> #action spotz to email the interested folks to make introduction, including diablo_rojo to assist
17:06:56 <spotz> That's better:)
17:07:07 <spotz> #link https://etherpad.openstack.org/p/DEN-diversity-sessions
17:07:19 <spotz> This was the etherpad for the sessions
17:08:24 <spotz> Shoot I have IRCs and no emails for folks:( megheisler if you could email me at amy@demarco.com I'd appreciate it and I'll track down Peter in the Horizon channel I think I saw him in their PTG room
17:09:04 <spotz> I went over the survey results and Jimmy has put them online officially vs in my GitHub if anyone wants to see them
17:09:04 <fungi> it sounds like getting something like "mentorship" added as a top-level icon on the community portal ought to be doable
17:09:41 <spotz> fungi: Cool, we just need to have something for it to go to:)
17:09:50 <fungi> #link https://docs.openstack.org/contributors/common/mentoring.html
17:10:01 <fungi> seems like that ought to be a decent initial placeholder?
17:10:13 <spotz> That will work!
17:10:35 <spotz> Our stickers were out at registration, though didn't see many people with them but they were there!:)
17:11:10 <fungi> i heard some folks in the session say they didn't notice them at registration, but not sure how to make them more visible
17:11:40 <spotz> fungi: Maybe stick some on the outside of the containers? I had to ask if they were there
17:11:48 <fungi> that could help
17:12:12 <fungi> if money were no object we'd just include one of each along with every badge, but... $$$
17:12:34 <spotz> Speed Mentoring had a nice turnout, I snagged 6 people out of a waitlist line next door or as we had plenty of food
17:12:38 <SWDevAngel> Which stickers?
17:12:48 <fungi> SWDevAngel: pronoun stickers
17:13:00 <spotz> Yeah and even then would people notice them. What he said
17:13:07 <SWDevAngel> Ahhhh. Right. I missed those too but I registered a day late.
17:13:52 <SWDevAngel> What they did at KubeCon is they had the person who registered you actually point you to them and ask you to put one on. It was pretty effective. They also had the color-coded do not disturb or talk to me stickers.
17:14:53 <spotz> Yeah or LF has a table next to registration with all the stickers at events. But having them there was a good start:)
17:15:10 <SWDevAngel> Yes
17:15:29 <spotz> Diversity Lunch had a nice turnout, the IBM presentation was a good kickoff and I think well received
17:15:40 <spotz> And new faces there as well
17:16:01 <SWDevAngel> Agreed and it was great to have Jennifer Cloer back.
17:16:05 <spotz> Any thing else on Summit? We have a few items I know we need to get to
17:16:08 <fungi> sorry i had to miss diversity lunch and speed mentoring for other obligations, but glad to hear there was a good turnout
17:16:11 <SWDevAngel> And the screening
17:16:39 <spotz> Yeah I had UC at the same time as screening so missed that, and we moved the survey results as it was at the same time:(
17:17:09 <spotz> I'm going to bump the WoO stuff over the CoC as I think it'll be quicker
17:17:18 <spotz> #topic WoO ML and linked in
17:17:25 <SWDevAngel> Nicole did a good job hosting it.
17:18:23 <spotz> So I think the Diversity mails have always been under the FOundation list as to be open and as we're technically a WG under the Board and not UC or TC. aprice this was your topic if you want to lead it
17:18:46 <aprice> sure
17:19:28 <aprice> so we have a linkedin group that has several hundred people and a WoO mailing list. With the recent shift to a broader sense of diversity, one of my questions was should we rename the mailing list?
17:20:07 <spotz> That's one reason I just gave that little blurb of history:)
17:20:10 <fungi> i was just browsing the list archive, and for at least the past year (i haven't gone back any farther yet) it looks like it's been used exclusively for announcements
17:20:25 <spotz> fungi: And most are probably from me:)
17:20:36 <aprice> The linkedin group has 750 members in it, but is rather old. we have not posted in it for some time. My recommendation was going to do a last post that points to official OSF diversity initiatives like this WG and then close the group so it's not another channel to monitor.
17:20:42 <fungi> spotz: yep, a vast majority of them ;)
17:20:42 <aprice> and people can get engaged in the right places
17:21:21 <spotz> aprice personally I have no issue of doing that with LinkedIn but I'm not the best LinkedIn user:)
17:21:54 <diablo_rojo> Sounds like a good plan to me for the linkedin
17:21:56 <spotz> As far as the mailing lists if we did rename it might lead to more discussion as I personally don't want to spam the Foundation list, but at the same time would we be as open
17:21:58 <aprice> yeah, my biggest concern is someone who is genuinely interested in getting involved, finds that group because it has good search, but then isn't able to find it
17:22:00 <diablo_rojo> and a rename of the ML makes sense to me too
17:22:03 <fungi> these sorts of announcements seem like they'd also be right at home on the foundation ml, to me
17:22:35 <aprice> +1
17:22:52 <spotz> Would it be worth renaming and then announcements to both lists as the volume is so low on them?
17:23:40 <spotz> And we'll do 2 polls, 1 for linkedin and 1 for the ML once we're ready as they're 2 topics
17:24:22 <fungi> if anything, posting announcements about diversity-related topics to the general foundation ml raises visibility of them as something we think everyone should be concerned about, and not just some fringe effort you need to subscribe to another place for information on
17:25:11 <aprice> yeah and i think that should be something we encourage for all WGs and SIGs. would probably help new folks find out how to get involved easier
17:25:19 <fungi> the wg is chartered by the board for a reason, so i would consider that an indication they think it's an important foundation-level area of interest
17:25:27 <spotz> fungi: So you're in favor of archiving WoO and staying as is? Just want to be clear
17:26:07 <fungi> archiving the women-of-openstack ml and moving future announcements of that nature to the foundation ml
17:26:56 <spotz> where they are now:)
17:27:05 <fungi> yeah, they're already being posted there as well
17:27:20 <spotz> Ok anyone have any other thoughts on this?
17:28:06 <fungi> basically the volume of messages on foundation is within the same order of magnitude, so there's not much reason to echo this subset of announcements to a second ml
17:28:10 <cmurphy> sounds good to me
17:29:02 <spotz> fungi: If we seem like we need more for conversations we can always make a new list. But yeah it seems to be just me with meetings and summit related announcemtns
17:29:08 <spotz> Ok making the poll
17:29:11 <fungi> the alternative of making it clear that the women-of-openstack list is an announcement-only list and discussion should happen on foundation seems like a reasonable alternative
17:29:46 <fungi> also, not the reason i'm arguing against, but renaming a mailing list is not easy and has a tendency to be disruptive to existing subscribers regardless
17:29:46 <SWDevAngel> Yes. Let’s streamline as much as possible.
17:30:10 <spotz> #startvote Archive the WoO mailing list and continue using the FOundation list for Diversity? Yes No Abstain
17:30:11 <openstack> Begin voting on: Archive the WoO mailing list and continue using the FOundation list for Diversity? Valid vote options are Yes, No, Abstain.
17:30:12 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:30:21 <spotz> #vote yes
17:30:28 <aprice> #vote yes
17:30:39 <fungi> #vote yes
17:31:00 <SWDevAngel> #vote yes
17:31:20 <fungi> as an aside, i'm happy to assist in the technical steps for shutting down the ml
17:31:32 <cmurphy> #vote yes
17:31:35 <diablo_rojo> #vote yes
17:31:38 <fungi> just did that recently for a bunch of technical lists on the same server
17:31:52 <spotz> fungi: Thanks, I'll poke about and ping:)
17:32:01 <fungi> at your convenience
17:32:42 <spotz> #endvote
17:32:43 <openstack> Voted on "Archive the WoO mailing list and continue using the FOundation list for Diversity?" Results are
17:32:44 <openstack> Yes (6): spotz, fungi, SWDevAngel, diablo_rojo, aprice, cmurphy
17:33:36 <spotz> And before I put up the poll for linked in just want to make sure I'm clear. We will be shutting that down with a final post sending people to this meeting and the Foundation list? Or something similar
17:34:10 <aprice> correct - probably the wiki where it lives in one place
17:34:27 <aprice> and we can leave it up for let's ay 6 weeks. and I can post multiple messages in case folks miss it
17:34:40 <spotz> aprice: Ok and we can make sure it's up to date before we send people there:)
17:34:53 <aprice> perfect
17:35:35 <spotz> #startvote Archive the WoO LinkedIn group and send a message with follow-ups for people to join ML, meeting and checkout the wiki? Yes No Abstain
17:35:36 <openstack> Begin voting on: Archive the WoO LinkedIn group and send a message with follow-ups for people to join ML, meeting and checkout the wiki? Valid vote options are Yes, No, Abstain.
17:35:37 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:35:42 <spotz> #vote yes
17:35:51 <aprice> #vote yes
17:36:46 <fungi> #vote abstain
17:36:55 <cmurphy> tbh i don't participate in the linkedin group so i have no opinion on its future
17:37:00 <cmurphy> #vote abstain
17:37:16 <fungi> (having never used linkedin, i'm happy to defer to others on this one, don't feel i can reasonably gauge)
17:37:22 <spotz> cmurphy: I've seen maybe 1 message in years:)
17:37:51 <spotz> But like I said I'm not the best LinkedIn user
17:38:27 <spotz> We could always poke it with a we're think of doing.... and see if anyone even replies
17:38:34 <aprice> yeah, the posts are largely irrelevant
17:38:37 <fungi> my only exposure to linkedin is training invites from it into my personal spam detector
17:38:54 <aprice> ok - I can take that action of posting that it might be something we do
17:39:16 <aprice> and report any feedback / concerns
17:39:26 <spotz> #vote abstain
17:39:44 <spotz> I'll officialyy abstain so we don't have a good vote and we'll do that step first
17:39:52 <spotz> #endvote
17:39:53 <openstack> Voted on "Archive the WoO LinkedIn group and send a message with follow-ups for people to join ML, meeting and checkout the wiki?" Results are
17:39:54 <fungi> makes sense
17:39:55 <openstack> Yes (1): aprice
17:39:56 <openstack> Abstain (3): cmurphy, fungi, spotz
17:40:18 <spotz> #action aprice to Poke the linked in group and see if there's any response then we can decide to retire it
17:40:20 <fungi> i'm perfectly happy for aprice to do whatever she thinks as best on this
17:40:42 <spotz> I think we'll retire it after the poke:)
17:41:03 <spotz> Anything else on this?
17:41:26 <aprice> nope - thanks!
17:41:49 <spotz> #topic CoC review
17:42:27 <spotz> Aeva brought to our attention during sessions that our CoC is out dated and some of the wording might put people off from reporting things
17:44:10 <fungi> #link https://www.openstack.org/legal/community-code-of-conduct/ current osf community coc
17:44:14 <spotz> The Django CoC we were based on has been updated and I've included a link to that on the etherpad I've made and linked to
17:44:35 <spotz> fungi: Yep I cut and pasted it into the ether so we could mark it up as we wanted to:)
17:45:03 <spotz> Any changes we make will need to go through the OSF and most likely they're legal
17:45:08 <fungi> though the summit code of conduct includes the same phrases aeva brought attention to, and it claims to be based on the pycon conference coc
17:45:27 <fungi> so odds are if we alter those bits of one, we'd do the same with the other
17:45:30 <aprice> was there a particular section or phrases that were particularly off-putting?
17:45:31 <spotz> So Summit one was good and regular one was bad?
17:45:44 <aprice> and yeah, it would definitely need to go through our legal team
17:45:45 <spotz> Or both are bad?
17:45:49 <fungi> both have the same phrases aeva mentioned
17:45:58 <spotz> Ok so we'd need to update both
17:46:03 <fungi> so that section, at least, is effectively identical
17:46:19 <fungi> #link https://www.openstack.org/summit/shanghai-2019/code-of-conduct/
17:46:22 <fungi> for reference
17:46:52 <fungi> the response procedure is similar in both cases
17:49:17 <spotz> aprice using will vs may was a big one as someone may want to report but have it go no further
17:50:27 <fungi> it sounds like we do need to be clear though that you should not report an incident to osf staff unless you're okay with the idea that they may be legally obligated to follow up on some kinds of incidents
17:50:55 <aprice> yeah, that was what i was about to say. even if someone doesnt want it reported, we may be legally obligated to
17:51:01 <aprice> so it's definitely a fine line
17:51:39 <spotz> I think using like complaintant and offender might be older wording as well
17:51:52 <fungi> cases like that could i suppose start with a hypothetical probe, but i'm unsure how to outline that sort of process in plain english
17:52:35 <spotz> Here's their updated reporting
17:52:37 <spotz> #link https://www.djangoproject.com/conduct/reporting/
17:53:14 <spotz> And this is definitely not something we're going to solve in one meeting but maybe put aside time for a bit each upcoming meeting like we did the survey and see what we can come up with
17:54:38 <fungi> to be fair, i don't see anywhere in the django coc reporting guide which says that you can ask them not to follow up on a report
17:54:55 <fungi> but also, one major difference i see is the scope
17:55:12 <spotz> I think it's the use of may
17:55:30 <diablo_rojo> (5 min left)
17:55:55 <fungi> our coc includes reporting guidelines and process for the response, whereas django's just has the first thing and then an explanation of what to expect from the process but not the process itself
17:56:27 <spotz> Maybe we can get Aeva to join us next meeting?
17:56:45 <fungi> #link https://github.com/django/code-of-conduct/blob/master/reports.md
17:56:50 <fungi> that seems to be the equivalent for them
17:57:03 <aprice> yeah, i think that showing exact places, because i think that there are places where ours tries to add things like "if any" noting that sometimes no additional action is taken
17:57:25 <aprice> so it may be worth going through and highlighting the issues and doing it all in one round so we can see what changes are needed / possible
17:57:34 <spotz> If it's as simple as will/may and toning down complainant/offender type wording is different then us throwing things out and redoing
17:57:41 <fungi> we could be like them if we moved the process somewhere else and replaced it in the coc text with a brief bit which sets expectations
17:58:10 <spotz> I'll ping Aeva at least for some clarification if they can't join in
17:58:22 <spotz> #topic open discussion
17:58:30 <aprice> i think that will / may would be a hard change to accomplish fwiw
17:59:08 <spotz> I'll skip Grace Hopper except to say we've accepted the invitation to be there and we'll be doing something Horizon related I hope with resources donated by City Network
17:59:31 <spotz> I haven't actually tried doing what I'm hoping to do yet:)
17:59:36 <fungi> also one other significant difference is that django's coc response handling is done by a committee of community volunteers, not a legal entity, so they may not be legally obligated to follow up on things the osf is
17:59:39 <spotz> Anyone have anything for the last minute?
17:59:53 <spotz> fungi: good point
18:00:45 <spotz> Ok thanks for coming everyone, we'll continue at least the CoC stuff next meeting!
18:00:48 <spotz> #endmeeting