13:01:53 <annegentle> #startmeeting Doc Team Meeting
13:01:53 <openstack> Meeting started Tue Jul  9 13:01:53 2013 UTC.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:56 <openstack> The meeting name has been set to 'doc_team_meeting'
13:02:00 <Daisy> hello
13:02:08 <fifieldt> big team :D
13:02:13 <annegentle> yeah, great!
13:02:15 <annegentle> #topic Action items from the last meeting
13:02:26 <annegentle> the action was for EmilienM create a blueprint on openstack-manuals to link to https://etherpad.openstack.org/HA-Active-Active
13:02:29 <annegentle> that's done
13:02:51 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/improve-high-availability-support
13:03:07 <annegentle> and this one was just for posterity
13:03:08 <annegentle> NickChase to convert google docs to docbook, when the time comes
13:03:17 <roadnick> right, turns out that it's in Asciidoc
13:03:22 <EmilienM> o/
13:03:25 <roadnick> so it's less of a hassle than we expected.
13:03:28 <annegentle> sure
13:03:31 <annegentle> cool roadnick
13:03:50 <annegentle> EmilienM: how goes it?
13:03:52 <koolhead17> hi
13:04:06 <EmilienM> annegentle: Nick and I continue the work
13:04:11 <roadnick> And Emilien's been converting his own stuff as well
13:04:12 <annegentle> EmilienM: sounds good
13:04:21 <annegentle> last Action item, sld get in touch with conf file code people to collaborate
13:04:26 <EmilienM> my next step is Network node in HA
13:04:29 <annegentle> sld did so via email
13:05:16 <annegentle> I did add some agenda items this morning, so next up is
13:05:18 <annegentle> #topic Completion of Security Guide book sprint
13:05:35 <annegentle> Congratulations to the team! It's 227 pages in PDf in Crown Quarto format.
13:05:54 <annegentle> Plus dcramer_ already converted it and we're patching to get PDF and HTML
13:05:54 <slong_> Impressive stuff!
13:05:55 <EmilienM> wow
13:06:00 <EmilienM> great job guys
13:06:05 <fifieldt> +1
13:06:10 <annegentle> #link http://docs.openstack.org/sec/
13:06:31 <annegentle> Already getting requests for it and attention on the epub, really great stuff.
13:06:32 <roadnick> nice!
13:06:40 <annegentle> I've encouraged them to present as a panel at the Summit
13:06:40 <sarob> cool
13:06:46 <koolhead17> good idea
13:06:58 <annegentle> and invited bdpayne to be on doc-core
13:07:06 <annegentle> so all around great event, great outcome
13:07:22 <annegentle> anyone from the sprint here and want to say anything?
13:07:40 * annegentle doesn't see anyone right away
13:07:46 <lorin1> I just did some reviewing on one of the days, but I thought they did a really great job.
13:07:51 <koolhead17> annegentle: so we have someone who will lead the whole security doc related fix/upgrade
13:07:53 <koolhead17> *identified
13:08:00 <lorin1> It was a good group of people assembled for that.
13:08:12 <annegentle> koolhead17: the team is very keen to keep updates and be part of the process
13:08:22 <annegentle> koolhead17: bdpayne has esp. stepped up
13:08:34 <koolhead17> annegentle: great than.
13:08:43 <lorin1> I think book sprints may be a useful mechanism for drawing people into the doc effort.
13:08:48 <annegentle> lorin1: did it feel like a larger group than the Ops one? From pics I couldn't tell
13:08:57 <fifieldt> looked it to me
13:09:01 <annegentle> lorin1: agreed
13:09:08 <lorin1> It was a slightly bigger group
13:09:17 <sgordon> on the list i saw it was supposed to be around 15
13:09:28 <fifieldt> 13  listed on the cover page
13:09:36 <annegentle> sgordon: yeah I don't know if they got all 15, 2 were MIA
13:09:43 <sarob> something we should copy for the training manuals?
13:09:44 <annegentle> fifieldt: yeah that sounds right
13:09:58 <annegentle> sarob: a sprint is a powerful mechanism, costs about $10k-15k
13:10:19 <sarob> why costs?
13:10:24 <annegentle> sarob: with a specific goal and team assembled it might make sense, could certainly talk through it
13:10:35 <annegentle> sarob: flying everyone in, paying for facilitation, possibly renting space
13:10:41 <sarob> ah, right
13:11:00 <roadnick> Mirantis would be interested in doing a sprint
13:11:01 <annegentle> sarob: contact me for more details if you want to know all the gory guts of it :)
13:11:02 <sarob> maybe
13:11:08 <annegentle> roadnick: what topic?
13:11:11 <sarob> will do
13:11:41 <roadnick> I'm not sure yet; HA perhaps.
13:11:41 <annegentle> roadnick: or just funding one?
13:12:01 <fifieldt> (annegentle, minor note to clean up for the sec guide - there's two near-identical reviews open for infra/config https://review.openstack.org/#/c/35592/ & https://review.openstack.org/#/c/36102/ )
13:12:04 <annegentle> roadnick: ok we could certainly talk more about details
13:12:07 <roadnick> I was handed goals for Q3, which included "host an upstream sprint".
13:12:14 <annegentle> fifieldt: aw man
13:12:26 <roadnick> Boris is sick this week, so I haven't gotten details yet.
13:12:34 <koolhead17> roadnick: sounds good!!
13:12:51 <koolhead17> roadnick: the HA sprint idea
13:12:55 <annegentle> fifieldt: he hadn't assigned himself so i picked it up. Drat
13:13:05 <roadnick> I think he would have jumped on the boot camp if Rackspace wasn't hosting that. :)
13:13:16 <annegentle> roadnick: oh that's cool. We can certainly talk.
13:13:19 <roadnick> in fact, I know he would
13:13:32 <roadnick> k
13:13:39 <annegentle> roadnick: and we're just offering space so we could certainly adjust
13:13:47 <roadnick> ok, let's talk.
13:13:50 <annegentle> ok, great
13:13:55 <annegentle> #topic v3 Compute API doc plan
13:14:42 <annegentle> just to give the background, there was a thread started by Chris Yeoh about which extensions would be deprecated for v3
13:14:59 <annegentle> I suggested they need to get the word out beyond just the -dev mailing list and really what they need is a document
13:15:24 <annegentle> I still don't have a clear plan from the nova team about what they want to do to document v3
13:15:41 <sgordon> there is clearly a wider issue here about API upgrades in general though IMO
13:15:44 <cyeoh> well what I'd like is at least something similar to what we have for V2
13:15:59 <annegentle> cyeoh: sure, makes sense
13:16:10 <cyeoh> eg. something that can be used a reference/spec for anyone wanting to develop against v3.
13:16:12 <annegentle> cyeoh: and you know all the pieces and parts for that now
13:16:30 <cyeoh> and my thought was that if we can make the process easier for the doc team by what we do on the Nova side, then we'll do that
13:16:35 <annegentle> cyeoh: you know about the openstack/compute-api repo right? That's where the spec is housed
13:16:54 <annegentle> cyeoh: the doc team doesn't write specs, the original v2 spec for Compute was written by Jorge Williams.
13:17:21 <annegentle> cyeoh: for sure, we definitely like what nova does for response/requests already, it's great
13:17:29 <cyeoh> annegentle: i haven't actually looked at it - I don't know much about the whole process except for what Tom was helped me understand :-)
13:17:45 <annegentle> cyeoh: okay, yup, and I was on vacation last week
13:18:08 <cyeoh> ah I didn't realise that about the original V2 spec
13:18:11 <annegentle> cyeoh: so the openstack/compute-api repo is specifically set up for governance by the nova core team with doc-core also having +2 privileges
13:18:23 <annegentle> cyeoh: but the openstack-api-site repo is where all the extensions are documentd
13:18:35 <annegentle> cyeoh: and since compute is so extension heavy it seems out of balance
13:18:43 <annegentle> cyeoh: but there is a pattern there :)
13:18:50 <annegentle> cyeoh: just making sure you know the history
13:19:00 <annegentle> cyeoh: the original v2 spec has WADL and XSDs that validate
13:19:13 <annegentle> cyeoh: I don't get the sense that anyone's stepping up to do that for v3
13:20:00 <annegentle> cyeoh: and v2.0 Identity is the only other spec that had full WADL and XSD
13:20:10 <cyeoh> annegentle: ah yea I was kind of hoping that all we'd need to do is produce the api samples (plus a bit more if we can), but looks like it might be more required?
13:20:17 <cyeoh> (we from the Nova side that is)
13:20:32 <bitcoinnn> tutorial - how to get free bitcoins daily - http://imagetwist.com/hen1q41kb9bu/bitcoin.jpg.html
13:20:46 <cyeoh> and um, to be honest I'm really unfamiliar with WADL/XSD
13:20:48 <annegentle> cyeoh: well I think nova should provide an app dev reference, also known as a spec
13:20:54 <annegentle> cyeoh: yeah fair enough.
13:21:07 <annegentle> cyeoh: other PTLs just write it all down in markdown in their project-api repo
13:21:16 <roadnick> cyeoh:  If you are willing to do the coding, I can help you with WADL/XSD
13:21:28 <annegentle> cyeoh: the main thing you need to provide is enough info for an SDK dev to know how to update their code to fit v3
13:21:59 <annegentle> cyeoh: WADL is a good step that way since we have tooling around it
13:22:01 <cyeoh> roadnick: thanks!
13:22:08 <annegentle> roadnick: cool
13:22:34 <annegentle> ok can't really spend all the meeting on v3 but that should give you a good next step or two or three
13:22:40 <cyeoh> annegentle: ok. it sounds like I need to have a good look at  the openstack/compute-api repo
13:22:47 <cyeoh> to better scope out what we need to do
13:22:51 <sarob> cyeoh: theres a guy on my team that wants to help on the API docs
13:22:52 <annegentle> cyeoh: sounds good.
13:22:59 * fifieldt senses an action item :)
13:23:07 <dianefleming> what was the topic? I came in late - regarding v3?
13:23:10 <annegentle> sarob: that would be awesome you can tell we need it
13:23:17 <annegentle> dianefleming: yeah v3 compute
13:23:25 <dianefleming> thx
13:23:26 <cyeoh> sarob: that would be really helpful as we're very under resourced for this
13:23:51 <sarob> cyeoh: no prob, ill put him in touch with you
13:23:56 <annegentle> #action cyeoh to study openstack/compute-api for the v2 docs
13:24:02 <cyeoh> sarob: thx!
13:24:06 <annegentle> #action roadnick to help with WADL for Compute v3
13:24:15 <annegentle> #action sarob to get cyeoh in touch with API docs volunteer
13:24:25 <annegentle> any more?
13:24:42 <annegentle> #topic Install guide plan
13:24:43 <roadnick> On that, or in general?
13:24:51 <annegentle> roadnick: open discussion will come
13:24:57 <annegentle> shaunm needs hardware, requesting from Cisco
13:25:12 <annegentle> does anyone else have access to hardware that shaunm could use to test install instructions?
13:25:20 <annegentle> vbox all the way down only goes so far :)
13:25:31 <koolhead17> annegentle: i need HW too :)
13:26:01 <sarob> annegentle: im working on getting public access hardware setup
13:26:06 <koolhead17> especially for nova/quantum. Vbox covers rest
13:26:07 <annegentle> sarob: ohhh cool
13:26:15 <sgordon> yeah quantum is troublesome
13:26:17 <annegentle> koolhead17: yeah it's neutron that's the most difficult
13:26:27 <sgordon> even with hardware it clashes with corporate network setups a bit
13:26:28 <annegentle> shaunm has been using old laptops
13:26:29 <sarob> annegentle: prim for rhok, but we could use too
13:26:46 <koolhead17> sgordon: true. corporate firewall :)
13:26:51 <annegentle> I had always wished trystack could give access
13:27:05 <sarob> it may take a few months though
13:27:12 <annegentle> anyway, it's a known difficulty with writing install docs
13:27:19 <annegentle> we'll keep trying
13:27:36 <koolhead17> soren: we can use 2 test new release :)
13:27:45 <annegentle> dianefleming: I had another "User Guide status" topic on the agenda, but it was just holdover
13:27:54 <annegentle> dianefleming: do you want to give an update?
13:28:03 <dianefleming> ok -
13:28:05 <annegentle> #topic User Guide status
13:28:10 <annegentle> ok
13:28:26 <dianefleming> the update is, I'm still working on the User Guide but got sidetracked on Identity v2.0 and v3 stuff -
13:28:41 <dianefleming> I hope to have a first draft of User guide ready for review by next Monday -
13:28:52 <dianefleming> I'll let everyone know by way of the docs d-list
13:29:01 <dianefleming> I'll point people to the review
13:29:05 <dianefleming> does that sound okay?
13:29:12 <annegentle> dianefleming: sounds good
13:29:18 <sgordon> yup, excellent
13:29:20 <annegentle> yeah v3 Identity also came out of the woodwork
13:29:22 <dianefleming> follow-on to that is the admin user guide
13:29:27 <annegentle> dianefleming: ah yes
13:29:33 <koolhead17> dianefleming: great
13:29:46 <annegentle> dianefleming: still think that's the way to go, "admin user guide" or do we just go with "admin guide?"
13:30:00 <annegentle> (not that the title is crucial but...)
13:30:00 <roadnick> good question
13:30:07 <roadnick> well, its one book or two
13:30:09 <annegentle> trying to determine whether we have an overarching like roadnick suggests
13:30:09 <dianefleming> i like the "end user guide" and "admin user guide" that we are using as a model
13:30:13 <roadnick> and I do have updates on that...
13:30:19 <annegentle> roadnick: sure
13:30:30 <roadnick> I agree with diane on that; I think it's good to have those two
13:30:30 <dianefleming> overarching?
13:30:33 <annegentle> actually let me hijack the user guide topic to let you discuss admin user guide :)
13:30:49 <roadnick> OK, but you hijacked it, not me. :)
13:30:51 <dianefleming> i haven't had time to look at your blueprint yet, nick
13:30:56 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/modularize-admin-guide
13:31:14 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/os-admin-docs
13:31:18 <roadnick> Right.
13:31:25 <annegentle> #topic Admin docs
13:31:34 <annegentle> and hijacked! Thanks dianefleming
13:31:58 <roadnick> So Nermina Miller (who should be here) and I went through the current docs and reorganized them by concept.
13:31:59 <annegentle> roadnick: you have the floor
13:32:07 <roadnick> thank you, ma'am!
13:32:21 <dianefleming> here's the blueprint for admin user guide: https://wiki.openstack.org/wiki/Blueprint-os-user-docs#Blueprint_-_OpenStack_Admin_User_Guide
13:32:23 <roadnick> The idea was to break out of the usual way of thinking aobut it
13:32:48 <roadnick> and to think about it more like a book about it than a collection of instructions.
13:33:06 <nermina> hello everyone
13:33:10 <dianefleming> hi!
13:33:14 * roadnick waves to Nermina
13:33:17 <slong_> Hi
13:33:36 <dianefleming> roadnick i looked at your blueprint - it looks like your idea is to single-source one to multiple books from one set of source files
13:33:39 <dianefleming> is that right?
13:33:43 <roadnick> correct.
13:33:46 <roadnick> well, sort of
13:34:04 <dianefleming> auth 2.0 tried to do that and it had problems, but i can tell you what they were
13:34:07 <koolhead17> does this also cover distro specific install instructions
13:34:07 <sgordon> does clouddoc-maven support docbook "sets" ?
13:34:15 <roadnick> the idea is to make it possible to keep the multiple books, but make it possible to bring them together
13:34:33 <roadnick> dianefleming: that would be useful, thanks
13:34:37 <dianefleming> you could have multiple book files - each one pulls in different common files
13:34:40 <roadnick> sgordon: I don't know
13:34:43 <dianefleming> to create different books?
13:34:44 <sgordon> right
13:34:48 <lorin1> I do like the idea of presenting the books as a coherent set of manuals.
13:34:53 <sgordon> typically that is how you pull multiple "books" together
13:35:01 <sgordon> we use it with publican but somewhat infrequently
13:35:03 <roadnick> well, I did a test doc that pulled together multiple books as a single book
13:35:12 <sarob> that would be cool for training too
13:35:22 <annegentle> sgordon: I dont' know if the plugin supports sets but I'll take an action item to find out
13:35:23 <dianefleming> however, i think there's a first step, which is to outline what would go into each "book" before deciding how to implement this
13:35:28 <roadnick> we will need a bit more work to get more granular in pulling -- say, XPointer rather than just a file
13:35:38 <annegentle> #action anne to find out if our maven plugin supports sets
13:35:46 <dianefleming> what is a "set"?
13:35:46 <sgordon> dianefleming, yes - these only work well if the information architecture of each stands on its own
13:35:49 <roadnick> dianefleming:  that's why I broke them out into two blueprints
13:35:50 <sgordon> http://www.docbook.org/tdg/en/html/set.html
13:36:01 <roadnick> sgordon: thanks, I'll have a look at that
13:36:07 <sgordon> A Set is a collection of Books.
13:36:11 <sgordon> Set is the very top of the DocBook structural hierarchy. There's nothing that contains a Set.
13:36:14 <sgordon> is the main two things
13:36:21 <dianefleming> thanks
13:36:22 <sgordon> other items are left up to the implementation
13:36:40 <dianefleming> so a set is a parent to a book?
13:36:43 <sgordon> publican for instance will pull books into a set even if they are from completely different source control repos
13:36:44 <sgordon> yes
13:36:46 <roadnick> so we have the blueprint that includes the TOC; if we can agree on that, then we can start figuring out what content exists and can be used "as-is" and what needs to be wrtten
13:36:57 <annegentle> koolhead17: no an admin guide will not also cover distro specific install
13:36:58 * fifieldt likes the idea, but notes that if we're doing anything 'comprehensive', it's probably going to land post-havana ...
13:36:59 <sgordon> you can use it to combine multiple books into a "megabook" for want of a better term
13:37:05 <roadnick> what we do NOT plan to do is just assume that every book is pulled in wholesale.
13:37:11 <sgordon> right
13:37:27 <koolhead17> annegentle: cool
13:37:28 <roadnick> Each project is an entity in and of itself; some books, as has been pointed out, are well maintained, some are not.
13:37:29 <annegentle> I'm with fifieldt on scope
13:37:35 <roadnick> Some will fit with this structure, some will not.
13:37:54 <annegentle> roadnick: your criteria for inclusion?
13:38:00 <roadnick> I missed fifieldt's scope comment
13:38:08 <fifieldt> * fifieldt likes the idea, but notes that if we're doing anything 'comprehensive', it's probably going to land post-havana ...
13:38:11 <annegentle> roadnick: the timing of post-havana
13:38:33 <sgordon> for what it's worth summer is really wanting to get involved in this full time but we're looking to make sure there is a clear direction to follow here
13:38:39 <annegentle> roadnick: we do have time (I think) for dianefleming (or I should ask dianefleming if that's accurate)
13:38:44 <fifieldt> this is refering to producing the actual guide -- I think we've already started on the modularity work with the various other restructure blueprints
13:38:45 <sgordon> ("this" being admin materials)
13:38:46 <roadnick> I think that's fine
13:38:46 <annegentle> sgordon: yes agreed
13:38:47 <koolhead17> fifieldt: that also means we will need to add many new studd
13:38:47 <koolhead17> *stuff
13:38:57 <fifieldt> yes, that's the issue koolhead17
13:38:58 <dianefleming> studds
13:39:00 <roadnick> but I don't think it would hurt to start now
13:39:06 <slong_> Hadn't seen that you'd posted the blueprints riadnick, will view asap
13:39:11 <roadnick> and try to land it as close to havana as possible
13:39:29 <sgordon> speak of the devil :)
13:39:33 <fifieldt> to be honest, I think we already have too much work roadnick :)
13:39:34 <roadnick> I will post the blueprints to the list; they were just finished
13:39:35 <koolhead17> fifieldt: will that require us doc sprint every release for all these guides?
13:39:38 <annegentle> welcome slong_
13:40:00 <slong_> O/
13:40:02 <annegentle> koolhead17: I'd like to talk about that in the Program discussion because yes, only a very few guides will be released at release time
13:40:13 <fifieldt> koolhead17, I'm just noting that we have a ton of restructure work to do before we can do mass content adds again :)
13:40:19 <roadnick> fifieldt:  that's fine with me
13:40:19 <annegentle> fifieldt: right
13:40:30 <fifieldt> roadnick, I would be very happy to be wrong :)
13:40:34 <roadnick> :)
13:40:48 <annegentle> let's keep talking becaue I think this is shaping us towards 2 more topics, the auto-gen and the Program...
13:40:48 <roadnick> Nermina has been working on bugs -- though we have some issues getting her connected that we need help wtih
13:40:50 * koolhead17 is not intersted in re-writing same every release
13:40:55 <annegentle> #topic Auto-generated configuration reference tables for milestone
13:40:57 <fifieldt> maybe we will just finish the restructure this month - we can try :)
13:41:01 <roadnick> but when she's done maybe she can help on that, and then when that's done we can start
13:41:08 <annegentle> orignally we wanted to generate the config tables each milestone, if my memory serves
13:41:16 <fifieldt> sounds correct :)
13:41:25 <annegentle> we do have the patch in review now
13:41:27 <annegentle> #link https://review.openstack.org/#/c/35726/
13:41:29 <fifieldt> #link https://wiki.openstack.org/wiki/Havana_Release_Schedule
13:41:39 <annegentle> fifieldt: I haven't tried it again this morning to see if I can generate cinder
13:41:54 <fifieldt> code's not much different annegentle, need to look into it with sld :(
13:42:00 <lorin1> There's a patch into keystone to actually add their doc strings.
13:42:10 <annegentle> lorin1: ok
13:42:16 <fifieldt> an important feature missing from the code right now (as noted by lorinh) is the ability to update the mapping files
13:42:20 <annegentle> fifieldt: ok fair enough
13:42:20 <fifieldt> i.e. detect new options added
13:42:28 <fifieldt> so you can add the categories just for that
13:42:30 <annegentle> fifieldt: I think a good test will be to spin up a Jenkins slave and run it there
13:42:32 <fifieldt> but that's not too hard to do
13:42:44 <fifieldt> sounds good to me
13:42:45 <annegentle> fifieldt: they have a script that'll create a Jenkins slave
13:42:52 <annegentle> fifieldt: ok cool, that's probably how I should've been testing already
13:43:06 <annegentle> fifieldt: so are you still good with the shape of the config guide?
13:43:08 <fifieldt> it should have worked - apologies it has been soo much trouble annegentle
13:43:15 <annegentle> fifieldt: nah no worries
13:43:19 <annegentle> fifieldt: testing is good for me!
13:43:27 <annegentle> fifieldt: I like how the config guide is going
13:43:36 <fifieldt> slowly crafting things
13:43:41 <fifieldt> modularising
13:43:47 <annegentle> it's the admin guides that we're going to struggle with
13:43:50 <annegentle> seems like anyway
13:43:52 <fifieldt> I should show you some of the patches roadnick
13:43:56 <roadnick> sure
13:44:00 <fifieldt> since they're examples of modularising
13:44:03 <fifieldt> I'd hope you'd approve of
13:44:05 <fifieldt> :)
13:44:08 <roadnick> :)
13:44:15 <roadnick> I'll learn something if nothing else
13:44:43 <annegentle> fifieldt: so how will it work to update the tables?
13:44:46 <fifieldt> if you can follow https://review.openstack.org/#/c/35027/, it's a few moves along those lines
13:44:51 <fifieldt> annegentle, what needs to happen is
13:44:58 <fifieldt> 1. update mapping tables based on milestone code
13:45:07 <fifieldt> 2. run the tool over the code to generate new xml tables
13:45:15 <fifieldt> 3. submit a gerrit patch with the new xml tables
13:45:29 <fifieldt> steps 2/3 are the easy ones
13:45:38 <fifieldt> 1 is not too hard, if the code to make it easy is in place
13:46:03 <annegentle> fifieldt: okay sounds good... wish I could run step 1 myself but oh well :)
13:46:10 <fifieldt> apologies again
13:46:14 <fifieldt> you can assign it to me/sld and we'll get it done, if you like :)
13:46:17 <annegentle> lorin1: were you able to get it to work?
13:46:25 <fifieldt> I will also try and get the code working on some other environments
13:46:42 <lorin1> I tried it with nova, and it generated the DocBook for me.
13:46:45 <annegentle> fifieldt: yes, please run the tables -- we need to start editing the descripitions as some are quite crap. :)
13:46:55 <annegentle> lorin1: ok I'll try that. Maybe it's cinder.
13:47:10 <fifieldt> indeed - recall all - option strings are now edited in code, rather than in docs :)
13:47:31 <annegentle> fifieldt: right... my thinking exactly, we need tons of time to get those patches reviewed and in
13:47:44 <annegentle> ok any questions on the config guide and autogen tables?
13:48:03 <annegentle> slong_: the config guide might also be a good place to get started?
13:48:17 <annegentle> slong_: if you study what fifieldt has been doing and it makes sense to do more patching, feel free to hop in
13:48:21 <slong_> Sure!
13:48:25 <annegentle> slong_: ok cool
13:48:34 <koolhead17> dianefleming: good work with the docs. :)
13:48:34 <annegentle> #topic Documentation is now a Program, needs leader and mission statement
13:48:51 <slong_> Will have a chat with fifieldt
13:48:57 <fifieldt> cheers slong_
13:48:59 <dianefleming> thanks!
13:49:05 <annegentle> so this is the good news out of last week's technical committee meeting
13:49:11 <annegentle> Documentation is now a Program
13:49:15 <koolhead17> annegentle: o/
13:49:20 <annegentle> koolhead17: yeah
13:49:24 <fifieldt> congratulations :)
13:49:44 <roadnick> yay!
13:49:44 <sarob> :)
13:49:46 <koolhead17> so finally i will become official OS contributor
13:49:56 <annegentle> koolhead17: you were already but this move cements it
13:50:04 <annegentle> We need a name, acting PTL, and a Mission Statement.
13:50:10 <annegentle> Here's what Monty has for Infrastructure.
13:50:11 <koolhead17> sounds cool
13:50:16 <annegentle> #link http://lists.openstack.org/pipermail/openstack-dev/2013-July/011471.html
13:50:25 <annegentle> it's simple, and to the point
13:50:55 <lorin1> annegentle: What are the implications of being a "Program"? Is there a page somewhere that describes this?
13:51:21 <annegentle> lorin1: yes, it involes changes to the governance on the wiki, just a min.
13:51:32 <sgordon> they updated https://wiki.openstack.org/wiki/Governance/Foundation/TechnicalCommittee
13:51:36 <annegentle> #link https://wiki.openstack.org/w/index.php?title=Governance%2FFoundation%2FTechnicalCommittee&diff=25309&oldid=24429
13:51:43 <annegentle> yep, and that one shows the changes.
13:51:58 <annegentle> lorin1: the essence is
13:51:59 <annegentle> OpenStack "Programs" are efforts which are essential to the completion of the OpenStack project mission, which is ''to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable''. Programs can create any code repository and produce any deliverable they deem necessary to achieve thei
13:51:59 <annegentle> r goals.
13:52:04 <sgordon> the bigger difference is for some other projects
13:52:05 <annegentle> sorry for the big paste
13:52:09 <sgordon> which didnt get ATC status
13:52:12 <sgordon> automatically
13:52:14 <annegentle> sgordon: right
13:52:42 <annegentle> and I like that we can create any repo we need to get the job done. Which we were doing already. but I like it spelled out
13:52:42 <slong_> Thx for that clarification
13:53:01 <annegentle> it does mean that documentation is part of the integrated release
13:53:12 <annegentle> so we need to state which deliverables are part of that integrated release quite firmly.
13:53:25 <dianefleming> yes -
13:53:42 <fifieldt> fun!
13:53:46 <annegentle> and we'll need to redesign the docs.o.o page to reflect that integrated release
13:53:56 <koolhead17> annegentle: cool
13:54:15 <annegentle> so it requires more focus I believe... not sure how that'll exactly happen though with book sprints and etc.
13:54:35 <annegentle> my idea is that we'll have at least install docs for the integrated release
13:54:46 <annegentle> other ideas for scope on integrated release docs?
13:54:50 <koolhead17> annegentle: but install doc will still take time from the day new release comes
13:54:51 <sarob> annegentle: milestone deliverables now?
13:55:01 <sgordon> annegentle, i think ideally install and user at least
13:55:08 <annegentle> sarob: we don't do milesteon deliverables now
13:55:19 <annegentle> sgordon: ah yes, user guides
13:55:22 <sgordon> koolhead17, i disagree - it shouldnt really
13:55:35 <fifieldt> +1
13:55:36 <sgordon> we have access to the milestone builds of the code to work against
13:55:37 <annegentle> koolhead17: I don't htink we have much choice in the matter
13:55:47 <sgordon> for *manual* install instructions anyway
13:55:47 <annegentle> sgordon: but not packages
13:55:50 <sgordon> sure
13:55:53 <annegentle> sgordon: right :)
13:56:00 <sgordon> but as per my email yesterday i dont think that should be the focus
13:56:04 <annegentle> sgordon: we've not documented a manual install
13:56:20 * koolhead17 had his share in previous releases 2 achieve same
13:56:32 <annegentle> I'm hoping shaunm can document a manual install
13:56:39 <annegentle> koolhead17: true true
13:56:39 * fifieldt feels that package managers have won the install debate long ago for many purposes
13:56:48 <sgordon> yeah
13:56:54 <sgordon> what is the state of debian packaging
13:56:55 <annegentle> fifieldt: yep, too true
13:57:05 <sgordon> i know for RDO we are started to attempt havana nightlies *now*
13:57:12 <sgordon> *starting
13:57:16 <koolhead17> sgordon::P
13:57:17 <fifieldt> niice
13:57:19 <annegentle> sgordon: nice
13:57:31 <koolhead17> for ubuntu can anyway get from testing repo
13:57:35 <annegentle> next steps, I'll draft up a mission statement and send to the docs mailing list
13:57:40 <sgordon> http://repos.fedorapeople.org/repos/openstack/openstack-trunk/
13:57:54 <annegentle> do we want me to be acting PTL for now? Guess I should ask that!
13:57:58 <fifieldt> sounds good annegentle
13:58:03 <fifieldt> all hail annegentle
13:58:03 <sgordon> +1
13:58:04 <sarob> +1
13:58:06 <Daisy> agree
13:58:07 <annegentle> heh
13:58:08 <lorin1> +1
13:58:08 <koolhead17> annegentle: +1
13:58:10 <koolhead17> :)
13:58:11 <slong_> +q
13:58:16 <roadnick> +1 of course!
13:58:23 <annegentle> aw you do like me :)
13:58:26 * roadnick though Anne was already the PTL
13:58:27 <dianefleming> annegentle: +1
13:58:28 <slong_> :) +1
13:58:37 <annegentle> #action anne to draft a Mission Statement for Documentation and send to docs mailing list
13:58:45 <annegentle> roadnick: heh
13:58:53 <annegentle> roadnick: for all intents and purposes!
13:59:12 <roadnick> :)
13:59:26 <annegentle> ok any more questions on our new Program status?
13:59:43 <annegentle> I do have to do a small happy dance on that, seems like a long time coming!
13:59:47 <annegentle> Very excited about it.
13:59:49 * fifieldt also dances
13:59:56 <annegentle> #topic Bug report, DocImpact state
14:00:09 <annegentle> fifieldt has been doing awesome work keeping up
14:00:20 <annegentle> fifieldt: and the bad times of manual bug movements are over!
14:00:23 <fifieldt> it's much easier now :)
14:00:35 * koolhead17 2
14:00:38 <fifieldt> also, you would have noticed the spam reduction
14:00:39 <annegentle> fifieldt: well you always made it look easy, sheesh
14:00:46 <annegentle> fifieldt: yes, real discussions, woo!
14:00:47 <koolhead17> fifieldt: :)
14:00:48 <fifieldt> #link https://launchpad.net/openstack-manuals/+milestone/havana
14:01:12 <fifieldt> so if anyone feels like working on the ;confirmed bugs for havana, feel free
14:01:15 <annegentle> fifieldt: I did move about half the blueprints off that page to reflect what I think is really going to happen
14:01:20 <fifieldt> cheers
14:01:34 <annegentle> slong_: that is another idea for you and other newcomers, pick up bugs
14:01:40 <koolhead17> yes please especially pre essex
14:01:44 <koolhead17> i would say
14:01:57 <annegentle> slong_: I know some are intimidating but you definitely know how the life of a writer works I think :)
14:02:03 <slong_> Yeah, was talking to sgordon about that.
14:02:15 <annegentle> so my thinking on onboarding would be something like this:
14:02:24 <annegentle> 1. Go through Conventions and spell check a document.
14:02:38 <annegentle> 2. Pick up low-hanging-fruit bugs
14:02:38 <koolhead17> ooh BTW B1 for havana has landed in ubuntu repo as well https://wiki.ubuntu.com/ServerTeam/CloudArchive#Havana
14:02:43 <annegentle> 3. Pick up harder bugs
14:02:54 <annegentle> 4. Start really writing on the restructure stuff.
14:03:01 <annegentle> does that make sense? any other ideas?
14:03:13 <annegentle> I feel it's too tough to ask newcomers to skip to 4.
14:03:25 <fifieldt> I'd also suggest: keep in touch with others during the process
14:03:27 <sgordon> i think from my pov my concern is investing effort in content that may be obliterated as a result of the restructure
14:03:28 <fifieldt> we're here to help :)
14:04:00 <sgordon> it is pretty clear at some point there is going to need to be some culling of content to make the whole thing manageable
14:04:02 <annegentle> sgordon: absolutely a valid concern... but with merging and stuff, content doesn't just get obliterated...
14:04:03 <koolhead17> annegentle: also add get a core from every project involved with us
14:04:04 <koolhead17> :)
14:04:07 <annegentle> sgordon: at least I don't think so
14:04:22 <fifieldt> so far I've been 'splitting' content, rather than obliterating
14:04:29 <annegentle> sarob: koolhead17 reminds me that the timing is probably right now that programs are established to ask for a doc rep
14:04:30 <roadnick> sgordon:  I think that until the bugs are all squashed, we can't really do much of the restructuring anyway
14:04:44 <sgordon> roadnick, i dont think that is realistic
14:04:44 <annegentle> roadnick: oh you don't mean that :)
14:04:54 <sgordon> otherwise we will never restructure
14:05:00 <sgordon> it's a vicious cycle to get stuck in
14:05:01 <annegentle> sgordon: yeah I'm never deleting content so far
14:05:06 <annegentle> sgordon: right agreed
14:05:16 <sarob> annegentle:doc rep?
14:05:27 <roadnick> sgordon/annegentle:  well, not completely!
14:05:28 <annegentle> sarob: weren't you saying we need to make each project have a doc representative
14:05:40 <slong_> I am so just listening at this point.
14:05:41 <roadnick> I just mean that we need to make sure that the bugs DO get squashed for release.
14:05:45 <annegentle> slong_: :)
14:05:53 <annegentle> slong_: this is quite active for a doc team meeting
14:06:04 <annegentle> oh crum and we've gone over time
14:06:06 <slong_> Exciting..
14:06:08 <annegentle> #topic open discussion
14:06:11 <sarob> annegentle: the pdl idea, right
14:06:12 <annegentle> at least want to open it up!
14:06:15 <annegentle> I have 2 bits to share
14:06:34 <annegentle> One is, this week there's going to be an annoucement about  a travel support program for the Icehouse summit
14:06:37 <sgordon> annegentle, maybe i am misunderstanding roadnick's proposal for admin materials but it sounds like an implicit part of it is that not all content from existing admin guides would necessarily be in the restructured ones
14:06:40 * fifieldt is going to brush his teeth, hoping the water is back on, back in 2min
14:06:50 <annegentle> sgordon: ah right
14:06:52 <sgordon> and i am onboard with that if it would result in a more manageable and *correct* guide
14:06:56 <roadnick> true
14:06:59 <sarob> annegentle: yes, I think we should have an formal doc position in each project
14:07:02 <roadnick> but I think that maybe the first step...
14:07:12 <annegentle> sgordon: So far I've seen a need to for example, delete install info from the Networking Admin Guide.
14:07:21 <roadnick> is to go through and mark parts that may not make it into the restructure document.
14:07:26 <annegentle> so yeah, there are examples where deletion is needed
14:07:28 <sarob> annegentle: PDL is what we came up with
14:07:37 <annegentle> sarob: yeah Projet Doc Lead
14:07:38 <roadnick> because if the restructure doesn't happen until post-havana, those parts still have to be right when Havana is released
14:07:44 * annegentle can't spell
14:07:49 <roadnick> but at least you know where to NOT sweat blood
14:07:57 <annegentle> roadnick: I think realistically, some guides won't be updated for havanah
14:08:04 <roadnick> right
14:08:14 <annegentle> roadnick: but we need to ensure they're not marked as havana either :)
14:08:23 <annegentle> roadnick: that's the tricky bit, making a "release" doc site
14:08:28 <annegentle> something we havent' done before
14:08:34 <annegentle> we just released everything
14:08:34 <roadnick> How about this:
14:09:03 <roadnick> How about if we concentrate on an outline that shows what pieces WILL get carried over, so that we know that we need to focus there.  But...
14:09:13 * fifieldt back
14:09:18 <roadnick> we won't worry about writing the rest until everything else is done.
14:09:25 <annegentle> fifieldt: water out? Eek.
14:09:36 <koolhead17> roadnick: i read modular somewhere
14:09:37 <fifieldt> yeah, they're trying to fix the exploding pipes
14:09:44 <roadnick> this way the "fluff" will be a known quantity, addressing sgordon's concerns.
14:09:49 <annegentle> #action anne to float the Project Doc Lead idea to mailing list
14:09:51 <koolhead17> that will take care of it i guess or was it for the BOOKS
14:09:54 <annegentle> fifieldt: yikes
14:10:20 <annegentle> roadnick: so dianefleming's outline isn't wha tyou're thinking of, and you have another?
14:10:20 <Daisy> Hi, I'd like to discuss the publish of operation guide in Japnese and Chinese to the doc website.
14:10:21 <roadnick> koolhead17:  Yes.  that's correct.  the overall book will be made from modular pieces of other books.
14:10:27 <annegentle> Daisy: yes, go ahead
14:10:30 <fifieldt> annegentle, my life: http://www.goodreads.com/book/show/70256.High_Rise
14:10:42 <roadnick> Dianefleming has the admin user guide, which I think we should keep in addition to this.
14:10:46 <annegentle> roadnick: let's take the other discussion about admin guides to #openstack-docs so we can finish out the meeting
14:10:52 <roadnick> Maybe this is more of an Admin Reference Guide.,
14:10:55 <annegentle> roadnick: ooo
14:10:56 <annegentle> ok
14:11:01 <sgordon> at this stage i like diane's plan
14:11:02 <roadnick> annegentle:  agreed.
14:11:06 <sgordon> but perhaps that is because i can see it clearly
14:11:09 <dianefleming> roadnick - what is more of an admin reference guide?
14:11:10 <sgordon> :)
14:11:10 <Daisy> So the translation of Japanese are completed finished in Transifex. The Chinese in Transifex is not, but I'm sure the translation are finished but not in po format.
14:11:13 <annegentle> Daisy: sorry to make you wait so long
14:11:27 <Daisy> we are a big team and with a big mission.
14:11:29 <Daisy> it's all right.
14:11:31 <annegentle> Daisy: wow that's fantastic
14:11:35 <roadnick> dianefleming:  the "comprehensive" Administration Guide
14:11:42 <roadnick> Daisy:  great!
14:11:43 <dianefleming> ok!
14:11:57 <Daisy> so I want to try to publish operation guide in Japanese as the first case.
14:12:02 <annegentle> Daisy: so you need a way to publish
14:12:06 <Daisy> as the first test case.
14:12:13 <fifieldt> Daisy, what do we need to do to get the Japanese guide on docs.openstack.org ?
14:12:14 <annegentle> Daisy: the docs landing page needs even more work
14:12:22 <Daisy> yes. I need to understand the structure of the website, and where to put the Japnese version.
14:12:37 <fifieldt> do you want me to help run through the various components
14:12:43 <fifieldt> such as the maven build system?
14:12:48 <annegentle> Daisy: a couple of thoughts... the index.html lives in openstack-manuals in the www directory
14:12:55 <Daisy> I think we can brainstorming.
14:13:00 <annegentle> Daisy: we have a drop down now for each release
14:13:16 <annegentle> Daisy: when you click More Releases... you can see the drop down
14:13:27 <Daisy> I know the drop down.
14:13:37 <annegentle> Daisy: but is that too hidden?
14:14:07 <annegentle> is auto-detect yucky? as in, know what language their browser is and present a different landing page?
14:14:10 <Daisy> it's ok. I can see the drop down.
14:14:31 <annegentle> we could add a row for language choices at the top?
14:14:33 <Daisy> so maybe we want such a link: http://docs.openstack.org/jp/ ?
14:14:41 <Daisy> or http://docs.openstack.org/folsom/jp?
14:14:47 <annegentle> honestly I might want to get Todd Morey or a designer at the Foundation involved to redesign the landing page?
14:15:14 <fifieldt> (just on auto-detect: I know some people take issue with it, annegentle, but I'm not sure what the general consensus 'round the net is)
14:15:20 <annegentle> Daisy: maybe... that would work too, and just maintain them by hand in www/jp/ www/zh?
14:15:42 <annegentle> fifieldt: yeah I hear mixed feedback on auto-detect
14:15:57 <Daisy> we can add the drop down when the link is ready.
14:16:06 <annegentle> How about this -- fifieldt can you ask Mark/Todd/others if we can get a designer to help with the landing page for 1. translation 2. releases
14:16:32 <annegentle> then in the meantime we do something like what Daisy suggests, with docs.openstack.org/jp
14:16:43 <fifieldt> Sure, I'll do that
14:16:43 <fifieldt> maybe even some of the horizon UX folks might be interested?
14:16:48 <Daisy> annegentle: do you want index page in different languages too?
14:17:02 <annegentle> #action fifieldt to see design resources for the docs.openstack.org landing page for 1. translation 2. releases
14:17:09 <annegentle> Daisy: if possible, yes!
14:17:13 <Daisy> annegentle: I mean, for example, if users open http://docs.openstack.org/jp, he will see all jp characters and he will see the availabe jp documents.
14:17:27 <annegentle> Daisy: yes, that's what I'm thinking...
14:17:35 <annegentle> Daisy: and a link to transifex too possibly
14:17:47 <annegentle> Ok good thing no one needs this meeting room...
14:17:52 <annegentle> I'm going to end the logging
14:17:57 <annegentle> thanks everyone!
14:18:00 <annegentle> #endmeeting