20:01:09 <annegentle> #startmeeting Doc/Web meeting
20:01:10 <openstack> Meeting started Mon Sep 10 20:01:09 2012 UTC. The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:12 <openstack> The meeting name has been set to 'doc_web_meeting'
20:01:22 <annegentle> nice underbars
20:01:32 <annegentle> Agenda at http://wiki.openstack.org/Meetings/DocTeamMeeting
20:01:40 <annegentle> #topic Action items from last meeting
20:01:50 <annegentle> #info Done - Anne to send a memo to the mailing list about doc planning for Compute | Storage | Networking
20:02:01 <annegentle> I've been sending weekly updates, has anyone any feedback on those?
20:03:02 <annegentle> ok, moving alon
20:03:08 <annegentle> along
20:03:11 <annegentle> #topic Folsom doc bugs status
20:03:27 <annegentle> We're now at 18 open High priority doc bugs targeted for Folsom, down from 34 last week.
20:03:33 <annegentle> #link https://bugs.launchpad.net/openstack-manuals/+milestone/folsom
20:04:05 <annegentle> Nice work. Two of those 18 are related to Quantum docs which are definitely making progress.
20:05:02 <annegentle> We're still at 112 open bugs overall, 31 marked High, so plenty of work to be done.
20:05:28 <annegentle> #info We're still at 112 open bugs overall, 31 marked High, so plenty of work to be done.
20:05:54 <annegentle> #topic Summit planning
20:06:06 <annegentle> #info The doc track has three 40-minute slots.
20:06:58 <annegentle> #info Submit topics at summit.openstack.org
20:07:14 <annegentle> does anyone have any doc blueprints or topics for discussion?
20:07:34 <annegentle> #link http://summit.openstack.org
20:07:54 <annegentle> #info The sessions are allocated for first thing Monday morning, 9:30-lunchtime
20:08:48 <annegentle> I can definitely move on to blueprints then if no one has any suggestions for topics. I'd welcome doc topics.
20:09:02 <annegentle> #topic Blueprint status
20:09:26 <dwcramer> Question (back on doc topics)
20:09:30 <annegentle> sure go ahead
20:09:41 <dwcramer> Are there any doc tools related things people would like to know about?
20:10:21 <annegentle> I think a doc tools session would be interesting, do you want me to find out questions ahead of time?
20:10:42 <wabat> Do we mean tools like Oxygen?
20:10:46 <dwcramer> Yes. I was thinking there might be some specific topic...like a tutorial on foo.
20:10:48 <annegentle> Often we use the sessions for blueprints, maybe we do a doc tools session to come up with a blueprint or two?
20:10:56 <dwcramer> Sure.
20:11:12 <dwcramer> I haven't been to the summit before, so I don't know what usually goes on.
20:11:38 <dwcramer> wabat: Sure, like Oxygen or the clouddocs plugin.
20:11:52 <annegentle> This summit is going to be a good mix of "how to" and "blueprints"
20:12:06 <wabat> I for one would love more info on using Oxygen
20:12:15 <annegentle> this specific track is for future planning but can certainly be used for "how to"
20:12:18 <kpepple_> +1 for wabat
20:12:34 <annegentle> cool. dwcramer with a Launchpad login you can propose on the summit.openstack.org site
20:12:45 <dwcramer> Ok, will do.
20:13:06 <wabat> What about information gathering for docs content?
20:13:09 <annegentle> #action dwcramer to propose a doc tool how-to session for Summit
20:13:21 <annegentle> wabat: ah that's a good one, it's tough to know how/who to ask
20:13:28 <wabat> Exactly
20:13:39 <wabat> I've run into many roadblocks due to this
20:13:41 <annegentle> wabat: esp. for some of the doc bugs (nearly all the ones not yet triaged)
20:14:08 <wabat> Yes, it's hard to put an answer to something that you may not have the full knowledge of
20:14:18 <annegentle> wabat: mostly people email the mailing list so far, or ask coworkers, but it would be good to discuss
20:14:40 <wabat> Summit topic or no?
20:15:01 <annegentle> wabat: thinking… might not be enough for 40 minutes?
20:15:22 <wabat> YEah, I agree. PErhaps something else mixed in?
20:15:45 <annegentle> I think that bug triaging is related… as in, if you can get enough info into the doc bug itself, you're not so stuck.
20:16:31 <wabat> So bug triage and how to get answers
20:16:33 <annegentle> Maybe a session about triaging doc bugs and how to get enough info to triage them and update docs.
20:16:34 <annegentle> yup
20:16:52 <wabat> Sounds like a session unless anyone objects
20:17:04 <annegentle> Sure, can you propose it?
20:17:11 <annegentle> Even if you don't have all the answers? :)
20:17:12 <wabat> Yes I can
20:17:17 <annegentle> Ok, great
20:17:36 <annegentle> #action wabat to propose a doc bug triage and information seeking session for Summit
20:17:53 <annegentle> Ok, let's switch to blueprint status as it could also give ideas for the Summit.
20:18:25 <annegentle> We had four blueprints not really "targeted" for Folsom but certainly being discussed since the last design summit.
20:18:36 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/openstack-operations-manual
20:19:14 <annegentle> This is the operations manual, we now have an outlined structure ready to go at https://review.openstack.org/#/c/10487/
20:19:34 <annegentle> #help Fill in the outline structure at https://review.openstack.org/#/c/10487/ for an operations manual
20:20:28 <annegentle> Another blueprint is content sharing, we have a proof of concept and could demo it at the summit.
20:20:34 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/design-content-sharing
20:21:08 <annegentle> dwcramer: We presented the concept of content sharing at the last summit, not sure if we should do a show-n-tell, probably so!
20:21:25 <annegentle> dwcramer: seems like it would fit into the doc tools session
20:21:58 <annegentle> Another one is the Deployment template, not really finished though. A couple of reasons for that I think…
20:22:00 <dwcramer> Sure.
20:22:06 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/deployment-template
20:22:26 <annegentle> TryStack rolled out 2 deployments on Essex, neither was really documented though.
20:22:44 <annegentle> And MediaWiki, another candidate for a deployment template, mostly did a migration in the last 4-6 months.
20:23:15 <annegentle> so those contributing factors affected what we can do for a deployment template as those were the two I was hoping to document…
20:23:39 <annegentle> still, would welcome more ideas on how to handle - I still think it's a good idea, to document example deployments.
20:24:19 <annegentle> just need some examples that aren't in flux I guess?
20:25:01 <annegentle> And then the last two blueprints are more "implementation" related than content alone, API try-it-out and metadata in docs.
20:25:56 <annegentle> The person who created a prototype has a team of grad students who may be able to work on the API try-it-out implementation, still waiting a response from him.
20:25:58 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/api-try-it-out
20:26:40 <annegentle> Adding metadata to doc output helps with troubleshooting output. Not crucial but a nice-to-have.
20:26:42 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/doc-metadata
20:27:09 <annegentle> Metadata might be a good part of the doc tools session as well?
20:27:51 <annegentle> That's it for blueprints. Any questions?
20:27:58 <annegentle> Any more blueprints someone wants to propose?
20:29:04 <annegentle> Ok, next topic.
20:29:14 <annegentle> #topic Doc tools status
20:29:40 <annegentle> Here's a collection of what the tools team is working on this sprint:
20:29:41 <annegentle> http://bit.ly/Q9eGsu
20:30:22 <annegentle> These should offer better troubleshooting for doc builds, I think.
20:30:26 <annegentle> dwcramer: anything to add?
20:31:08 <dwcramer> Nope...hopeful that we can get those done in the next couple of weeks.
20:31:24 <annegentle> ok, great. I'll open it up for open discussion then.
20:31:27 <annegentle> #topic Open discussion
20:31:36 <wabat> I have something
20:31:54 <annegentle> sure, go ahead
20:32:09 <wabat> My company has me currently working on a different project
20:32:28 <wabat> They've not really allowed me the time I need to get more involved with the docs
20:32:33 <annegentle> wabat: rats!
20:32:43 <wabat> When I can it's usually on the weekend
20:32:58 <annegentle> wabat: too bad, but appreciate you saying so. It's funny, I get a ton of doc reviews on Friday nights (my time).
20:33:10 <annegentle> So I think there are others in the same boat
20:33:22 <wabat> Is there anyboday on the weekends who I can go to for answers?
20:33:38 <annegentle> hm, not really on IRC, but the mailing list usually gets responses
20:34:15 <wabat> Okay, I'll give that a shot
20:34:16 <kpepple_> simple question here: since we are after RC freeze, do I need to create a bug to get something changed in the manuals ? or can I just fire it up to gerrit ?
20:35:15 <annegentle> kpepple_: no need for a bug, just fire it up to gerrit
20:35:22 <kpepple_> thx
20:35:30 <annegentle> during the Essex timeframe we kept the stable/essex back ports going strong, also
20:36:29 <annegentle> Okay, I can give you back 24 minutes if you want!
20:36:39 <annegentle> Appreciate the input, all.
20:37:31 <annegentle> #endmeeting