13:01:37 <annegentle> #startmeeting Doc/Web team
13:01:38 <ladquin> good morning / evening / afternoon, folks
13:01:38 <openstack> Meeting started Tue Jun 11 13:01:37 2013 UTC.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:41 <openstack> The meeting name has been set to 'doc_web_team'
13:02:04 <annegentle> Agenda can be found at https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Agenda_for_next_meeting
13:02:18 <annegentle> #topic Action items from the last meeting
13:02:29 <annegentle> er maybe I should ask who all is here?
13:02:46 <annegentle> then again maybe I see all I need to :)
13:02:50 <sgordon> >.>
13:02:53 <annegentle> :)
13:02:55 <t4nk778> :>
13:03:07 <annegentle> 1. annegentle ask about DocImpact automation. Done, sld started a patch to automate
13:03:14 <annegentle> #link https://review.openstack.org/#/c/30718/ original patch
13:03:21 <fifieldt_> NickChase, writerDiane_, annegentle, koolhead17, sld, EmilienM (no lorinh or razique)
13:03:37 <annegentle> also fifieldt_ picked up the work while sld was on vaction
13:03:43 <koolhead17> hi all
13:03:50 <annegentle> at least that's what I got from reading through the links
13:03:52 <annegentle> #link https://review.openstack.org/#/c/32348/ new patch while sld went on vacay
13:04:04 <t4nk778> can someone help me with the nova live migration feature ?
13:04:17 <annegentle> looks like there are more TODOs to try to make it expandable for other impact flags, but we need to stop drowning in DocImpact emails.
13:04:24 * ladquin here
13:04:27 <fifieldt_> not in this channel t4nk778, we're having a meeting :) try #openstack
13:04:36 <t4nk778> ah ok ^^
13:04:40 <annegentle> fifieldt_: do you have any more details about DocImpact automation?
13:04:52 <annegentle> t4nk778: yeah we can try to help elsewhere though!
13:05:03 <fifieldt_> well, Steven did all the hard work
13:05:18 <fifieldt_> effectively making code that creates bugs in launchpad similar to what I'm doing now
13:05:25 <annegentle> fifieldt_: sweet
13:05:26 <sld> I do, sortof... by 'borrowing' some other code and then changing that, and generalizing it... ;)
13:05:37 <fifieldt_> then extended that so that it only makes one bug per DocImpact
13:05:46 <annegentle> sld: hehe isn't that the way it goes
13:05:53 <fifieldt_> the bugs will still need some triaging after being created
13:05:58 <fifieldt_> but it removes a silly manual process
13:06:02 <annegentle> fifieldt_: that sounds really more reasonable though
13:06:07 <fifieldt_> then there are extensions we can add
13:06:11 <fifieldt_> eg
13:06:12 <fifieldt_> 1) alter the text on bug update
13:06:12 <fifieldt_> 2) close bugs associated with abandoned patch sets
13:06:12 <fifieldt_> 3) mark patch-merged bugs as 'confirmed'
13:06:14 <fifieldt_> in the future
13:06:30 <annegentle> Freakin' nifty
13:06:49 <annegentle> esp. the close doc bugs when a patch gets abandoned
13:06:58 <annegentle> ok there was one more action item
13:07:05 <annegentle> 2. annegentle and sld meet to talk about install docs
13:07:25 <annegentle> Met, talked about install docs, docimpact, config automation. Probably about rain too since we are in Texas. :)
13:07:38 <annegentle> That was sld's action item too. Done and done.
13:08:15 <annegentle> Oh and I forgot to mention, fifieldt_ is going to take over the meeting later when I have to leave early... we sorted the agenda
13:08:22 <annegentle> ok next topic
13:08:23 <annegentle> #topic Shaun McCance starting June 20, contractor for Cisco
13:08:45 <annegentle> It took a pile of paperwork but Shaun's hired. Woo.
13:08:52 <fifieldt_> congratulations
13:08:53 <NickChase> Congrats
13:08:53 <annegentle> He's running the Open Help Conference June 15-19.
13:08:59 <annegentle> #link http://openhelpconference.com/
13:09:14 <annegentle> He'll be working on sorting through install guides to create explanatins for multiple architectures.
13:09:21 * annegentle can't spell
13:09:41 <sld> isn't that a requirement for someone working with docs? :)
13:09:45 <annegentle> The contract is 3 months if I recall correctly.
13:09:50 <annegentle> sld: pretty much!
13:10:12 <annegentle> I think we can all help Shaun get onboard
13:10:22 <fifieldt_> indeed
13:10:25 <fifieldt_> have to make the most of the time
13:10:25 <NickChase> Definitely
13:10:32 <annegentle> Oh and I made a blueprint for that install sorting.
13:10:34 <annegentle> #topic Install guides blueprint - https://wiki.openstack.org/wiki/Install-with-multiple-architectures
13:10:49 <annegentle> #link https://wiki.openstack.org/wiki/Install-with-multiple-architectures
13:11:21 <annegentle> Hoenstly part of the work is to figure out if that's the right approach (example architecture) but that sounded like what we decided at the Summit. Any discussion, questions?
13:11:38 <writerDiane_> I still think we could consolidate into one install guide
13:11:52 <annegentle> My only hesitation for a single install guide is that "everyone" wants a "simple test" one.
13:12:02 <sgordon> yeah
13:12:18 <annegentle> oh and my other hesitation is, the distros that have their own install guides, how do we differentiate ours as the "official" one?
13:12:24 <sgordon> problem is they also want expandable :)
13:12:34 <annegentle> sgordon: yeah
13:12:42 <writerDiane_> okay - that sounds reasonable - but they could share some common files and be made more consistent
13:12:46 <annegentle> So some of Shaun's work will be that analysis.
13:12:50 <writerDiane_> in organization and style
13:12:55 <annegentle> writerDiane_: for sure
13:12:58 <fifieldt_> cool
13:13:03 <NickChase> As the "official" one we're talking about the bare bones, no external tools version.
13:13:06 <annegentle> writerDiane_: that would greatly improve the install experience from docs.o.o
13:13:16 <writerDiane_> okay!
13:13:30 <annegentle> NickChase: right, can be core and integrated, but no more
13:13:47 <annegentle> NickChase: or we decide core only to lessen scope
13:13:58 <sgordon> i would +1 core only
13:14:15 <annegentle> sgordon: yeah might be the best to stick to core only, good input
13:14:23 <sgordon> from my pov as an employee of a vendor we are happy to maintain a doc for our specific deployment method
13:14:30 <annegentle> then we just coach the integrated on how to document their install processes
13:14:31 <fifieldt_> I would instead go "best practice"/"usual practice" :)
13:14:32 <sgordon> but would like to collaborate on 'manual' deployment
13:14:34 <sgordon> of the core
13:14:34 <annegentle> install/config
13:14:46 <writerDiane_> i think the horizon info can definitely move into the new user guide
13:15:04 <writerDiane_> or at least be shared
13:15:05 <NickChase> I think it'd be good to start with core only, but ultimately there should be "official" doc on how to install all "official" software.
13:15:09 <annegentle> sgordon: cool, Shaun is used to working in open source collaborations so I think he'll be very open to help
13:15:23 <NickChase> Diane:  I agree.
13:15:26 <sgordon> yes, will be meeting him for the first time on the weekend :)
13:15:26 <annegentle> writerDiane_: Horizon install/conig?
13:15:29 <annegentle> config
13:15:48 <annegentle> sgordon: aw cool! I so wish I could go but my son's camp dates prevented it...
13:15:57 <annegentle> I nearly bought a ticket last week in fact :)
13:16:32 <annegentle> fifieldt_: do you think we'll have some data for "usual" in the next few weeks from the user committee?
13:16:48 <annegentle> fifieldt_: it would be great to apply some of that knowledge (what lots of deployers are doing)
13:17:10 <annegentle> fifieldt_: or, are you familiar enough to tell Shaun what's best practice/usual?
13:17:10 <fifieldt_> that data will be months, rather than weeks
13:17:19 <annegentle> fifieldt_: ah ok
13:17:30 <annegentle> ok any more on install guide?
13:17:32 <fifieldt_> I'm just thinking of the approach from the ops guide
13:17:37 <annegentle> fifieldt_: yeah good one
13:17:39 <fifieldt_> which was opinionated
13:17:49 <annegentle> aren't they all :)
13:17:57 <annegentle> #topic User Guide - https://wiki.openstack.org/wiki/Blueprint-os-user-docs
13:18:06 <fifieldt_> mm.
13:18:13 <annegentle> writerDiane_ has been going great gangbusters on the user guide
13:18:32 <annegentle> writerDiane_: you want to talk about it? your findings re: sharing and user v admin user?
13:18:42 <writerDiane_> yes
13:19:13 <writerDiane_> i think it's possible to share, but the user guide I'm creating is going to be larger than the SUSE one - but I think that parts of it can use conditional tags
13:19:15 <writerDiane_> and be shared
13:19:29 <writerDiane_> but we can figure that out later -
13:19:34 <annegentle> Oy! And I have to go now, fifieldt_ you have the ocn.
13:19:36 <annegentle> er, con
13:19:39 <fifieldt_> ok
13:19:40 <fifieldt_> ta
13:19:42 <NickChase> Bye, Anne
13:19:45 <writerDiane_> bye anne
13:19:47 <annegentle> bye, thanks writerDiane_!
13:19:57 <fifieldt_> sounds impressive writerDiane_
13:20:06 <writerDiane_> tom, i also think we'll need an admin users guide
13:20:17 <fifieldt_> ok, two separate guides? cool
13:20:25 <NickChase> I was about to say that I was looking into splitting them out
13:20:28 <writerDiane_> that's what I'm thinking
13:20:32 <fifieldt_> cool, nice
13:20:46 <writerDiane_> both would have same format, but the admin guide would focus on admin-only tasks
13:20:53 <NickChase> and I am thinking that maybe you and I can get together to make sure nothing slips through the cracks?
13:21:02 <writerDiane_> sure nick
13:21:11 <NickChase> great, we'll schedule offline?
13:21:27 <writerDiane_> yes - i've written a similar guide for cloud servers at rackspace -
13:21:36 <writerDiane_> yes, schedule offline
13:21:38 <fifieldt_> brilliant work guys
13:21:55 <fifieldt_> shall we move on then? or is anything else bothering you about the user guide?
13:22:07 <writerDiane_> move on
13:22:09 <fifieldt_> ok!
13:22:12 <fifieldt_> #topic  Auto-generated configuration reference tables for milestone
13:22:21 <fifieldt_> so, you've probably seen the patches floating about
13:22:27 <fifieldt_> generated by Steven & I's code
13:22:34 <sld> ...not sure when we'll have that done, but you know the progress. :)
13:22:45 <fifieldt_> that runs through every python file in an openstack product and extracts options and their help text
13:22:51 <fifieldt_> recent patches to go in include
13:23:02 <fifieldt_> https://review.openstack.org/#/c/28904/
13:23:17 <fifieldt_> which went through and added config reference tables in the compute admin guide
13:23:32 <fifieldt_> if you're looking for something that might be an example of this fabled 'config reference'
13:23:37 <fifieldt_> check out the RPC section in that
13:23:43 <fifieldt_> and how it includes rabbit, qpid etc
13:23:58 <fifieldt_> we also have quantum (https://review.openstack.org/#/c/28905/) and glance(https://review.openstack.org/#/c/28903/)
13:24:02 <fifieldt_> the key problem right now
13:24:15 <fifieldt_> is that the config tables don't track which file to configure the options in
13:24:23 <fifieldt_> as raised in the quantum review and glancve
13:24:30 <fifieldt_> so that'll be the next step, capturing that
13:24:45 <fifieldt_> Steven was also working on some code today which might be more robust than what we're currently doing
13:24:48 <fifieldt_> ok, end of rant
13:24:49 <fifieldt_> any queries?
13:25:09 <sld> nope. :)
13:25:27 <fifieldt_> writerDiane_, NickChase is this whole automated config table thing making sense?
13:25:35 <writerDiane_> yes!
13:25:39 <NickChase> Yes.  I'm thinking...
13:25:47 <fifieldt_> a dangerous activity
13:25:56 <NickChase> :)
13:26:05 <NickChase> ... that it shouldn't be too much to include an ID in the docs and the code to match them up
13:26:37 <fifieldt_> perhaps we should discuss offline - thought through many things on making this work :)
13:26:45 <NickChase> sounds good
13:26:51 <fifieldt_> cool, I'll hit you on skype
13:26:55 <NickChase> great
13:27:13 <fifieldt_> ok, if there's nothing else .... ?
13:27:34 <NickChase> not on this
13:27:37 <fifieldt_> #topic  Bug report, DocImpact state
13:27:50 <fifieldt_> so, I think we covered this just before in the action items
13:27:53 <fifieldt_> sld, any comments?
13:28:36 <sld> nope
13:28:50 <sld> i think?
13:28:59 <sld> you know all i know. heh..
13:28:59 <fifieldt_> cool, is everyone else comfortable with what's going on with the DocImpact-becomes-bug process>?
13:29:09 <NickChase> I am
13:29:12 <writerDiane_> yes
13:29:16 <fifieldt_> brilliant, ta
13:29:20 <fifieldt_> in that case, we're on to ...
13:29:26 <fifieldt_> #topic  Open discussion
13:29:49 <fifieldt_> anything you want to talk about?
13:30:00 <NickChase> OK, well, briefly, I got with Emilien and we're going to expand the HA guide.
13:30:08 <fifieldt_> oh, great!
13:30:20 <NickChase> we decided to keep what is there and add the new content to it
13:30:23 <fifieldt_> did you sort out the active-active vs active-passtive thing?
13:30:30 <EmilienM> o/
13:30:41 <fifieldt_> it's alive
13:30:42 <NickChase> yes, we're going to do an intro that starts with the general concepts
13:30:48 <NickChase> Hey there. :)
13:30:53 <EmilienM> https://etherpad.openstack.org/HA-Active-Active
13:31:10 <fifieldt_> #link https://etherpad.openstack.org/HA-Active-Active
13:31:15 <fifieldt_> #info https://etherpad.openstack.org/HA-Active-Active
13:31:23 <fifieldt_> hmm, I was sure one of those fed the meet bot :)
13:31:33 <NickChase> And we have an Etherpad. :)
13:31:42 <fifieldt_> looks good
13:32:09 <NickChase> Anyway, the idea (as I understood it) was to start with concepts, then discuss them as potential ways to do it.
13:32:22 <fifieldt_> a sound plan
13:32:27 <EmilienM> and share use cases
13:32:28 <NickChase> What we want is to provide a way to do it "out of the box" without stifling innovation on the topic.
13:32:32 <NickChase> right
13:32:59 <fifieldt_> (minor administrative note: do you want to create a blueprint on launchpad as well - it can link to the etherpad - just to give others visibility on the work that's going on?)
13:33:07 <EmilienM> it seems Mirantis & eNovance are doing HA on the same way for almost all OpenStack components
13:33:17 <fifieldt_> how convenient :)
13:33:23 <EmilienM> fifieldt: sounds good ! let's for a blueprint
13:33:29 <EmilienM> let's go*
13:33:37 <NickChase> Yes, good idea.  Emilien, you or me?
13:33:50 <EmilienM> I can write it
13:33:52 <fifieldt_> #action EmilienM create a blueprint on openstack-manuals to link to https://etherpad.openstack.org/HA-Active-Active
13:34:01 <NickChase> great, thanks
13:34:27 <fifieldt_> cool
13:34:33 <fifieldt_> on random thing I should note is - has everyone seen the bootcamp the infrastructure team is having?
13:34:43 <NickChase> no
13:35:06 <writerDiane_> i heard about it
13:35:10 <fifieldt_> there's some posts on the openstack-infra mailing list explaining it recently
13:35:29 <fifieldt_> essentially they are looking for long term sustained contributors (please don't abandon us for infra :D)
13:35:41 <fifieldt_> and having a meeting to bring people up to speed to be useful in this way
13:35:46 <fifieldt_> I think sld was considering joining
13:35:54 <fifieldt_> after his recent work into that side of things
13:36:13 <fifieldt_> but anyway, check out the infra mailing list archives if it interests you
13:36:22 <fifieldt_> we could also consider doing such a boot camp for docs
13:36:24 <sld> hehe
13:36:24 <fifieldt_> thoughts on that?
13:36:36 <NickChase> I'd be all for a docs boot camp
13:36:37 <writerDiane_> yes, a boot camp for docs would be good
13:36:42 <fifieldt_> what would the scope be?
13:36:47 <fifieldt_> & purpose
13:37:00 <writerDiane_> doc tools, common practices for contributing
13:37:17 <NickChase> the actual process of contributing is a bit confusing
13:37:18 <writerDiane_> best practices - writing style, spellcheck,
13:37:23 <writerDiane_> i agree -
13:37:30 <writerDiane_> people are intimidated
13:37:31 <NickChase> actually
13:37:52 <NickChase> unofficially, we are in the process of writing up a document on it
13:37:59 <writerDiane_> we?
13:38:12 <NickChase> I've got a guy here, Tyler.
13:38:17 <NickChase> I put him on it.
13:38:27 <NickChase> The doc he produced isn't ready for prime time yet
13:38:36 <fifieldt_> on contributing, that is?
13:38:41 <NickChase> but ultimately it could serve as a good foundation for a boot camp
13:38:44 <NickChase> yes
13:38:55 <fifieldt_> sounds cool
13:38:59 <NickChase> but it does need work
13:39:06 <fifieldt_> no dramas
13:39:21 <fifieldt_> my feeling is that we need to "get our house in order" before we can ramp up contributors in a big way
13:39:24 <NickChase> thank you.
13:39:27 <fifieldt_> and by that I mean the restructure
13:39:33 <writerDiane_> rackspace recently created a course for docbook - we could borrow from that
13:39:40 <NickChase> nice
13:39:49 <fifieldt_> ok, everyone has awesome ideas
13:39:55 <fifieldt_> let's start an etherpad on planning this
13:40:10 <fifieldt_> and eventually turn it into a proposal
13:40:15 <fifieldt_> we might be able to get fundingz
13:40:19 <EmilienM> #link https://blueprints.launchpad.net/openstack-manuals/+spec/improve-high-availability-support
13:40:31 <fifieldt_> love your work EmilienM
13:40:38 <EmilienM> ;)
13:40:47 <NickChase> thanks, Emilien :)
13:40:50 <fifieldt_> #link fifieldt to create an etherpad for potential doc boot camp and communicate link
13:41:04 <fifieldt_> #link https://etherpad.openstack.org/DocsBootCamp2013
13:41:37 <fifieldt_> ok - any other general doc discussion?
13:41:53 <fifieldt_> we have 19 minutes of meeting time left that we could give back to our lives :)
13:42:03 <NickChase> +1 on that. :)
13:42:23 <writerDiane_> +1
13:42:41 <fifieldt_> oh damn, why didn't you use +2 s :)
13:42:43 <EmilienM> I have one question
13:42:46 <fifieldt_> yes EmilienM
13:43:10 <EmilienM> for the HA doc, is it a good idea to work with Google Doc first, to collaborate with the community ?
13:43:17 <EmilienM> first with NickChase
13:43:27 <EmilienM> but maybe other people would like to see our work
13:43:30 <EmilienM> before patching the doc
13:43:46 <NickChase> I'm for that.
13:43:46 <sgordon> that would be great in my opinion
13:43:59 <fifieldt_> for the rapid development stage, whatever works
13:44:03 * sgordon is having a lot of difficulty working out where to fit in with a lot of things happening offline
13:44:20 <fifieldt_> oh, how can we fix that sgordon
13:44:34 <EmilienM> ok, NickChase : I start a google doc
13:44:38 <sgordon> fifieldt, EmilenM's suggestion seems reasonable
13:44:50 <sgordon> still have rapid development just have it in the open
13:44:58 <fifieldt_> ya
13:45:01 <fifieldt_> 'course
13:45:10 <NickChase> Emilien:  thx
13:45:14 <sgordon> tooling doesnt really phase me
13:45:18 <sgordon> google docs seems fine :)
13:45:29 <fifieldt_> some would argue that vehemently :)
13:45:36 <fifieldt_> tehehe
13:45:42 <sgordon> hey if the NSA want to contribute...
13:45:43 <sgordon> ;p
13:45:46 <fifieldt_> :D
13:45:53 <fifieldt_> but yeah, all of the other work like the new docs is already in the gerrit system
13:46:07 <writerDiane_> I have no problem with google-docs, but then there is the conversion from the google-docs to docbook, which I've done for quantum and it's a pain in the neck
13:46:10 <writerDiane_> not easy
13:46:10 <NickChase> Well, it will be when it's ready for review
13:46:13 <writerDiane_> especially with tables
13:46:18 <NickChase> It is a pain, true
13:46:18 <fifieldt_> indeed
13:46:23 <NickChase> but I volunteer
13:46:27 <fifieldt_> yay!
13:46:30 <NickChase> done it before, I can do it again. :)
13:46:30 <writerDiane_> alternatively, you can generate PDF for a doc patch and have people review that
13:46:39 <fifieldt_> #action NickChase to convert google docs to docbook, when the time comes
13:46:46 <writerDiane_> wow, glutton for punishment? :)
13:46:51 <EmilienM> \o/
13:47:01 <fifieldt_> cool, so it seems that is progressing
13:47:11 <fifieldt_> perhaps you can update your etherpad with the new gdoc link EmilienM :)
13:47:17 <fifieldt_> so, we have 13 minutes of meeting time left
13:47:21 <fifieldt_> life or docs? :)
13:47:27 <NickChase> writerDiane:  I'm here, aren't I?
13:47:28 <NickChase> :)
13:47:45 <ekarlso-> ello folks
13:47:50 <fifieldt_> hi ekarlso-
13:48:08 <fifieldt_> we're just in open discussion on docs now
13:48:08 <writerDiane_> yes!!!! ha ha ha
13:48:15 <fifieldt_> any thoughts?
13:48:27 <EmilienM> fifieldt: of course I can
13:48:32 <fifieldt_> cheers EmilienM
13:49:11 <fifieldt_> ok, unless ekarlso- has comments in the next half minute, I'm tempted to call the meeting to a close :)
13:49:33 <sld> lol
13:49:43 <sld> i had an addendum.
13:49:47 <fifieldt_> yes?
13:50:32 <sld> i was thinking of emaililng the guy that did the config-option-grabbing stuff for nova/c...was it cinder or ceilometer i don't remember.. to see if had anything more genericised. (sp?).
13:50:41 <sld> ...since apparenlty that stuff is from last year - if not older.
13:50:46 <fifieldt_> yes, sounds good
13:51:01 <fifieldt_> #action sld get in touch with conf file code people to collaborate
13:51:16 <fifieldt_> anyone else?
13:51:24 <fifieldt_> I have to run to another meeting now myself
13:51:34 <writerDiane_> bye
13:51:38 <fifieldt_> thanks all!
13:51:40 <NickChase> thanks fifieldt_
13:51:41 <fifieldt_> #endmeeting
13:51:51 <fifieldt_> have fun!
13:51:54 <NickChase> bye!
13:55:47 <EmilienM> o/
14:13:58 <annegentle> #endmeeting