06:00:44 <loquacities> #startmeeting docinstallteam
06:00:45 <openstack> Meeting started Tue Jun  7 06:00:44 2016 UTC and is due to finish in 60 minutes.  The chair is loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
06:00:49 <openstack> The meeting name has been set to 'docinstallteam'
06:00:54 <loquacities> ok, who's here?
06:00:58 <lbragstad> o/
06:01:06 <loquacities> hi lbragstad good to see you :)
06:01:10 <strigazi> o/ Spyros Trigazis (magnum)
06:01:21 <loquacities> hi strigazi
06:01:24 <lbragstad> loquacities thanks for the reminders :)
06:01:33 <loquacities> no trouble, sometimes i remember to send them ;)
06:02:03 <loquacities> anyone else?
06:02:43 <katomo> |_-)
06:02:49 <loquacities> hiya katomo
06:02:57 <katomo> hello
06:03:10 <bmoss> hi katomo
06:03:28 <loquacities> oh hi bmoss :)
06:03:35 <katomo> hi bmoss
06:03:48 <bmoss> howdy lo
06:03:52 <bmoss> howdy loquacities
06:04:10 <loquacities> ok, let's kick off then
06:04:14 <loquacities> #topic Action items
06:04:24 <loquacities> #info loquacities to email CPLs about install guide meeting attendance
06:04:34 <loquacities> #info i have done so, and look! people are here! :D
06:04:57 <katomo> :)
06:05:17 <loquacities> #info loquacities to create poll on naming
06:05:36 <loquacities> #info i have also done that, and we got 31 responses, and a clear winner :)
06:06:07 <loquacities> #link https://docs.google.com/spreadsheets/d/1VlNFebI_KFobs-XIT5oRhULRymwrqON8SV9pH4uiYIQ/pubchart?oid=2070399201&format=interactive
06:06:12 <loquacities> i hope that link works
06:06:29 <loquacities> we'll come back to that :)
06:06:31 <katomo> I can see it
06:06:38 <loquacities> #topic Infra setip
06:06:43 <loquacities> #undo
06:06:44 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x7fe23773ae90>
06:06:46 <loquacities> #topic Infra setup
06:07:02 <loquacities> #link https://review.openstack.org/#/c/326039/
06:07:12 <loquacities> #info Andreas created this overnight
06:07:25 <bmoss> awesome!
06:07:32 <strigazi> So, we add our project here? https://review.openstack.org/#/c/326039/6/jenkins/jobs/projects.yaml
06:07:36 <katomo> great
06:07:45 <loquacities> i'm hoping to have some instructions written up soon, but for now i'm still trying to get my head around it ;)
06:07:51 <loquacities> strigazi: yes, that's my understanding
06:08:24 <strigazi> ok, In out project of course
06:08:27 <loquacities> strigazi: i also saw your convo with andreas on irc overnight last night (my time), so thanks for all your help on getting this sorted :)
06:08:31 <strigazi> but in this file
06:08:51 <loquacities> yeah, so my understanding so far is:
06:08:58 <loquacities> * Project creates $repo/install-guide and puts something in it (based on the cookiecutter)
06:08:58 <loquacities> * Docs (?) update the install-guide-jobs directive in the projects.yaml file with the name of the service
06:10:27 <loquacities> ok, any questions on that?
06:10:44 <katomo> I'm okay.
06:10:47 <loquacities> cool
06:10:55 <loquacities> #topic New title: OpenStack Installation Tutorial
06:11:24 <loquacities> not much to say there, except we need to go ahead and do it
06:11:45 <loquacities> i'm also trying to work out what other content 'glue' we need to get this all published
06:12:18 <loquacities> #topic reps for moving content
06:12:30 <loquacities> #info We have reps for Orchestration (pkovar), Shared File Systems (gouthamr), Object Storage (pkovar), and Telemetry (ildikov) (Thanks!)�
06:12:44 <loquacities> #info Still need a rep for Trove
06:13:01 <loquacities> #action loquacities to reach out to reps shortly with instructions for moving content
06:14:05 <loquacities> laurelm is listed as the CPL for trove, so i'll contact her this week to find out who we should be talking to for that content
06:14:40 <lbragstad> loquacities are those the only projects listed for moving content? or are there others, too?
06:14:40 <ildikov> o/
06:14:50 * ildikov is sorry for being late, wifi issues
06:14:59 <loquacities> they're the ones that need to be moved out of the existing install guide and into their own repos
06:15:05 <loquacities> the other defcore projects will stay
06:15:11 <lbragstad> got it
06:15:12 <loquacities> ildikov: welcome :)
06:15:19 <katomo> hi, ildikov
06:15:40 <loquacities> ok, questions on that topic?
06:16:07 <ildikov> do we have a target finish date?
06:16:30 <loquacities> ildikov: well, not other than 'before newton'
06:16:55 <loquacities> but there's going to be a lot of polishing to be done, i imagine, so i want to get the content moved as soon as the infrastructure is ready to go
06:16:55 <ildikov> loquacities: ok, cool tnx
06:17:16 <loquacities> ok, moving on
06:17:23 <loquacities> #topic Work Items
06:17:30 <loquacities> #link https://wiki.openstack.org/wiki/Documentation/InstallGuideWorkItems
06:17:48 <loquacities> i think we're in pretty good shape right now
06:18:11 <loquacities> once we get the infra up and running and some basic instructions, we can start moving projects from the existing install guide over to their own repos
06:18:32 <loquacities> we can also get the name changed, and then start working on any content for the new guide to glue it all together
06:18:41 <loquacities> any questions on work items?
06:19:54 <strigazi> I'm good
06:19:57 <loquacities> yay!
06:20:04 <loquacities> #topic open discussion
06:20:17 <strigazi> about debconf
06:20:22 <loquacities> yep?
06:20:37 <strigazi> How we should write instructions? I mean, to be manual
06:20:58 <loquacities> by 'manual' we really mean 'not using an automated tool'
06:21:14 <loquacities> so if it's opening config files and editing them, then it's manual
06:21:35 <loquacities> debconf is considered an automated tool, in this sense
06:21:53 <loquacities> which is why we split it out
06:22:12 <katomo> yeah
06:22:55 <strigazi> We should pass some parameters to apt-get install to stop debconf of configuring anything?
06:23:20 <loquacities> which book are you talking about? the debconf book or the non-debconf book?
06:23:31 <strigazi> non-debconf
06:23:44 <loquacities> well, it shouldn't have debconf at all in it
06:24:54 <strigazi> I guess we should do DEBIAN_FRONTEND=noninteractive apt-get install openstack-<service> right?
06:25:01 <katomo> by default, on installing packages on debian, debconf configuration screen automatically appears. right?
06:25:32 <strigazi> by default it does appear
06:25:33 <katomo> strigazi: I'm not sure, but I think so.
06:26:26 <loquacities> that sounds about right to me
06:26:35 <loquacities> ok, any other items?
06:26:35 <katomo> I need to talk with debian master :)
06:26:49 <loquacities> heh, yeah :)
06:26:54 <katomo> none from me
06:27:01 <loquacities> great, thanks katomo
06:27:03 <loquacities> everyone happy?
06:27:16 <strigazi> yeap
06:27:18 <bmoss> yep
06:27:24 <lbragstad> i think i'm good - unless there are specific keystone items needed from my end :)
06:27:39 <ildikov> I'm sleepy, otherwise good :)
06:27:47 <loquacities> lbragstad: not yet, but very soon!
06:27:55 <lbragstad> loquacities awesome
06:27:56 <loquacities> ildikov: time for coffee? ;)
06:27:56 <ildikov> will come back with items after starting moving the docs :)
06:28:02 <loquacities> great!
06:28:10 <ildikov> loquacities: in progress by now :)
06:28:16 <loquacities> thanks everyone for coming, this will be much easier now we're all talking to each other :)
06:28:18 <loquacities> ildikov: \o/
06:28:27 <loquacities> #endmeeting