14:04:16 <annegentle> #startmeeting DocTeam
14:04:17 <openstack> Meeting started Wed Mar 26 14:04:16 2014 UTC and is due to finish in 60 minutes. The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:20 <openstack> The meeting name has been set to 'docteam'
14:04:22 <annegentle> ok!
14:04:24 <Sam-I-Am> yay
14:04:33 <annegentle> who is here for the Doc Team meeting?
14:04:42 * Sam-I-Am raises hand (with coffee in it)
14:04:43 <annegentle> #link https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Agenda_for_next_meeting
14:04:47 <annegentle> Agenda ^^
14:05:08 <annegentle> I don't have much (and we can talk more at the hangout later!)
14:05:14 <annegentle> but feel free to add topics
14:05:29 <annegentle> #topic Action items from the last meeting
14:06:01 * annegentle nickchase talk with annegentle about a cross-project
14:06:01 <annegentle> proposal for getting docs easier in?
14:06:20 <annegentle> I haven't talked with Nick on that one
14:06:46 * annegentle nickchase to talk with annegentle about getting the blueprint approved and how to use it
14:06:58 <Sam-I-Am> i think thats done
14:07:03 <annegentle> Not sure on that one either, something about https://wiki.openstack.org/wiki/GitCommitMessages#Including_external_references
14:07:14 * annegentle Sam-I-Am to update the work items in the blueprint
14:07:35 <annegentle> which blueprint?
14:07:37 <Sam-I-Am> i think we're ok there... i figured out how to update the blueprint in the commit message
14:07:42 <Sam-I-Am> annegentle: the install guide one
14:07:50 <annegentle> Sam-I-Am: ok, yep, that's done
14:07:55 <annegentle> (well the action item is)
14:08:02 <Sam-I-Am> lol
14:09:43 <annegentle> Oh just read the log more closely, I agree with Nick/sgordon that a knowledge base would fit the bill. I'd like to experiment with a non-CLA authoring system
14:09:51 <annegentle> especially for user docs
14:10:01 <annegentle> but yes we still need our "guides" deliverables
14:10:08 <annegentle> Someone propose a summit topic!
14:10:25 <Sam-I-Am> should nick propose that?
14:10:40 <annegentle> Sam-I-Am: yep
14:10:59 <annegentle> #action NickChase please propose a summit topic on a nonCLA authoring system
14:11:09 <Sam-I-Am> he's usually on this meeting...
14:11:44 <annegentle> Okay, this one is done:
14:11:53 * annegentle Sam-I-Am propose 21:00 UTC on 2014-03-19 for Google Hangout on mailing list
14:12:04 <annegentle> And then the last one, ACTION: propose talks at http://summit.openstack.org
14:12:06 <annegentle> is in progress
14:12:17 <annegentle> which is a nice transition to
14:12:21 <annegentle> #topic Design Summit proposal system now open, doc slots Wed-Fri. morning
14:12:31 <annegentle> Thierry updated the schedule, we have four slots
14:12:49 <annegentle> Though I would like us to use a crossproject slot to discuss blueprints, dev authoring, etc
14:13:04 <Sam-I-Am> maybe i should talk about a crash course in learning how to patch things :)
14:13:04 <annegentle> I can propose it if you don't know if Nick is buried
14:13:10 <annegentle> heh
14:14:00 <annegentle> The last doc topic is 11:40 - 12:20 Friday morning
14:14:21 <annegentle> The first doc topic is 9:00 - 9:40 Wed. morning. Those are tentative since it could still change
14:14:39 <annegentle> Our proposal for the business side was not accepted but I repurposed it for a blog post
14:14:48 <Sam-I-Am> business side?
14:15:00 <annegentle> #link http://justwriteclick.com/2014/03/21/how-to-build-openstack-docs-and-contributors-through-community/
14:15:07 <annegentle> oh it's what I call the non-Design Summit
14:15:13 <annegentle> dunno what else to call it
14:15:35 <ttx> annegentle: also note the slots are sprinkled over the 4 days to make sure every project can attend some of those.
14:15:47 <annegentle> yes!
14:15:49 <ttx> rqther than being in block at the beginning
14:15:58 <annegentle> I like the schedule ttx
14:16:07 <annegentle> I wonder though if operators won't be around Friday?
14:16:09 <Sam-I-Am> annegentle: i like that blog post
14:16:21 <annegentle> need them in docs sessions if we can
14:17:29 <annegentle> also note
14:17:31 <annegentle> #topic Summit schedule now posted to http://openstacksummitmay2014atlanta.sched.org/
14:17:40 <annegentle> #link http://openstacksummitmay2014atlanta.sched.org/
14:17:47 <annegentle> Sam-I-Am: I guess it's the Summit and the Design Summit
14:17:57 <annegentle> not much more to say there!
14:18:05 <annegentle> #topic Installation guide updates for Icehouse
14:18:11 <annegentle> Got anything to report Sam-I-Am?
14:18:25 <Sam-I-Am> yep...
14:18:47 <annegentle> floor is yours!
14:18:49 <Sam-I-Am> the project is progressing nicely, minus the actual ml2 instructions because the rdo neutron packages still dont work
14:19:02 <Sam-I-Am> in the meantime i'm working on plenty of ancillary patches to clean up the install guide
14:19:10 <Sam-I-Am> never a shortage of work!
14:20:00 <Sam-I-Am> next patches will move 'launch an instance' and clarify the 'basic os config' chapter
14:20:02 <annegentle> Sam-I-Am: I should have some Object Storage edits ready soon
14:20:10 <Sam-I-Am> and at that point... i'll be done except for the ml2 specifics
14:20:16 <annegentle> NICE
14:20:34 <annegentle> I wanted to do a call for help on ceilometer testing and heat testing
14:20:37 <annegentle> I think trove is being covered
14:20:48 <annegentle> #help test the ceilometer instructions in Install Guide master branch
14:20:52 <Sam-I-Am> then we get to see what RC1 does... and the final release. unfortunately we can't update the docs for ubuntu 14.04 or rhel 7 until those are released :/
14:20:58 <annegentle> #help test the heat instructions in Install Guide master branch
14:21:10 <annegentle> Sam-I-Am: what's the date for 14.04?
14:21:26 <Sam-I-Am> we need cinder/swift/heat/ceilometer/horizon testing
14:21:35 <Sam-I-Am> i still havent been back to horizon after the mess a few weeks ago.
14:21:47 <Sam-I-Am> annegentle: right around when icehouse releases
14:21:55 <Sam-I-Am> there are no packages for 14.04 yet
14:22:00 <annegentle> ttx: do you know the release date for 14.04?
14:22:03 <Sam-I-Am> everyone is building against 12.04
14:22:22 <annegentle> okay
14:22:31 <ttx> annegentle: https://wiki.ubuntu.com/TrustyTahr/ReleaseSchedule
14:22:37 <annegentle> I think we'll release on April 17th by cutting a stable/icehouse branch
14:22:40 <ttx> April 17th
14:22:42 <annegentle> and then backport
14:22:47 <Sam-I-Am> i suspect the actual openstack instructions won't change, but the base OS configuration and package names may change
14:22:48 <annegentle> ttx: perfect, thanks
14:22:59 <annegentle> Sam-I-Am: okay, let's hope it's minimal
14:23:10 <Sam-I-Am> i'm not sure why openstack is aligned to a major ubuntu release
14:23:15 <Sam-I-Am> it makes documentation really difficult
14:23:16 <Sam-I-Am> and testing
14:23:29 <annegentle> Sam-I-Am: best way to get into LTS
14:23:37 <annegentle> as far as I understand it
14:23:43 <annegentle> perhaps only way
14:23:59 <annegentle> any questions?
14:23:59 <Sam-I-Am> hmm :/ i wish we had access to testing icehouse on 14.04 somewhere
14:24:34 <Sam-I-Am> i guess this only comes around every 2 years, but i think we should try to get a foot in the door for... 16.04?
14:24:52 <annegentle> yeah!
14:25:02 <annegentle> Sam-I-Am: not sure how to get early access
14:25:13 <annegentle> #topic Preparation for release - freeze on 1.15.0 in pom.xml files
14:25:29 <annegentle> Okay I was thinking of what we need to do to prep for release
14:25:43 <annegentle> Config Ref and Install Guides are "released" to a stable/icehouse branch
14:25:54 <annegentle> and we make a new sitemap.xml
14:25:58 <Sam-I-Am> yup...
14:26:11 <annegentle> #link https://wiki.openstack.org/wiki/Documentation/Release
14:26:18 <annegentle> that's where it's documented
14:26:52 <sld> Thanks for that. (Oftentimes I wonder how many links you have handy at any given point in time. ;-) )
14:27:03 <annegentle> Summer had asked about cross linking, do you go to /trunk? The answer is yes, you have to, then in the final stable branch cut, you have to go through the repo and change the links from /trunk to /icehouse when referring to install and config
14:27:04 <Sam-I-Am> its the annepedia
14:27:11 <annegentle> heh sld
14:27:12 <annegentle> :)
14:28:26 <annegentle> also wanted to let everyone know we'll standardize on 1.15.0 for the Icehouse builds
14:28:43 <annegentle> No more updates to our use of the maven plugin unless it's absolutely necessary
14:29:04 <Sam-I-Am> woohoo
14:29:16 <Ajaeger1> ;(
14:29:27 <annegentle> Oh, that reminds me did anyone have comments on my post about 1.15.0?
14:29:29 <annegentle> #link http://lists.openstack.org/pipermail/openstack-docs/2014-March/004164.html
14:30:14 <Sam-I-Am> no questions from me (yet)
14:30:31 <Ajaeger1> No preference...
14:30:42 <sld> Nope. ..just read it.. all good.
14:31:05 <annegentle> okie
14:31:14 <annegentle> #topic Google Hangout today
14:31:22 <annegentle> #link https://wiki.openstack.org/wiki/Meetings/DocTeamMeeting#Google_Hangout_for_Docs
14:31:27 <annegentle> Feel free to add to that agenda!
14:31:33 <annegentle> I'm looking forward to it!
14:31:42 <Sam-I-Am> yes!
14:31:46 <Sam-I-Am> hopefully we can make live mode work
14:31:54 <sld> when is that?
14:32:11 <sld> (i'm not good at time conversion.)
14:32:29 <Sam-I-Am> today, at... 4 pm ct
14:32:35 <sld> ah, ok.
14:32:41 <sld> if I'm awake, I'll try and make it. :)
14:33:14 <Sam-I-Am> lol
14:33:18 <annegentle> hee
14:33:34 <Sam-I-Am> well, thats awesome... the carpet installers rescheduled for... right during our meeting.
14:33:41 <Sam-I-Am> they were supposed to be here now
14:33:43 <annegentle> Okay!
14:33:46 <Sam-I-Am> so.. it could be exciting.
14:33:47 <annegentle> Sam-I-Am: aw man
14:33:53 <annegentle> #topic Open disussion
14:34:18 <Sam-I-Am> disussion...
14:34:27 <Sam-I-Am> -1 spelling error
14:35:02 <Sam-I-Am> nothing else new here. i'm working with a bunch of redhat folks to resolve the neutron issues... never a lack of helpful people.
14:35:28 <Sam-I-Am> rrreeally looking forward to the summit
14:35:35 <annegentle> #topic Open discussion
14:35:36 <annegentle> lol
14:35:43 <annegentle> that's good Sam-I-Am!
14:36:20 <annegentle> I would like to hear back from the training guides team, sarob or colin
14:36:30 <annegentle> on your query to the list... I'll write back today though
14:36:32 <Sam-I-Am> did you post to the ml? i didnt see anything.
14:36:59 <Sam-I-Am> ok...
14:37:06 <annegentle> not yet yeah
14:37:30 <annegentle> okay, take back your day!
14:37:38 <annegentle> if there's nothing else.
14:37:38 <Sam-I-Am> annegentle: at some point i'll try to put together a ref guide for diagrams
14:37:41 <Sam-I-Am> annegentle: at least i would like to
14:37:47 <Sam-I-Am> i just can't get to it right now :/
14:37:48 <annegentle> Sam-I-Am: great idea, we had a section in the HowTo wiki page
14:37:50 <sld> that would be cool.
14:38:01 <Sam-I-Am> its interesting to explain pictures with text
14:38:07 <Sam-I-Am> a picture is worth a 1000 words?
14:38:14 <sld> or more sometimes. ;)
14:38:32 <Sam-I-Am> i'll probably post a "sample" SVG where people can just suck attributes out of it
14:38:51 <Sam-I-Am> colors, shapes, line thickness, font, etc.
14:39:00 <Sam-I-Am> kind of a template of sorts?
14:39:17 <annegentle> yes
14:39:21 <annegentle> that would be great!
14:39:33 <Sam-I-Am> cool... we definitely need it
14:39:35 <annegentle> attach it to the wiki page
14:39:38 <Ajaeger1> Sam-I-Am: Great, go for it!
14:39:42 <annegentle> I get asked for arch diagrams all the time
14:39:45 <Sam-I-Am> i'm also not sure how we review this sort of stuff
14:39:53 <Ajaeger1> To the wiki page - or find a place in the git repo
14:39:54 <Sam-I-Am> and my ideas need reviewing :P
14:40:00 <sld> I can look it over when you are done?
14:40:12 <sld> Sam-I-Am: I'll do that as time permits, myself.
14:40:14 <annegentle> Sam-I-Am: generally post to the ML then update the wiki (sound right?)
14:40:25 <Sam-I-Am> annegentle: that works
14:40:30 <annegentle> ok cool
14:40:36 <Sam-I-Am> i need something where i can get a pile of -1's :)
14:40:38 <sld> Sam-I-Am: I'm referring to reviewing your stuff, myself. ;-)
14:40:41 <annegentle> pick it up in #openstack-doc if there's anything else!
14:40:42 <sld> lol
14:40:45 <annegentle> #endmeeting