03:03:23 <Loquacities> #startmeeting docteam
03:03:24 <openstack> Meeting started Wed Apr  2 03:03:23 2014 UTC and is due to finish in 60 minutes.  The chair is Loquacities. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:03:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:03:25 <Sam-I-Am> there... should be
03:03:27 <openstack> The meeting name has been set to 'docteam'
03:03:28 <Loquacities> tchaypo: or so you thought :P
03:03:33 <Sam-I-Am> Loquacities: BOOM!
03:03:33 <tchaypo> oh
03:03:46 <tchaypo> and strangely this is probably one I'm interested in lurking in.
03:04:07 <Loquacities> so was there no US docs meeting last week?
03:04:10 * Loquacities can't find minutes
03:04:16 <Loquacities> welcome tchaypo ;)
03:04:30 * tchaypo settles in
03:04:54 <Sam-I-Am> there was a meeting
03:05:00 <Sam-I-Am> we also had the google hangout
03:05:02 <Alexandra_> Was? Past tense?
03:05:04 <Sam-I-Am> (which you missed!)
03:05:06 <sld> lol
03:05:42 <Loquacities> #topic Action items from the last meeting
03:05:44 <fifieldt> mmmm
03:06:31 <Loquacities> Sam-I-Am to add the image elements he is using to a wiki page, as the beginnings of an image library
03:06:31 <Loquacities> Sam-I-Am: hem, i wonder where the minutes are then
03:06:56 <Sam-I-Am> me too
03:07:14 <Sam-I-Am> the image elements thing is on hold until post-icehouse release
03:07:17 <Sam-I-Am> just too much going on
03:07:22 <Loquacities> yep fair enough
03:07:27 <Loquacities> we'll just hold it over then
03:07:30 <Sam-I-Am> but it's on my list!
03:07:42 <Loquacities> #action Sam-I-Am to add the image elements he is using to a wiki page, as the beginnings of an image library
03:07:48 <Loquacities> thanks Sam-I-Am :)
03:08:02 <Loquacities> i think that's all i have, given that i'm missing the minutes from the last US meeting
03:08:12 <Sam-I-Am> great :/
03:08:23 <Loquacities> #topic Design Summit proposal system now open, doc slots Wed-Fri. morning
03:09:02 <Loquacities> i don't think i have anything to add for that
03:09:08 <Loquacities> do people know who's going to atlanta yet?
03:09:14 * fifieldt raises hand
03:09:28 <Loquacities> yay!
03:09:38 <tchaypo> o/
03:09:48 <tchaypo> but since I'm just a lurker that's not very helpful
03:09:51 <Loquacities> heh
03:10:05 * Sam-I-Am raises hand
03:10:20 <Loquacities> neat!
03:10:22 * Sam-I-Am gets to see y'all
03:10:29 <Loquacities> i'm not going going, sadly
03:10:32 <Sam-I-Am> i will be wearing my au de -1
03:10:55 <Loquacities> #topic Summit schedule now posted to http://openstacksummitmay2014atlanta.sched.org/
03:11:01 <Loquacities> so there you go ...
03:11:15 <Loquacities> #topic Installation guide updates for Icehouse
03:11:20 <Loquacities> Sam-I-Am: wanna give us the lowdown?
03:11:22 <fifieldt> https://wiki.openstack.org/wiki/IcehouseDocTesting#Install_Guide
03:11:23 <Sam-I-Am> ahh yes
03:11:33 <Sam-I-Am> plenty of patches going in
03:11:33 <fifieldt> #link https://wiki.openstack.org/wiki/IcehouseDocTesting#Install_Guide
03:11:51 <Sam-I-Am> i finally got ml2 to work on rhel this weekend
03:11:59 <Sam-I-Am> turns out it was an obscure database problem
03:12:35 <Sam-I-Am> that means i can start on the ml2 config docs... which i'm working on as we type
03:12:59 <Loquacities> neat :)
03:13:22 <Sam-I-Am> yes!
03:13:33 <Sam-I-Am> focusing on content rather than making it look pretty
03:13:43 <Sam-I-Am> need to get people testing the "meat" of the configs
03:13:52 <Sam-I-Am> hence tom's link
03:14:02 <Sam-I-Am> need more people installing from the install guide
03:14:14 <Loquacities> looks like you're starting to get somewhere
03:14:22 <Loquacities> i promise i'll try and do more reviews this week!
03:14:33 <fifieldt> we also need testing :)
03:14:36 <Sam-I-Am> anything between the beginning and launching a basic instance (keystone+glance+nova+neutron) ... let me know
03:14:38 <fifieldt> ask your friends :)
03:14:51 <sld> that page has changed to be wrong, or something.. i test centos on 'install and configure openstack clients' and it was fine for a +2 (b2 packages) not sure where my +2 went.
03:15:28 <fifieldt> feel free to re-edit :)
03:15:44 <sld> will do, after i test again, since b3 is out now.
03:15:50 <Sam-I-Am> i keep saying i'm going to go through and clean up the OSs in there
03:16:00 <fifieldt> sld, so is rc1 for many things :)
03:16:11 <sld> right on
03:16:42 <Loquacities> #topic Preparation for release - freeze on 1.15.0 in pom.xml files
03:16:49 <Sam-I-Am> i think we support ubuntu 12.04/14.04, fedora 20, sles 11?, opensuse 13?, rhel 6.5, rh-like 6.5, rhel 7 ???
03:17:04 <Sam-I-Am> and deb 7 i guess...
03:17:40 <annegentle> I've got a Racker testing Ceilometer on Ubuntu
03:17:48 <Sam-I-Am> its an anne!
03:17:49 <Loquacities> oh, hi annegentle
03:17:53 * annegentle waves
03:18:29 <Loquacities> ok, so that's all that i'm seeing on the meeting page
03:18:38 <Loquacities> annegentle: since you're here, i haven't found the minutes of the last US meeting
03:18:43 <Loquacities> so i may be a bit behind the times
03:18:49 <Loquacities> is there anything you would like to add?
03:19:00 <annegentle> Loquacities: yeah I realized I hadn't posted them, sorry. Update dnow.
03:19:02 <annegentle> #link http://eavesdrop.openstack.org/meetings/docteam/2014/docteam.2014-03-26-14.04.html
03:19:07 <Loquacities> ah, cool, thanks
03:19:18 <ddomingo_> summer mentioned something the other day about DocImpact patches
03:19:20 <Sam-I-Am> for some reason i thought those were automated...
03:19:29 <annegentle> The one action was for Nick to make a proposal for a new doc contribution system, but I did it for the Cross-Project track
03:19:44 <annegentle> Sam-I-Am: you still have to copy/paste them to the wiki
03:19:59 <Sam-I-Am> whoops, guess i should have done that for the meeting during sxsw :/
03:20:18 <annegentle> Sam-I-Am: I can figure out the links, no worries
03:20:39 <Loquacities> anyway, that's all i had on my list
03:20:39 <annegentle> Sam-I-Am: oh they're there no worries
03:21:06 <Loquacities> #topic Open discussion
03:21:14 <Sam-I-Am> test early, test often.
03:21:18 <annegentle> There are just 2 Doc track proposals so far, any one else want to talk about doc topics at the Summit?
03:21:22 <Loquacities> Sam-I-Am: +1
03:21:28 <annegentle> One is: Continuous publishing and automation
03:21:34 <annegentle> Two is: Install Guide Discussion
03:21:50 <annegentle> Cross Project is:
03:21:51 <Sam-I-Am> annegentle: anything i can help out with? (besides the install guide)
03:21:52 <annegentle> #link http://summit.openstack.org/cfp/details/204
03:22:06 <Sam-I-Am> "how i became addicted to writing docs"
03:22:17 <annegentle> Sam-I-Am: config too! That's part of the automation discussion I think.
03:22:20 <Sam-I-Am> there's no feeling like git review -v
03:22:25 <annegentle> heh
03:22:30 <ddomingo_> lol
03:22:47 <Loquacities> lol
03:22:54 <Loquacities> that talk looks good
03:23:01 <annegentle> I will write a mailing list post to kick off the discussion, but I want to consider an additional doc writing system
03:23:10 <Sam-I-Am> annegentle: oooooo?
03:23:12 <Loquacities> such as?
03:23:58 <brucer_> the more the merrier?
03:24:05 <annegentle> Well, we know that we need cross-project guides. And I think that we do a good job with Guides. But there's a need for a more article-driven site, such as a support base. Steve Gordon and I talked some about it this week and I definitely want more input
03:24:44 <sld> annegentle:  like.. a knowledge base of sorts?
03:24:52 <annegentle> We haven't yet addressed the Application Developer needs for docs.
03:25:07 <annegentle> sld: yes - thinking of the support content
03:25:13 <sld> right on
03:25:18 <annegentle> sld: and also avoiding getting too boxed in with "books"
03:25:39 <annegentle> Also, does everyone know we're gathering authors for another book sprint, an architecture design guide?
03:25:50 <sld> i'd love to be in on that, if possible.
03:25:50 <annegentle> Not architectures for app dev, but architectures for use cases for OpenStack.
03:25:54 <Sam-I-Am> i didnt know about that
03:25:55 <Loquacities> no, i didn't
03:26:00 <sld> sounds awesome
03:26:04 <annegentle> okay I need to make sure I post that to the list
03:26:04 <Loquacities> +1
03:26:04 <Sam-I-Am> not sure what i could add...
03:26:30 <annegentle> Ken Hui is leading it, met with Adam Hyde last week, gathering authors. We need about 5 more authors who have experience designing production clouds.
03:26:40 <annegentle> Looking at July/Aug timeframe.
03:26:54 <sld> well, not sure if my experience counts, but i have plenty experience. hehe
03:26:55 * Sam-I-Am does not have such experience
03:27:06 <Sam-I-Am> i only design install guide clouds
03:27:11 <sld> production,yes... just... private clouds. ;)
03:27:12 <Sam-I-Am> over and over and over....
03:27:55 <annegentle> sld: I do want the private cloud architectures documented in the community - Rackspace, Mirantis. Mirantis is likely hosting in Mountain View. I think Ken can probably cover the Rackspace archs but let's connect you to him for sure.
03:28:40 <annegentle> so many mailing list posts... need to get to posting! Another item I've been working on is increasing docs contributors... sort of in conjunction with the "new doc platform" but kind of separate
03:28:56 <Sam-I-Am> we need more people :P
03:29:08 <annegentle> I've run some stats for the last 5-6 months of contributions in OpenStack. There were about 275 RST doc contributions and about 1800 XML (DocBook/WADL) doc contributions.
03:29:43 <sld> woah
03:29:44 <sld> thats a lot
03:29:58 <Loquacities> wow
03:30:00 <annegentle> I didn't count README contribs. It's probably an unfair comparison, but I'm next going to work on a survey asking key questions -- what's the detractor for doc contrib? git/gerrit? workflow? separate repo? obstacles? That sort of thing.
03:30:15 <tchaypo> does that include tripleo's clever shell scripts that have built-in RST docs that get extracted as part of the build?
03:30:16 <annegentle> The 1800 isn't really a great comparison since many many are not really content contribs.
03:30:33 <annegentle> tchaypo: it includes only the 9 integrated projects, not tripleo
03:31:01 <annegentle> docs mission is core-only, basically, but I expanded to what I know is integrated release for icehouse
03:31:17 * tchaypo nods
03:31:34 <annegentle> Also I want to encourage people to log doc bugs with a lot of detail... people do this already, but I'm not sure everyone knows to do this. Then we find the best location for the info.
03:31:45 <annegentle> I just sense we need another location for some info.
03:32:01 <annegentle> Possibly another workflow. Want to investigate.
03:32:47 <annegentle> wow I can type alot even when I'm tired :)
03:32:49 <brucer_> annegentle: another as in additional, or different/
03:32:52 <annegentle> don't let me go on and on :)
03:32:56 <annegentle> brucer_: additional
03:33:09 <brucer_> ok
03:33:11 <Loquacities> no, i'm interested, keep going!
03:33:38 <annegentle> it's hard to measure true doc contribs... because patches aren't a great metric for docs.
03:33:56 <sld> I was thinking that instead of additional... now feel free to ignore me here, but... thinking out loud... it might be simpler to consolidate things to one place for documentation... for example - there is the wiki, there is the docs site, etc., etc.. might be easier to have everything in one spot.  *shrug*
03:34:03 <annegentle> like there was a single docs patch for neturon dev docs... I think it got up over 65 reviews... it was gut wrenching to watch.
03:34:56 <annegentle> sld: yeah it's pretty much how the world of info works though, we already are pretty strict about "this goes here" yet there are still blog entries, terribad outdated wiki pages, and so on... better to segment by audience purposefully than try to control it all
03:35:34 <sld> makes sense, just seems some information may end up redundant is all.
03:35:42 <annegentle> and we seriously haven't addressed sdk users with docs
03:35:55 <annegentle> sld: yeah for SEO it is a concern, that we don't duplicate horribly
03:35:56 <Loquacities> it does make a lot of sense
03:36:26 <annegentle> also as I go to work on DocImpact, I find it really hard to know where to write up something to close the doc bug... sgordon had a better example than I can come up with...
03:36:52 <annegentle> but basically, he had a libvirt addition that was a doc impact... it needs config docs as well as admin user docs... but an admin user only gets it if it's configure.
03:37:27 <Loquacities> hrm
03:37:28 <annegentle> so one docimpact requires updates in 2 guides, which is fine, but how do we think devs will navigate all this properly? How can we coach them to?
03:37:49 <Loquacities> can't you then just do the patch in one doc as a partial close?
03:37:51 <sld> the right entry point and/or seo results?
03:37:58 <Loquacities> or are we assuming too much there?
03:38:30 <annegentle> Loquacities: yeah, that's the solution now. We were noodling on "what if there was an article about "This cool thing you can now do with libvirt"
03:38:43 <ddomingo_> one other thing to consider here: i've seen cases where the DocImpact was actually already addressed by whoever, but the docs patches aren't actually in the Blueprint
03:38:47 <annegentle> Then the article is searchable based on the feature, taggable by release, that sort of thing
03:38:59 <Loquacities> hem, good point
03:39:00 <annegentle> ddomingo_: interesting
03:39:20 <ddomingo_> i've seen it happen twice, can't quote the exact bp
03:39:34 <ddomingo_> and i only found the doc patches by *pure dumb luck*
03:39:43 <annegentle> I think user guides and admin guides could go into a support center, possibly. Just thinking aloud. We could do only release docs as "guides" and then migrate content to article-driven-site...
03:39:49 <annegentle> yeah noodling! :)
03:40:37 <annegentle> need to be sure it's a site that's correctly motivating (not a junk drawer wiki!) to make good, concise, accurate, updated content.
03:41:16 <annegentle> The Foundation is working on a content site for operators, for example, how can we motivate good content there and on a support site? How can this integrate with ask.openstack.org? And on and on.
03:42:22 <sld> i like the ask site.
03:42:39 <Loquacities> there's a lot of noodling to be done here i think, anne :P
03:43:01 <Sam-I-Am> noodles are tasty
03:43:54 <Loquacities> i'm thinking that that's a great note to close the meeting on :P
03:44:12 <Sam-I-Am> heh
03:44:14 <sld> lol
03:44:15 <annegentle> sld: me too
03:44:17 <Sam-I-Am> can you tell i'm tired?
03:44:17 <annegentle> nice!
03:44:18 <annegentle> :)
03:44:20 <Loquacities> #endmeeting