03:08:24 <slong> #startmeeting docteam
03:08:26 <openstack> Meeting started Wed Apr 16 03:08:24 2014 UTC and is due to finish in 60 minutes.  The chair is slong. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:08:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:08:29 <openstack> The meeting name has been set to 'docteam'
03:08:53 <slong> sorry for my tardiness all.
03:09:28 <slong> Er, perhaps I'm the only one?
03:10:20 * dnavale is lurking..
03:10:37 <slong> Ok, will talk at the meetBot. Nick isn't here, and that's the only action item from the US mtg.
03:10:44 <slong> :) dnavale
03:11:12 <slong> Sam-I-Am isn't here, and that's the only action from the last AUS mtg.
03:12:55 <asettle> Woops
03:12:57 <asettle> Here
03:12:57 <fifieldt> hi
03:13:01 <slong> #action configScripts
03:13:06 <slong> hey there
03:13:20 <slong> fifieldt, any news on the config scripts?
03:13:30 <fifieldt> erm, which?
03:13:45 <slong> On the agenda: "Final run of configuration scripts to land before April 17"
03:13:54 <fifieldt> gpocentek has volunteered to do this
03:14:06 <fifieldt> so it's in good hands ;)
03:14:09 <slong> nice.
03:14:18 <slong> #action InstallGuide
03:14:40 <slong> Anyone have something to add?
03:15:05 <slong> #action OpsGuide
03:15:07 <slong> ditto?
03:15:21 <fifieldt> install guide is going well
03:15:26 <fifieldt> just need more testers
03:15:34 <fifieldt> see https://wiki.openstack.org/wiki/IceHouseDocTesting for gaps
03:15:55 <slong> K, ta. Urgh, using the wrong key...
03:16:34 <slong> #topic UserSurvey
03:16:50 <fifieldt> I sent anne some rapid analysis yesterday
03:17:11 <slong> Anything immediately interesting?
03:17:41 <fifieldt> recall that the question was about API/SDK docs. ... people want Quality, and Examples
03:18:27 <slong> Ok, and then there's the doc contribution survey.
03:18:33 <slong> # topic docContribSurvey
03:18:33 <fifieldt> oh, that one
03:18:48 <slong> Just realised there are a couple of lists I could post to.
03:19:39 <slong> Anything else on that one? Tom, am shamelessly using you as the news source...
03:19:57 <fifieldt> 30 responses maybe?
03:20:03 <fifieldt> I haven't done any analysis
03:20:19 <slong> Cutoff will be after release?
03:20:47 <fifieldt> don't know
03:20:55 <fifieldt> but seems likely
03:21:04 <slong> kk, next one.
03:21:19 <slong> #topic newsForDocTools
03:21:52 <slong> Well, this must be one Anne is anticipating.
03:22:15 <fifieldt> the requirements.txt was updated slightly
03:22:19 <fifieldt> for some new cli doc runs
03:22:56 <slong> Have you been working on that or Andreas?
03:23:03 <fifieldt> andreas
03:23:14 <fifieldt> I just review the patches :)
03:23:16 <fifieldt> no work done here :D
03:23:23 <slong> :)
03:23:28 <slong> k, and finally
03:23:36 <slong> # topic IcehouseStatus
03:23:57 <fifieldt> based on the mailing list, it seems that we are going to alias /icehouse to /trunk for a while
03:24:02 <fifieldt> to avoid backport hell
03:24:09 <fifieldt> are you familiar with backport hell, slong?
03:24:14 <slong> I know we're all feverishly trying to finish bugs. Very happy about that grace period.
03:24:20 <slong> And have only heard about it.
03:24:33 <fifieldt> to explain briefly
03:24:42 <fifieldt> the rule is that fixes go in the master branch
03:24:48 <fifieldt> so the master is always the most up to date
03:25:07 <fifieldt> then, they are copied back into the stable/* branch that is appropriate
03:25:19 <fifieldt> eg you may have seen some things go from master to stable/havana
03:25:35 <fifieldt> the process is called backporting
03:25:47 <fifieldt> and basically means you end up making two commits
03:25:53 <fifieldt> and the backport can sometimes be hard
03:26:06 <fifieldt> since, increasingly, as time goes on, things are not backported
03:26:10 <slong> cherrypicking is used to get single items?
03:26:12 <fifieldt> and master diverges from stable/*
03:26:14 <fifieldt> yup
03:26:46 <slong> question.
03:27:00 <fifieldt> so our cycle kind goes |working on master| working on master masquerading as icehouse | working on master, backporting to icehouse| working on master, in prep for juno|
03:27:03 <fifieldt> ya?
03:27:11 <slong> Anne was saying that the Install Guide and Config Ref were the ones being branched.
03:27:27 <slong> Why the Config Ref and not the CLI, if both use automated scripts?
03:27:44 <fifieldt> that might be one to ask her :)
03:27:51 <slong> I did, no answer yet.
03:27:51 <fifieldt> there was some justification a while back
03:27:55 <fifieldt> but I can't recall it
03:28:09 <fifieldt> It was something around having release docs and another 'library'
03:28:13 <fifieldt> of books for reference
03:29:13 <slong> I would vote to moving the ConfigRef to continuous integration.
03:29:46 <slong> Anyway, am happy the whole question is on hold for a bit.
03:30:24 <slong> And, finally
03:30:30 <slong> #topic openDiscussion
03:30:59 <slong> Anything?
03:31:03 <fifieldt> trove patch for install guide
03:31:08 <fifieldt> we need it asap :)
03:31:29 <fifieldt> #link https://review.openstack.org/#/c/87135/
03:31:49 <fifieldt> guessing Laurel is asleep
03:31:55 <slong> Ah, cool. Will review after the updates for Andreas.
03:31:55 <fifieldt> anyone got time to fix it up a bit?
03:32:15 <fifieldt> I'm also seeking good instructions for making trove guestagent images
03:32:24 <fifieldt> there aren't any right now
03:32:28 <fifieldt> and it's a bit confusing
03:32:37 <fifieldt> (also not explained by that patch, but that's OK - I'd prefer to get it in)
03:33:02 <slong> dnavale, is there a trove dev person fifieldt can ask?
03:33:15 <slong> (dnavale is our Trove person.)
03:33:19 <fifieldt> :)
03:33:57 <dnavale> Sergey Gotliv from RH has installed it..
03:34:18 <slong> sgotliv@redhat.com
03:34:25 <fifieldt> hi guys, I want to introduce jeffshantz_
03:34:30 <dnavale> but he's still working out some kinks, i think..
03:34:31 <fifieldt> he's been helping out the install guide
03:34:33 <jeffshantz_> Hi all
03:34:38 <slong> hi jeffshantz_
03:34:39 <dnavale> hey jeffshantz_
03:34:43 <slong> Welcome
03:34:48 <jeffshantz_> Thank you!
03:34:50 <fifieldt> if you guys can ask sergey if he wrote anything down, that'd be great
03:35:01 <dnavale> will do, fifieldt
03:35:24 <fifieldt> cheers
03:35:34 <fifieldt> I have to get on user survey analysis, otherwise I'd be on it
03:35:43 <dnavale> but that might be sometime next week, they are off till tuesday, 22 Apr..
03:35:46 <fifieldt> gotta get some raw results for PTLs/TCs asap timeframe
03:35:50 <fifieldt> righto
03:35:55 <fifieldt> probably need it well before then
03:35:59 <fifieldt> no dramas
03:36:09 <slong> fifieldt, am doing a couple of reworks, but will get on it after (if nobody else does first).
03:37:42 <slong> Anything else?
03:38:01 <slong> Ok, have a lovely Easter all of you. :)
03:38:12 <fifieldt> thanks slong :)
03:38:19 <slong> #endmeeting